## Contents

Preface ................................................................................................................................. xvii
1 Getting Started .................................................................................................................. 1
  1.1 In This Chapter .......................................................................................................... 1
  1.2 Introduction to Maple .................................................................................................. 2
    Working in Maple ........................................................................................................... 2
    Starting the Standard Document Interface .................................................................. 3
    Entering 2-D Math ......................................................................................................... 5
    Toolbar Options ........................................................................................................... 9
    Context Menus and Copy & Drag ................................................................................. 11
    Saving a Maple Document ......................................................................................... 18
  1.3 Entering Expressions ................................................................................................. 18
    Execution Groups ........................................................................................................ 18
    Math Mode vs. Text Mode ............................................................................................ 19
    Palettes ....................................................................................................................... 21
    Symbol Names ............................................................................................................. 28
    Toolbar Icons ............................................................................................................. 30
  1.4 Point-and-Click Interaction ....................................................................................... 32
    Assistants .................................................................................................................... 32
    Tutors .......................................................................................................................... 37
    Math Apps .................................................................................................................... 38
    Context Menus ............................................................................................................. 39
    Task Templates ............................................................................................................ 40
    Exploration Assistant .................................................................................................. 43
  1.5 Commands .................................................................................................................. 45
    The Maple Library ........................................................................................................ 45
    Entering Commands ..................................................................................................... 45
    Document Blocks ......................................................................................................... 50
  1.6 The Maple Help System .............................................................................................. 53
    Accessing the Help System .......................................................................................... 53
    Using the Help Navigator ............................................................................................. 55
    Viewing Help Pages as Documents .............................................................................. 55
    Viewing Examples in 2-D Math .................................................................................... 56
    Copying Examples ........................................................................................................ 56
  1.7 Available Resources ................................................................................................... 56
    Resources Available through the Maple Help System ................................................. 57
    Maple Tour and Quick Resources ............................................................................... 58
    Web Site Resources ..................................................................................................... 58
2 Document Mode ............................................................................................................... 61
  2.1 In This Chapter .......................................................................................................... 61
  2.2 Introduction ............................................................................................................... 61
  2.3 Entering Expressions ................................................................................................. 62
<p>| Example 1 - Enter a Partial Derivative | 63 |
| Example 2 - Define a Mathematical Function | 64 |
| 2.4 Evaluating Expressions | 65 |
| 2.5 Editing Expressions and Updating Output | 66 |
| 2.6 Performing Computations | 67 |
| Computing with Palettes | 67 |
| ContextMenus | 68 |
| Assistants and Tutors | 73 |
| 3 Worksheet Mode | 77 |
| 3.1 In This Chapter | 77 |
| 3.2 Input Prompt | 78 |
| Suppressing Output | 79 |
| 1-D Math Input | 79 |
| Input Separators | 80 |
| 3.3 Commands | 80 |
| The Maple Library | 81 |
| Top-Level Commands | 81 |
| Package Commands | 83 |
| 3.4 Palettes | 86 |
| 3.5 Context Menus | 88 |
| Example - Using Context Menus | 89 |
| 3.6 Assistants and Tutors | 90 |
| Launching an Assistant or Tutor | 90 |
| 3.7 Task Templates | 90 |
| 3.8 Text Regions | 92 |
| 3.9 Names | 92 |
| Assigning to Names | 93 |
| Unassigning Names | 94 |
| Valid Names | 95 |
| 3.10 Equation Labels | 95 |
| Displaying Equation Labels | 96 |
| Referring to a Previous Result | 96 |
| Execution Groups with Multiple Outputs | 97 |
| Label Numbering Schemes | 98 |
| Features of Equation Labels | 99 |
| 4 Basic Computations | 101 |
| 4.1 In This Chapter | 101 |
| 4.2 Symbolic and Numeric Computation | 102 |
| Exact Computations | 103 |
| Floating-Point Computations | 103 |
| Converting Exact Quantities to Floating-Point Values | 104 |
| Sources of Error | 105 |
| 4.3 Integer Operations | 106 |</p>
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non-Base 10 Numbers and Other Number Systems</td>
<td>108</td>
</tr>
<tr>
<td>4.4 Solving Equations</td>
<td>111</td>
</tr>
<tr>
<td>Solving Equations and Inequations</td>
<td>111</td>
</tr>
<tr>
<td>Other Specialized Solvers</td>
<td>120</td>
</tr>
<tr>
<td>4.5 Units, Scientific Constants, and Uncertainty</td>
<td>127</td>
</tr>
<tr>
<td>Units</td>
<td>127</td>
</tr>
<tr>
<td>Scientific Constants and Element Properties</td>
<td>133</td>
</tr>
<tr>
<td>Uncertainty Propagation</td>
<td>138</td>
</tr>
<tr>
<td>4.6 Restricting the Domain</td>
<td>141</td>
</tr>
<tr>
<td>Real Number Domain</td>
<td>141</td>
</tr>
<tr>
<td>Assumptions on Variables</td>
<td>142</td>
</tr>
<tr>
<td>5 Mathematical Problem Solving</td>
<td>147</td>
</tr>
<tr>
<td>5.1 In This Chapter</td>
<td>147</td>
</tr>
<tr>
<td>5.2 Algebra</td>
<td>148</td>
</tr>
<tr>
<td>Polynomial Algebra</td>
<td>148</td>
</tr>
<tr>
<td>5.3 Linear Algebra</td>
<td>155</td>
</tr>
<tr>
<td>Creating Matrices and Vectors</td>
<td>156</td>
</tr>
<tr>
<td>Accessing Entries in Matrices and Vectors</td>
<td>164</td>
</tr>
<tr>
<td>Linear Algebra Computations</td>
<td>166</td>
</tr>
<tr>
<td>Student LinearAlgebra Package</td>
<td>171</td>
</tr>
<tr>
<td>5.4 Calculus</td>
<td>172</td>
</tr>
<tr>
<td>Limits</td>
<td>172</td>
</tr>
<tr>
<td>Differentiation</td>
<td>174</td>
</tr>
<tr>
<td>Series</td>
<td>178</td>
</tr>
<tr>
<td>Integration</td>
<td>179</td>
</tr>
<tr>
<td>Differential Equations</td>
<td>182</td>
</tr>
<tr>
<td>Calculus Packages</td>
<td>182</td>
</tr>
<tr>
<td>5.5 Optimization</td>
<td>184</td>
</tr>
<tr>
<td>Point-and-Click Interface</td>
<td>184</td>
</tr>
<tr>
<td>Large Optimization Problems</td>
<td>187</td>
</tr>
<tr>
<td>MPS(X) File Support</td>
<td>188</td>
</tr>
<tr>
<td>Optimization Package Commands</td>
<td>189</td>
</tr>
<tr>
<td>5.6 Statistics</td>
<td>189</td>
</tr>
<tr>
<td>Probability Distributions and Random Variables</td>
<td>190</td>
</tr>
<tr>
<td>Statistical Computations</td>
<td>191</td>
</tr>
<tr>
<td>Plotting</td>
<td>192</td>
</tr>
<tr>
<td>Additional Information</td>
<td>194</td>
</tr>
<tr>
<td>5.7 Teaching and Learning with Maple</td>
<td>194</td>
</tr>
<tr>
<td>Student Packages and Tutors</td>
<td>196</td>
</tr>
<tr>
<td>Calculus Problem Solving Examples</td>
<td>203</td>
</tr>
<tr>
<td>5.8 Clickable Math</td>
<td>209</td>
</tr>
<tr>
<td>Smart Popups</td>
<td>210</td>
</tr>
<tr>
<td>Drag-to-Solve</td>
<td>210</td>
</tr>
</tbody>
</table>
List of Figures

Figure 1.1: The Maple Environment ................................................................. 3
Figure 1.2: Text and Math Buttons on the Toolbar ............................................ 19
Figure 1.3: Handwriting Palette ..................................................................... 28
Figure 1.4: Optimization Assistant ................................................................ 32
Figure 1.5: Accessing the Assistants from the Tools Menu .............................. 33
Figure 1.6: Accessing Tutors from the Tools Menu .......................................... 37
Figure 1.7: Calculus - Single Variable → Differentiation Methods Tutor ........... 38
Figure 1.8: Right-click the expression to see a menu of applicable operations ..... 40
Figure 1.9: Right-click the plot to see a menu of plot options ......................... 40
Figure 1.10: Browse Tasks Dialog ................................................................. 41
Figure 1.11: Equation Label .......................................................................... 48
Figure 1.12: Inserting an Equation Label ......................................................... 49
Figure 1.13: Format Labels Dialog: Adding a Prefix ....................................... 50
Figure 1.14: Label Reference .......................................................................... 50
Figure 1.15: Document Block Markers ............................................................. 51
Figure 1.16: Expanded Document Block ......................................................... 51
Figure 1.17: Sample Help Page ...................................................................... 54
Figure 2.1: Context Menu ............................................................................... 68
Figure 2.2: Approximating the Value of a Fraction .......................................... 69
Figure 2.3: Finding the Approximate Solution to an Equation ......................... 71
Figure 2.4: FPS Units Palette ......................................................................... 72
Figure 2.5: SI Units Palette ........................................................................... 72
Figure 3.1: Expression Palette ....................................................................... 87
Figure 3.2: Integer Context Menu .................................................................. 88
Figure 3.3: ODE Analyzer Assistant ............................................................... 90
Figure 3.4: Task Browser ............................................................................... 91
Figure 3.5: Insert Label Dialog ..................................................................... 96
Figure 3.6: Format Labels Dialog: Adding a Prefix ....................................... 98
Figure 4.1: Context Menu for an Integer ....................................................... 106
Figure 4.2: Context Menu for an Equation ..................................................... 112
Figure 4.3: ODE Analyzer Assistant .............................................................. 120
Figure 4.4: ODE Analyzer Assistant: Solve Numerically Dialog .................... 122
Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog .................... 123
Figure 4.6: Units Calculator Assistant ............................................................ 129
Figure 4.7: Units (FPS) Palette .................................................................... 130
Figure 4.8: Units (SI) Palette ....................................................................... 130
Figure 5.1: Sorting a Polynomial Using a Context Menu ................................. 152
Figure 5.2: Matrix Palette ........................................................................... 157
Figure 5.3: Matrix Palette: Choosing the Size ............................................... 158
Figure 5.4: Insert Matrix or Insert Vector ....................................................... 159
Figure 5.5: Matrix Browser ......................................................................... 161
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.6</td>
<td>Computing the Infinit Norm of a Matrix</td>
<td>169</td>
</tr>
<tr>
<td>5.7</td>
<td>Directional Derivative Tutor</td>
<td>177</td>
</tr>
<tr>
<td>5.8</td>
<td>Optimization Assistant</td>
<td>185</td>
</tr>
<tr>
<td>5.9</td>
<td>Optimization Assistant Plotter Window</td>
<td>187</td>
</tr>
<tr>
<td>5.10</td>
<td>Calculus 1 Derivatives Tutor</td>
<td>197</td>
</tr>
<tr>
<td>5.11</td>
<td>Calculus 1 Differentiation Methods Tutor</td>
<td>198</td>
</tr>
<tr>
<td>5.12</td>
<td>Multivariate Calculus Gradient Tutor</td>
<td>199</td>
</tr>
<tr>
<td>5.13</td>
<td>Multivariate Calculus Gradient Tutor Showing x-y Plane</td>
<td>200</td>
</tr>
<tr>
<td>5.14</td>
<td>Flowchart of solving a problem</td>
<td>204</td>
</tr>
<tr>
<td>5.15</td>
<td>Volume of Revolution Tutor</td>
<td>206</td>
</tr>
<tr>
<td>5.16</td>
<td>Inserted Task Template</td>
<td>207</td>
</tr>
<tr>
<td>5.17</td>
<td>Example Worksheet</td>
<td>208</td>
</tr>
<tr>
<td>6.1</td>
<td>Interactive Parameter Window</td>
<td>244</td>
</tr>
<tr>
<td>7.1</td>
<td>Select Color Dialog</td>
<td>284</td>
</tr>
<tr>
<td>7.2</td>
<td>Character Style Dialog</td>
<td>285</td>
</tr>
<tr>
<td>7.3</td>
<td>Paragraph Style Dialog</td>
<td>286</td>
</tr>
<tr>
<td>7.4</td>
<td>Style Management Dialog</td>
<td>288</td>
</tr>
<tr>
<td>7.5</td>
<td>Defining a Character Style</td>
<td>290</td>
</tr>
<tr>
<td>7.6</td>
<td>Defining a Paragraph Style</td>
<td>293</td>
</tr>
<tr>
<td>7.7</td>
<td>Style Set Management Dialog</td>
<td>294</td>
</tr>
<tr>
<td>7.8</td>
<td>Header and Footer Dialog</td>
<td>296</td>
</tr>
<tr>
<td>7.9</td>
<td>Show Contents Dialog</td>
<td>297</td>
</tr>
<tr>
<td>7.10</td>
<td>Working with Document Blocks</td>
<td>300</td>
</tr>
<tr>
<td>7.11</td>
<td>Delete Table Contents Verification Dialog</td>
<td>307</td>
</tr>
<tr>
<td>7.12</td>
<td>Table Paste Mode Selection Dialog</td>
<td>307</td>
</tr>
<tr>
<td>7.13</td>
<td>Two Cells</td>
<td>307</td>
</tr>
<tr>
<td>7.14</td>
<td>Merged Cells</td>
<td>307</td>
</tr>
<tr>
<td>7.15</td>
<td>Drawing Tools and Canvas</td>
<td>316</td>
</tr>
<tr>
<td>7.16</td>
<td>Drawing Outline Color Icon</td>
<td>317</td>
</tr>
<tr>
<td>7.17</td>
<td>Drawing Properties Canvas Icon - Change the Gridline Color</td>
<td>319</td>
</tr>
<tr>
<td>7.18</td>
<td>Hyperlink Properties Dialog</td>
<td>321</td>
</tr>
<tr>
<td>7.19</td>
<td>Bookmark Indicator</td>
<td>324</td>
</tr>
<tr>
<td>7.20</td>
<td>Create Bookmark Dialog</td>
<td>325</td>
</tr>
<tr>
<td>7.21</td>
<td>Components Palette</td>
<td>327</td>
</tr>
<tr>
<td>7.22</td>
<td>Interactive Application Task Template</td>
<td>328</td>
</tr>
<tr>
<td>7.23</td>
<td>Spellcheck Dialog</td>
<td>329</td>
</tr>
<tr>
<td>8.1</td>
<td>Function Definition Palette Items</td>
<td>339</td>
</tr>
<tr>
<td>8.2</td>
<td>Evaluate at a Point</td>
<td>354</td>
</tr>
<tr>
<td>9.1</td>
<td>Code Edit Region</td>
<td>382</td>
</tr>
<tr>
<td>9.2</td>
<td>Collapsed Code Edit Region</td>
<td>382</td>
</tr>
<tr>
<td>9.3</td>
<td>Startup Code Editor</td>
<td>383</td>
</tr>
<tr>
<td>10.1</td>
<td>Components Palette</td>
<td>389</td>
</tr>
<tr>
<td>10.2</td>
<td>Label Properties Dialog</td>
<td>391</td>
</tr>
</tbody>
</table>
Figure 10.3: Slider Properties Dialog ................................................................. 391
Figure 10.4: The Inserted Components ............................................................... 393
Figure 10.5: DialComponent Action Dialog ....................................................... 395
Figure 10.6: A Simple Maplet ......................................................................... 398
Figure 10.7: Maplet Builder Interface ............................................................... 399
Figure 10.8: Image of the Maplet ................................................................. 400
Figure 10.9: Body Elements Used to Define This Maplet ............................... 400
Figure 11.1: Import Data Assistant ................................................................. 410
List of Tables

Table 1.1: Common Keystrokes for Entering Symbols and Formats ........................................ 6
Table 1.2: Maple Toolbar Options ........................................................................................... 9
Table 1.3: Tab Icon Description ............................................................................................. 9
Table 1.4: Toolbar Icons and their Tools ................................................................................. 10
Table 1.5: Toolbar Icon Availability ....................................................................................... 11
Table 1.6: Math Mode vs. Text Mode ..................................................................................... 20
Table 1.7: Palette Categories .................................................................................................... 22
Table 1.8: Managing Palettes .................................................................................................. 24
Table 1.9: Help Page Icons ..................................................................................................... 55
Table 3.1: Top Commands ....................................................................................................... 82
Table 3.2: Top Packages .......................................................................................................... 85
Table 4.1: Select Integer Commands ....................................................................................... 107
Table 4.2: Modular Arithmetic Operators .............................................................................. 109
Table 4.3: Overview of Solution Methods for Important Equation Types .............................. 111
Table 4.4: Sample Dimensions .............................................................................................. 128
Table 4.5: Scientific Constants ............................................................................................... 134
Table 5.1: Polynomial Arithmetic Operators ......................................................................... 149
Table 5.2: Polynomial Coefficient and Degree Commands .................................................. 153
Table 5.3: Select Other Polynomial Commands .................................................................... 154
Table 5.4: Additional Polynomial Help .................................................................................. 155
Table 5.5: Matrix and Vector Arithmetic Operators .............................................................. 166
Table 5.6: Select Matrix and Vector Operators ....................................................................... 168
Table 5.7: Select LinearAlgebra Package Commands ............................................................ 170
Table 5.8: Limits ...................................................................................................................... 173
Table 5.9: Optimization Package Commands ......................................................................... 189
Table 5.10: Student and Instructor Resources ....................................................................... 195
Table 6.1: Windows of the Interactive Plot Builder ............................................................... 239
Table 6.2: The plot and plot3d Commands ............................................................................ 249
Table 6.3: Common Plot Options ............................................................................................ 267
Table 6.4: Plot Analysis Options ............................................................................................. 269
Table 6.5: The animate Command ........................................................................................ 272
Table 6.6: Animation Options ................................................................................................. 276
Table 9.1: Default Clause Values ............................................................................................ 369
Table 9.2: Iterative Commands ............................................................................................... 374
Table 9.3: The seq Command ................................................................................................. 375
Table 9.4: The add and mul Commands ................................................................................. 375
Table 9.5: The select, remove, and selectremove Commands ................................................. 376
Table 9.6: The map Command ............................................................................................... 377
Table 9.7: The zip Command ................................................................................................. 378
Table 10.1: Embedded Component Descriptions .................................................................... 385
Table 11.1: Summary of Content Translation When Exporting to Different Formats ............ 414
Preface

Maple Software

Maple™ software is a powerful system that you can use to solve mathematical problems from simple to complex. You can also create professional quality documents, presentations, and custom interactive computational tools in the Maple environment.

You can access the power of the Maple computational engine through a variety of interfaces.

<table>
<thead>
<tr>
<th>Interface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard (default)</td>
<td>A full-featured graphical user interface that helps you create electronic documents to show all your calculations, assumptions, and any margin of error in your results. You can also hide the computations to allow your reader to focus on the problem setup and final results. The advanced formatting features let you create the customized document you need. Because the documents are live, you can edit the parameters and, with the click of a button, compute the new results. The Standard interface has two modes: Document mode and Worksheet mode. An interactive version of this manual is available in the Standard Worksheet interface. From the Help menu, select Manuals, Resources, and more → Manuals → User Manual.</td>
</tr>
<tr>
<td>Classic</td>
<td>A basic worksheet environment for older computers with limited memory. The Classic interface does not offer all of the graphical user interface features that are available in the Standard interface. The Classic interface has only one mode, Worksheet mode.</td>
</tr>
<tr>
<td>Command-line version</td>
<td>A command-line interface for solving very large complex problems or batch processing with scripts. No graphical user interface features are available.</td>
</tr>
<tr>
<td>Maplet™ Applications</td>
<td>Graphical user interfaces containing windows, textbox regions, and other visual interfaces, which gives you point-and-click access to the power of Maple. You can perform calculations and plot functions without using the worksheet.</td>
</tr>
<tr>
<td>Maplesoft™ Graphing Calculator</td>
<td>A graphical calculator interface to the Maple computational engine. Using it, you can perform simple computations and create customizable, zoomable graphs. This is available on Microsoft® Windows® only.</td>
</tr>
</tbody>
</table>

This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes: Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same features and functionality, the only difference is the default input region of each mode.
Shortcut Keys by Platform

This manual will frequently refer to context menus and command completion when entering expressions. The keyboard keys used to invoke these features differ based on your operating system.

This manual will only refer to the keyboard keys needed for a Windows operating system. The shortcut keys for your operating system can be viewed from the Help menu (Help → Manuals, Resources, and more → Shortcut Keys).

Context Menus

- **Right-click**, Windows and UNIX®
- **Control-click**, Macintosh®

That is, place the mouse over the input or output region and press the right button on the mouse or press and hold the Control key and click the mouse key for Macintosh.

For more information on Context Menus, see *Context Menus (page 39)*.

Command Completion

- **Esc**, Macintosh, Windows, and UNIX
- **Ctrl + Space**, Windows
- **Ctrl + Shift + Space**, UNIX

Begin entering a command in a Maple document. Press the Esc key. Alternatively, use the platform-specific keys. For Windows, press and hold the Ctrl key and then press the Space bar.

For more information on Command Completion, see *Command Completion (page 47)*.

In This Manual

This manual provides an introduction to the following Maple features:

- Ease-of-use when entering and solving problems
- Point-and-click interaction with various interfaces to help you solve problems quickly
- Maple commands and standard math notation
- Clickable Calculus
- The help system
- Online resources
• Performing computations
• Creating plots and animations
• The Maple programming language
• Using and creating custom Maplet applications
• File input and output, and using Maple with third party products
• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft web site at http://www.maplesoft.com

Audience

The information in this manual is intended for first-time Maple users and users looking for a little more information.

Conventions

This manual uses the following typographical conventions.

• **bold** font - Maple command, package name, option name, dialog, menu, or text field
• *italics* - new or important concept
• **Note** - additional information relevant to the section
• **Important** - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact doc@maplesoft.com.
1 Getting Started

Don't worry about your difficulties in Mathematics. I can assure you mine are still greater.

~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating the total cost of our purchases to the complex calculations used to construct the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.

1.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Introduction to Maple (page 2) - The main features of Maple's Standard Interface | • Starting the Standard Document Interface  
• Entering commands and mathematical expressions  
• Toolbars  
• Context menus  
• Copy and drag keys  
• Saving Maple documents |
| Entering Expressions (page 18) - Methods of entering expressions in 1-D and 2-D Math | • Execution groups  
• Math Mode and Text Mode  
• Palettes  
• Symbol names  
• Toolbar icons |
| Point-and-Click Interaction (page 32) - An introduction to the point-and-click features in Maple | • Assistants  
• Tutors  
• Context menus  
• Task templates  
• Exploration Assistant |
| Commands (page 45) - An introduction to the commands of the Maple language | • Using commands from the Maple library  
• Entering commands  
• Document blocks |
1.2 Introduction to Maple

Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets you start solving problems right away by entering expressions in 2-D Math and solving these expressions using point-and-click interfaces. You can combine text and math in the same line, add tables to organize the content of your work, or insert images, sketch regions, and spreadsheets. You can visualize and animate problems in two and three dimensions, format text for academic papers or books, and insert hyperlinks to other Maple files, web sites, or email addresses. You can embed and program graphical user interface components, as well as devise custom solutions using the Maple programming language.
Starting the Standard Document Interface

To start Maple on:

<table>
<thead>
<tr>
<th>Platform</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>From the Start menu, select All Programs → Maple 16 → Maple 16. Alternatively: Double-click the Maple 16 desktop icon.</td>
</tr>
</tbody>
</table>
1. From the Finder, select Applications and Maple 16.
2. Double-click Maple 16.

UNIX
Enter the full path, for example, /usr/local/maple/bin/xmaple
Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your command search path.
2. Enter xmaple.

The first Maple session opens with a Startup dialog explaining the difference between Document Mode and Worksheet Mode. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same features and functionality; the only difference is the default input region of each mode.

**Document Mode**

Document mode uses Document Blocks as the default input region to hide Maple syntax. A Document Block region is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document, □□. If the Markers column is not visible, open the View menu and select Markers. This allows you to focus on the problem instead of the commands used to solve the problem. For example, when using context menus on Maple input in Document mode (invoked by right-clicking or Control-clicking for Macintosh), input and output are connected using an arrow or equal sign with self-documenting text indicating the calculation that had taken place. The command used to solve this expression is hidden.

```
\[ x^2 + 7x + 10 \quad \text{solve} \rightarrow \{x = -2\}, \{x = -5\} \]
```

When starting Standard Maple, the default mode is Document mode.

**Worksheet Mode**

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red angle bracket, \[ \textgreater \]. When using context menus on input in Worksheet mode, all commands are displayed.

```
\[ \textgreater x^2 + 7x + 10 \]
\[ \textgreater \text{solve}( \{ x^2 + 7x + 10 = 0 \} ) \]
\[ \{x = -2\}, \{x = -5\} \]
```

To work in Worksheet mode, select File → New → Worksheet Mode.
Document and Worksheet Modes

Regardless of which mode you are working in, you have the opportunity to show or hide your calculations. You can hide commands in Worksheet Mode by adding a document block from the **Format** menu, **Format → Create Document Block** (see *Document Blocks* (page 50)), or you can show commands in Document mode by adding a Maple prompt from the **Insert** menu, **Insert → Execution Group → Before / After Cursor** (see *Input Prompt* (page 78)).

This chapter discusses features common to both modes. Specific aspects of Document mode are explained in *Document Mode* (page 61), and aspects of Worksheet mode are explained in *Worksheet Mode* (page 77).

The Startup dialog also contains links to items, such as various document options, help resources including updates and other introductory help pages, and application resources on the Maplesoft web site. Subsequent sessions display **Tip of the Day** information.

**To start a Maple session:**

1. In the **Startup** dialog, select **Blank Document** or **Blank Worksheet**. A blank document displays.

or

1. Close the **Startup** dialog.

2. From the **File** menu, select **New**, and then either **Document Mode** or **Worksheet Mode**. A blank document displays.

Every time you open a document, Maple displays a **Quick Help** pop-up list of important shortcut keys. To invoke **Quick Help** at any time, press the **F1** key.

**Entering 2-D Math**

In Maple, the default format for entering mathematical expressions is 2-D Math. This results in mathematical expressions that are equivalent to the quality of math found in textbooks. Entering 2-D Math in Maple is done using common key strokes or palette items. For more information on palettes, see *Palettes* (page 21). An example of entering an expression using common key strokes is presented in the following section. An example of entering an expression using palette items is presented in *Example 3 - Enter an Expression Using Palettes* (page 26).

**Common Operations**

Entering mathematical expressions, such as \( \frac{35}{99} + \frac{1}{9}, x^2 + x, \) and \( x \cdot y \) is natural in 2-D Math.
To enter a fraction:
1. Enter the numerator.
2. Press the forward slash (/) key.
3. Enter the denominator.
4. To leave the denominator, press the right arrow key.

To enter a power:
1. Enter the base.
2. Press the caret (^) key.
3. Enter the exponent, which displays in math as a superscript.
4. To leave the exponent, press the right arrow key.

To enter a product:
1. Enter the first factor.
2. Press the asterisk (*) key, which displays in 2-D Math as a dot, \cdot.
3. Enter the second factor.

Implied Multiplication:
In most cases, you do not need to include the multiplication operator, \cdot. Insert a space character between two quantities to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or a space character. For example, Maple interprets a number followed by a variable as multiplication.

Important: Maple interprets a sequence of letters, for example, xy, as a single variable. To specify the product of two variables, you must insert a space character (or multiplication operator), for example, \(x \cdot y\) or \(x \cdot y\). For more information, refer to the 2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

<table>
<thead>
<tr>
<th>Symbol/Formats</th>
<th>Key</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>implicit multiplication</td>
<td>Space key</td>
<td>((x^2 - 7xy + 3y^2) \cdot xy)</td>
</tr>
<tr>
<td>explicit multiplication(^1)</td>
<td>* (asterisk)</td>
<td>2 \cdot 3</td>
</tr>
<tr>
<td>Symbol/Formats</td>
<td>Key</td>
<td>Example</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>fraction(^2)</td>
<td>/ (forward slash)</td>
<td>1/4</td>
</tr>
<tr>
<td>exponent (superscript)(^2)</td>
<td>(^\wedge) (\text{Shift} + 6 or caret key)</td>
<td>(x^2)</td>
</tr>
<tr>
<td>subscript(^2)</td>
<td>(_) (\text{Shift} + underscore)</td>
<td>(a_x)</td>
</tr>
<tr>
<td>navigating expressions</td>
<td>Arrow keys</td>
<td></td>
</tr>
<tr>
<td>command / symbol comple-</td>
<td>• Esc, Macintosh, Windows, and</td>
<td></td>
</tr>
<tr>
<td>tion(^3)</td>
<td>UNIX</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Ctrl + Space, Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Ctrl + Shift + Space, UNIX</td>
<td></td>
</tr>
<tr>
<td>square root</td>
<td>(\text{sqrt}) and then command completion</td>
<td>(\sqrt{25})</td>
</tr>
<tr>
<td>exponential function(^2)</td>
<td>(\text{exp}) and then command completion</td>
<td>(e^x)</td>
</tr>
<tr>
<td>enter / exit 2-D Math</td>
<td>• F5 key</td>
<td>(1/4) versus 1/4</td>
</tr>
<tr>
<td></td>
<td>• Math and Text icons in the toolbar</td>
<td></td>
</tr>
</tbody>
</table>

1 required for products of numbers

2 use the right arrow key to leave a denominator, superscript, or subscript region

3 for more information, see Command Completion (page 47).

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help page in the Maple software, in Math mode enter MathShortcuts and then press Enter. For information on the Maple Help System, see The Maple Help System (page 53).

**Example 1 - Enter and Evaluate an Expression Using Keystrokes**

Review the following example:

\[ \frac{x^2 + y^2}{2} \]

In this example, you will enter \(\frac{x^2 + y^2}{2}\) and evaluate the expression.
### To enter the expression:

1. Enter \( x \).

\[
\frac{x}{x^2}
\]

2. Press \( \text{Shift} + 6 \) (the ^ or caret key). The cursor moves to the superscript position.

\[
\frac{1}{x^2}
\]

3. Enter \( 2 \).

\[
\frac{2}{x^2}
\]

4. Press the right arrow key. The cursor moves right and out of the superscript position.

\[
\frac{2}{x^2}
\]

5. Enter the + symbol.

\[
\frac{x^2 + 1}{x^2}
\]

6. Enter \( y \).

\[
\frac{x^2 + y^2}{x^2}
\]

7. Press \( \text{Shift} + 6 \) to move to the superscript position.

\[
\frac{x^2 + y^2}{x^2 + y^2}
\]

8. Enter \( 2 \) and press the right arrow key.

\[
\frac{x^2 + y^2}{x^2 + y^2}
\]

9. With the mouse, select the expression that will be the numerator of the fraction.

\[
\frac{x^2 + y^2}{x^2 + y^2}
\]

10. Enter the / symbol. The cursor moves to the denominator, with the entire expression in the numerator.

\[
\frac{x^2 + y^2}{2}
\]

11. Enter \( 2 \).

\[
\frac{x^2 + y^2}{2}
\]

12. Press the right arrow key to move right and out of the denominator position.

\[
\frac{x^2 + y^2}{2}
\]

### To evaluate the expression and display the result inline:

13. Press \( \text{Ctrl} + = \) (\( \text{Command} + = \), for Macintosh).

\[
\frac{x^2 + y^2}{2} = \frac{1}{2} x^2 + \frac{1}{2} y^2
\]

To execute 2-D Math, you can use any of the following methods.

- Pressing \( \text{Ctrl} + = \) (\( \text{Command} + = \), for Macintosh). That is, press and hold the \( \text{Ctrl} \) (or \( \text{Command} \)) key, and then press the equal sign (=) key. This evaluates and displays results inline.

- Pressing the \text{Enter} key. This evaluates and displays results on the next line and centered.

- Right-click (\( \text{Control} \)-click for Macintosh) the input to invoke a context menu item. From the context menu, select \text{Evaluate and Display Inline}. See \text{Context Menus (page 39)} for more details.
Using the **Edit** menu items **Evaluate** and **Evaluate and Display Inline**.

**Toolbar Options**

The Maple toolbar offers several buttons to assist you when interacting with Maple. See **Table 1.2**.

**Table 1.2: Maple Toolbar Options**

<table>
<thead>
<tr>
<th>Basic Usage</th>
<th>Icon</th>
<th>Equivalent Menu Option or Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inserts plain text after the current execution group.</td>
<td>![Text Icon]</td>
<td>From the <strong>Insert</strong> menu, select <strong>Text</strong>.</td>
</tr>
<tr>
<td>Inserts Maple Input after the current execution group. For details, refer to Execution Groups (page 18).</td>
<td>![Insert Execution Group Icon]</td>
<td>From the <strong>Insert</strong> menu, select <strong>Execution Group</strong> and then <strong>After Cursor</strong>.</td>
</tr>
<tr>
<td>Encloses the selection in a subsection. For details, refer to Sections (page 294).</td>
<td>![Indent Icon]</td>
<td>From the <strong>Format</strong> menu, select <strong>Indent</strong>.</td>
</tr>
<tr>
<td>Removes any section enclosing the selection.</td>
<td>![Outdent Icon]</td>
<td>From the <strong>Format</strong> menu, select <strong>Outdent</strong>.</td>
</tr>
<tr>
<td>Executes all commands in the worksheet or document</td>
<td>![Execute All Commands Icon]</td>
<td>From the <strong>Edit</strong> menu, select <strong>Execute</strong> and then <strong>Worksheet</strong>.</td>
</tr>
<tr>
<td>Executes a selected area.</td>
<td>![Execute Selection Icon]</td>
<td>From the <strong>Edit</strong> menu, select <strong>Execute</strong> and then <strong>Selection</strong>.</td>
</tr>
<tr>
<td>Clears Maple's internal memory. For details, refer to the restart help page.</td>
<td>![Execute Restart Icon]</td>
<td>Enter <strong>restart</strong>.</td>
</tr>
<tr>
<td>Add and edit Maple code that is executed each time the worksheet is opened. For details, refer to the startupcode help page.</td>
<td>![Execute Startup Code Icon]</td>
<td>From the <strong>Edit</strong> menu, select <strong>Startup Code</strong>.</td>
</tr>
<tr>
<td>Adjusts the display size of document content. Note: plots, spreadsheets, images, and sketches remain unchanged.</td>
<td>![Zoom Factor Icon]</td>
<td>From the <strong>View</strong> menu, select <strong>Zoom Factor</strong> and then a zoom size.</td>
</tr>
<tr>
<td>Opens the Maple help system. For details, refer to The Maple Help System (page 53).</td>
<td>![Help Icon]</td>
<td>From the <strong>Help</strong> menu, select <strong>Maple Help</strong>.</td>
</tr>
</tbody>
</table>

For 1-D Math and text regions, the **Tab** icon in the toolbar allows you to set the **Tab** key to move between placeholders (or cells in a table) or to indent text.

**Table 1.3: Tab Icon Description**

<table>
<thead>
<tr>
<th>Tab Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>! ![Tab Icon]</td>
<td>Tab icon <strong>off</strong>. Allows you to move between placeholders using the <strong>Tab</strong> key.</td>
</tr>
</tbody>
</table>
Tab Icon | Description
--- | ---
| | Tab icon on. Allows you to indent in the worksheet using the Tab key.

The Tab icon is disabled when using 2-D Math (Math mode), and as such, the Tab key allows you to move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document. For example, place the cursor at an input region and the Text and Math icons are accessible while the others are dimmed. See Table 1.4 for a list of the tools available in each icon.

**Table 1.4: Toolbar Icons and their Tools**

<table>
<thead>
<tr>
<th>Toolbar Icon Options</th>
<th>Text tools</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Text</strong></td>
</tr>
<tr>
<td></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>Math</strong></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>Drawing</strong></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>2-D Plot</strong></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>3-D Plot</strong></td>
<td>![Text Icon]</td>
</tr>
<tr>
<td><strong>Animation</strong></td>
<td>![Text Icon]</td>
</tr>
</tbody>
</table>
Table 1.5: Toolbar Icon Availability

<table>
<thead>
<tr>
<th>Region</th>
<th>Available Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input region</td>
<td>Text and Math icons</td>
</tr>
<tr>
<td>Plot region</td>
<td>Drawing and Plot icons</td>
</tr>
<tr>
<td>Animation region</td>
<td>Drawing, Plot, and Animation icons</td>
</tr>
<tr>
<td>Canvas and Image regions</td>
<td>Drawing icon</td>
</tr>
</tbody>
</table>

The **Text** and **Math** icons allow you to enter text and math in the same line by choosing the appropriate input style at each stage when entering the sentence.

The derivative of $\sin(x)$ is $\cos(x)$.

For an example, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 30).

Using the tools available in these icons, you can customize the input style of the text and 2-D Math. For the **Text** and **Math** icons, the icon that is selected remains in that state until prompted otherwise; therefore, if the **Text** icon is selected and you press the **Enter** key, the new input region remains a Text region.

The **Text** and **Math** icons differ while at a Maple input prompt. The Math icon displays input as 2-D Math, whereas the Text icon displays Maple input. For details, refer to Math Mode vs. Text Mode (page 19).

\[
> \frac{x^2}{2} \\
> x^2/2;
\]

To access the tools available in the **Plot** and **Drawing** icons, click a plot region. These tools allow you to manipulate the plot or draw shapes and enter text on the plot region. By clicking an animation region, you have the same features available for a plot region, in addition to tools for playing the animation in the **Animation** icon. For details on plots and animations, refer to Plots and Animations (page 237).

For the remaining icons, hover the mouse over the icon to display the icon description.

**Context Menus and Copy & Drag**

**Context Menus**

Maple dynamically generates a context menu of applicable options when you right-click an object, expression, or region. The options available in the context menu depend on the selected input region. For example, you can manipulate and graph expressions, enhance plots, format text, manage palettes, structure tables, and more. When using context menus
to perform an action on an expression, the input and output are connected with a self-docu-
menting arrow or equal sign indicating the action that had taken place. For more information,
see Context Menus (page 39).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input region.
This is done by highlighting the input or selecting the curve and dragging it with your mouse
into a new input region. Dragging the highlighted region will cut or delete the original input.
To prevent this, use the copy and drag feature.

• Ctrl + drag, Windows and UNIX
• Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag
the input to the new region using the mouse. The steps are the same for Macintosh with the
exception of pressing the Command key.

Example 2 - Solve and Plot an Equation Using Context Menus and Copy &
Drag

Review the following example:

\[ 5x - 7 = 3x + 2 \]

In this example, we will enter the equation and then solve and plot the equation using context
menus and Maple's copy & drag feature. This example will only refer to the keystrokes
needed on a Windows operating system to invoke the context menus and the copy & drag
feature. For your operating system, refer to section Shortcut Keys by Platform (page xviii)
for the equivalent keystrokes.
To solve the equation:

1. Enter the equation.
2. Right-click the equation and select **Move to Left**.

**Input:**

\[ 5x - 7 = 3x + 2 \]

**Result:**

\[ 5x - 7 = 3x + 2 \rightarrow 2x - 9 = 0 \]

A brief description, "move to left" is displayed above the arrow that connects the input and output.
3. Right-click the output from the previous action, $2x - 9 = 0$, and select Solve → Isolate Expression for $x$.

Input:

$$5x - 7 = 3x + 2 \quad \text{move to left} \quad 2x - 9 = 0$$

Result:

$$5x - 7 = 3x + 2 \quad \text{move to left} \quad 2x - 9 = 0 \quad \text{isolate for } x \quad x = \frac{9}{2}$$
Now that we have solved the equation, we can plot it. To do this, we will copy the equation \(2x - 9 = 0\) to a new document block and use context menus again.

4. From the **Format** menu, select **Create Document Block**.

5. To copy the expression \(2x - 9 = 0\), highlight only this expression from the previous result. Press and hold the Ctrl key and drag the expression to the new document block region.

**Result:**

\[
\begin{array}{c}
5x - 7 = 3x + 2 \quad \text{move to left} \quad 2x - 9 = 0 \quad \text{isolate for } x \quad x = \frac{9}{2}
\end{array}
\]

\[
\begin{array}{c}
5x - 7 = 3x + 2 \quad \text{move to left} \quad 2x - 9 = 0 \quad \text{isolate for } x \quad x = \frac{9}{2}
\end{array}
\]

\[
\begin{array}{c}
5x - 7 = 3x + 2 \quad \text{move to left} \quad 2x - 9 = 0 \quad \text{isolate for } x \quad x = \frac{9}{2}
\end{array}
\]

\[
\begin{array}{c}
2x - 9 = 0
\end{array}
\]
To plot the expression:
6. Right-click the equation, and select Left-hand Side.

**Input:**

\[ 2x - 9 = 0 \]

**Result:**

\[ 2x - 9 = 0 \overset{\text{left hand side}}{\longrightarrow} 2x - 9 \]

7. Right-click the expression and select Plots → 2-D Plot.
Saving a Maple Document

To save these examples you created, from the File menu, select Save. Maple documents are saved as .mw files.

1.3 Entering Expressions

Execution Groups

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following: a plot, a spreadsheet, text, embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the document. If you place the cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the current execution group.
Math Mode vs. Text Mode

The default mode of entry in Document or Worksheet mode is Math Mode, which displays input in 2-D Math. In earlier releases of Maple, commands and expressions were entered using Maple Input or 1-D Math.

**Important:** With Maple input, you must terminate commands with a semicolon or colon.

```maple
> \cos(\alpha)^2 + \sin(\alpha)^2;
\cos(\alpha)^2 + \sin(\alpha)^2

> a*\int(\exp(\sqrt(2)*x),x);
\frac{1}{2} a \sqrt{2} e^{\sqrt{2} x}

> \lim_{x\to\infty} f(x);
limit(f(x), x=\infty)

> \sum(a[k]*x^k, k=0..m)=\prod(b[j]*x^j, j=0..n);
\sum_{k=0}^{m} a_k x^k = \prod_{j=0}^{n} (b_j x^j)
```

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by clicking in the toolbar, and then click the Text button in the toolbar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

![Figure 1.2: Text and Math Buttons on the Toolbar](image-url)
Table 1.6: Math Mode vs. Text Mode

<table>
<thead>
<tr>
<th>Math Mode</th>
<th>Text Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Maple's default setting.</em> Executable standard math notation. This is also referred to as 2-D Math Input.</td>
<td>Executable Maple notation. This is also referred to as 1-D Math Input or Maple Input.</td>
</tr>
<tr>
<td>( \int x^2 + 2x + 1 , dx )</td>
<td>( \int (x^2+2x+1, , x); )</td>
</tr>
<tr>
<td>( \frac{1}{3} x^3 + x^2 + x )</td>
<td>( \frac{1}{3} x^3 + x^2 + x )</td>
</tr>
</tbody>
</table>

Access from the **Insert → 2-D Math** menu. Access from the **Insert → Maple Input** menu.

When using 2-D Math, the **Math** mode icon is highlighted in the toolbar, ![Math mode icon](image).

When entering Maple Input or text in a text region, the **Text** mode icon is highlighted in the toolbar, ![Text mode icon](image).

In Document Mode (or a document block), input is entered in a document block with a slanted cursor, ![Slanted cursor](image).

In Document Mode (or a document block), input is entered with a vertical cursor, as plain text, ![Vertical cursor](image).

In Worksheet Mode, input is made at an input prompt with a slanted cursor, ![Slanted cursor](image).

In Worksheet Mode, input is made at an input prompt with a vertical cursor, ![Vertical cursor](image).

To convert a 2-D Math expression to 1-D Math, right-click the expression (**Command-click**, Macintosh) and select **2-D Math → Convert To → 1-D Math Input**.

To convert a 1-D Math expression to 2-D Math, right-click the expression (**Command-click**, Macintosh) and select **Convert To → 2-D Math Input**.

No termination symbol is required. All input must end with a semi-colon (;) or a colon (:).

Palettes make entering expressions in familiar notation easier than entering foreign syntax and reduces the possibility of introducing typing errors.

Using palettes while in 1-D Math teaches you the related Maple command syntax.

If you prefer 1-D Math input, you can change the default math input notation.

**To change math input notation for a session or globally across all documents:**
1. From the **Tools** menu, select **Options**. The **Options Dialog** opens.
2. Click the **Display** tab.
3. In the **Input Display** drop-down list, select **Maple Notation**.
4. Click the **Apply to Session** or **Apply Globally** button.

**Important:** The new input display becomes the default setting after pressing the **Enter** key.

**Palettes**

Palettes are collections of related items that you can insert into a document by clicking or drag-and-dropping. The Maple environment provides access to over 20 palettes containing items such as symbols ($\infty$), layouts ($A^b$), mathematical operations ($\int_a^b f \, dx$), and much more.

By default, palettes are displayed in the left pane of the Maple environment when you launch Maple. If the palettes are not displayed,

1. From the **View** menu, select **Palettes**.
2. Select **Expand Docks**.
3. Right-click (**Control-click**, Macintosh) the palette dock. From the context menu, select **Show All Palettes**.

Alternatively, from the main menu, select **View** $\rightarrow$ **Palettes** $\rightarrow$ **Arrange Palettes** to display specific palettes.

You can create a **Favorites** palette of the expressions and entities you use often by right-clicking (**Control-click**, Macintosh) the palette template you want to add and selecting **Add To Favorites Palette** from the context menu.
<table>
<thead>
<tr>
<th>Palette Category</th>
<th>Palette Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expression Palettes</strong></td>
<td><strong>MapleCloud</strong> - view worksheets shared by other users and share your worksheets.</td>
</tr>
<tr>
<td></td>
<td><strong>Variables</strong> - manage all of your assigned variables in your current Maple session.</td>
</tr>
<tr>
<td></td>
<td><strong>Expression</strong> - construct expressions such as integrals $\int_a^b f(x) , dx$.</td>
</tr>
<tr>
<td></td>
<td><strong>Matrix</strong> - enter the number of rows and columns required, designate type, such as zero-filled and designate shape, such as diagonal.</td>
</tr>
<tr>
<td></td>
<td><strong>Layout</strong> - add math content that has specific layout, such as expressions with one or more superscripts and subscripts $a^b$.</td>
</tr>
<tr>
<td></td>
<td><strong>Components</strong> - embed graphical interface components such as a button into your document or worksheet. Components can be programmed to perform an action when selected such as executing a command when a button is clicked.</td>
</tr>
<tr>
<td></td>
<td><strong>Handwriting</strong> - an easy way to find a desired symbol.</td>
</tr>
<tr>
<td></td>
<td><strong>Units (SI)</strong> - insert a unit from the International System of Units (SI), or any general unit $[kg]$.</td>
</tr>
<tr>
<td></td>
<td><strong>Units (FPS)</strong> - insert a unit from the Foot-Pound-Second System (FPS), or any general unit $[ft]$.</td>
</tr>
<tr>
<td></td>
<td><strong>Accents</strong> - insert decorated names, such as an $\hat{x}$ with an arrow over it to denote a vector $\vec{A}$.</td>
</tr>
<tr>
<td></td>
<td><strong>Favorites</strong> - add templates that you use most often from other palettes.</td>
</tr>
<tr>
<td></td>
<td><strong>LiveDataPlots</strong> - templates for visual representation of your data.</td>
</tr>
<tr>
<td></td>
<td><strong>eBookMetadata</strong> - markup tags</td>
</tr>
<tr>
<td>Palette Category</td>
<td>Palette Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Mathematical Palettes</strong></td>
<td>Palettes for constructing expressions</td>
</tr>
<tr>
<td>Common Symbols,</td>
<td>Common Symbols, Relational $\geq$, Relational Round $\gtrless$, Operators $\div$,</td>
</tr>
<tr>
<td>Relational Round $\gtrless$,</td>
<td>Large Operators $\emptyset$, Negated $\neq$, Fenced $\langle$, Arrows $\to$,</td>
</tr>
<tr>
<td>Operators $\div$,</td>
<td>Constants and Symbols $\infty$.</td>
</tr>
<tr>
<td><strong>Greek</strong></td>
<td>Punctuation - insert punctuation symbols, such as inserting the registered trademark</td>
</tr>
<tr>
<td><strong>Script</strong></td>
<td>and copyright symbols $\circ$ into text regions</td>
</tr>
<tr>
<td><strong>Fraktur</strong></td>
<td>Miscellaneous - insert miscellaneous math and other symbols outside the above</td>
</tr>
<tr>
<td><strong>Open Face</strong></td>
<td>categories $\square$.</td>
</tr>
<tr>
<td><strong>Cyrillic</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Diacritical Marks</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Roman Extended Upper Case</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Roman Extended Lower Case</strong></td>
<td></td>
</tr>
</tbody>
</table>

### Viewing and Arranging Palettes

By default, palettes display in palette docks at the right and left sides of the Maple window. To view and manage palettes and palette docks, see Table 1.8.
To view palette docks:

- From the **View** menu, select **Palettes**, and then **Expand Docks**. There are docks on the far right and left of the window.
To add a palette:
1. Right-click the palette dock. Maple displays a context menu near the palette.
2. From the context menu, select **Show Palette** and then select the palette.
To expand or collapse a palette in the palette dock:
• Click the triangle at the left of the palette title.

To move a palette in the palette dock:
• Move the palette by clicking the title and dragging the palette to the new location.

To expand or collapse the palette docks:
• Select the appropriate triangle at the top right or top left side of the palette region.

Example 3 - Enter an Expression Using Palettes

Review the following example:

\[
\sum_{i=1}^{10} (7i^2 - 5i) = 2420
\]
In this example, we will enter \( \sum_{i=0}^{10} (7i^2 - 5i) \) and evaluate the expression.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Place the cursor in a new document block. In the Expression palette, click the summation template ( \sum_{i=k}^{n} f(i) ). Maple inserts the summation symbol with the range variable placeholder highlighted.</td>
<td>( \sum_{i=k}^{n} f(i) )</td>
</tr>
<tr>
<td>2. Enter ( i ) and then press Tab. The left endpoint placeholder is selected. Notice that the color of the range placeholder has changed to black. Each placeholder must have an assigned value before you execute the expression. The Tab key advances you through the placeholders of an inserted palette item.</td>
<td>( \sum_{i=k}^{n} f(i) )</td>
</tr>
<tr>
<td>3. Enter ( 1 ) and then press Tab. The right endpoint placeholder is selected.</td>
<td>( \sum_{i=1}^{n} f(i) )</td>
</tr>
<tr>
<td>4. Enter ( 10 ) and then press Tab. The expression placeholder is selected.</td>
<td>( \sum_{i=1}^{10} f(i) )</td>
</tr>
<tr>
<td>5. Enter ( (7i^2 - 5i) ). For instructions on entering this type of expression, see Example 1 - Enter and Evaluate an Expression Using Keystrokes (page 7).</td>
<td>( \sum_{i=1}^{10} (7i^2 - 5i) )</td>
</tr>
<tr>
<td>6. Press Ctrl + (Command + for Macintosh) to evaluate the summation.</td>
<td>( \sum_{i=1}^{10} (7i^2 - 5i) = 2420 )</td>
</tr>
</tbody>
</table>

**Handwriting Palette**

The Handwriting palette provides another way to find and insert desired symbols easily.

1. Draw the symbol with your mouse in the space provided.

2. Click the recognize button, \( \pi \). Maple matches your input against symbols available in the system. See Figure 1.3.
3. To view more symbols (where indicated with a box around the result), click the displayed symbol and choose one of the selections from the drop-down menu.

4. To insert a symbol, click the displayed symbol.

![Handwriting Palette](image)

Figure 1.3: Handwriting Palette

For more information, refer to the **handwritingpalette** help page.

**Snippets Palettes**

You can create your own custom Snippets palettes for tasks that you find most useful. Details on how to create and customize Snippets palettes can be found on the **createpalette** help page.

**Symbol Names**

Each symbol has a name and some have aliases. By entering its name (or an alias) in Math mode, you can insert the symbol in your document. All common mathematical symbols, including all Greek characters, $\pi$, and the square root symbol ($\sqrt{}$), are recognized by Maple.

**Note:** If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.

To insert a symbol, enter the first few characters of a symbol name using a keyword that is familiar to you and then press the completion shortcut key, **Esc** (see **Shortcut Keys by Platform (page xviii)**). Symbol completion works in the same way as command completion (see **Command Completion (page 47)**).
• If a unique symbol name matches the characters entered, Maple inserts the corresponding symbol.

• If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches, including commands. To select an item, click its name or symbol.

**Example 4 - Square Root**

To find the square root of 603729:

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a new document block, enter <code>sqrt</code>.</td>
<td><code>sqrt</code></td>
</tr>
<tr>
<td>2. Press the symbol completion shortcut key, Esc. Maple displays a pop-up list of exact matches.</td>
<td><code>sqrt</code></td>
</tr>
<tr>
<td>3. In the completion list, select ( \sqrt{x} ). Maple inserts the symbol with the ( x ) placeholder selected.</td>
<td>( \sqrt{603729} )</td>
</tr>
<tr>
<td>4. Enter 603729.</td>
<td>( \sqrt{603729} = 777 )</td>
</tr>
<tr>
<td>5. Press Ctrl + = (Command + =, Macintosh).</td>
<td></td>
</tr>
</tbody>
</table>

**Example 5 - Complex Numbers**

When you simply type the letter \( i \) in Math mode, it is in italics. This letter is just a variable, and is not the same as the imaginary unit \( \sqrt{-1} \), denoted by \( 1 \) or \( i \) in Maple.

Multiply two complex numbers, \( -0.123 + 0.745i \) and \( 4.2 - i \):

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a new document block, enter ( (-0.123 + 0.745i) ).</td>
<td>( (-0.123 + 0.745i) )</td>
</tr>
<tr>
<td>2. Press the symbol completion shortcut key, Esc. Maple displays a pop-up list of partial and exact matches, including symbols and commands.</td>
<td><code>(-0.123 + 0.745i)</code></td>
</tr>
</tbody>
</table>
3. Select the imaginary unit, \( i \).

\[
(-0.123 + 0.745 i)
\]

4. Close the parentheses, enter a space (for implicit multiplication), and type the second expression in parentheses, using symbol completion for the second imaginary number.

\[
(-0.123 + 0.745 i)(4.2 - i)
\]

5. Press Ctrl+= (Command+=, Macintosh) to evaluate the product.

\[
(-0.123 + 0.745 i)(4.2 - i) = 0.2284 + 3.2520 i
\]

For more information on entering complex numbers, refer to the **HowDoI** help page.

**Toolbar Icons**

In the introduction section, you learned about the toolbar icons and context toolbars available in Maple (see Toolbar Options (page 9)). The toolbar can be used to format your document, alter plots and animations, draw in a canvas, write in both Math and Text modes in one line and much more. The last of these is demonstrated in the next example.

**Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons**

Enter the following sentence:

Evaluate \( \int_{1}^{5} \left( 3x^2 + 2\sqrt{x} + 3^3 \sqrt{x} \right) \, dx \) and write in simplest terms.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To enter this sentence:</strong></td>
<td></td>
</tr>
<tr>
<td>1. Select the Text icon and enter <strong>Evaluate</strong>.</td>
<td>![Text Icon]</td>
</tr>
<tr>
<td>2. Select the Math icon.</td>
<td>![Math Icon]</td>
</tr>
<tr>
<td>3. From the Expression palette, select the definit integration template, ( \int_{a}^{b} f(x) , dx ). The expression is displayed with the first placeholder highlighted.</td>
<td>![Expression Icon]</td>
</tr>
</tbody>
</table>

Evaluate \( \int_{1}^{5} \left( 3x^2 + 2\sqrt{x} + 3^3 \sqrt{x} \right) \, dx \) and write in simplest terms.
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>4. With the first placeholder highlighted, enter 1, then press Tab.</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>5. Enter 5 and press Tab to highlight the integrand region.</td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>6. Enter $(3x^2$ and press the right arrow to leave the superscript position.</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
<tr>
<td>7. Enter $+2$.</td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
<tr>
<td>8. Press the Space bar for implicit multiplication. Enter <code>sqrt</code> and press Esc to show the command completion options. Maple displays a pop-up list of exact matches. Select the square root symbol, $\sqrt{x}$. Maple inserts the symbol with the x placeholder selected. Alternatively, select the square root symbol from the Expression palette.</td>
<td><img src="image5.png" alt="Image" /></td>
</tr>
<tr>
<td>9. Enter $x$, then press the right arrow to leave the square root region.</td>
<td><img src="image6.png" alt="Image" /></td>
</tr>
<tr>
<td>10. Enter $+3$, and then press the Space bar.</td>
<td><img src="image7.png" alt="Image" /></td>
</tr>
<tr>
<td>11. Select the n-th root symbol from the Expression palette, $\sqrt[n]{x}$.</td>
<td><img src="image8.png" alt="Image" /></td>
</tr>
<tr>
<td>12. Enter 3, then press Tab.</td>
<td><img src="image9.png" alt="Image" /></td>
</tr>
<tr>
<td>13. Enter $x)$, then press Tab.</td>
<td><img src="image10.png" alt="Image" /></td>
</tr>
<tr>
<td>14. Enter $x$ for the integration variable.</td>
<td><img src="image11.png" alt="Image" /></td>
</tr>
<tr>
<td>15. Click the Text icon in the toolbar, then enter the rest of the sentence: &quot;and write in simplest terms.&quot;</td>
<td><img src="image12.png" alt="Image" /></td>
</tr>
</tbody>
</table>
1.4 Point-and-Click Interaction

Maple contains many built-in features that allow you to solve problems quickly without having to know any commands.

Assistants

Maple offers a set of assistants in the form of graphical user interfaces to perform many tasks without the need to use any syntax. An example of an assistant is shown in Figure 1.4.

![Optimization Assistant](image)

Figure 1.4: Optimization Assistant

Using the Tools → Assistants menu, you can access tools to help you accomplish various tasks. See Figure 1.5. In some cases, you can launch an assistant by entering an expression and selecting the assistant from the context menu that displays.
1.4 Point-and-Click Interaction

![Diagram showing the Tools Menu with options like Assistants, Tutors, Tasks, Demonstrations, Load Package, Unload Package, Spellcheck, Complete Command, Help Database, Options, and Check for Updates.](image)

**Figure 1.5: Accessing the Assistants from the Tools Menu**
Example 7 - Curve Fitting Assistant

Enter a data sample and use the Curve Fitting Assistant to find the best approximation of a function to fit the data.

**Action**

1. From the Tools menu, select Assistants → Curve Fitting. The first dialog in the Curve Fitting Assistant appears.

2. Enter data as Independent Values and Dependent Values. Alternatively, you could import a file containing data. If you have more data than the space provided, click the Next Page button for more space. For this example, enter the data as shown.
3. Once you have entered the data, click the **Fit** button. The second dialog of the **Curve Fitting Assistant** appears.

4. In this dialog, you can plot the data and several types of interpolations, including **Polynomial**, **Spline**, and **Least Squares**. For example, click the **Plot** button in the **Polynomial Interpolation** section. The polynomial is plotted with the data, and the interpolating function is displayed below.

5. You can choose to return either the interpolating function or the plot to your document. When finished click **Done**.

### Descriptions of Assistants

The remaining assistants are described below. Some of the assistants are interfaces to package commands. For more information on package commands, see [Package Commands](page 47).

- **Back-Solver** - an interface that allows you to take a mathematical formula, involving multiple parameters, enter values for all but one of the parameters and solve for the remaining value. You can also plot the behavior of the formula as one of the parameters change.

- **Curve Fitting** - an interface to commands in the **CurveFitting** package. Data points can be entered as independent and dependent values, and interpolated with polynomials, rational functions, or splines.

- **Data Analysis** - an interface to the data analysis commands in the **Statistics** package.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Once you have entered the data, click the Fit button. The second dialog of the Curve Fitting Assistant appears.</td>
<td><img src="image" alt="Curve Fitting Assistant" /></td>
</tr>
<tr>
<td>4. In this dialog, you can plot the data and several types of interpolations, including Polynomial, Spline, and Least Squares. For example, click the Plot button in the Polynomial Interpolation section. The polynomial is plotted with the data, and the interpolating function is displayed below.</td>
<td><img src="image" alt="Curve Fitting Assistant" /></td>
</tr>
<tr>
<td>5. You can choose to return either the interpolating function or the plot to your document. When finished click Done.</td>
<td><img src="image" alt="Interpolating Function" /></td>
</tr>
</tbody>
</table>

\[ -0.002762122808x^7 + 0.04971820957x^6 - 0.3259304755x^5 + 0.8949276991x^4 - 0.665671371x^3 - 0.9888404085x^2 + 1.082752470x - 0.044194 \]
• **Equation Manipulator** - an interface for interactively performing a sequence of operations on an equation. You can group terms, apply an operation to both sides of the equation, complete the square, and so on.

• **Import Data** - an interface to read data from an external file into Maple.

• **eBook Publisher** - an interface to the eBook Publisher tools.

• **Installer Builder** - an interface to the **InstallerBuilder** package in which you can create installers for your Maple toolboxes.


• **Library Browser** - an interface to manipulate the libraries in a specific directory.

• **Maplet Builder** - an interface to the **Maplets** package. The **Maplets** package contains commands for creating and displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can define the layout of a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements, and directly run a Maplet application. The Maplet Builder is available in the Standard interface only.

• **ODE Analyzer** - an interface to obtain numeric or symbolic solutions to a single ordinary differential equation (ODE) or a system of ODEs and plot a solution of the result.

• **Optimization** - an interface to the solver commands in the **Optimization** package. The **Optimization** package is a collection of commands for numerically solving optimization problems, which involves finding the minimum or maximum of an objective function possibly subject to constraints.

• **Plot Builder** - an interface for creating two and three-dimensional plots, animations, and interactive plots.

• **Scientific Constants** - an interface to over 20,000 values of physical constants and properties of chemical elements. All of these constants come with the corresponding unit and, if applicable, with the uncertainty or error, that is, how precisely the value of this constant is known.

• **Special Functions** - an interface to the properties of over 200 special functions, including the Hypergeometric, Bessel, Mathieu, Heun and Legendre families of functions.

• **Units Calculator** - an interface to convert between 500 units of measurement.

• **Worksheet Migration** - an interface to convert worksheets from Classic Maple (.mws files) to Standard Maple (.mw files).

• **CAD Link** - an interface to explore the properties of models from supported CAD applications (available on Microsoft Windows only).
Tutors

Maple provides over 40 interactive tutors to aid in the learning of

• Precalculus
• Calculus
• Multivariate Calculus
• Vector Calculus
• Differential Equations
• Linear Algebra
• Complex Variables

These tutors are easily accessible in the **Tools** menu by selecting **Tutors**. See **Figure 1.6**.

Some of the tutors can also be accessed through the **Student** package. The Differential Equations tutor, **DE Plots**, is accessible through the **DEtools** package. For a definition of the term **package**, see **Package Commands** (page 47).

The **Student** package is a collection of subpackages designed to assist with the teaching and learning of standard undergraduate mathematics. The subpackages contain many commands for displaying functions, computations, and theorems in various ways, and include support for stepping through important computations.
The **interactive** commands help you explore concepts and solve problems using a point-and-click interface. These commands launch tutors that provide a graphical interface to some of the visualization and computation commands described above. See for an example of one of the tutors.

![Figure 1.7: Calculus - Single Variable → Differentiation Methods Tutor](image)

**Math Apps**

Maple provides Math Apps that offer interactive, entertaining ways to explore precalculus concepts. The demonstrations are accessible in the *Tools* menu by selecting *Math Apps*.

For more information on the tutors, demonstrations, and related resources for mathematics education, see *Teaching and Learning with Maple* (page 194).
Context Menus

A context menu is a dynamically generated menu of actions that are applicable for the region upon which it is invoked. Context menus allow you to perform calculations and manipulations on expressions without using Maple syntax. To display a context menu, right-click an object, expression, or region. Context menus are available for many input regions, including:

- **expressions** to perform calculations, manipulations, or plotting
- **plot regions** to apply plot options and manipulate the plot
- **tables** to modify the table properties
- **palette regions** to add or remove palettes and palette regions
- **text regions** to add annotations and format text
- **spreadsheets** to manipulate the spreadsheet

When performing calculations or manipulations on an expression, a self-documenting arrow or equal sign connects the input and output, indicating the action that took place. See Figures 1.8 and 1.9 for two examples of context menus.
Task Templates

Task templates help you perform specific tasks in Maple, such as:

• performing a mathematical computation such as solving an equation symbolically or numerically, or determining the Taylor approximation of a function of one variable
• constructing a Maple object such as a function
• creating a document such as an application

Each task contains a description along with a collection of content that you can insert directly into your document. Content consists of 2-D mathematics, commands, embedded components (for example, buttons), and plots. You specify the parameters of your problem and then execute the commands in the document. See Figure 1.10 for an example of a Task Template.
To preview Maple tasks,

- From the **Tools** menu, select **Tasks**, and then **Browse**. The **Browse Tasks** dialog opens and displays the list of tasks.

The tasks are sorted by subject to help you quickly find the desired task. In the **Browse Tasks** dialog, you can view tasks without inserting them into your document.
**Inserting a Task into the Document**

To insert a task into your document,

1. Select the **Insert into New Worksheet** check box to insert the task into a new document.
2. Click one of the insert buttons.

   - Click the **Insert Default Content** button. Maple inserts the *default content*. The default content level is set using the **Options** dialog. For instructions, see the **using tasks** help page.
   - Click the **Insert Minimal Content** button. Maple inserts only the commands and embedded components, for example, a button to launch the related assistant or tutor.
   - Click the **Copy Task to Clipboard** button. Place the cursor where you want to insert the task, and then paste the task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

**Note**: You can view the history of previously inserted tasks. From the **Tools** menu, select **Tasks**. Previously selected task names are displayed below the **Browse** menu item.

Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task variable is assigned, the **Task Variables** dialog opens to allow you to modify the names. Maple uses the edited variable names for all variable instances in the inserted task.

By default, the **Task Variables** dialog is displayed only if there is a naming conflict. You can set it to display every time you insert a task.

**To specify that the Task Variables dialog be displayed every time you insert a task:**

1. From the **Tools** menu, select **Options**.
2. Click the **Display** tab.
3. In the **Show task variables on insert** drop-down list, select **Always**.
4. Click **Apply to Session** or **Apply Globally**, as necessary.

**Updating Parameters and Executing the Commands**

In inserted Task Templates, parameters are marked as placeholders (in purple text) or specific using sliders or other embedded components.

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the next placeholder by pressing **Tab**.
2. Execute all commands in the task by:
   - Placing the cursor in the first task command, and then pressing **Enter** repeatedly to execute each command.
• Selecting all the template commands, and then clicking the execute toolbar icon.

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the tasks help page.

**Exploration Assistant**

The Exploration Assistant allows you to interactively make parameter changes to expressions and view the result. The assistant can be used with almost any Maple expression or command that has at least one variable or parameter.

**To launch the Exploration Assistant:**

1. Enter an expression or command.
2. Right-click (Control-click, Macintosh) the expression or command. From the context menu, select Explore.
3. The Explore parameter selection dialog appears, where you can select the parameters to explore and the range for each parameter.

If you enter integer ranges, only integer values are allowed for parameters. To allow floating point values, enter floating-point ranges.

Select skip for any of the parameters to leave that parameter as a variable.

4. Click Explore to continue to the Exploration Assistant. The assistant opens in a new document. You can use the slider or sliders to vary the parameters and see your changes as the expression output is updated.

5. Once you are finished interacting with the assistant, you can copy and paste the results into your document, or save the interactive document for later use.
Example 8 - Use the Exploration Assistant to Explore a Plot

In this example, we will explore how the plot of \( \frac{\sin(ax) - b\cos(x)}{x} \) changes as we vary the parameters \( a \) and \( b \).

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the plot command shown.</td>
<td>( \text{plot}\left( \frac{\sin(ax) - b\cos(x)}{x}, x = 1..10 \right) )</td>
</tr>
<tr>
<td>2. Right-click (Control-click for Macintosh) the expression and select Explore.</td>
<td><img src="image" alt="Plot Example" /></td>
</tr>
<tr>
<td>3. In the Explore parameter selection dialog, set the ranges ( a = 0..10.0 ) and ( b = -5.0..5.0 ). Select floating-point computation.</td>
<td><img src="image" alt="Explore Window" /></td>
</tr>
</tbody>
</table>
1.5 Commands

Even though Maple comes with many features to solve problems and manipulate results without entering any commands, you may find that you prefer greater control and flexibility by using the set of commands and programming language that Maple offers.

The Maple Library

Commands are contained in the Maple library, which is divided into two groups: the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related commands for performing tasks from disciplines such as Student Calculus, Statistics, or Differential Geometry. For example, the Optimization package contains commands for numerically solving optimization problems.

For details on top-level and package commands, see *Commands (page 80).*

Entering Commands

If you want to interact with Maple using commands, simply enter the command using 2-D math. Notice that commands and variable names display in italics. Maple commands are constructed in a format similar to `command(arguments)`, based on the command you are using.
For example, to factor an expression, enter:

\[ \text{factor}(x^2 + 2x + 1) \]

\[ (x + 1)^2 \]

To differentiate an expression, enter:

\[ \text{diff}(\sin(x),x) \]

\[ \cos(x) \]

To integrate an expression on the interval \([0, 2\pi]\), enter:

\[ \text{int}(2x + \cos(x), x = 0 .. 2\pi) \]

\[ 4\pi^2 \]

To plot an expression, enter:

\[ \text{plot}((\sin(x))^2, x = -10 .. 10) \]

For a list of the top commands in Maple, see *Top Commands* (page 82).
Package Commands

There are two ways to access commands within a package, using the long form of the package command or the short form.

Long Form of Accessing Package Commands:

The long form specifies both the package and command names using the syntax `package[command](arguments).

\[
\text{LinearAlgebra[RandomMatrix]}(2)
\begin{bmatrix}
44 & -31 \\
92 & 67
\end{bmatrix}
\]

Short Form of Accessing Package Commands:

The short form makes all of the commands in the package available using the `with` command, `with(package)`. If you are using a number of commands in a package, loading the entire package is recommended. When you execute the `with` command, a list of all commands in the package displays. To suppress the display of all command names, end the `with(package)` command with a colon. Alternatively, you can load packages through the `Tools` menu, by selecting `Load Package`, and then the package name.

\[
\text{with(Optimization)}
\begin{bmatrix}
\text{ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPsolve, QPSolve}
\end{bmatrix}
\]

After loading a package, you can use the short-form names, that is, the command names, without the package name.

\[
\text{LSSolve}([x - 2, x - 6, x - 9])
\begin{bmatrix}
12.3333333333333322, [x = 5.6666666666666696]
\end{bmatrix}
\]

For a list of the top packages in Maple, see Top Packages (page 85).

Command Completion

To help with syntax and reduce the amount of typing when entering Maple commands, you can use command completion. Command completion displays a list of all Maple packages, commands, and functions that match the entered text. If there are multiple ways to call a command, then the command completion list contains each one, with appropriate placeholders.
To use command completion:

1. Begin entering a command or package name.

2. Select **Tools → Complete Command** or use the shortcut key **Esc** (see *Shortcut Keys by Platform* (page xviii)). If there is a unique completion, it is inserted. Otherwise, a list of possible matches is displayed.

3. Select the correct completion from the list.

4. Some inserted commands have placeholders, denoted by purple text. The first placeholder is highlighted after you insert it into the document. Replace it with your parameter, then move to the next placeholder by pressing the **Tab** key.

**Equation Labels**

Equation labels help to save time entering expressions by referencing Maple output. See Figure 1.11.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the **Tools** menu, select **Options**, and click the **Display** tab. Ensure that the **Show equation labels** check box is selected.

2. From the **Format** menu, select **Equation Labels**. Ensure that both **Execution Group** and **Worksheet** are selected.

![Figure 1.11: Equation Label](image-url)
To apply equation labels:

1. Enter an expression and press **Enter**. Note that the equation label is displayed to the right of the answer in the document.

2. In a new execution group, enter another expression that will reference the output of the previous execution group.

3. From the **Insert** menu, select **Label**. Alternatively, press **Ctrl+L** (**Command+L**, for Macintosh) to open the **Insert Label** dialog. Enter the label number in the **Insert Label** dialog and click **OK**. The item is now a label. See **Figure 1.12**.

![Inserting an Equation Label](image)

**Figure 1.12:** Inserting an Equation Label

4. Press **Enter** to obtain the result.

To change the format of equation labels:

- Select **Format → Equation Labels → Label Display**. In the **Format Labels** dialog, select one of the numbering schemes.
- Optionally, enter an appropriate numbering prefix
The **Label Reference** menu item allows you to switch between the label name and its reference content. Place the cursor on the referenced equation label and select **Format → Equation Labels → Label Reference**.

The label is associated with the last output within an execution group.

You cannot apply equation labels to the following:

- Error, warning, and information messages
- Tables, images, plots, sketches, or spreadsheets

**Document Blocks**

In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax used to perform calculations, which in turn lets you focus on the concept presented instead of the command used to manipulate or solve the problem. You can also create document blocks in Worksheet mode to perform the same function.
Document blocks are typically collapsed to hide the Maple code, but these regions can also be expanded to reveal this code.

**To create a document block:**

From the **Format** menu, select **Create Document Block**. If text or math in one or more execution groups is selected, then a document block is created that contains those execution groups. If not, a new document block is created after the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a vertical bar along the left pane of the document. See **Figure 1.15**. In addition to document block boundaries, these markers (icons) indicate the presence of hidden attributes in the document such as annotations, bookmarks, and numeric formatting.

**To activate markers:**

From the **View** menu, select **Markers**. See **Figure 1.15**.

**Figure 1.15: Document Block Markers**

**To view code in a document block:**

1. Place the cursor in a document block to be expanded.
2. From the **View** menu, select **Expand Document Block**.

**Figure 1.16: Expanded Document Block**

With the Document Block expanded, you can see the Maple command that was used to perform this calculation. In **Figure 1.16**, the `solve` command was used.
Also notice a red prompt (> ) before the original expression and the solve command. Entering commands outside of a document block region is done at this input region. To insert an input region, click the button in the toolbar menu.

In Figure 1.16, an equation label was used to refer to the expression. For more information, see Equation Labels (page 48).

To collapse a Document Block:

- With your cursor inside the document block, select View → Collapse Document Block.

You can use this process of expanding document blocks to view and edit Maple commands within a document block.

Changing the Display:

You can specify which parts of the input and output are displayed when the document block is collapsed. For each execution group in the block, you can choose to display either the input or the output.

- Place the cursor in the execution group.
- From the View menu, select Toggle Input/Output Display.

Also, you can choose to display output either inline or centered on a new line.

- From the View menu, select Inline Document Output.

Example 9 - Creating a Document Block in Worksheet Mode

In Worksheet mode, you can create the content using commands, and then use a document block to choose how much information to display.

Enter the following sentence using text and 2-D Math input and output:

The answer to \( \int \sin(x) \, dx \) is \( -\cos(x) \).

1. At an input prompt, click the text icon, \( T \), to enter plain text. Enter "The answer to ". Note: these instructions are for Worksheet mode.

2. Click the input prompt icon, > , to enter Maple commands. Enter \( \int \sin(x) \, dx \), and then press Enter to execute the command.

<table>
<thead>
<tr>
<th>The answer to ( \int \sin(x) , dx ) is ( -\cos(x) ).</th>
<th>The answer to ( \int \sin(x) , dx ) is ( -\cos(x) ).</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \int \sin(x) , dx )</td>
<td>( \int \sin(x) , dx )</td>
</tr>
<tr>
<td>( -\cos(x) )</td>
<td>( -\cos(x) )</td>
</tr>
</tbody>
</table>

(2. 3)
3. Again, click the text icon to insert the rest of the text, "is", and then enter another input prompt icon. Make sure to put spaces around all of the text, so the sentence displays properly.

\[
\int \sin(x) \, dx = -\cos(x)
\] (1.3)

4. To display the same output again, use the `value` command and an equation label. This allows you to insert text between the input and output of a single command: there are really two commands. Enter and execute the command, as shown.

\[
\text{The answer to }
\int \sin(x) \, dx
\]
\[
\text{is}
\]
\[
\text{is}
\]
\[
\text{value(1.3)}
\]
\[
\text{is}
\]
\[
\text{value(1.4)}
\] (1.3) (1.4)

5. To finish the sentence, click the text icon in the last execution group and enter a period.

\[
\int \sin(x) \, dx = -\cos(x)
\] (1.3)
\[
\text{value(1.3)}
\]
\[
\text{is}
\]
\[
\text{value(1.4)}
\] (1.3) (1.4)

6. Select the entire sentence, then from the `Format` menu, select, `Create Document Block`. By default, only the text and output remains visible, and output is centered on a new line.

\[
\text{The answer to }
\int \sin(x) \, dx
\]
\[
\text{is}
\]
\[
\text{is}
\]
\[
\text{value(1.3)}
\]
\[
\text{is}
\]
\[
\text{value(1.4)}
\] (1.3) (1.4)

7. To display the text and output on one line, place the cursor in the document block. From the `View` menu, select `Inline Document Output`.

\[
\text{The answer to } -\cos(x) \text{ is } -\cos(x).
\]

8. To display input instead of output for the first expression, place the cursor in the first expression. From the `View` menu, select `Toggle Input/Output Display`. Only the first region displays input.

\[
\text{The answer to } \int \sin(x) \, dx \text{ is } -\cos(x).
\]

1.6 The Maple Help System

The Maple program provides a custom help system consisting of almost 5000 reference pages. The help system is a convenient resource for determining the syntax of Maple commands and for learning about Maple features.

Accessing the Help System

There are several ways to access the Maple help system:

- From the `Help` menu, select `Maple Help`
- Click in the toolbar
To get help on a specific word:

- In a document, place the insertion point in a word for which you want to obtain help. From the **Help** menu, select **Help on...**. Alternatively, press **F2** (**Control + ?**, for Macintosh) to access context-sensitive help.
- In a document, execute the command **?topic**, for example, enter **?LinearAlgebra** and press **Enter**

The Maple help system opens in a separate window with two panes. The left pane contains the Help Navigator where you initiate searches and browse the table of contents, and the right pane displays the final search result, such as a specific help page.

![Sample Help Page](image)

Every help page in Maple lists the command's calling sequence, parameters, and a description, with examples of the command at the end of the page. Some help pages also contain hyperlinks to related help pages and hyperlinks to dictionary definitions. Hyperlinks to help pages display in green, while hyperlinks to dictionary definitions display in dark red.
Using the Help Navigator

The Help Navigator contains a field for topic or text-based searches. The Table of Contents tab provides a structured list of all topics in the help system.

To search the help system:
1. In the left pane, enter a string in the search field
2. By default, a topic search is performed. To perform a text search, select the Text radio button.
3. Enter the term and click Search.

- **Topic** searches reveal a list of matching topics sorted by the precision of the match.
- **Text** searches reveal a list of topics based on keyword frequency.
- You can search all of the help system or specific Resources such as Help Pages, Tasks, Tutorials, and Manuals by selecting the Resources drop-down menu.

Search results are displayed as a list in the **Search Results** tab of the left pane. Click the **Table of Contents** tab to view a structured list of all topics in the help system.

To display potential matches in the right pane, click a topic preceded by an icon. **Table 1.9** describes the different icons.

**Table 1.9: Help Page Icons**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Folder Icon" /></td>
<td>A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.</td>
</tr>
<tr>
<td><img src="image" alt="Question Mark Icon" /></td>
<td>Question mark icon indicates a help page and displays the associated help page in the right pane when selected.</td>
</tr>
<tr>
<td><img src="image" alt="WS Icon" /></td>
<td>WS icon indicates an example worksheet. Example worksheets open in a new tab in the Maple document.</td>
</tr>
<tr>
<td><img src="image" alt="Dictionary Icon" /></td>
<td>D icon indicates a definition and displays the associated dictionary definition in the right pane when selected.</td>
</tr>
<tr>
<td><img src="image" alt="Task Icon" /></td>
<td>T icon indicates a Task template and displays the associated Task Template in the right pane when selected.</td>
</tr>
</tbody>
</table>

Viewing Help Pages as Documents

In the help system, examples are not executable.

The Maple help system allows you to open help pages as documents that you can execute.
To open a help page as a document or worksheet:

- With the help page displayed in the right pane of the help system, from the View menu, select **Open Page as Worksheet**. A new worksheet tab opens and displays the help page as an executable document.

Alternatively, in the help system toolbar, click the **open current help page in a worksheet window** icon.

**Viewing Examples in 2-D Math**

You can choose to view the examples in most help pages in either 1-D Math (Maple input) or 2-D Math mode. The default is 1-D Math.

**To change the math mode:**

In the Maple help system:

- From the View menu, select or clear the **Display Examples with 2D math** check box.
- Click the 2-D Math icon, $x^2$.

**Note**: Some input in help pages displays as 1-D Math, no matter which option you have chosen. This is for Maple procedures and other code that is best input in 1-D Math. For more information, see the helpnavigator help page.

**Copying Examples**

Instead of opening the entire page as a document, you can copy the **Examples** section only.

**To copy examples:**

1. With the help page displayed in the right pane of the help system, from the Edit menu, select **Copy Examples**.
2. Close or minimize the Help Navigator and return to your document.
3. In your document, place the cursor at the location where you want to paste the examples.
4. From the Edit menu, select **Paste**. The **Examples** section of the help page is inserted as executable content in your document.

**1.7 Available Resources**

Your work with Maple is supported by numerous resources.
Resources Available through the Maple Help System

Help Pages

Use the help system to find information about a specific topic, command, package, or feature. For more information, see *The Maple Help System* (page 53).

Dictionary

More than 5000 mathematical and engineering terms with over 300 figure and plots.

1. From the Help menu, select Maple Help.
2. Enter a search term. Dictionary entries that match your query are displayed in the left pane with a icon.

Tutorials and the Maple Portal

The Maple Portal includes material designed for all Maple users, from new users to users who want more advanced tutorials. The Maple Portal also includes specific sections for students, math educators, and engineers. The Maple Portal includes:

- How Do I... topics that give quick answers to essential questions
- Tutorials that provide an overview of topics from getting started to plotting, data manipulation, and interactive application development
- Navigation to portals with specialized information for students, math educators, and engineers

Access the portal from the Help menu (Help → Manuals, Resources, and More → Maple Portal).

Applications and Example Worksheets

Applications

Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some applications allow for input or contain animations that you can run; however, their primary use is for demonstrations. Topics include DC Motor Control Design, Digital Filter Design, Frequency Domain System Identification Harmonic Oscillator, Image Processing, and Radiator Design with CAD Systems.

Examples

Example worksheets are executable documents covering topics that demonstrate syntax or invoke a user interface to make complex problems easy to solve and visualize. You can copy and modify the examples as needed. Topics include Algebra, Calculus, Connectivity, Discrete Mathematics, General Numerics and Symbolics, and Integral Transforms.
From the Help menu, select Manuals, Resources, and more, and then Applications and Examples.

**Manuals**

You can access all of Maple's manuals from within Maple, including the Maple Programming Guide and this manual. You can execute examples, copy content into other documents, and search the contents using the Maple Help System.

- From the Help menu, select Manuals, Resources, and more and then Manuals.

**Task Templates**

Set of commands with placeholders that you can use to quickly perform a task. For details, see Task Templates (page 40).

- From the Tools menu, select Tasks, and then Browse.

**Maple Tour and Quick Resources**

**Maple Tour**

The Maple Tour consists of interactive sessions on several of the following topics: Ten Minute Tour, Numeric and Symbolic Computations, Matrix Computations, Differential Equations, Statistics, Programming and Code Generation, Units and Tolerances, and Education Assessment with Maple T.A.

- From the Help menu, select Take a Tour of Maple.

**Quick Help and Quick References**

The Quick Help dialog is a list of key commands and concepts.

- From the Help menu, select Quick Help. Alternatively, press F1. For additional information, click an item in the Quick Help.

The Quick Reference is a table of commands and information for new users that opens in a new window. It contains hyperlinks to help pages for more information.

- From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Macintosh).

**Web Site Resources**

**Welcome Center**

A Maple web site offering all of Maplesoft's key user resources in one central location. In the Welcome Center, you can view sample applications, participate in user forums, access
exclusive premium content, and listen to podcasts. You can also access our support services, view training videos, download user manuals, and more.

**http://www.maplesoft.com/welcome**

**Student Help Center**

The Student Help Center offers a Maple student forum, online math Oracles, training videos, and a math homework resource guide.

**http://www.maplesoft.com/studentcenter**

**Teacher Resource Center**

The Teacher Resource Center is designed to ensure you get the most out of your Maple teaching experience. It provides sample applications, course material, training videos, white papers, e-books, podcasts, and tips.

**http://www.maplesoft.com/teachercenter**

**Application Center**

Maple web site resource for free applications related to mathematics, education, science, engineering, computer science, statistics and data analysis, finance communications, and graphics. Many applications are available in translations (French, Spanish, and German).

You can also search for Education and Research PowerTools, which provide free course curricula and are available as add-on Maple packages and courses. PowerTools are developed by experts in their field to help users configure Maple for research in specific application areas.

**http://www.maplesoft.com/applications**

**Training**

Maplesoft offers a comprehensive set of complementary training materials. From complete training videos to recorded training seminars to downloadable documentation, you have many options to get familiar with Maplesoft products. In addition, whether you are an expert or someone who is considering a new license purchase, a custom training session that is right for you and/or your organization can be created.

**http://www.maplesoft.com/support/training**

**MaplePrimes**

A web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as well as general interest topics in math and computing.
http://www.mapleprimes.com

Online Help
All of Maple's help pages are available online.

http://www.maplesoft.com/support/help

Technical Support
A Maple web site containing FAQs, downloads and service packs, links to discussion groups, and a form for requesting technical support.

http://www.maplesoft.com/support

For a complete list of resources, refer to the MapleResources help page.
2 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-modify interactive documents. You can also devise custom solutions using the Maple programming language. While you work, you can document your process, providing text descriptions.

2.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction (page 61)</td>
<td>• Comparison of Document and Worksheet Modes</td>
</tr>
<tr>
<td>Entering Expressions (page 62)</td>
<td>• Palettes</td>
</tr>
<tr>
<td>- Overview of tools for creating</td>
<td>• Symbol Names</td>
</tr>
<tr>
<td>complex mathematical expressions</td>
<td>• Mathematical Functions</td>
</tr>
<tr>
<td>Evaluating Expressions (page 65)</td>
<td>• Displaying the Value Inline</td>
</tr>
<tr>
<td>- How to evaluate expressions</td>
<td>• Displaying the Value on the Following Line</td>
</tr>
<tr>
<td>Editing Expressions and Updating</td>
<td>• Updating a Single Computation</td>
</tr>
<tr>
<td>Output (page 66)</td>
<td>• Updating a Group of Computations</td>
</tr>
<tr>
<td>- How to update expressions and</td>
<td>• Updating All Computations in a Document</td>
</tr>
<tr>
<td>regenerate results</td>
<td></td>
</tr>
<tr>
<td>Performing Computations (page 67)</td>
<td>• Computing with Palettes</td>
</tr>
<tr>
<td>- Overview of tools for performing</td>
<td>• Context Menus</td>
</tr>
<tr>
<td>computations and solving problems</td>
<td>• Assistants and Tutors</td>
</tr>
</tbody>
</table>

2.2 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of Document mode.

Document mode sample:

Find the value of the derivative of \( \ln(x^2 + 1) \) at \( x = 4 \).

\[
\ln(x^2 + 1) \quad \text{differentiate w.r.t.} \quad x \quad \frac{2x}{x^2 + 1} \quad \text{evaluate at point} \quad 8 \quad \frac{17}{17}
\]
Integrate $\sin \left( \frac{1}{x} \right)$ over the interval $[0, \pi]$.

$$
\int_0^\pi \sin \left( \frac{1}{x} \right) \, dx = \sin \left( \frac{1}{\pi} \right) \pi - Ci \left( \frac{1}{\pi} \right)
$$

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The Worksheet mode supports the features available in Document mode described in this chapter. For information on using Worksheet mode, see Chapter 3, *Worksheet Mode (page 77)*. **Note:** To enter a Maple input prompt while in Document mode, click `[>` in the Maple toolbar.

**Important:** In any Maple document, you can use Document mode and Worksheet mode.

Interactive document features include:

- Embedded graphical interface components, like buttons, sliders, and check boxes
- Automatic execution of marked regions when a file is opened
- Tables
- Character and paragraph formatting styles
- Hyperlinks

These features are described in Chapter 7, *Creating Mathematical Documents (page 281)*.

**Note:** This chapter and Chapter 1 were created using Document mode. All of the other chapters were created using Worksheet mode.

### 2.3 Entering Expressions

Chapter 1 provided an introduction to entering simple expressions in 2-D Math (see *Entering Expressions (page 18)*). It is also easy to enter mathematical expressions, such as:

- Piecewise-continuous functions: $|x| = \begin{cases} 
-x & x < 0 \\
0 & x = 0 \\
x & 0 < x
\end{cases}$

- Limits: $\delta(x) = \lim_{\epsilon \to 0} \frac{|x|^\epsilon - 1}{\epsilon}$
• Continued fractions: \[ \sqrt{2} = 1 + \frac{1}{2 + \frac{1}{2 + \cdots}} \]

and more complex expressions.

Mathematical expressions can contain the following objects.

• Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, \(i\), \(\infty\), ...

• Operators: \(+\), \(-\), \(!\), \(/\), \(\cdot\), \(\int\), \(\lim\), \(\frac{\partial}{\partial x}\), ...

• Constants: \(\pi\), \(e\), ...

• Mathematical functions: \(\sin(x)\), \(\cos\left(\frac{\pi}{3}\right)\), \(\Gamma(2)\), ...

• Names (variables): \(x, y, z, \alpha, \beta, \ldots\)

• Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding key, for example, 9, =, >, or \(x\). Most symbols are not available on the keyboard, but you can insert them easily using two methods, palettes and symbol names.

**Example 1 - Enter a Partial Derivative**

To insert a symbol, you can use palettes or symbol names.

Enter the partial derivative \(\frac{\partial}{\partial t} e^{-t^2}\) using palettes.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Expression</strong> palette, click the partial differentiation item (\frac{\partial}{\partial x}). Maple inserts the partial derivative. The variable placeholder is selected.</td>
<td>(\frac{\partial}{\partial x})</td>
</tr>
<tr>
<td>2. Enter (t), and then press <strong>Tab</strong>. The expression placeholder is selected.</td>
<td>(\frac{\partial}{\partial t})</td>
</tr>
<tr>
<td>Action</td>
<td>Result in Document</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------</td>
</tr>
<tr>
<td>3. Enter $e^{-t^2}$. <strong>Note:</strong> To enter the exponential e, use the expression palette or command completion.</td>
<td>$\frac{\partial}{\partial t} e^{-t^2}$</td>
</tr>
</tbody>
</table>

To evaluate the integral and display the result inline, press **Ctrl+=** (**Command+=**, for Macintosh) or **Enter**. For more information, see *Computing with Palettes* (page 67).

You can enter any expression using symbol names and the symbol completion list.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. Begin typing the name of the symbol, **diff**, and press the symbol completion key (see *Shortcut Keys by Platform* (page xviii)). | ![Symbol Completion](image)
| 2. Select the partial differentiation item, $\frac{\partial}{\partial x}$ | $\frac{\partial}{\partial x} e^{-t^2}$ |
| 3. Replace the placeholder with $t$. Use the right arrow to move out of the denominator. Enter $e^{-t^2}$ as in the previous example. | $\frac{\partial}{\partial t} e^{-t^2}$ |

### Example 2 - Define a Mathematical Function

Define the function *twice*, which doubles its input.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Expression</strong> palette, click the single variable function definition item, $f := a \to y$.</td>
<td>$f := a \to y$</td>
</tr>
<tr>
<td>2. Replace the placeholder $f$ with the function name, <em>twice</em>. Press <strong>Tab</strong> to move to the next placeholder.</td>
<td>twice := $a \to y$</td>
</tr>
<tr>
<td>3. Replace the parameter placeholder, $a$, with the independent variable $x$. Press <strong>Tab</strong>.</td>
<td>twice := $x \to y$</td>
</tr>
</tbody>
</table>
4. Replace the output placeholder, \( y \), with the desired output, \( 2x \).

\[
twice := x \rightarrow 2x
\]

\[
x \rightarrow 2x
\]

\[
twice(1342) = 2684
\]

\[
twice(y - z) = 2y - 2z
\]

**Note:** To insert the right arrow symbol \( \rightarrow \), you can also enter the characters \( \rightarrow \) in Math mode. In this case, symbol completion is automatic.

**Important:** The expression \( 2x \) is different from the function \( x \rightarrow 2x \).

For more information on functions, see *Functional Operators* (page 339).

### 2.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press **Ctrl + =** (**Command + =**, for Macintosh). That is, *press and hold* the **Ctrl** (or **Command**) key, and then press the equal sign (\( = \)) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99}
\]

You can replace the inserted equal sign with text or mathematical content.

**To replace the equal sign:**

1. Select the equal sign. Press **Delete**.
2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

\[
\frac{2}{9} + \frac{7}{11} \text{ is equal to } \frac{85}{99}
\]

In mathematical content, pressing **Enter** evaluates the expression and displays it centered on the following line. The cursor moves to a new line below the output.
By default, Maple labels output that is generated by pressing **Enter**. For information on equation labels, see *Equation Labels* (page 95). In this manual, labels are generally not displayed.

In text, pressing **Enter** inserts a line break.

You can use the basic algebraic operators, such as + and –, with most expressions, including polynomials—see *Polynomial Algebra* (page 148)—and matrices and vectors—see *Matrix Arithmetic* (page 166).

\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99} \tag{2.1}
\]

\[
(2x^2 - x + 1) - (x^2 + 2x + 12) = x^2 - 3x - 11
\]

\[
3 \cdot \begin{bmatrix}
-4 & 8 & 99 \\
27 & 69 & 29
\end{bmatrix}
= \begin{bmatrix}
-12 & 24 & 297 \\
81 & 207 & 87
\end{bmatrix}
\]

### 2.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are *live*. That is, you can edit expressions and quickly recalculate results.

**To update one computation:**
1. Edit the expression.
2. Press **Ctrl** + = (**Command** + =, for Macintosh) or **Enter**.

   The result is updated.

**To update a group of computations:**
1. Edit the expressions.
2. Select all edited expressions and the results to recalculate.
3. Click the Execute toolbar icon !.

   All selected results are updated.

**To update all output in a Maple document:**
- Click the Execute All toolbar icon !!
All results in the document are updated.

## 2.6 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

- Palettes
- Context menus
- Assistants and tutors

**Note:** The Document mode is designed for quick calculations, but it also supports Maple commands. For information on commands, see *Commands (page 80)* in Chapter 3, *Worksheet Mode (page 77)*.

**Important:** In Document mode, you can execute a statement *only if* you enter it in Math mode. To use a Maple command, you must enter it in Math mode.

### Computing with Palettes

As discussed in *Entering Expressions (page 62)*, some palettes contain mathematical operations.

**To perform a computation using a palette mathematical operation:**

1. In a palette that contains operators, such as the Expression palette, click an operator item.
2. In the inserted item, specify values in the placeholders.
3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.

**For example, to evaluate \( \frac{\partial}{\partial t} e^{-t^2} \) inline:**

1. Using the Expression palette, enter the partial derivative. See *Example 1 - Enter a Partial Derivative (page 63)*.
2. Press Ctrl+= (Command+=, for Macintosh).

\[
\frac{\partial}{\partial t} e^{-t^2} = -2te^{-t^2}
\]
Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 2.1.

![Figure 2.1: Context Menu]

To display the context menu for an expression:

- Right-click (Control-click, for Macintosh) the expression.

The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus. The Evaluate and Display Inline operation (see Figure 2.1) is equivalent to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value of the expression.

Alternatively, press Enter to evaluate the expression and display the result centered on the following line.

For more information on evaluation, see Evaluating Expressions (page 65).

From the context menu, you can also select operations different from evaluation. To the right of the expression, Maple inserts a right arrow symbol (→) and then the result.
For example, use the **Approximate** operation to approximate a fraction:

\[
\frac{2}{3} \quad \text{at 10 digits} \rightarrow 0.6666666667
\]

You can perform a sequence of operations by repeatedly using context menus. For example, to compute the derivative of \( \cos(x^2) \), use the **Differentiate** operation on the expression, and then to evaluate the result at a point, use the **Evaluate at a Point** operation on the output and enter 10:

\[
\cos(x^2) \xrightarrow{\text{differentiate w.r.t. } x} -2 \sin(x^2) \xrightarrow{\text{evaluate at point}} -20 \sin(100)
\]

The following subsections provide detailed instructions on performing a few of the numerous operations available using context menus. Figures in the subsections show related context menus or palettes.

**Approximating the Value of an Expression**

**To approximate a fraction numerically:**

1. Enter a fraction.
2. Display the context menu. See **Figure 2.2**.
3. From the context menu, select **Approximate**, and then the number of significant digits to use: 5, 10, 20, 50, or 100.
\[ \frac{2}{3} \text{ at 10 digits} \rightarrow 0.666666667 \]

You can replace the inserted right arrow with text or mathematical content.

**To replace the right arrow ( \( \rightarrow \))**:

1. Select the arrow and text. Press **Delete**.
2. Enter the replacement text or mathematical content.

**Note**: To replace the right arrow with text, you must first press **F5** to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol \( \approx \).

\[ \frac{2}{3} \text{ is approximately equal to } 0.666666667 \]

\[ \frac{2}{3} \approx 0.666666667 \]

**Solving an Equation**

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information on symbolic and numeric computations, see *Symbolic and Numeric Computation* (page 102).

**To solve an equation**:

1. Enter an equation.
2. Display the context menu. See **Figure 2.3**.
3. From the context menu, select **Solve** or **Numerically Solve** in the **Solve** menu item.
Figure 2.3: Finding the Approximate Solution to an Equation

\[
\frac{7x^2}{3} - \frac{x}{\pi} = 12 \quad \text{solve} \quad \left\{ \begin{array}{l}
x = \frac{3}{14} \frac{1 + \sqrt{1 + 112\pi^2}}{\pi} \\
x = -\frac{3}{14} -1 + \sqrt{1 + 112\pi^2} \end{array} \right.
\]

\[
\frac{7x^2}{3} - \frac{x}{\pi} = 12 \quad \text{solve} \quad -2.200603126, 2.337021648
\]

For more information on solving equations, including solving inequations, differential equations, and other types of equations, see Solving Equations (page 111).
Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palettes. The Units (FPS) palette (Figure 2.4) contains important units from the foot-pound-second (FPS) system of units used in the United States. The Units (SI) palette (Figure 2.5) contains important units from the international system (SI) of units.

To insert an expression with a unit:
1. Enter the expression.
2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.
To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.
2. Right-click (Control-click, for Macintosh) the expression.
3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

\[
\frac{590 \text{[C]}}{2.9 \text{[s]}} \quad \text{simplify units} \rightarrow 203.4482759 \text{[A]}
\]

For more information on using units, see Units (page 127).

**Assistants and Tutors**

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. For details on assistants and tutors, see Point-and-Click Interaction (page 32).

Assistants and tutors can be launched from the Tools menu or the context menu for an expression. For example, you can use the Linear System Solving tutor to solve a linear system, specified by a matrix or a set of equations.
Example 3 - Using a Context Menu to Open the Linear System Solving Tutor

Use the **Linear System Solving** tutor to solve the following system of linear equations, written in matrix form:

\[
\begin{bmatrix}
1 & 3 & 0 & -2 & -1 \\
4 & 2 & -1 & 5 & 7 \\
0 & -3 & 5 & 4 & -7 \\
1 & -1 & 3 & 6 & 5 \\
\end{bmatrix}
\]

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. In a new document block, create the matrix or set of linear equations to be solved. | \[
\begin{bmatrix}
1 & 3 & 0 & -2 & -1 \\
4 & 2 & -1 & 5 & 7 \\
0 & -3 & 5 & 4 & -7 \\
1 & -1 & 3 & 6 & 5 \\
\end{bmatrix}
\] |
| 2. Load the **Student[LinearAlgebra]** package. From the **Tools** menu, select **Load Package → Student Linear Algebra**. This makes the tutors in that package available. For details, see **Package Commands (page 47)**. | **Loading Student:-LinearAlgebra** |
| 3. Right-click the matrix and select **Tutors → Linear Algebra → Linear System Solving...**. The **Linear System Solving** dialog appears, where you can choose the solving method. **Gaussian Elimination** reduces the matrix to row-echelon form, then performs back-substitution to solve the system. **Gauss Jordan Elimination** reduces the matrix to reduced row-echelon form, where the equations are already solved. For this example, choose **Gaussian Elimination**. | ![Linear Algebra - Linear System Solving](image) |
4. The **Gaussian Elimination** dialog opens. You can specify the Gaussian elimination step-by-step, or you can use the **Next Step** or **All Steps** buttons to have Maple perform the steps for you.

5. Once the matrix is in row-echelon (upper-triangular) form, click the **Solve System** button to move to the next step.

6. The **Solve the system of equations in Row-Echelon Form** dialog appears. Click the buttons on the right to calculate the solution: first find the **Equations**, then solve for each variable. Click the **Solution** button to display the solution in the tutor.

7. Click the **Close** button to return the solution to your document.

For more information on linear systems and matrices, see *Linear Algebra* (page 155).
3 Worksheet Mode

The *Worksheet* mode of the Standard Worksheet interface is designed for:

- Interactive use through Maple commands, which offers advanced functionality and customized control not available using context menus or other syntax-free methods
- Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described in Chapter 1, and most of those described in Chapter 2, including:

- Math and Text modes
- Palettes
- Context menus
- Assistants and tutors

For information on these features, see Chapter 1, *Getting Started* (page 1) and Chapter 2, *Document Mode* (page 61).

**Note:** Using a document block, you can use all Document mode features in Worksheet mode. For information on document blocks, see *Document Blocks* (page 50).

**Note:** This chapter and the following chapters except Chapter 7 were created using Worksheet mode.

### 3.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| *Input Prompt* (page 78) - Where you enter input | • The Input Prompt (>)
|                                | • Suppressing Output                                                  |
|                                | • 2-D and 1-D Math Input                                              |
|                                | • Input Separators                                                    |

| *Commands* (page 80) - Thousands of routines for performing computations and other operations | • The Maple Library
|                                                                                       | • Top-Level Commands
|                                                                                       | • Package Commands
|                                                                                       | • Lists of Common Commands and Packages

| *Palettes* (page 86) - Items that you can insert by clicking or dragging | • Using Palettes |

| *Context Menus* (page 88) - Pop-up menus of common operations | • Using Context Menus |
### 3.2 Input Prompt

In Worksheet mode, you enter input at the Maple *input prompt* (>). The default mode for input is Math mode *(2-D Math)*.

To evaluate input:

- Press **Enter**.

Maple displays the result (output) below the input.

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assistants and Tutors (page 90)- Graphical interfaces with buttons and sliders</td>
<td>• Launching Assistants and Tutors</td>
</tr>
</tbody>
</table>
| Task Templates (page 90) - Sets of commands with placeholders that you can insert and use to perform a task | • Viewing Task Templates  
• Inserting a Task Template  
• Performing the Task |
| Text Regions (page 92) - Areas in the document in which you can enter text | • Inserting a Text Region  
• Formatting Text |
| Names (page 92) - References to the expressions you assign to them | • Assigning to Names  
• Unassigning Names  
• Valid Names |
| Equation Labels (page 95) - Automatically generated labels that you can use to refer to expressions | • Displaying Equation Labels  
• Referring to a Previous Result  
• Execution Groups with Multiple Outputs  
• Label Numbering Schemes  
• Features of Equation Labels |
For example, to find the value of $\sin^3\left(\frac{\pi}{3}\right)$, enter the expression, and then press Enter.

\[
> \sin^3\left(\frac{\pi}{3}\right)
\]

\[
\frac{3}{8}\sqrt{3}
\]

(3.1)

For example, compute the sum of two fractions.

\[
> \frac{2}{9} + \frac{7}{11}
\]

\[
\frac{85}{99}
\]

(3.2)

**Suppressing Output**

To suppress the output, enter a colon (:) at the end of the input.

\[
> \frac{2}{9} + \frac{7}{11}:
\]

A set of Maple input and its output are referred to as an *execution group*.

**1-D Math Input**

You can also insert input using Text mode (*1-D Math*). The input is entered as a one-dimensional sequence of characters. 1-D Math input is red.

**To enter input using 1-D Math:**

- At the input prompt, press F5 or click the Text button in the toolbar, to switch from 2-D Math to 1-D Math.

\[
> 123^2 - 29857/120;
\]

\[
\frac{1785623}{120}
\]

**Important:** 1-D Math input must end with a semicolon or colon. If you use a semicolon, Maple displays the output; if you use a colon, Maple suppresses the output.

\[
> 123^2 - 29857/120:
\]
To set the default input mode to 1-D Math:
1. From the Tools menu, select Options. The Options dialog is displayed.
2. On the Display tab, in the Input display drop-down list, select Maple Notation.
3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:
1. Select the 2-D Math input.
2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you enter it in Math mode.

Input Separators
In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

> \( \sqrt{4.4} ; \tan(3.2) \)

\[
\begin{align*}
2.097617696 \\
0.05847385446
\end{align*}
\]

If you do not specify a semicolon or colon, Maple interprets it as a single input. This can either give unexpected results, as below, or an error.

> \( \sqrt{4.4} \tan(3.2) \)

\[
0.1226557919
\]

3.3 Commands
Maple contains a large set of commands and a powerful programming language. Most Maple commands are written using the Maple programming language.

You can enter commands using 1-D or 2-D Math. You must use 1-D Math input when programming in Maple. Basic Programming (page 365) provides an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use task templates. For more information, see The Maple Help System (page 53) and Task Templates (page 90).
The Maple Library

Maple's commands are contained in the Maple library. There are two types of commands: top-level commands and package commands.

- The top-level commands are the most frequently used Maple commands.
- Packages contain related specialized commands in areas such as calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the index help pages. To access the index overview help page, enter ?index, and then press Enter. For information on the Maple Help System, see The Maple Help System (page 53).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (()) containing any parameters. This is referred to as a calling sequence for the command.

command( arguments )

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the diff command. The required parameters are the expression to differentiate, which must be specified first and the independent variable.

> diff(tan(x) sin(x), x)

\[ (1 + \tan(x)^2) \sin(x) + \tan(x) \cos(x) \]

For a complete list of functions (commands that implement mathematical functions), such as BesselI and AiryAi, available in the library, refer to the initialfunctions help page.

> BesselI(0.1, 1)

AiryAi(2.2)

47.53037086

For detailed information on the properties of a function, use the FunctionAdvisor command.
For detailed information on how to use a function in Maple, refer to its help page.

For example:

> ?Bessel

**Note:** In 1-D and 2-D Math input, when accessing a help page using ?, you do not need to include a trailing semicolon or colon.

### Top Commands

Here are a few of the most frequently used Maple commands. A complete list of top-level commands is available at Help → Manuals, Resources, and more → List of Commands.

<table>
<thead>
<tr>
<th>Command Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot and plot3d</td>
<td>Create a two-dimensional and three-dimensional plot of functions.</td>
</tr>
<tr>
<td>solve</td>
<td>Solve one or more equations or inequalities for their unknowns.</td>
</tr>
<tr>
<td>fsolve</td>
<td>Solve one or more equations using floating-point arithmetic.</td>
</tr>
<tr>
<td>eval</td>
<td>Evaluate an expression at a given point.</td>
</tr>
<tr>
<td>evalf</td>
<td>Numerically evaluate expressions.</td>
</tr>
<tr>
<td>dsolve</td>
<td>Solve ordinary differential equations (ODEs).</td>
</tr>
<tr>
<td>int</td>
<td>Compute an indefinite or definite integral.</td>
</tr>
<tr>
<td>diff</td>
<td>Compute an ordinary or partial derivative, as the context dictates.</td>
</tr>
<tr>
<td>limit</td>
<td>Calculate the limiting value of a function.</td>
</tr>
<tr>
<td>sum</td>
<td>For symbolic summation. It is used to compute a closed form for an indefinite or definite sum.</td>
</tr>
<tr>
<td>assume/is</td>
<td>Set variable properties and relationships between variables. Similar functionality is provided by the assuming command.</td>
</tr>
<tr>
<td>assuming</td>
<td>Compute the value of an expression under assumptions.</td>
</tr>
<tr>
<td>simplify</td>
<td>Apply simplification rules to an expression.</td>
</tr>
<tr>
<td>factor</td>
<td>Factor a polynomial.</td>
</tr>
</tbody>
</table>
### Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed in square brackets ([ ]).

\[
\text{package[command](arguments)}
\]

If you are frequently using the commands in a package, load the package.

**To load a package:**

- Use the `with` command, specifying the package as an argument.

The `with` command displays a list of the package commands loaded (unless you suppress the output by entering a colon at the end of the calling sequence).

After loading a package, you can use the short form names of its commands. That is, you can enter the commands without specifying the package name.
For example, use the `NLPSolve` command from the `Optimization` package to find a local minimum of an expression and the value of the independent variable at which the minimum occurs.

```maple
> Optimization[NLPSolve](sin(x)/x, x = 1 .. 15)

[-0.0913252028230576718, [x = 10.9041216700744900]]
```

```maple
> with(Optimization);

[ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]
```

```maple
> NLPSolve(sin(x)/x, x = 1 .. 15)

[-0.0913252028230576718, [x = 10.9041216700744900]]
```

For more information on optimization, see `Optimization (page 184)`.

To unload a package:
- Use the `unwith` command, specifying the package as an argument.

```maple
> unwith(Optimization)
```

Alternatively, use the `restart` command. The restart command clears Maple's internal memory. The effects include unassigning all names and unloading all packages. For more information, refer to the `restart` help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between examples.

Some packages contain commands that have the same name as a top-level command. For example, the `plots` package contains a `changecoords` command. Maple also contains a top-level `changecoords` command.

```maple
> with(plots) :
```

After the plots package is loaded, the name `changecoords` refers to the `plots[changecoords]` command. To use the top-level `changecoords` command, unload the package or use the restart command. (For alternative methods of accessing the top-level command, see the `rebound` help page.)
Top Packages

Here are a few of the most frequently used Maple packages. A complete list of packages is available in the Maple help system at Help → Manuals, Resources, and more → List of Packages.

Table 3.2: Top Packages

<table>
<thead>
<tr>
<th>Package Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CodeGeneration</td>
<td>The Code Generation package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages, such as C, C#, Fortran, MATLAB®, Visual Basic®, and Java™.</td>
</tr>
<tr>
<td>LinearAlgebra</td>
<td>The Linear Algebra package contains commands to construct and manipulate Matrices and Vectors, and solve linear algebra problems. LinearAlgebra routines operate on three principal data structures: Matrices, Vectors, and scalars.</td>
</tr>
<tr>
<td>Optimization</td>
<td>The Optimization package is a collection of commands for numerically solving optimization problems, which involve finding the minimum or maximum of an objective function possibly subject to constraints.</td>
</tr>
<tr>
<td>Physics</td>
<td>The Physics package implements computational representations and related operations for most of the objects used in mathematical physics computations.</td>
</tr>
<tr>
<td>RealDomain</td>
<td>The Real Domain package provides an environment in which Maple assumes that the basic underlying number system is the field of real numbers instead of the complex number field.</td>
</tr>
<tr>
<td>ScientificConstant</td>
<td>The Scientific Constants package provides access to the values of various physical constants, for example, the velocity of light and the atomic weight of sodium. This package provides the units for each of the constant values, allowing for greater understanding of an equation. The package also provides units-matching for error checking of the solution.</td>
</tr>
<tr>
<td>ScientificErrorAnalysis</td>
<td>The Scientific Error Analysis package provides representation and construction of numerical quantities that have a central value and an associated uncertainty (or error), which is a measure of the degree of precision to which the quantity's value is known. Various first-order calculations of error analysis can be performed with these quantities.</td>
</tr>
<tr>
<td>Statistics</td>
<td>The Statistics package is a collection of tools for mathematical statistics and data analysis. The package supports a wide range of common statistical tasks such as quantitative and graphical data analysis, simulation, and curve fitting.</td>
</tr>
</tbody>
</table>
The Student package is a collection of subpackages designed to assist with teaching and learning standard undergraduate mathematics. The many commands display functions, computations, and theorems in various ways, including stepping through important computations.

The Student package contains the following subpackages:
- Calculus1 - single-variable calculus
- LinearAlgebra - linear algebra
- MultivariateCalculus - multivariate calculus
- NumericalAnalysis - numerical analysis
- PreCalculus - precalculus
- VectorCalculus - multivariate vector calculus

The Units package contains commands for unit conversion and provides environments for performing calculations with units. It accepts approximately 300 distinct unit names (for example, meters and grams) and over 550 units with various contexts (for example, standard miles and U.S. survey miles). Maple also contains two Units palettes that allow you to enter the unit for an expression quickly.

The VectorCalculus package is a collection of commands that perform multivariate and vector calculus operations. A large set of predefined orthogonal coordinate systems is available. All computations in the package can be performed in any of these coordinate systems. It contains a facility for adding a custom but orthogonal coordinate system and using that new coordinate system for your computations.

### 3.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. For example, see Figure 3.1.
Figure 3.1: Expression Palette

You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item in the Expression palette.

In 2-D Math, clicking the definite integration item inserts:

\[
\int_a^b f(x) \, dx
\]

1. Enter values in the placeholders. To move to the next placeholder, press \textit{Tab}. \textbf{Note:} If pressing the \textit{Tab} key inserts a tab, click the Tab icon in the toolbar.

2. Evaluate the integral, press \textit{Enter}.

\[
\int_0^1 \tanh(x) \, dx
\]

\[-\ln(2) + \ln( e^{-1} + e )\]

In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.
> int(f, x=a..b);

Specify the problem values (using the Tab to move to the next placeholder), and then press Enter.

> int(tanh(x), x = 0..1);

\[-\ln(2) + \ln(e^{-1} + e)\]

Note: Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes on page 21 in Chapter 1.

### 3.5 Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 3.2.

> 946929

![Figure 3.2: Integer Context Menu](image)

In Worksheet mode, you can use context menus to perform operations on 2-D Math and output.
To use a context menu:
1. Right-click (Control-click, for Macintosh) the expression. The context menu is displayed.
2. From the context menu, select an operation.

Maple inserts a new execution group containing:
• The calling sequence that performs the operation
• The result of the operation

Example - Using Context Menus

Determine the rational expression (fraction) that approximates the floating-point number $0.3463678 + 1.7643$.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter and execute the expression.</td>
<td>&gt; $0.3463678 + 1.7643$</td>
</tr>
<tr>
<td></td>
<td>[ 2.1106678 ] (3.3)</td>
</tr>
<tr>
<td>2. Right-click (Control-click, for Macintosh) the output floating-point number.</td>
<td>2.1106678</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Context Menu" /></td>
</tr>
<tr>
<td>3. From the context menu, select Conversions → Rational.</td>
<td>&gt; <code>convert(3.3,'rational')</code></td>
</tr>
<tr>
<td></td>
<td>[ \frac{32270}{15289} ]</td>
</tr>
</tbody>
</table>

Notice that an equation label reference has been used. For information on equation labels and equation label references, see *Equation Labels* (page 95).

For more information on context menus, see *Context Menus* (page 68) in Chapter 2.
3.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. See Figure 3.3.

![Figure 3.3: ODE Analyzer Assistant](image)

**Launching an Assistant or Tutor**

To launch an assistant or tutor:
1. Open the Tools menu.
2. Select Assistants or Tutors.
3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see Assistants (page 32) in Chapter 1.

3.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the commands, or click a button.

The Task Browser (Figure 3.4) organizes task templates by subject.

**To launch the Task Browser:**
- From the Tools menu, select Tasks, and then Browse.
You can also browse the task templates in the Table of Contents of the Maple Help System.

![Image: Task Browser](image)

**Figure 3.4: Task Browser**

For details on inserting and using task templates, see *Task Templates (page 40)*. You can also create your own task templates for performing common tasks. For details, refer to the *creatingtasks* help page.
3.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

• In the toolbar, click the Text region icon  

The default mode in a text region is Text mode.

In a text region, you can:

• Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text mode and Math mode, press F5 or click the Math and Text toolbar icons,  

  Note: The mathematical content in a text region is not evaluated. To enter mathematical content that is evaluated, enter it at an Input Prompt (page 78).

• Insert any palette item. Palette items are inserted in Math mode (2-D Math). Note: After you insert a palette item, you must press F5 or click the toolbar icon to return to Text mode.

You can format text in a text region. Features include:

• Character styles
• Paragraph styles
• Sections and subsections
• Tables

For more information on formatting documents, see Creating Mathematical Documents (page 281).

3.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a name or add an equation label to it. Then you can quickly refer to the expression using the name or an equation label reference. For information on labels, see the following section, Equation Labels (page 95).

Note: Through the Variable Manager you can manage the top-level assigned variables currently active in your Maple Session. For more information about the Variable Manager, see the Variable Manager help page.
Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

> a

a

The assignment operator (:=) associates an expression with a name.

> a := π

a := π

Recall that you can enter \( \pi \) using the following two methods.

- Use the Common Symbols palette
- In 2-D Math enter \( pi \), and then press the symbol completion shortcut key. See Shortcuts for Entering Mathematical Expressions (page 6).

When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:

> cos(a)

-1

For information on Maple evaluation rules, see Evaluating Expressions (page 353).

Mathematical Functions

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

> cube := x → x^3

For information on creating functions, see Example 2 - Define a Mathematical Function (page 64).
> \textit{cube}(3); \textit{cube}(1.666)

\begin{align*}
27 \\
4.624076296
\end{align*}

\textbf{Note}: To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol \(\rightarrow\). In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.

\begin{align*}
> \textit{square} := x \rightarrow x^2: \\
> \textit{square}(32);
\end{align*}

1024

For more information on functions, see \textit{Functional Operators (page 339)}.

\textbf{Protected Names}

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.

\begin{align*}
> \textit{sin} := 2 \\
\text{Error, attempting to assign to} \ `\textit{sin}` \text{ which is protected}
\end{align*}

For more information, refer to the \texttt{type/proTECTED} and \texttt{protect} help pages.

\textbf{Unassigning Names}

The \texttt{unassign} command resets the value of a name to itself. \textbf{Note}: You must enclose the name in right single quotes (' ').

\begin{align*}
> \texttt{unassign( 'a')}
\end{align*}

\begin{align*}
> a
\end{align*}

\(a\)

Right single quotes (\textit{unevaluation quotes}) prevent Maple from evaluating the name. For more information on unevaluation quotes, see \textit{Delaying Evaluation (page 361)} or refer to the \texttt{uneVAL} help page.

See also \textit{Unassigning a Name Using Unevaluation Quotes (page 362)}.
Unassigning all names:

The **restart** command clears Maple's internal memory. The effects include unassigning all names. For more information, refer to the **restart** help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between examples.

**Valid Names**

A Maple name must be one of the following.

- A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character. **Note:** To enter an underscore character in 2-D Math, enter a backslash character followed by an underscore character, that is, \\_.

- A sequence of characters enclosed in left single quotes (` `).

**Important:** Do not begin a name with an underscore character. Maple reserves names that begin with an underscore for use by the Maple library.

Examples of valid names:

- a
- a1
- polynomial
- polynomial1\_divided\_by\_polynomial2
- `2a`
- `x y`

**3.10 Equation Labels**

Maple marks the output of each execution group with a unique equation label.

**Note:** The equation label is displayed to the right of the output.

\[
> \int \sin(x) \, dx \\
\quad \quad \quad -\cos(x) \\
\text{(3.4)}
\]

Using equation labels, you can refer to the result in other computations.
Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both of the following operations.

• From the Format menu, select Equation Labels, and then ensure that Worksheet is selected.
• In the Options dialog (Tools→Options), on the Display tab, ensure that Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to refer to a previous result, insert an equation label reference.

To insert an equation label reference:

1. From the Insert menu, select Label. (Alternatively, press Ctrl+L; Command+L, Macintosh.)
2. In the Insert Label dialog (see Figure 3.5), enter the label value, and then click OK.

![Insert Label Dialog](image)

Figure 3.5: Insert Label Dialog

Maple inserts the reference.
For example:

To integrate the product of (3.4) and (3.5):

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the Expression palette, click the indefinite integration item $\int f , dx$. The item is inserted and the integrand placeholder is highlighted.</td>
<td>$\int f , dx$</td>
</tr>
</tbody>
</table>
| 2. Press Ctrl+L (Command+L, for Macintosh).  
3. In the Insert Label dialog, enter 3.4. Click OK. | $\int f \, dx$ |
| 4. Press *.  
5. Press Ctrl+L (Command+L, for Macintosh).  
6. In the Insert Label dialog, enter 3.4. Click OK. | $(3.4) (3.5) \, dx$ |
| 7. To move to the variable of integration placeholder, press Tab.  
8. Enter x.  
9. To evaluate the integral, press Enter. | $(3.4) \cdot (3.5) \, dx$  
$- \frac{1}{2} \cos(x)^2$  
(3.6) |

**Execution Groups with Multiple Outputs**

An equation label is associated with the last output within an execution group.
Label Numbering Schemes

You can number equation labels in two ways:

- **Flat** - Each label is a single number, for example, 1, 2, or 3.
- **Sections** - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

- From the **Format** menu, select **Equation Labels → Label Display**. In the **Format Labels** dialog (Figure 3.6), select one of the formats.
- Optionally, enter a prefix

\[
\begin{align*}
\text{> } & \int \sin(x) \, dx \\
\text{= } & \left[-\cos(x)\right]_0^{\pi} \\
\text{> } & \int \text{f(Question1)} \, dx
\end{align*}
\]

Figure 3.6: Format Labels Dialog: Adding a Prefix
Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.

- Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.
- Maple labels the output values sequentially. If you remove or insert an output, Maple automatically re-numbers all equation labels and updates the label references.
- If you change the equation label format (see Label Numbering Schemes (page 98)), Maple automatically updates all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 92).

For more information on equation labels, refer to the equationlabel help page.

The following chapters describe how to use Maple to perform tasks such as solving equations, producing plots and animations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where noted, all features are available in both Worksheet mode and Document mode.
4 Basic Computations

This chapter discusses key concepts related to performing basic computations with Maple. It discusses important features that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve problems in specific mathematical disciplines in the following chapter.

4.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Symbolic and Numeric Computation (page 102)</em>- An overview of exact and floating-point computation</td>
<td>• Exact Computations</td>
</tr>
<tr>
<td></td>
<td>• Floating-Point Computations</td>
</tr>
<tr>
<td></td>
<td>• Converting Exact Quantities to Floating-Point Values</td>
</tr>
<tr>
<td></td>
<td>• Sources of Error</td>
</tr>
<tr>
<td><em>Integer Operations (page 106)</em> - How to perform integer computations</td>
<td>• Important Integer Commands</td>
</tr>
<tr>
<td></td>
<td>• Non-Base 10 Numbers</td>
</tr>
<tr>
<td></td>
<td>• Finite Rings and Fields</td>
</tr>
<tr>
<td></td>
<td>• Gaussian Integers</td>
</tr>
<tr>
<td><em>Solving Equations (page 111)</em> - How to solve standard mathematical equations</td>
<td>• Equations and Inequalities</td>
</tr>
<tr>
<td></td>
<td>• Ordinary Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Partial Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Integer Equations</td>
</tr>
<tr>
<td></td>
<td>• Integer Equations in a Finite Field</td>
</tr>
<tr>
<td></td>
<td>• Linear Systems</td>
</tr>
<tr>
<td></td>
<td>• Recurrence Relations</td>
</tr>
</tbody>
</table>
### 4.2 Symbolic and Numeric Computation

**Symbolic computation** is the mathematical manipulation of expressions involving symbolic or abstract quantities, such as variables, functions, and operators; and exact numbers, such as integers, rationals, π, and e². The goal of such manipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood formulas.

**Numeric computation** is the manipulation of expressions in the context of finite-precision arithmetic. Expressions involving exact numbers, for example, \( \sqrt{2} \), are replaced by close approximations using floating-point numbers, for example 1.41421. These computations generally involve some error. Understanding and controlling this error is often of as much importance as the computed result.
In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a decimal point) or the `evalf` command. The `plot` command (see Plots and Animations (page 237)) uses numeric computation, while commands such as `int`, `limit`, and `gcd` (see Integer Operations (page 106) and Mathematical Problem Solving (page 147)) generally use only symbolic computation to achieve their results.

**Exact Computations**

In Maple, integers, rational numbers, mathematical constants such as \( \pi \) and \( \infty \), and mathematical structures such as matrices with these as entries are treated as exact quantities. Names, such as `x`, `y`, `my_variable`, and mathematical functions, such as `\sin(x)` and `\text{LambertW}(k, z)`, are symbolic objects. Names can be assigned exact quantities as their values, and functions can be evaluated at symbolic or exact arguments.

\[
\frac{3}{2} + \frac{1}{3} , 1 + \frac{\pi}{2} \quad \frac{11}{6} , 1 + \frac{1}{2} \pi
\]

**Important:** Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approximations, as you normally obtain from a standard hand-held calculator.

\[
\sin(1), \sin(\pi), \sin(x) \\
\sin(1), 0, \sin(x)
\]

\[
\int \tan(t) \, dt \\
-\ln(\cos(t))
\]

\[
\sqrt{32} \\
4\sqrt{2}
\]

**Floating-Point Computations**

In some situations, a numeric approximation of an exact quantity is required. For example, the `plot` command requires the expression it is plotting to evaluate to numeric values that can be rendered on the screen: \( \pi \) cannot be so rendered, but 3.14159 can be. Maple distin-
guishes *approximate* from *exact* quantities by the presence or absence of a decimal point:

1.9 is approximate, while \( \frac{19}{10} \) is exact.

**Note:** An alternative representation of floating-point numbers, called *e-notation*, may not include an explicit decimal point: \( 1e5 = 100000 \), \( 3e-2 = .03 \).

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric approximations. Arithmetic involving mixed exact and floating point quantities results in a floating-point result.

\[
> 1.5 + \frac{2}{3}
\]

\[
2.16666667
\]

If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approximation of the result.

\[
> \sin(1.5), \int_{0}^{1.0} e^x \, dx
\]

\[
0.9974949866, 1.718281828
\]

**Converting Exact Quantities to Floating-Point Values**

To convert an exact quantity to a numeric approximation of that quantity, use the `evalf` command or the Approximate context menu operation (see *Approximating the Value of an Expression (page 69)*).

\[
> \text{evalf}(\pi), \text{evalf}(\sin(3)), \text{evalf}\left(\frac{3}{2} + \frac{1}{3}\right)
\]

\[
3.141592654, 0.1411200081, 1.833333333
\]

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

- *Locally*, you can pass the precision as an index to the `evalf` call.

\[
> \text{evalf}[20](\exp(2)), \text{evalf}\left(\Gamma\left(\frac{2}{3}\right)\right)
\]

\[
7.3890560989306502272, 1.354117939
\]

- *Globally*, you can set the value of the `Digits` environment variable.
For more information, see the evalf and Digits help pages.

**Note:** When appropriate, Maple performs floating-point computations directly using your computer's underlying hardware.

### Sources of Error

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject of active research in *Numerical Analysis*. Some sources of error are:

- An exact quantity may not be exactly representable in decimal form: \( \frac{1}{3} \) and \( \pi \) are examples.
- Small errors can accumulate after many arithmetic operations.
- Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the computation \( x - \sin(x) \) for \( x \approx 0 \).

\[
> (x - \sin(x)) \bigg|_{x = .00001} \\
0.
\]

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a representation that is more accurate for small values of \( x \), a fully accurate 10-digit result can be obtained.

\[
> t := taylor(x - \sin(x), x) \\
t := \frac{1}{6} x^3 - \frac{1}{120} x^5 + O(x^6)
\]

\[
> t \bigg|_{x = 0.00001} \\
1.666666667 \times 10^{-16}
\]
For information on evaluating an expression at a point, see *Substituting a Value for a Subexpression (page 353)*. For information on creating a series approximation, see *Series (page 178)*. For more information on floating-point numbers, refer to the `float` and `type/float` help pages.

### 4.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the greatest common divisor (GCD) of a pair of integers.

**Note:** Many integer operations are available as task templates ([Tools→Tasks→Browse](Tools→Tasks→Browse), under **Integer Operations**).

You can quickly perform many integer operations using context menus. Selecting an integer, and then right-clicking (for Macintosh, **Control**-clicking) displays a context menu with integer commands. For example, the context menu item **Integer Factors** applies the `ifactor` command to compute the prime factorization of the given integer. See **Figure 4.1**.

![Figure 4.1: Context Menu for an Integer](9469629)
The result of applying Integer Factors is shown:

> 9469629

9469629

(4.1)

> ifactor((4.1))

\((3^4 \cdot 13 \cdot 17 \cdot 23^2)\)

(4.2)

Maple inserts the command ifactor, using an equation label reference to the integer 946929. For more information on equation labels, see Equation Labels (page 95).

For more information on using context menus in Worksheet mode, see Context Menus (page 88). For information on using context menus in Document mode, see Context Menus (page 68).

Maple has many other integer commands, including those listed in Table 4.1.

Table 4.1: Select Integer Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs</td>
<td>absolute value (displays in 2-D math as (</td>
</tr>
<tr>
<td>factorial</td>
<td>factorial (displays in 2-D math as (a!))</td>
</tr>
<tr>
<td>ifactor</td>
<td>prime factorization</td>
</tr>
<tr>
<td>igcd</td>
<td>greatest common divisor</td>
</tr>
<tr>
<td>iquo</td>
<td>quotient of integer division</td>
</tr>
<tr>
<td>irem</td>
<td>remainder of integer division</td>
</tr>
<tr>
<td>iroot</td>
<td>integer approximation of nth root</td>
</tr>
<tr>
<td>isprime</td>
<td>test primality</td>
</tr>
<tr>
<td>isqrt</td>
<td>integer approximation of square root</td>
</tr>
<tr>
<td>max, min</td>
<td>maximum and minimum of a set</td>
</tr>
<tr>
<td>mod</td>
<td>modular arithmetic (See Finite Rings and Fields (page 109).)</td>
</tr>
<tr>
<td>numtheory[divisors]</td>
<td>set of positive divisors</td>
</tr>
</tbody>
</table>
Non-Base 10 Numbers and Other Number Systems

Maple supports:
- Non-base 10 numbers
- Finite ring and field arithmetic
- Gaussian integers

Non-Base 10 Numbers

To represent an expression in another base, use the `convert` command.

```plaintext
> convert(6000,'binary')
1011101110000

> convert(34271,'hex')
85DF
```

For information on enclosing keywords in right single quotes ('), see *Delaying Evaluation* (page 361).

You can also use the `convert/base` command.

```plaintext
> convert(34271,'base', 16)
[15, 13, 5, 8]
```
Note: The convert/base command returns a list of digit values in order of increasing significance.

**Finite Rings and Fields**

Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.

```maple
> 27 mod 4

3
```

By default, the mod operator uses positive representation (modp command). Symmetric representation is available using the mods command.

```maple
> modp(27, 4)

3
```

```maple
> mods(27, 4)

-1
```

For information on setting symmetric representation as the default, refer to the mod help page.

The modular arithmetic operators are listed in Table 4.2.

**Table 4.2: Modular Arithmetic Operators**

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>&gt; 7 + 6 mod 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>&gt; mods(3 - 16, 11)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiplication (displays in 2-D Math as ⋅)</td>
<td>*</td>
<td>&gt; 13 ⋅ 5 mod 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiplicative inverse (displays in 2-D Math as a superscript)</td>
<td>^(-1)</td>
<td>&gt; 3^(-1) mod 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Operation Table

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Division (displays in 2-D Math as ( \frac{a}{b} ))</td>
<td>( / )</td>
<td>( \frac{2}{3} \mod 5 ) 4</td>
</tr>
<tr>
<td>Exponentiation(^1)</td>
<td>( &amp;^\wedge )</td>
<td>( (100&amp;^\wedge100)\mod 7 ) 2</td>
</tr>
</tbody>
</table>

\(^1\)To enter a caret (^) in 2-D Math, enter a backslash character followed by a caret, that is, \( \text{\textbackslash}^ \). For information on solving an equation modulo an integer, see *Integer Equations in a Finite Field (page 125)*.

The **mod** operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information, refer to the **mod** help page.

### Gaussian Integers

Gaussian integers are complex numbers in which the real and imaginary parts are integers.

The **GaussInt** package contains commands that perform Gaussian integer operations.

The **GIfactor** command returns the Gaussian integer factorization.

\[ > \text{GaussInt}[\text{GIfactor}](173 + 16 i) \]

\[ (1 + 2 i) (41 - 66 i) \]

In Maple, complex numbers are represented as \( a+b\times i \), where the uppercase I represents the imaginary unit \( \sqrt{-1} \).

You can also enter the imaginary unit using the following two methods.

- In the **Common Symbols** palette, click the I, i or j item. See *Palettes (page 21)*.
- Enter i or j, and then press the symbol completion key. See *Symbol Names (page 28)*.

Note that the output will still be displayed with I, no matter what symbol was used for input.

You can customize Maple's settings to use a different symbol for \( \sqrt{-1} \). For more information on entering complex numbers, including how to customize this setting, refer to the **HowDoI** help page.

The **Glsqrt** command approximates the square root in the Gaussian integers.
> GaussInt[GIsqrt](9 - 5 j)

3 - 1

For more information on Gaussian integers including a list of GaussInt package commands, refer to the GaussInt help page.

4.4 Solving Equations

You can solve a variety of equation types, including those described in Table 4.3.

Table 4.3: Overview of Solution Methods for Important Equation Types

<table>
<thead>
<tr>
<th>Equation Type</th>
<th>Solution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equations and inequations</td>
<td>solve and fsolve commands</td>
</tr>
<tr>
<td>Ordinary differential equations</td>
<td>ODE Analyzer Assistant (and dsolve command)</td>
</tr>
<tr>
<td>Partial differential equations</td>
<td>pdsolve command</td>
</tr>
<tr>
<td>Integer equations</td>
<td>isolve command</td>
</tr>
<tr>
<td>Integer equations in a finit  fiel</td>
<td>msolve command</td>
</tr>
<tr>
<td>Linear integral equations</td>
<td>intsolve command</td>
</tr>
<tr>
<td>Linear systems</td>
<td>LinearAlgebra[LinearSolve] command</td>
</tr>
<tr>
<td>Recurrence relations</td>
<td>rsolve command</td>
</tr>
</tbody>
</table>

Note: Many solve operations are available in context menus and as task templates (Tools→Tasks→Browse). Most of this section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

To solve an equation or set of equations using context menus:
1. Right-click (for Macintosh, Control-click) the equations.
2. From the context menu, select Solve (or Solve Numerically). See Figure 4.2.
In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.

If you select Solve, Maple computes exact solutions.
If you select Solve Numerically, Maple computes floating-point solutions.

\[
\frac{7}{3} x^2 - x = 12
\]

> solve( \{ (4.3) \} )

\[
\left\{ x = \frac{3}{14} + \frac{3}{14} \sqrt{113} \right\}, \left\{ x = \frac{3}{14} - \frac{3}{14} \sqrt{113} \right\}
\]

If you select Solve Numerically, Maple computes floating-point solutions.

\[
\frac{7}{3} x^2 - x = 12
\]

> fsolve( \{ (4.5) \} )

\[
\{ x = -2.063602674 \}, \{ x = 2.492174103 \}
\]

For information on solving equations and inequations symbolically using the solve command, see the following section. For information on solving equations numerically using the fsolve command, see Numerically Solving Equations (page 116).

**Symbolically Solving Equations and Inequalities**

The solve command is a general solver that determines exact symbolic solutions to equations or inequations. The solutions to a single equation or inequation are returned as an expression sequence. For details, see Creating and Using Data Structures (page 333). If Maple does not find any solutions, the solve command returns the empty expression sequence.

> solve( \{ x^2 + 3 x + 14 = 0 \} )

\[
-\frac{3}{2} + \frac{1}{2} i \sqrt{47}, -\frac{3}{2} - \frac{1}{2} i \sqrt{47}
\]

In general, solve computes solutions in the field of complex numbers. To restrict the problem to only real solutions, see Restricting the Domain (page 141).

It is recommended that you verify the solutions returned by the solve command. For details, see Working with Solutions (page 118).

To return the solutions as a list, enclose the calling sequence in brackets ([ ]).
Expressions: You can specify expressions instead of equations. The `solve` command automatically equates them to zero.

\[
>\ [\text{solve}(x^2 + x = 256 y, x)]
\]

\[
\left[\frac{-1}{2} + \frac{1}{2} \sqrt{1 + 1024 y}, \ -\frac{1}{2} - \frac{1}{2} \sqrt{1 + 1024 y}\right]
\]

**Expressions:** You can specify expressions instead of equations. The `solve` command automatically equates them to zero.

\[
>\ \text{solve}(e^x + z)
\]

- LambertW(1)

**Multiple Equations:** To solve multiple equations or inequations, specify them as a `Creating and Using Data Structures (page 333)`.

\[
>\ \text{solve}([x y^2 - y = 5, x > 0])
\]

\[
\left\{x = \frac{y + 5}{y^2}, \ \frac{y + 5}{y^2} = \frac{y + 5}{y^2}, \ 0 < y\right\}, \ \left\{x = \frac{y + 5}{y^2}, \ \frac{y + 5}{y^2} = \frac{y + 5}{y^2}, \ -5 < y, y < 0\right\}
\]

\[
>\ \text{solve}([x y^2 - y = 5, x < 0])
\]

\[
\left\{x = \frac{y + 5}{y^2}, \ \frac{y + 5}{y^2} = \frac{y + 5}{y^2}, \ y < -5\right\}
\]

**Solving for Specific Unknowns:** By default, the `solve` command returns solutions for all unknowns. You can specify the unknowns for which to solve.

\[
>\ \text{solve}(q^2 - rs + \frac{q}{r} = 5, q)
\]

\[
\frac{1}{2} - \frac{1}{2} + \frac{1 + 4 r^3 s + 20 r^2}{r}, \ -\frac{1}{2} + \frac{1 + 4 r^3 s + 20 r^2}{r}
\]

To solve for multiple unknowns, specify them as a list.
Transcendental Equations: In general, the solve command returns one solution to transcendental equations.

\[
> \text{solve}(\left\{ \frac{q}{s} - \frac{r}{s + 1} + \frac{q}{r} = 5, rs = 1 \right\}, [q, r])
\]

\[
\begin{bmatrix}
\left[ q = \frac{5s^2 + 1 + 5s}{s + 1 + s^2 + s^2}, r = \frac{1}{s} \right]
\end{bmatrix}
\]

To produce all solutions, use the allsolutions option.

\[
> \text{solve}(\text{equation1}, \text{allsolutions} = \text{true})
\]

\[
\frac{1}{4} \pi + \pi \_Z1\_~
\]

Maple uses variables of the form \_ZN~, where N is a positive integer, to represent arbitrary integers. The tilde (~) indicates that it is a quantity with an assumption. For information about names with assumptions, see Assumptions on Variables (page 142).

RootOf Structure: The solve command may return solutions, for example, to higher order polynomial equations, in an implicit form using RootOf structures.

\[
> \text{solve}(x^5 - 2x^4 + 3x^3 - 2)
\]

\[
[1, \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, \text{index} = 1), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, \text{index} = 2), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, \text{index} = 3), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, \text{index} = 4)]
\]

These RootOf structures are placeholders for the roots of the equation \(x^4 - x^3 + 2x^2 + 2x + 2\). The index parameter numbers and orders the four solutions.

Like any symbolic expression, you can convert RootOf structures to a floating-point value using the evalf command.
Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do not in general have a solution in terms of radicals. If the `solve` command does not find any solutions, it is recommended that you use the Maple numerical solver, `fsolve`. For information, see the following section, Numerically Solving Equations.

For more information on the `solve` command, including how to solve equations defined as procedures and how to find parametric solutions, refer to the `solve/details` help page.

For information on verifying and using solutions returned by the `solve` command, see Working with Solutions (page 118).

**Numerically Solving Equations**

The `fsolve` command solves equations numerically. The behavior of the `fsolve` command is similar to that of the `solve` command.

\[
\text{example:}\quad \text{evalf((4.7))}
\]

\[
[1.0, 0.984001051867989 + 1.52659083388421 \times 10^{-9}, -0.484001051867989 + 6.09947140486231 \times 10^{-9}, -0.484001051867989 - 6.09947140486231 \times 10^{-9}, 0.984001051867989 - 1.52659083388421 \times 10^{-9}]
\]

Note: You can also numerically solve equations using the context menus. See Solving Equations and Inequalities (page 111).

It is recommended that you verify the solutions returned by the `fsolve` command. For details, see Working with Solutions (page 118).

**Multiple Equations:** To solve multiple equations, specify them as a set. For more information, see Creating and Using Data Structures (page 333). The `fsolve` command solves for all unknowns.

\[
\text{example:}\quad \text{fsolve}(\{\ln(x) = y^2 + 1, xy = e^y\})
\]

\[
\{x = 3.396618823, y = 0.4719962637\}
\]

**Univariate Polynomial Equations:** In general, the `fsolve` command finds one real solution. However, for a univariate polynomial equation, the `fsolve` command returns all real roots.

\[
\text{example:}\quad \text{equation3 := y^4 - 3y^2 - 2y + 1:}
\]
Controlling the Number of Solutions: To limit the number of roots returned, specify the \texttt{maxsols} option.

\begin{verbatim}
> fsolve(equation3, y)
\end{verbatim}

\begin{verbatim}
0.3365322739, 1.940392664
\end{verbatim}

To find additional solutions to a general equation, use the \texttt{avoid} option to ignore known solutions.

\begin{verbatim}
> fsolve(equation3, y, \texttt{maxsols'= 1})
\end{verbatim}

\begin{verbatim}
0.3365322739
\end{verbatim}

Complex Solutions: To search for a complex solution or find all complex and real roots for a univariate polynomial, specify the \texttt{complex} option for the \texttt{fsolve} command.

\begin{verbatim}
> fsolve(equation3, y, 'complex')
\end{verbatim}

\begin{verbatim}
-1.13846246879373 - 0.4850624940594351 \text{I}, -1.13846246879373 + 0.4850624940594351 \text{I}, 0.336532273926790, 1.94039266366067
\end{verbatim}

If the \texttt{fsolve} command does not find any solutions, it is recommended that you specify a range in which to search for solutions, or specify an initial value.

Range: To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.

\begin{verbatim}
> fsolve(equation2, z, \texttt{\{z= (4 . 8) \}})
\end{verbatim}

\begin{verbatim}
-2.498755763
\end{verbatim}

Initial Values: You can specify a value for each unknown. The \texttt{fsolve} command uses these as initial values for the unknowns in the numerical method.
> \texttt{fsolve(equation2, \{z=100\})}

\begin{align}
\{z = 98.98037599\} & \quad (4.9)
\end{align}

For more information and examples, refer to the \texttt{fsolve/details} help page.

For information on verifying and using solutions returned by the \texttt{fsolve} command, see the following section, \textit{Working with Solutions}.

\textbf{Working with Solutions}

\textbf{Verifying:} It is recommended that you always verify solutions (that the \texttt{solve} and \texttt{fsolve} commands return) using the \texttt{eval} command.

> \texttt{equation4 := sin(x) = -cos(x):}

> \texttt{solve(equation4)}

\begin{align}
-\frac{1}{4} \pi & \quad (4.10)
\end{align}

> \texttt{eval(equation4, x = (4.10))}

\begin{align}
-\frac{1}{2} \sqrt{2} = -\frac{1}{2} \sqrt{2} & \quad (4.11)
\end{align}

> \texttt{equation5 := cos(z) = \frac{2}{z}:}

> \texttt{fsolve(equation5)}

\begin{align}
-2.498755763 & \quad (4.12)
\end{align}

> \texttt{eval(equation5, \{z = (4.12)\})}

\begin{align}
-0.8003983544 = -0.8003983540 & \quad (4.13)
\end{align}

For more information, see \textit{Substituting a Value for a Subexpression (page 353)}.

\textbf{Assigning the Value of a Solution to a Variable:} To assign the value of a solution to the corresponding variable as an \textit{expression}, use the \texttt{assign} command.

For example, consider the numeric solution in \texttt{(4.9), \\{z = 98.98037599\}}, found using the starting value \texttt{z = 100}.

> \texttt{assign((4.9))}
Creating a Function from a Solution: The `assign` command assigns a value as an expression to a name. It does not define a function. To convert a solution to a function, use the `unapply` command.

Consider one of the solutions for `q` to the equation \( q^2 - rs + \frac{q}{r} = 5 \).

\[
\text{> solutions} := \left[ \text{solve} \left( q^2 - rs + \frac{q}{r} = 5, q \right) \right]
\]

\[
solutions := \left[ \frac{1}{2} \left( -1 + \sqrt{1 + 4 r^3 s + 20 r^2} \right), \frac{1}{2} \left( 1 + \sqrt{1 + 4 r^3 s + 20 r^2} \right) \right]
\]

\[
\text{> f} := \text{unapply(solutions[1], r, s)}
\]

\[
f := (r, s) \mapsto \frac{1}{2} \frac{-1 + \sqrt{1 + 4 r^3 s + 20 r^2}}{r}
\]

Here, `solutions[1]` selects the first element of the list of solutions. For more information on selecting elements, see Accessing Elements (page 334).

You can evaluate this function at symbolic or numeric values.

\[
\text{> f(x, y)}
\]

\[
\frac{1}{2} \frac{-1 + \sqrt{1 + 4 x^3 y + 20 x^2}}{x}
\]

\[
\text{> f}\left( \frac{1}{\sqrt{2}}, 1 \right)
\]

\[
\frac{1}{2} \sqrt{2} \left( -1 + \sqrt{11 + \sqrt{2}} \right)
\]

\[
\text{> f}(5.7, 2.1)
\]

\[
4.032680522
\]

For more information on defining and using functions, see Functional Operators (page 339).
Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations including:

- Ordinary differential equations (ODEs)
- Partial differential equations (PDEs)
- Integer equations
- Integer equations in a finite field
- Linear systems
- Recurrence relations

Ordinary Differential Equations (ODEs)

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and numerically.

**ODE Analyzer Assistant** The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving routines.

To open the ODE Analyzer:

- From the Tools menu, select Assistants, and then ODE Analyzer.

Maple inserts the `dsolve[interactive]()` calling sequence in the document. The ODE Analyzer Assistant (Figure 4.3) is displayed.

![ODE Analyzer Assistant](Image)

Figure 4.3: ODE Analyzer Assistant
In the main **ODE Analyzer Assistant** window, you can define ODEs, initial or boundary value conditions, and parameters. To define derivatives, use the `diff` command. For example, `diff(x(t), t)` corresponds to \( \frac{dx(t)}{dt} \), and `diff(x(t), t, t)` corresponds to \( \frac{d^2x(t)}{dt^2} \). For more information on the `diff` command, see *The diff Command (page 175).*

After defining an ODE, you can solve it numerically or symbolically.

**To solve a system numerically using the ODE Analyzer Assistant:**

1. Ensure that the conditions guarantee uniqueness of the solution.
2. Ensure that all parameters have fixed values.
3. Click the **Solve Numerically** button.
4. In the **Solve Numerically** window (Figure 4.4), you can specify the numeric method and relevant parameters and error tolerances to use for solving the problem.
5. To compute solution values at a point, click the **Solve** button.
To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the **Solve Symbolically** button.
2. In the **Solve Symbolically** window (Figure 4.5), you can specify the method and relevant method-specific options to use for solving the problem.
3. To compute the solution, click the **Solve** button.
When solving numerically or symbolically, you can view a plot of the solution by clicking the Plot button.

- To plot the solution to a symbolic problem, all conditions and parameters must be set.
- To customize the plot, click the Plot Options button to open the Plot Options window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the Show Maple commands check box.

You can control the return value of the ODE Analyzer using the On Quit, Return drop-down list. You can select to return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic solutions), or the Maple commands needed to produce the solution values and the displayed plot.
For more information, refer to the **ODEAnalyzer** help page.

**The dsolve Command**

The ODE Analyzer provides a point-and-click interface to the Maple `dsolve` command.

For ODEs or systems of ODEs, the `dsolve` command can find
- Closed form solutions
- Numerical solutions
- Series solutions

In addition, the `dsolve` command can find
- Formal power series solutions to linear ODEs with polynomial coefficient
- Formal solutions to linear ODEs with polynomial coefficient

To access all available functionality, use the `dsolve` command directly. For more information, refer to the `dsolve` help page.

**Partial Differential Equations (PDEs)**

To solve a PDE or PDE system symbolically or numerically, use the `pdsolve` command. PDE systems can contain ODEs, algebraic equations, and inequations.

For example, solve the following PDE symbolically. For help entering a partial derivative, see *Example 1 - Enter a Partial Derivative (page 63)*.

```maple
> x * (D[2](f)(x, y)) - y * (D[1](f)(x, y)) = 0
> x * (D[2](f)(x, y)) - y * (D[1](f)(x, y)) = 0
(4.14)

> pdsolve((4.14))

f(x, y) = _F1(x^2 + y^2)
```

The solution is an arbitrary univariate function applied to $x^2 + y^2$.

Maple generally prints only the return value, errors, and warnings during a computation. To print information about the techniques Maple uses, increase the `infolevel` setting for the command.

To return all information, set `infolevel` to 5.
Checking arguments ...

First set of solution methods (general or quase general solution)
Second set of solution methods (complete solutions)
Trying methods for first order PDEs
Second set of solution methods successful

\[ f(x, y) = _F1(x^2 + y^2) \]

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the `pdsolve` help page.

**Integer Equations**

To find only integer solutions to an equation, use the `isolve` For more information, refer to the `isolve` help page.

\[ > \text{isolve}\{x^2 + y = 13\}\]

\[ \{x = \mathbb{Z}, y = -\mathbb{Z}^2 + 13\} \]

**Integer Equations in a Finite Field**

To solve an equation modulo an integer, use the `msolve` For more information, refer to the `msolve` help page.

\[ > \text{msolve}\{\{x^2 = 1\}, 13\}\]

\[ \{x = 1\}, \{x = 12\} \]

**Solving Linear Systems**

To solve a linear system, use the `LinearAlgebra[LinearSolve]` For more information, refer to the `LinearAlgebra[LinearSolve]` help page.
For example, construct an augmented matrix using the **Matrix** palette (see *Creating Matrices and Vectors* (page 156)) in which the first four columns contain the entries of $A$ and the final column contains the entries of $B$.

```
> linearsystem :=
\begin{bmatrix}
59 & 44 & 17 & 1 & 1 \\
10 & 25 & 2 & 100 & 2 \\
1 & 0 & 7 & \frac{533}{100} & \frac{61}{50} \\
98 & 21 & 3 & \frac{7}{10} & \frac{2178}{25} \\
23 & 9 & 12 & \frac{51}{10} & \frac{786}{25}
\end{bmatrix}
```

```maple
> LinearAlgebra[LinearSolve](linearsystem)
\begin{bmatrix}
31753441047 \\
41858667400 \\
16991806239 \\
8371733480 \\
-1489266217 \\
1674346696 \\
262603866 \\
209293337
\end{bmatrix}
```

For more information on using Maple to solve linear algebra problems, see *Linear Algebra* (page 155).

**Solving Recurrence Relations**

To solve a recurrence relation, use the **rsolve** command. For more information, refer to the **rsolve** help page.

```maple
> rsolve({f(n)=f(n-1)+f(n-2),f(0)=1,f(1)=1},{f(n)})
\begin{bmatrix}
f(n) = \left(-\frac{1}{10}\sqrt{5} + \frac{1}{2}\right) \left(-\frac{1}{2}\sqrt{5} + \frac{1}{2}\right)^n + \left(\frac{1}{10}\sqrt{5} + \frac{1}{2}\right) \left(\frac{1}{2} + \frac{1}{2}\sqrt{5}\right)^n
\end{bmatrix}
```
4.5 Units, Scientific Constants, and Uncertainty

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

Units

The Units package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible so that you can add units and unit systems as required.

Note: Some unit operations are available as task templates (see Tools→Tasks→Browse) and through context menus.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and independent are known as base dimensions.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of substance, luminous intensity, information, and currency. For a complete list, enter and execute Units[GetDimensions]().

Complex dimensions (or composite dimensions) measure other quantities in terms of a combination of base dimensions. For example, the complex dimension force is a measurement of \( \frac{mass \cdot length}{time^2} \).

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure a complex dimension.) Maple supports over 40 units of length, including feet, miles, meters, angstroms, microns, and astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

Table 4.4 lists some dimensions, their corresponding base dimensions, and example units.
Table 4.4: Sample Dimensions

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Base Dimensions</th>
<th>Example Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>time</td>
<td>second, minute, hour, day, week, month, year, millennium, blink, lune</td>
</tr>
<tr>
<td>Energy</td>
<td>$\frac{length^2 \cdot mass}{time^2}$</td>
<td>joule, electron volt, erg, watt hour, calorie, Calorie, British thermal unit</td>
</tr>
<tr>
<td>Electric potential</td>
<td>$\frac{length^2 \cdot mass}{time^3 \cdot electric current}$</td>
<td>volt, abvolt, statvolt</td>
</tr>
</tbody>
</table>

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding help page, for example, the **Units/length** help page for the units of length.

Each unit has a *context*. The context differentiates between different definition of the unit. For example, the standard and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the context for a unit by appending the context as an index to the unit, for example, **mile[US_survey]**. If you do not specify a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or *système international*, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound, and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI, the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed, magnetic flux, and power are the meter/second, weber, and watt, respectively.

**Unit Conversions**

To convert a value measured in a unit to the corresponding value in a different unit, use the **Units Calculator**.

- From the Tools→Assistants menu, select **Units Calculator**.

The **Units Calculator** application (Figure 4.6) opens.
Figure 4.6: Units Calculator Assistant

**To perform a conversion:**
1. In the **Convert** text field enter the numeric value to convert.
2. In the **Dimension** drop-down list, select the dimensions of the unit.
3. In the **From** and **To** drop-down lists, select the original unit and the unit to which to convert.
4. Click **Perform Unit Conversion**.

The same conversion can be done with the **convert/units** command.

```plaintext
> convert(1.0, 'units', 'lb*ft(radius)', 'N*m(radius)')
1.355817948
```

Using the **Units Calculator**, you can convert temperatures and temperature changes.

- To perform a temperature conversion, in the **Dimension** drop-down list, select temperature(absolute).
- To perform a temperature change conversion, in the **Dimension** drop-down list, select temperature(relative).

To convert temperature changes, the **Units Calculator** uses the **convert/units** command. For example, an increase of 32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.
To convert absolute temperatures, the Unit Converter uses the `convert/temperature` command. For example, 32 degrees Fahrenheit corresponds to 0 degrees Celsius.

```plaintext
> convert(32, 'temperature', 'degF', 'degC')
0
```

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 4.7) contains important units from the foot-pound-second system of units. The Units (SI) palette (Figure 4.8) contains important units from the international system of units.

![Units (FPS) Palette](image1)

![Units (SI) Palette](image2)

To insert a unit:
- In a Units palette, click a unit symbol.
To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol \([\text{unit}]\). Maple inserts a Unit object with the placeholder selected.
2. In the placeholder, enter the unit name (or symbol).

For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.

\[> 0.01 [\text{mile}]\]

The context of a unit is displayed only if it is not the default context.

**Important:** In 1-D Math input, the quantity and unit (entered using the top-level Unit command) are a product, not a single entity. The following calling sequences define different expressions.

\[> 1*Unit(m)/(2*Unit(s)); \quad > 1*Unit(m)/2*Unit(s);\]

\[
\frac{1}{2} \text{ [m]} \quad \frac{1}{2} \text{ [m]} \text{ [s]}
\]

Some units support prefixe. For more information, refer to the Units/prefixe help page.

\[> 1.5 [\text{km}_{\text{SI}}]\]

**Performing Computations with Units**

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform only unit conversions. For more information about the default environment, refer to the Units/default help page.

To compute with expressions that have units, you must load a Units environment, Natural or Standard. It is recommended that you use the Standard environment.

\[> \text{with(Units[Standard])} :\]

In the Standard Units environment, commands that support expressions with units return results with the correct units.
> area := 3[ft] \cdot \frac{1}{8} [mile]

\[
area := \frac{14370939}{78125} [m^2]
\]

> \( -12 \sin(x) + x^2 \) [m]

\[
\frac{(-12 \sin(x) + x^2)}{[s]}
\]

(4.15)

> \text{int}(4.15), x[s])

\[
12 \cos(x) + \frac{1}{3} x^3 [m]
\]

(4.16)

> \text{diff}(4.16), x[s])

\[
(-12 \sin(x) + x^2) \frac{m}{s}
\]

For information on differentiation and integration, see *Calculus (page 172).*

**Changing the Current System of Units**

If a computation includes multiple units, all units are expressed using units from the current system of units.

> 132.25[mile]

\[
132.25 [mi]
\]

(4.17)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.

> \( 4.17 \)

\[
\frac{19.70701333}{[s]}
\]

(4.17)

To view the name of the default system of units, use the Units[UsingSystem] command.

> with(Units):
To change the system of units, use the `Units[UseSystem]` command.

\[ (4.17) \cdot 3\, [m] \cdot 1.1\, [kg] \]

\[ 1.666720741 \times 10^7 \, [f^2 lb] \]

**Extensibility**

You can extend the set of:

- Base dimensions and units
- Complex dimensions
- Complex units
- Systems of units

For more information, refer to the `Units[AddBaseUnit]`, `Units[AddDimension]`, `Units[AddUnit]`, and `Units[AddSystem]` help pages.

For more information about units, refer to the `Units` help page.

**Scientific Constants and Element Properties**

Computations often require not only units (see Units (page 127)), but also the values of scientific constants, including properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-in constants and add custom constants.

**Overview of Scientific Constants and Element Properties**

The `ScientificConstant` package provides the values of constant physical quantities, for example, the velocity of light and the atomic weight of sodium. The `ScientificConstant` package also provides the units for the constant values, allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the `ScientificConstant` package are divided into two distinct categories.

- Physical constants
- Chemical element (and isotope) properties
Scientific Constants

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 4.5 lists some of the supported constants. For a complete list of scientific constants, refer to the ScientificConstants/PhysicalConstant help page.

Table 4.5: Scientific Constants

<table>
<thead>
<tr>
<th>Name</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Newtonian constant of gravitation</td>
<td>G</td>
</tr>
<tr>
<td>Planck constant</td>
<td>h</td>
</tr>
<tr>
<td>elementary charge</td>
<td>e</td>
</tr>
<tr>
<td>Bohr radius</td>
<td>a[0]</td>
</tr>
<tr>
<td>deuteron magnetic moment</td>
<td>mu[d]</td>
</tr>
<tr>
<td>Avogadro constant</td>
<td>N[A]</td>
</tr>
<tr>
<td>Faraday constant</td>
<td>F</td>
</tr>
</tbody>
</table>

You can specify a constant using either its name or symbol.

Accessing Constant Definition

The GetConstant command in the ScientificConstants package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol G (or its name) in a call to the GetConstant command.

> with(ScientificConstants):

> GetConstant('G')

*Newtonian_constant_of_gravitation, symbol = G, value = 6.673 10^{-11}, uncertainty*

* = 1.0 10^{-13}, units = \( \frac{m^3}{kg \ s^2} \)

For information on accessing a constant's value, units, or uncertainty, see Value, Units, and Uncertainty (page 136).

Element Properties

Maple also contains element properties and isotope properties.
Elements

Maple supports all 117 elements of the periodic table. Each element has a unique name, atomic number, and chemical symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the `ScientificConstants/element` help page.

Maple supports key element properties, including atomic weight (`atomicweight`), electron affinity (`electronaffinit`), and density. For a complete list of element properties, refer to the `ScientificConstants/properties` help page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the `GetIsotopes` command.

```maple
> GetIsotopes('element' = 'Li')

Li_4, Li_5, Li_6, Li_7, Li_8, Li_9, Li_{10}, Li_{11}, Li_{12}
```

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy (`bindingenergy`), and mass excess (`massexcess`). For a complete list of isotope properties, refer to the `ScientificConstants/properties` help page.

Accessing an Element or Isotope Property Definition

The `getElement` command in the `ScientificConstants` package returns the complete definition of an element or isotope.
Value, Units, and Uncertainty

To use constants or element properties, you must first construct a `ScientificConstant` object.

To construct a scientific constant, use the `Constant` command.

```maple
> Constant('G')
```

To construct an element (or isotope) property, use the `Element` command.

```maple
> LiAtomicWeight := Element('Li', atomicweight)
```

Value

To obtain the value of a `ScientificConstant` object, use the `evalf` command.
Note: The value returned depends on the current system of units.

Units

To obtain the units for a \texttt{ScientificConstant} object, use the \texttt{GetUnit} command.

\begin{verbatim}
> GetUnit(G)  
\left[ \frac{ft^3}{lb s^2} \right]
\end{verbatim}

\begin{verbatim}
> GetUnit(LiAtomicWeight)  
[\text{lb}]
\end{verbatim}

For information on changing the default system of units, for example, from SI to foot-pound-second, see \textit{Changing the Current System of Units (page 132)}.

Value and Units

If you are performing computations with units, you can access the value and units for a \texttt{ScientificConstant} object by specifying the \texttt{units} option when constructing the object, and then evaluating the object.

\begin{verbatim}
> evalf(Constant('G', units))  
1.068912061 \times 10^{-9} \left[ \frac{ft^3}{lb s^2} \right]
\end{verbatim}

\begin{verbatim}
> evalf(Element('Li[5]', atomicmass, units))  
1.835022162 \times 10^{-26} [lb]
\end{verbatim}
Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an associated uncertainty. To obtain the uncertainty in the value of a `ScientificConstant` object, use the `GetError` command.

```
> GetError(G)
1.0 \times 10^{-13}

> GetError(LiAtomicWeight)
3.321080400 \times 10^{-30}
```

Performing Computations

You can use constant values in any computation. To use constant values with units, use a `Units` environment as described in *Performing Computations with Units* (page 131). For information on computing with quantities that have an uncertainty, see the following section.

Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the `ScientificConstants[ModifyConstant]` and `ScientificConstants[ModifyElement]` help pages.

You can extend the set of:

- Constants
- Elements (and isotopes)
- Element (or isotope) properties


For more information about constants, refer to the `ScientificConstant` help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the `ScientificErrorAnalysis` package, you can propagate the uncertainty in these values through the computation to indicate the possible error in the final result.

The `ScientificErrorAnalysis` package does not perform interval arithmetic. That is, the error of an object does not represent an interval in which possible values must be contained.
(To perform interval arithmetic, use the Tolerances) The quantities represent unknown values with a central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences or engineering. For more information, refer to the Tolerances help page.

**Quantities with Uncertainty**

**Creating:** To construct quantities with uncertainty, use the `Quantity` command. You must specify the value and uncertainty. The uncertainty can be define absolutely, relatively, or in units of the last digit. For more information on uncertainty specification refer to the ScientificErrorAnalysis[Quantity] help page.

The output displays the value and uncertainty of the quantity.

\[
\text{Quantity}(105, 1.2)
\]

\[
\text{Quantity}(105, 3.15)
\]

To specify the error in units of the last digit, the value must be of floating-point type.

\[
\text{Quantity}(105.0, 12,'uld')
\]

To access the value and uncertainty of a quantity with uncertainty, use the `evalf` and ScientificErrorAnalysis[GetError] commands.

\[
\text{evalf}(4.18)
\]

105.

\[
\text{GetError}(4.18)
\]

3.15

**Rounding:** To round the error of a quantity with uncertainty, use the ApplyRule command. For a description of the predefined rounding rules, refer to the ScientificErrorAnalysis/rules help page.
Units: Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties in the ScientificConstant packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the Quantity calling sequence.

For an absolute error, you must specify the units in both the value and error.

\[
\text{Quantity}(3.5 \, [m], 0.1 \, [m])
\]

For a relative error, you can specify the units in only the value.

\[
\text{Quantity}(3.5 \, [m], 0.35 \, [m])
\]

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to the ScientificErrorAnalysis help page.

Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.

\[
q1 := \text{Quantity}(31., 2.):
\]

\[
q2 := \text{Quantity}(20., 1.):
\]

Compute the value of the derivative of \( q1 \cdot x^2 + \sin(q2 \cdot x) \) at \( x = \sin\left( \frac{\pi}{4} \right) \).

\[
\text{diff}\left( q1 \cdot x^2 + \sin(q2 \cdot x), x \right)
\]

\[
d1 := 2 \, \text{Quantity}(31., 2.) \, x + \cos(\text{Quantity}(20., 1.) \, x) \, \text{Quantity}(20., 1.)
\]

\[
d2 := \text{eval}\left( d1, x = \sin\left( \frac{\pi}{4} \right) \right)
\]
To convert the solution to a single quantity with uncertainty, use the `combine/errors` command.

```plaintext
> result := combine(d2,'errors');
```

The value of the result is:

```plaintext
> evalf(result)
```

43.74124725

The uncertainty of the result is:

```plaintext
> GetError(result)
```

14.42690612

**Additional Information**

For information on topics including:

- Creating new rounding rules,
- Setting the default rounding rule, and
- Creating a new interface to quantities with uncertainty,

refer to the *Scientific Error or Analysis* help page.

### 4.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.

**Real Number Domain**

To force Maple to perform computations in the field of real numbers, use the `RealDomain` package.

The `RealDomain` package contains a small subset of Maple commands related to basic precalculus and calculus mathematics, for example, `arccos`, `limit`, and `log`, and the symbolic manipulation of expressions and formulae, for example, `expand`, `eval`, and `solve`. For a complete list of commands, refer to the `RealDomain` help page.
After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results appropriate to the field of real numbers.

\[
> \text{with(RealDomain)}:
\]

\[
> \text{simplify}\left(\sqrt{x^2}\right)
\]

\[|x|\]

\[
> \text{ln(e}^x)\]

\[x\]

Some commands that generally return NULL instead return a numeric result when you use the RealDomain package.

\[
> (\text{-32})^{\left(\frac{1}{5}\right)}
\]

\[-2\]

Complex return values are excluded or replaced by undefined.

\[
> \text{solve}(x^2 = -1)
\]

\[
> \text{arcsin}(e^2)
\]

\[\text{undefined}\]

**Assumptions on Variables**

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can impose assumptions using the assume command. To apply assumptions for a single computation, use the assuming command.

**Note:** The assume and assuming commands are not supported by the RealDomain package.

**The assume Command**

You can use the assume command to set variable properties, for example, \( x::\text{real} \), and relationships between variables, for example, \( x < 0 \) or \( x < y \). For information on valid properties, refer to the assume help page. For information on the double colon (::) operator, refer to the type help page.

The assume command allows improved simplification of symbolic expressions, especially multiple-valued functions, for example, computing the square root.
To assume that \( x \) is a positive real number, use the following calling sequence. Then compute the square root of \( x^2 \).

\[
> \text{assume}(0 < x): \sqrt{x^2}
\]

\[ x~ \]

The trailing tilde (\(~\)) on the name \( x \) indicates that it carries assumptions.

When you use the \texttt{assume} command to place another assumption on \( x \), all previous assumptions are removed.

\[
> \text{assume}(x < 0): \sqrt{x^2}
\]

\[ ~x~ \]

**Displaying Assumptions:** To view the assumptions on an expression, use the \texttt{about} command.

\[
> \text{about}(x)
\]

Originally \( x \), renamed \( x~ \):

\[ \text{is assumed to be: RealRange(-infinity,Open(0))} \]

**Imposing Multiple Assumptions:** To simultaneously impose multiple conditions on an expression, specify multiple arguments in the \texttt{assume} calling sequence.

\[
> \text{assume}(0 < x, x < 2)
\]

To specify additional assumptions without replacing previous assumptions, use the \texttt{additionally} command. The syntax of the \texttt{additionally} calling sequence is the same as that of the \texttt{assume} command.

\[
> \text{additionally}(x :: \text{integer}): \text{about}(x)
\]

Originally \( x \), renamed \( x~ \):

\[ \text{is assumed to be: 1} \]

The only integer in the open interval \((0, 2)\) is \(1\).

**Testing Properties:** To test whether an expression always satisfies a condition, use the \texttt{is} command.
> assume(15 < x, 7 < y): is(100 < x y)

    true

The following test returns \texttt{false} because there are values of \(x\) and \(y\) (\(x = 0, y = 10\)) that satisfy the assumptions, but do not satisfy the relation in the \texttt{is} calling sequence.

> assume(x :: nonnegint, 10 \leq y): is(10 < x + y)

    false

To test whether an expression can satisfy a condition, use the \texttt{coulditbe} command.

> coulditbe(10 < x + y)

    true

\textbf{Removing Assumptions:} To remove all assumptions on a variable, unassign its name.

> unassign ('x', 'y')

For more information, see \textit{Unassigning Names (page 94)}.

For more information on the \texttt{assume} command, refer to the \texttt{assume} help page.

\textbf{The assuming Command}

To perform a single evaluation under assumptions on the names in an expression, use the \texttt{assuming} command.

The syntax of the assuming command is \texttt{<expression> assuming <property or relation>}.

Properties and relations are introduced in \textit{The assume Command (page 142)}.

The \texttt{frac} command returns the fractional part of an expression.

> frac(x) assuming x :: integer

    0

Using the \texttt{assuming} command is equivalent to imposing assumptions with the \texttt{assume} command, evaluating the expression, and then removing the assumptions.

> about(x)

\begin{verbatim}
x: nothing known about this object
\end{verbatim}

If you do not specify the names to which to apply a property, it is applied to all names.
Assumptions placed on names using the `assume` command are ignored by the `assuming` command, unless you include the `additionally` option.

\[
\sqrt{\left(\frac{a}{b}\right)^2}\] assuming positive

\[
\frac{a}{b}
\]

The `assuming` command does not affect variables inside procedures. (For information on procedures, see Procedures (page 378).) You must use the `assume` command.

\[
f := \text{proc}(x) \: \text{sqrt}(a^2) + x \: \text{end proc};
\]

\[
f := \text{proc}(x) \: \text{sqrt}(a^2) + x \: \text{end proc}
\]

\[
f(1)\] assuming \( a > 0 \)

\[
\sqrt{a^2} + 1
\]

\[
\text{assume}(a > 0); \: f(1)
\]

\[
a^2 + 1
\]

For more information on the `assuming` command, refer to the `assuming` help page.
This chapter focuses on solving problems in specific mathematical disciplines. The areas described below are not all that Maple provides, but represent the most commonly used packages. Examples are provided to teach you how to use the different methods of calculation available in Maple, including tutors, assistants, commands, task templates, plotting, and context menus.

The examples in this chapter assume knowledge of entering commands and mathematical symbols. For information, see *Entering Expressions (page 18)*. For information on basic computations, including integer operations and solving equations, see *Basic Computations (page 101)*.

### 5.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Algebra (page 148)</em> - Performing algebra computations</td>
<td>• Polynomial Algebra</td>
</tr>
<tr>
<td><em>Linear Algebra (page 155)</em> - Performing linear algebra computations</td>
<td>• Creating Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>• Accessing Entries in Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>• Linear Algebra Computations</td>
</tr>
<tr>
<td></td>
<td>• <strong>Student Linear Algebra</strong> Package</td>
</tr>
<tr>
<td><em>Calculus (page 172)</em> - Performing calculus computations</td>
<td>• Limits</td>
</tr>
<tr>
<td></td>
<td>• Differentiation</td>
</tr>
<tr>
<td></td>
<td>• Series</td>
</tr>
<tr>
<td></td>
<td>• Integration</td>
</tr>
<tr>
<td></td>
<td>• Differential Equations</td>
</tr>
<tr>
<td></td>
<td>• Calculus Packages</td>
</tr>
<tr>
<td><em>Optimization (page 184)</em> - Performing optimization computations using the <strong>Optimization</strong> package</td>
<td>• Point-and-Click Interface</td>
</tr>
<tr>
<td></td>
<td>• Efficient Computation</td>
</tr>
<tr>
<td></td>
<td>• MPS(X) File Support</td>
</tr>
<tr>
<td><em>Statistics (page 189)</em> - Performing statistics computations using the <strong>Statistics</strong> package</td>
<td>• Probability Distributions and Random Variables</td>
</tr>
<tr>
<td></td>
<td>• Statistical Computations</td>
</tr>
<tr>
<td></td>
<td>• Plotting</td>
</tr>
<tr>
<td><em>Teaching and Learning with Maple (page 194)</em> - Student and Instructor resources for using Maple in an academic setting</td>
<td>• Table of Student and Instructor Resources</td>
</tr>
<tr>
<td></td>
<td>• <strong>Student</strong> Packages and Tutors</td>
</tr>
</tbody>
</table>
### 5.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as described in *Integer Operations* (page 106). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see *Linear Algebra* (page 155).

#### Polynomial Algebra

A Maple polynomial is an expression in powers of an unknown. *Univariate* polynomials are polynomials in one unknown, for example, \( x^3 - 2x + 13 \). *Multivariate* polynomials are polynomials in multiple unknowns, such as \( x^3y - \frac{3}{2}xy^2 + 7x \).

The coefficient can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers, variables, or a combination of these types.

\[
> a x^2 + 7x - \frac{b}{2}
\]

\[
a x^2 + 7x - \frac{1}{2} b
\]

#### Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/). (The division operator accepts polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The *quo* and *rem* commands find the quotient and remainder of a polynomial division. See Table 5.1. (The *iquo* and *irem* commands find the quotient and remainder of an integer division. For more information, see *Integer Operations* (page 106).)
### Table 5.1: Polynomial Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
</table>
| Addition                   | +        | \( (x^2 + 1) + (3x^3 - 5x + 2) \)  
\[ \begin{align*} x^2 + 3 &+ 3x^3 - 5x \end{align*} \] |
| Subtraction                | −        | \( (x^2 + 1) - (3x^3 - 5x + 2) \)  
\[ \begin{align*} x^2 - 1 &- 3x^3 + 5x \end{align*} \] |
| Multiplication\(^1\)       | \(\ast\) | \( (x^2 + 1)(3x^3 - 5x + 2) \)  
\[ \begin{align*} (x^2 + 1) &\cdot (3x^3 - 5x + 2) \end{align*} \] |
| Division: Quotient and     | quo      | \( \text{quo}(2x^2 + x - 3, 3x + 5, x) \)  
\[ \begin{align*} \frac{2}{3}x &- \frac{7}{9} \end{align*} \] |
| Remainder                  | rem      | \( \text{rem}(2x^2 + x - 3, 3x + 5, x) \)  
\[ \begin{align*} \frac{8}{9} \end{align*} \] |
| Exponentiation\(^2\)       | \(^\wedge\) | \( (x^2 + 1)^3 \)  
\[ \begin{align*} (x^2 + 1)^3 \end{align*} \] |

\(^1\)You can specify multiplication explicitly by entering \(\ast\), which displays in 2-D Math as \(\cdot\). In 2-D Math, you can also implicitly multiply by placing a space character between two expressions. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

\(^2\)In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the **expand** command.

\[ > \text{expand}(3x^2 \cdot (3x+5) - (x^2 - 2)) \]

\[ 9x^3 + 14x^2 + 2 \]

If you need to determine whether one polynomial divides another, but do not need the quotient, use the **divide** command. The **divide** command tests for exact polynomial division.
> divide(x^4 y^2 + x^3 y^2 - x^2 y^2 + 13 x^2 + 13 x - 13 + y \cdot x^2 + x \cdot y - y, x^2 + x - 1)

    true

**Important:** You must insert a space character or a multiplication operator (\( \cdot \)) between adjacent variables names. Otherwise, they are interpreted as a single variable.

For example, \( x \) does not divide the single variable \( xy \).

> divide(xy,x)

    false

But, \( x \) divides the product of \( x \) and \( y \).

> divide(xy,x); divide(x*y,x)

    true

    true

For information on polynomial arithmetic over finite rings and fields refer to the `mod` help page.

**Sorting Terms**

To sort the terms of a polynomial, use the `sort` command.

> p1:=x^2 + x^3 - x + x^4

    \( p1 := x^2 + x^3 - x + x^4 \)

> sort(p1)

    \( x^4 + x^3 + x^2 - x \)

**Note:** The `sort` command returns the sorted polynomial, and updates the order of the terms in the polynomial.

The terms of \( p1 \) are sorted.

> p1

    \( x^4 + x^3 + x^2 - x \)

To specify the unknowns of the polynomial and their ordering, include a list of names.
By default, the `sort` command sorts a polynomial by decreasing total degree of the terms.

```maple
> sort(a^2*x^3 + x^2 + x*a + a + b, [a])
   x^3*a^2 + x*a + a + x^2 + b
```

```maple
> sort(a^2*x^3 + x^2 + x*a + a + b, [x, b])
   a^2*x^3 + x^2 + a*x + b + a
```

The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined by the order of their names in the list.

To sort the terms by pure lexicographic order, that is, first by decreasing order of the first unknown in the list option, and then by decreasing order of the next unknown in the list option, specify the `'plex'` option.

```maple
> p2 := x^3 + y^3 + x^2*y^2;
> sort(p2, [x, y])
   x^2*y^2 + x^3 + y^3
```

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 361).

The first term contains \( x \) to the power 3; the second, \( x \) to the power 2; and the third, \( x \) to the power 0.

Using context menus, you can perform operations, such as sorting, for polynomials and many other Maple objects.

**To sort a polynomial:**

1. Right-click (Control-click, for Macintosh) the polynomial.
2. The context menu displays. From the **Sorts** menu, select:
   - Single-variable, and then the unknown
   - Two-variable (or Three-variable), Pure Lexical or Total Degree, and then the sort priority of the unknowns.
Figure 5.1: Sorting a Polynomial Using a Context Menu
Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial.

\[ x^3 + y^3 + x^2y^2 : \]

\[ > \text{sort}(x^3 + y^3 + x^2 \cdot y^2, [y, x]) \text{plex} \]

\[ y^3 + y^2x^2 + x^3 \]

You can use context menus to perform operations on 2-D Math content including output. For more information, see Context Menus (page 68) (for Document mode) or Context Menus (page 88) (for Worksheet mode).

**Collecting Terms**

To collect the terms of polynomial, use the **collect** command.

\[ > \text{collect} \left( 2axy + cx^2y - zy^2 + az - 13by + \frac{3y^2}{x}, y \right) \]

\[ \left( -z + \frac{3}{x} \right)y^2 + \left( 2ax + cx^2 - 13b \right)y + az \]

**Coefficients and Degrees**

Maple has several commands that return coefficient and degree values for a polynomial. See Table 5.2.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
</table>
| coeff   | Coefficient of specific degree term | \[ > \text{coeff} \left( \frac{1}{2}x^3 - 2x + 5, x^3 \right) \]
|         |             | \[ \frac{1}{2} \] |
| lcoeff  | Leading coefficient | \[ > \text{lcoeff} \left( \frac{1}{2}x^3 - 2x + 5 \right) \]
|         |             | \[ \frac{1}{2} \] |
Example Description Command

Trailing coefficient

Sequence of all coefficients in one-to-one correspondence with the terms

Note: It does not return zero coefficient

(Highest) degree

Lowest degree term with a non-zero coefficient

Factorization

To express a polynomial in fully factored form, use the factor command.

```math
> factor(x^4 - 1)

(x - 1) (x + 1) (x^2 + 1)
```

The factor command factors the polynomial over the ring implied by the coefficients for example, integers. You can specify an algebraic number field over which to factor the polynomial. For more information, refer to the factor help page. (The ifactor command factors an integer. For more information, see Integer Operations (page 106).)

To solve for the roots of a polynomial, use the solve command. For information on the solve command, see Solving Equations and Inequalities (page 111). (The isolve command solves an equation for integer solutions. For more information, see Integer Equations (page 125).)

Other Commands

Table 5.3 lists other commands available for polynomial operations.

Table 5.3: Select Other Polynomial Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcoeff</td>
<td>Trailing coefficient</td>
<td>( &gt; ) tcoeff(\frac{1}{2}x^3 - 2x + 5) (5)</td>
</tr>
<tr>
<td>coeffs</td>
<td>Sequence of all coefficients in one-to-one correspondence with the terms</td>
<td>( &gt; ) coeffs(\frac{1}{2}x^3 - 2x + 5) (5, -2, \frac{1}{2})</td>
</tr>
<tr>
<td>degree</td>
<td>(Highest) degree</td>
<td>( &gt; ) degree(\frac{1}{2}x^3 - 2x + 5) (3)</td>
</tr>
<tr>
<td>ldegree</td>
<td>Lowest degree term with a non-zero coefficient</td>
<td>( &gt; ) ldegree(\frac{1}{2}x^3 - 2x) (1)</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>compoly</td>
<td>Decomposition</td>
<td></td>
</tr>
<tr>
<td>discrim</td>
<td>Discriminant</td>
<td></td>
</tr>
<tr>
<td>gcd</td>
<td>Greatest common divisor (of two polynomials)</td>
<td></td>
</tr>
<tr>
<td>gcdex</td>
<td>Extended Euclidean algorithm (for two polynomials)</td>
<td></td>
</tr>
<tr>
<td>CurveFitting[PolynomialInterpolation]</td>
<td>Interpolating polynomial (for list of points)</td>
<td></td>
</tr>
<tr>
<td>?polynom help page</td>
<td>General polynomial information</td>
<td></td>
</tr>
<tr>
<td>?PolynomialTools package overview help page</td>
<td>PolynomialTools package</td>
<td></td>
</tr>
<tr>
<td>?SNAP (Symbolic-Numeric Algorithms for Polynomials) package overview help page</td>
<td>Algebraic manipulation of numeric polynomials</td>
<td></td>
</tr>
<tr>
<td>?SDMPolynom (Sparse Distributed Multivariate Polynomial data structure) help page</td>
<td>Efficient arithmetic for sparse polynomials</td>
<td></td>
</tr>
<tr>
<td>Maple Help System Table of Contents: Mathematics→Algebra→Polynomials section</td>
<td>Polynomial information and commands</td>
<td></td>
</tr>
</tbody>
</table>

**Additional Information**

**Table 5.4: Additional Polynomial Help**

**5.3 Linear Algebra**

Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the **Task Browser** (Tools → Tasks → Browse), expand the **Linear Algebra** folder.
Creating Matrices and Vectors

Creating Matrices

You can create a Matrix using

- The **Matrix** command
- The angle bracket shortcut notation
- The **Matrix palette** (see Figure 5.2).

When creating a Matrix using the Matrix command, there are several input formats available. For example, enter a list of lists. The dimensions of the matrix are inferred from the number of entries given.

\[
> \text{Matrix}\left(\left[\begin{array}{ccc}
1, \pi, 0, & e^2, \sin(t), & \frac{87}{2}, \\
0, 0, 5e\end{array}\right]\right)
\]

\[
\begin{bmatrix}
1 & \pi & 0 \\
e^2 & \sin(t) & \frac{87}{2} \\
0 & 0 & 5e
\end{bmatrix}
\]

Alternatively, use the angle bracket shortcut, `<>`. Separate items in a column with commas, and separate columns with vertical bars, `|`.

\[
> \left(1, \pi, 0 \left| e^2, \sin(t), \frac{87}{2}\right| 0, 0, 5e\right)
\]

\[
\begin{bmatrix}
1 & e^2 & 0 \\
\pi & \sin(t) & 0 \\
0 & \frac{87}{2} & 5e
\end{bmatrix}
\]

For information on the Matrix command options, see *Creating Matrices and Vectors with Specified Properties* (page 162).
Use the Matrix palette to interactively create a matrix without commands:

![Matrix Palette](image)

**Figure 5.2: Matrix Palette**

In the Matrix palette, you can specify the matrix size (see Figure 5.3) and properties. To insert a matrix, click the Insert Matrix button.
After inserting the matrix:
1. Enter the values of the entries. To move to the next entry placeholder, press Tab.
2. After specifying all entries, press Enter.

\[
\begin{bmatrix}
1 & e^2 & 0 \\
\pi & \sin(r) & 0 \\
0 & \frac{87}{2} & 5e
\end{bmatrix}
\]
Creating Vectors

You can create a Vector using angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, \(<a, b, c>\). The number of elements is inferred from the number of expressions.

\[ \begin{bmatrix} 1 \\ 2 \\ 3 \end{bmatrix} \]

> \( \langle 1, 2, 3 \rangle \)

To create a row vector, specify a vertical-bar-delimited (|) sequence, \(<a | b | c>\). The number of elements is inferred from the number of expressions.

\[ \begin{bmatrix} 1 & 2 & 3 \end{bmatrix} \]

> \( \langle 1 | 2 | 3 \rangle \)

For information on the Vector command options, refer to the Vector help page.

You can also create vectors using the Matrix palette. If either the number of rows or number of columns specified is 1, then you have the option of inserting a matrix, or inserting a vector of the appropriate type. See Figure 5.4.

Figure 5.4: Insert Matrix or Insert Vector
**Viewing Large Matrices and Vectors**

Matrices $10 \times 10$ and smaller, and vectors with 10 or fewer elements, display in the document. Larger objects are displayed as a placeholder.

For example, insert a $15 \times 15$ matrix.

**In the Matrix palette:**

1. Specify the dimensions: 15 rows and 15 columns.
2. In the **Type** drop-down list, select a matrix type, for example, **Random**.
3. Click **Insert Matrix**. Maple inserts a placeholder.

\[
\begin{bmatrix}
15 \times 15 \text{ Matrix} \\
\text{Data Type: anything} \\
\text{Storage: rectangular} \\
\text{Order: Fortran_order}
\end{bmatrix}
\]

To edit or view a large matrix or vector, double-click the placeholder. This launches the **Matrix Browser**. See **Figure 5.5**.
To modify the entries using the Matrix Browser:

1. Select the Table tab.
2. Double-click an entry, and then edit its value. Press Enter.
3. Repeat for each entry to edit.
4. When you have finished updating entries, click Done.

You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more information, refer to the MatrixBrowser help page.
To set the maximum dimension of matrices and vectors displayed inline:
• Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the interface help page.

Creating Matrices and Vectors with Specific Properties

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create matrices and vectors with properties. You must specify the properties, for example, the matrix shape or data type, when defining the object.

The Matrix palette (Figure 5.2) supports several properties.

To specify the matrix type:
• Use the Shape and Type drop-down lists.

To specify the data type:
• Use the Data type drop-down list.

For example, define a diagonal matrix with small integer coefficients:

In the Matrix palette:
1. Specify the size of the matrix, for example, 3 × 3.
2. In the Shapes drop-down list, select Diagonal.
3. In the Data type drop-down list, select integer[1].
4. Click the Insert Matrix button.
5. Enter the values in the diagonal entries.

\[
\begin{bmatrix}
-23 & 0 & 0 \\
0 & 17 & 0 \\
0 & 0 & 32
\end{bmatrix}
\]

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the Vector constructor.

To define a column vector using the Vector constructor, specify:
• The number of elements. If you explicitly specify all element values, this argument is not required.
• A list of expressions that define the element values.
• Parameters such as **shape**, **datatype**, and **fill** that set properties of the vector.

The following two calling sequences are equivalent.

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]

To create a row vector using the **Vector** constructor, include **row** as an index.

\[
\begin{bmatrix}
1 & 1 & 1
\end{bmatrix}
\]

\[
\begin{bmatrix}
127 & 0 & 34
\end{bmatrix}
\]

The **Matrix** palette does not support some properties. To set all properties, use the **Matrix** constructor.

**To define a matrix using the Matrix constructor, specify:**

• The number of rows and columns. If you explicitly specify all element values, these arguments are not required.

• A list of lists that define the element values row-wise.

• Parameters such as **shape**, **datatype**, and **fill** that set properties of the matrix.
For example:

\[ \text{Matrix}([[1,2,3],[4,5,6]]) \]

\[
\begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6
\end{bmatrix}
\]

The `Matrix` palette cannot fill the matrix with an arbitrary value. Use the `fil` parameter.

\[ \text{Matrix}(3,4,[[1,2,3],[4,5,6]],'fil'=2+I) \]

\[
\begin{bmatrix}
1 & 2 & 3 & 2+1 \\
4 & 5 & 6 & 2+1 \\
2+1 & 2+1 & 2+1 & 2+1
\end{bmatrix}
\]

For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the `storage`, `Matrix`, and `Vector` help pages.

See also `Numeric Computations (page 171)`.

**Accessing Entries in Matrices and Vectors**

**Matrices**

To select an entry in a Matrix, enter the matrix name with a sequence of two non-zero integer indices, row first

\[ M := \langle -4.3, -6.7, 1.9|2.9, -1.2, 9.6|9.3, -8.0, -9.2 \rangle \]

\[
M := \\
\begin{bmatrix}
-4.3 & 2.9 & 9.3 \\
-6.7 & -1.2 & -8.0 \\
1.9 & 9.6 & -9.2
\end{bmatrix}
\]

\[ M[1,3] \]

\[ 9.3 \]

To select an entire row, enter a single index; to select an entire column, enter first the entire range of rows, 1 .. -1, then the column index.
Similarly, you can access submatrices. Enter the indices as a list or range.

\[
M[2]
\begin{bmatrix}
-6.7 & -1.2 & -8.0
\end{bmatrix}
\]

\[
M[1..-1, 1]
\begin{bmatrix}
-4.3 \\
-6.7 \\
1.9
\end{bmatrix}
\]

Similarly, you can access submatrices. Enter the indices as a list or range.

\[
M[2..3, 1..2]
\begin{bmatrix}
-6.7 & -1.2 \\
1.9 & 9.6
\end{bmatrix}
\]

**Vectors**

To select an entry in a vector, enter the vector name with a non-zero integer index.

\[
a := <85.3, 47.1, 59.9, 38.1>
\]

\[
a := \\
\begin{bmatrix}
85.3 \\
47.1 \\
59.9 \\
38.1
\end{bmatrix}
\]

\[
a[1]
85.3
\]

Negative integers select entries from the end of the vector.

\[
a[-1]
38.1
\]

To create a Vector consisting of multiple entries, specify a **list** or **range**. For more information, refer to the **set** and **range** help pages.
Linear Algebra Computations

Maple has extensive support for linear algebra. You can perform many matrix and vector computations using context menus. Matrix operations such as multiplication and inverses can be done with the basic matrix arithmetic operators. The **LinearAlgebra** package provides the full range of Maple commands for linear algebra and vector space computations, queries, and linear system solving.

**Matrix Arithmetic**

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differences.

- The scalar multiplication operator is the asterisk (*), which displays in 2-D Math as ·.
  The noncommutative matrix and vector multiplication operator is the period (.),
- There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent −1.)

Table 5.5 lists the basic matrix operators.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>&gt; A + B</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[141 63 ]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[38 74]</td>
</tr>
<tr>
<td>Operation</td>
<td>Operator</td>
<td>Example</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------</td>
<td>---------</td>
</tr>
<tr>
<td>Subtraction</td>
<td>−</td>
<td>$A - B$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 45 &amp; 23 \ 0 &amp; 0 \end{bmatrix}$</td>
</tr>
<tr>
<td>Multiplication</td>
<td>$\cdot$</td>
<td>$A.C$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 2397 \ 659 \end{bmatrix}$</td>
</tr>
<tr>
<td>Scalar Multiplication¹</td>
<td>$*$</td>
<td>$12A$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 1116 &amp; 516 \ 228 &amp; 444 \end{bmatrix}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$4\cdot C$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 92 \ 24 \end{bmatrix}$</td>
</tr>
<tr>
<td>Exponentiation²</td>
<td>$^\wedge$</td>
<td>$A^3$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 986548 &amp; 613868 \ 271244 &amp; 187092 \end{bmatrix}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$B^{-1}$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 37 &amp; -5 \ 1396 &amp; 349 \ -19 &amp; 12 \ -1396 &amp; 349 \end{bmatrix}$</td>
</tr>
</tbody>
</table>

¹You can specify scalar multiplication explicitly by entering $\ast$, which displays in 2-D Math as $\cdot$. In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space character between them. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

²In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 5.6.

Define two column vectors.
Table 5.6: Select Matrix and Vector Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transpose</td>
<td>( ^%T )</td>
<td>( d^%T )</td>
</tr>
<tr>
<td>Hermitian Transpose</td>
<td>( ^%H )</td>
<td>( \begin{bmatrix} 1 &amp; 2 &amp; 3 \ \end{bmatrix} )</td>
</tr>
<tr>
<td>Cross Product</td>
<td>&amp;x (^2)</td>
<td>( &gt; \text{with(LinearAlgebra)}: )</td>
</tr>
<tr>
<td>(3-D vectors only)</td>
<td></td>
<td>( &gt; d &amp;x e )</td>
</tr>
</tbody>
</table>

\(^1\)Exponential operators display in 2-D Math as superscripts.

\(^2\)After loading the \texttt{LinearAlgebra} package, the cross product operator is available as the \texttt{inf} operator \&x\ . Otherwise, it is available as the \texttt{LinearAlgebra[CrossProduct]} command.

For information on matrix arithmetic over finite rings and fields refer to the \texttt{mod} help page.

Point-and-Click Interaction

Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.

- Perform standard operations: determinant, inverse, norm (1, Euclidean, infinit, or Frobenius), transpose, and trace
- Compute eigenvalues, eigenvectors, and singular values
- Compute the dimension or rank
- Convert to the Jordan form, or other forms
- Perform Cholesky decomposition and other decompositions
For example, compute the infinit norm of a matrix. See Figure 5.6.

![Figure 5.6: Computing the Infinit Norm of a Matrix](image)

In Document mode, Maple inserts a right arrow and the name of the computation performed, followed by the norm.

\[
\begin{bmatrix}
18735.6985 & 349723.234987 \\
9859.459 & 798124.14089
\end{bmatrix}
\xrightarrow{\text{infinity-norm}} 8.0798359990 \times 10^5
\]

Vector operations available in the context menu include the following.

- Compute the dimension
- Compute the norm (1, Euclidean, and infinity)
Compute the transpose
Select an element

For more information on context menus, see Context Menus (page 68) (for Document mode) or Context Menus (page 88) (for Worksheet mode).

### LinearAlgebra Package Commands

The LinearAlgebra package contains commands that construct and manipulate matrices and vectors, compute standard operations, perform queries, and solve linear algebra problems.

Table 5.7 lists some LinearAlgebra package commands. For a complete list, refer to the LinearAlgebra/Details help page.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basis</td>
<td>Return a basis for a vector space</td>
</tr>
<tr>
<td>CrossProduct</td>
<td>Compute the cross product of two vectors</td>
</tr>
<tr>
<td>DeleteRow</td>
<td>Delete a row or rows of a matrix</td>
</tr>
<tr>
<td>Dimension</td>
<td>Determine the dimension of a matrix or a vector</td>
</tr>
<tr>
<td>Eigenvalues</td>
<td>Compute the eigenvalues of a matrix</td>
</tr>
<tr>
<td>Eigenvectors</td>
<td>Compute the eigenvectors of a matrix</td>
</tr>
<tr>
<td>FrobeniusForm</td>
<td>Reduce a matrix to Frobenius form</td>
</tr>
<tr>
<td>GaussianElimination</td>
<td>Perform Gaussian elimination on a matrix</td>
</tr>
<tr>
<td>HessenbergForm</td>
<td>Reduce a square matrix to Hessenberg form</td>
</tr>
<tr>
<td>HilbertMatrix</td>
<td>Construct a generalized Hilbert matrix</td>
</tr>
<tr>
<td>IsOrthogonal</td>
<td>Test if a matrix is orthogonal</td>
</tr>
<tr>
<td>LeastSquares</td>
<td>Compute the least-squares approximation to $A \cdot x = b$</td>
</tr>
<tr>
<td>LinearSolve</td>
<td>Solve the linear system $A \cdot x = b$</td>
</tr>
<tr>
<td>MatrixInverse</td>
<td>Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix</td>
</tr>
<tr>
<td>QRDecomposition</td>
<td>Compute the QR factorization of a matrix</td>
</tr>
<tr>
<td>RandomMatrix</td>
<td>Construct a random matrix</td>
</tr>
<tr>
<td>SylvesterMatrix</td>
<td>Construct the Sylvester matrix of two polynomials</td>
</tr>
</tbody>
</table>

For information on arithmetic operations, see Matrix Arithmetic (page 166).

For information on selecting entries, subvectors, and submatrices, see Accessing Entries in Matrices and Vectors (page 164).

**Example:** Determine a basis for the space spanned by the set of vectors $\{(2, 13, -15), (7, -2, 13), (5, -4, 9)\}$. Express the vector $(25, -4, 9)$ with respect to this basis.
> with(LinearAlgebra):

> v1 := <2, 13, -15>: v2 := <7, -2, 13>: v3 := <5, -4, 9>:

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.

> basis := Matrix(Basis([v1, v2, v3]));

```
basis :=
[  2   7   5 ]
[ 13  -2  -4 ]
[ -15  13   9 ]
```

To express \( (25, -4, 9) \) in this basis, use the LinearSolve command.

> LinearSolve(basis, <25, -4, 9>)

```
[ 170 ]
[  91 ]
[ -285 ]
[  91 ]
[  786 ]
[  91 ]
```

**Numeric Computations**

You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the LinearAlgebra package, refer to the EfficientLinearAlgebra help page.

See also Creating Matrices and Vectors with Specific Properties (page 162) and Reading from Files (page 409).

**Student LinearAlgebra Package**

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands.
In the Student[LinearAlgebra] subpackage, the environment differs from that of the LinearAlgebra package in that floating-point computations are generally performed using software precision, instead of hardware precision, and symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be controlled using the SetDefault. For more information, refer to the Student[LinearAlgebra][setDefault] help page.

For information on using Maple as a teaching and learning tool, see Teaching and Learning with Maple (page 194).

5.4 Calculus

The Task Browser (Tools→Tasks→Browse) contains numerous calculus task templates. For a list of tasks, navigate to one of the related folders, such as Calculus, Differential Equations, Multivariate Calculus, or Vector Calculus.

This section describes the key Maple calculus commands, many of which are used in task templates or available in the context menus.

For a complete list of calculus commands, refer to the Mathematics (including Calculus, Differential Equations, Power Series, and Vector Calculus subfolders) and Student Package sections of the Maple Help System Table of Contents.

Limits

To compute the limit of an expression as the independent variable approaches a value:

1. In the Expression palette, click the limit item $\lim_{x \to a}$.
2. Specify the independent variable, limit point, and expression, and then evaluate it. Press Tab to move to the next placeholder.

For example:

```maple
> \lim_{x \to 0} \left( \frac{x}{\sin(x)} \right)
```

The limit Command

By default, Maple searches for the real bidirectional limit (unless the limit point is $\infty$ or $-\infty$). To specify a direction, include one of the options left, right, real, or complex in a call to the limit command. See Table 5.8.
Table 5.8: Limits

<table>
<thead>
<tr>
<th>Limit</th>
<th>Command Syntax</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \lim_{x \to 0} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit}\left( \frac{1}{x}, x = 0 \right) )</td>
<td>undefined</td>
</tr>
<tr>
<td>( \lim_{x \to 0^+} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit}\left( \frac{1}{x}, x = 0, \text{`right' } \right) )</td>
<td>( \infty )</td>
</tr>
<tr>
<td>( \lim_{x \to 0^-} \left( \frac{1}{x} \right) )</td>
<td>( \text{limit}\left( \frac{1}{x}, x = 0, \text{`left' } \right) )</td>
<td>( -\infty )</td>
</tr>
</tbody>
</table>

Using the \texttt{limit} command, you can also compute multidimensional limits.

\[
> \text{limit} \left( \frac{x^2}{y}, \{ x = 1, y = \infty \} \right)
\]

\[ 0 \]

For more information on multidimensional limits, refer to the \texttt{limit/multi} help page.

**Numerically Computing a Limit**

To numerically compute a limit:

- Use the \texttt{evalf(Limit(arguments))} calling sequence.

**Important:** Use the inert \texttt{Limit} command, not the \texttt{limit} For more information, refer to the \texttt{limit} help page.

The \texttt{Limit} command accepts the same arguments as the \texttt{limit} command.

For example:

\[
> \text{evalf} \left( \text{Limit} \left( \frac{\sin(x)}{\cos(x) + \tan(x)}, x = 1.225 \right) \right)
\]

\[ 0.3020605357 \]

For information on the \texttt{evalf} command, see *Numerical Approximation* (page 356).

The \texttt{Limit} command does not compute the limit. It returns an unevaluated limit.

\[
> \text{Limit} \left( \frac{\sin(x)}{\cos(x) + \tan(x)}, x = 1.225 \right)
\]

\[
\lim_{x \to 1.225} \frac{\sin(x)}{\cos(x) + \tan(x)}
\]
For more information on the **Limit** command, refer to the **Limit** help page.

**Differentiation**

Maple can perform symbolic and numeric differentiation.

**To differentiate an expression:**

1. In the **Expression** palette, click the differentiation item \( \frac{d}{dx} \) or the partial differentiation item \( \frac{\partial}{\partial x} \).

2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate \( x \sin(a x) \) with respect to \( x \):

\[
> \frac{d}{dx} (x \sin(a x))
\]

\[
\sin(a x) + x \cos(a x) a
\]

You can also differentiate using context menus. For more information, see *Context Menus* (page 39).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the second derivative of \( x \sin(a x) + x^2 \) with respect to \( x \):

\[
> \frac{d^2}{dx^2} (x \sin(a x) + x^2)
\]

\[
2 \cos(a x) a - x \sin(a x) a^2 + 2
\]

To calculate the mixed partial derivative of \( x \sin(3 y) + y x^5 \):

\[
> \frac{\partial^2}{\partial y \partial x} (x \sin(3 y) + y x^5)
\]

\[
3 \cos(3 y) + 5 x^4
\]

**Note:** To enter another \( \partial \) symbol, you can copy and paste the existing symbol, or enter d and use symbol completion.
The \texttt{diff} Command

Maple computes derivatives using the \texttt{diff} command. To directly use the \texttt{diff} command, specify the expression to differentiate and the variable.

\begin{verbatim}
> x \sin(a \, x) + x^2

\sin(a \, x) + x^2
\end{verbatim}  \hspace{1cm} (5.1)

\begin{verbatim}
> diff((5.1), x)

\sin(a \, x) + x \cos(a \, x) \, a + 2 \, x
\end{verbatim}  \hspace{1cm} (5.2)

For information on equation labels such as \texttt{(5.1)}, see \textit{Equation Labels} (page 95).

You can calculate a higher order derivative by specifying a sequence of differentiation variables. Maple recursively calls the \texttt{diff} command.

\begin{verbatim}
> diff((5.1), x,x)

2 \cos(a \, x) \, a - x \sin(a \, x) \, a^2 + 2
\end{verbatim}  \hspace{1cm} (5.3)

To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives commute.

\begin{verbatim}
> diff(x \sin(3 \, y) + \sqrt{x}, x,y)

3 \cos(3 \, y) + \frac{1}{2 \sqrt{x}}
\end{verbatim}

To enter higher order derivatives, it is convenient to use the syntax \texttt{diff(f, x$n$)}. This syntax can also be used to compute the symbolic $n^{th}$ order derivative.

For example:

\begin{verbatim}
> diff(cos(t), t$n$)

\cos\left(t + \frac{1}{2} \, n \, \pi\right)
\end{verbatim}

Differentiating an Operator

You can also specify a mathematical function as a \textit{functional operator} (a mapping). For a comparison of operators and other expressions, see \textit{Distinction between Functional Operators and Other Expressions} (page 340).
To find the derivative of a functional operator:

- Use the D operator.

The D operator returns a functional operator.

For example, find the derivative of an operator that represents the mathematical function \( F : x \rightarrow x \cos(x) \).

First, define the operator \( F \).

1. In the Expression palette, click the single-variable function definition item \( f := a \rightarrow y \).
2. Enter placeholder values.
   - To move to the next placeholder, press the Tab key. Note: If pressing the Tab key inserts a tab, click the Tab icon in the toolbar.

> \( F := x \rightarrow x \cos(x) \):

Now, define the operator, \( G \), that maps \( x \) to the derivative of \( x \cos(x) \).

> \( G := D(F) \)

\[
G := x \rightarrow \cos(x) - x \sin(x)
\]

\( F \) and \( G \) evaluated at \( \frac{\pi}{2} \) return the expected values.

> \( F\left( \frac{\pi}{2} \right); G\left( \frac{\pi}{2} \right) \)

\[
0 \\
-\frac{1}{2} \pi
\]

For more information on the D operator, refer to the D help page. For a comparison of the diff command and D operator, refer to the diffVersusD help page.

**Directional Derivative**

To compute and plot a directional derivative, use the **Directional Derivative Tutor**. The tutor computes a floating-point value for the directional derivative.
To launch the tutor:

- From the **Tools** menu, select **Tutors, Calculus - Multivariate**, and then **Directional Derivatives**. Maple launches the **Directional Derivative Tutor**. See Figure 5.7.

![Maple screenshot](image)

**Figure 5.7: Directional Derivative Tutor**

To compute a symbolic value for the directional derivative, use the `Student[MultivariateCalculus][DirectionalDerivative]` command. The first list of numbers specifies the point at which to compute the derivative. The second list of numbers specifies the direction in which to compute the derivative.
For example, at the point \([1,2]\), the gradient of \(x^2 + y^2\) points in the direction \([2,4]\), which is the direction of greatest increase. The directional derivative in the orthogonal direction \([-2,1]\) is zero.

\[
> \text{with(Student[MultivariateCalculus])};
\]

\[
> \text{DirectionalDerivative}(x^2+y^2, [x,y] = [1,2], [1,2]);
\]

\[
2 \sqrt{5}
\]

\[
> \text{DirectionalDerivative}(x^2+y^2, [x,y] = [1,2], [-2,1]);
\]

\[
0
\]

**Series**

To generate the **Taylor series** expansion of a function about a point, use the `taylor` command.

\[
> \text{taylor(sin(4x)cos(x), x=0)}
\]

\[
4x - \frac{38}{3} x^3 + \frac{421}{30} x^5 + O(x^6)
\]

**Note:** If a Taylor series does not exist, use the `series` command to find a general series expansion.

For example, the **cosine integral function** For more information, refer to the `Ci` help page.

\[
> \text{taylor(Ci(x), x=0)}
\]

**Error, does not have a taylor expansion, try series()**

To generate a truncated series expansion of a function about a point, use the `series` command.

\[
> \text{series(Ci(x), x=0)}
\]

\[
\gamma + \ln(x) - \frac{1}{4} x^2 + \frac{1}{96} x^4 + O(x^6)
\]

By default, Maple performs series calculations up to order 6. To use a different order, specify a non-negative integer third argument.
To set the order for all computations, use the \texttt{Order} environment variable. For information about the \texttt{Order} variable and the $O(t^4)$ term, refer to the \texttt{Order} help page.

The expansion is of type \texttt{series}. Some commands, for example, \texttt{plot}, do not accept arguments of type \texttt{series}. To use the expansion, you must convert it to a polynomial using the \texttt{convert/polynom} command.

\begin{verbatim}
> expansion := series(Ci(t), t=0, 4)

expansion := \gamma + \ln(t) - \frac{1}{4} \, t^2 + O(t^4)
\end{verbatim}

For information on Maple types and type conversions, see \textit{Maple Expressions (page 333)}. For information on plotting, see \textit{Plots and Animations (page 237)}.

\textbf{Integration}

Maple can perform symbolic and numeric integration.
To compute the indefinite integral of an expression:

1. In the Expression palette, click the indefinite integration item $\int f\,dx$.
2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate $x \sin(ax)$ with respect to $x$:

$$\int x \sin(ax) \,dx$$

$$\frac{\sin(ax)}{a^2} - \frac{x \cos(ax)}{a}$$

Recall that you can also enter symbols, including $\int$ and $d$, using symbol completion.

- Enter the symbol name (or part of the name), for example, int or d, and then press the completion shortcut key.

For more information, see Symbol Names (page 28).

You can also compute an indefinite integral using context menus. For more information, see Context Menus (page 39).

To compute the definite integral of an expression:

1. In the Expression palette, click the definite integration item $\int_a^b f\,dx$.
2. Specify the endpoints of the interval of integration, integrand expression, and variable of integration, and then evaluate it.

For example, to integrate $e^{-at}\ln(t)$ over the interval $(0, \infty)$:

$$\int_0^\infty e^{-at}\ln(t) \,dt$$

$$\lim_{t \to \infty} \left( - \frac{e^{-at}\ln(t) + \text{Ei}(1, at) + \gamma + \ln(a)}{a} \right)$$

Maple treats the parameter $a$ as a complex number. As described in Assumptions on Variables (page 142), you can compute under the assumption that $a$ is a positive, real number using the assuming command.
To compute iterated integrals, line integrals, and surface integrals, use the task templates (Tools → Tasks → Browse) in the Multivariate and Vector Calculus folders.

The int Command

\[ \int_a^b f \, dx \text{ and } \int_a^b f \, dx \text{ use the int command. To use the int command directly, specify the following arguments.} \]

- Expression to integrate
- Variable of integration

\[ > x \sin(ax) \]

\[ x \sin(ax) \quad (5.4) \]

\[ > \text{int}(5.4, x) \]

\[ \frac{\sin(ax) - x \cos(ax) \cdot a}{a^2} \quad (5.5) \]

For a definite integration, set the variable of integration equal to the interval of integration.

\[ > \text{int}(5.4, x=0..\pi/a) \]

\[ \frac{\pi}{a^2} \quad (5.6) \]

Numeric Integration

To perform numeric integration:

- Use the evalf(Int(arguments)) calling sequence.

Important: Use the inert Int command, not the int. For more information, refer to the int help page.
In addition to the arguments accepted by the \texttt{int} command, you can include optional arguments such as \texttt{method}, which specifies the numeric integration method.

\begin{verbatim}
> evalf(Int(1/\Gamma(x), x=0..2, 'method' = _Dexp))
\end{verbatim}

\begin{verbatim}
1.626378399
\end{verbatim}

\textbf{Note:} To enter an underscore character (_\_) in 2-D Math, enter \texttt{\_}. 

For information on the \texttt{evalf} command, see \textit{Numerical Approximation} (page 356).

For information on numeric integration, including iterated integration and controlling the algorithm, refer to the \texttt{evalf/Int} help page.

\textbf{Differential Equations}

Maple has a powerful set of solvers for ordinary differential equations (ODEs) and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see \textit{Other Specialized Solvers} (page 120).

\textbf{Calculus Packages}

In addition to top-level calculus commands, Maple contains calculus packages.

\textbf{VectorCalculus Package}

The \texttt{VectorCalculus} package contains commands that perform multivariate and vector calculus operations on \texttt{VectorCalculus vectors} (vectors with an additional coordinate system attribute) and \texttt{vector field} (vectors with additional coordinate system and \texttt{vectorfield} attributes), for example, \texttt{Curl}, \texttt{Flux}, and \texttt{Torsion}.

\begin{verbatim}
> with(VectorCalculus) :

> BasisFormat(false) :

> SetCoordinates('cartesian'[x,y,z]) :
\end{verbatim}
> VectorField1 := VectorField([-y, x, z])

\[
VectorField1 := \begin{bmatrix} -y \\ x \\ z \end{bmatrix}
\]

**Note:** For information on changing the display format in the VectorCalculus package, see the `VectorCalculus[BasisFormat]` help page.

Find the curl of `VectorField1`.

> Curl(VectorField1);

\[
\begin{bmatrix} 0 \\ 0 \\ 2 \end{bmatrix}
\]

Find the flux of `VectorField1` through a sphere of radius `r` at the origin.

> Flux(VectorField1, Sphere([0, 0, 0], r))

\[
\frac{4}{3} r^3 \pi
\]

Compute the torsion of a space curve. The curve must be a vector with parametric function components.

> simplify(Torsion([t, t^2, t^3], t)) assuming t::real

\[
\frac{3}{9 t^4 + 9 t^2 + 1}
\]

For information on the `assuming` command, see *The assuming Command (page 144)*.

For more information on the `VectorCalculus` package, including a complete list of commands, refer to the `VectorCalculus` help page.

To find other calculus packages, such as `VariationalCalculus`, refer to the `index/package` help page.

**Student Calculus Packages**

The `Student` package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational
commands. The **Student** calculus subpackages include **Calculus1**, **MultivariateCalculus**, and **VectorCalculus**. The **Student[VectorCalculus]** package provides a simple interface to a limited subset of the functionality available in the **VectorCalculus** package.

For information on using Maple as a teaching and learning tool, and some computational examples, see *Teaching and Learning with Maple* (page 194).

### 5.5 Optimization

Using the **Optimization** package, you can numerically solve optimization problems. The package uses fast Numerical Algorithms Group (NAG) algorithms to **minimize** or **maximize** an objective function.

The **Optimization** package solves constrained and unconstrained problems.

- **Linear programs**
- **Quadratic programs**
- **Nonlinear programs**
- Linear and nonlinear **least-squares** problems

The **Optimization** package contains local solvers. In addition, for univariate finitely-bound nonlinear programs with no other constraints, you can compute global solutions using the **NLPSolve** command. To find global solutions generally, purchase the **Global Optimization Toolbox**. For more information, visit [http://www.maplesoft.com/products/toolboxes](http://www.maplesoft.com/products/toolboxes).

#### Point-and-Click Interface

The primary method for solving optimization problems is the **Optimization Assistant**.

**To launch the Optimization Assistant:**

- From the **Tools** menu, select **Assistants**, and then **Optimization**.

Maple launches the **Optimization Assistant**. See Figure 5.8.
To solve a problem:
1. Enter the objective function, constraints, and bounds.
2. Select the Minimize or Maximize radio button.
3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds) in the calling sequence of the Optimization[Interactive] command.
For example, find the maximum value of \( x^3 y - y^2 \) subject to the constraints 
\[ x + y \leq 6, x \in [0,5], y \in [0,5]. \]

\[
> \text{Optimization[Interactive]}(x^3 y - y^2, \{x + y \leq 6, x = 0..5, y = 0..5\})
\]
\[ [134.491161539748162, [x = 4.53559292539129189, y = 1.46440707460870746]] \]

- When the Optimization Assistant opens, select **Maximize**, then **Solve**.

After finding a solution, you can plot it. To plot a solution:

- In the **Optimization Assistant** window, click the **Plot** button. The **Optimization Plotter** window is displayed. See **Figure 5.9**.

**Note:** When you close the **Optimization Assistant**, you can choose to return the solution, problem, command used, plot, or nothing, using the drop-down in the bottom right corner of the assistant window.
Figure 5.9: Optimization Assistant Plotter Window

For information on the algorithms used to solve optimization problems, refer to the Optimization/Methods help page.

**Large Optimization Problems**

The Optimization Assistant accepts input in an algebraic form. You can specify input in other forms, described in the Optimization/InputForms help page, in command calling sequences.
The Matrix form, described in the **Optimization/MatrixForm** help page, is more complex but offers greater flexibility and efficiency.

For example, solve the linear program:

Maximize \( c^T x \) subject to \( Ax \leq b \), where \( x \) is the vector of problem variables.

1. Define the column vector, \( c \), of the linear objective function.

2. Define the matrix \( A \), the coefficient matrix for the linear inequality constraints.

3. Define the column vector \( b \), the linear inequality constraints.

4. The **QPSolve** command solves quadratic programs.

```plaintext
> with(LinearAlgebra):

> c := RandomVector[column](20, outputoptions = ['datatype'='float']):

> A := RandomMatrix(19, 20, outputoptions = ['datatype'='float']):

> b := RandomVector[column](19, outputoptions = ['datatype'='float']):

> Optimization[LPSolve](c, [A, b], maximize, assume = nonnegative)
```

This example uses a random data set to demonstrate the problem. You could also read data from an external file as Matrices, and use that data. For details and an example, see *Reading from Files* (page 409).

**Note:** For information on creating matrices and vectors (including how to use the Matrix palette to easily create matrices), see *Linear Algebra* (page 155).

For additional information on performing efficient computations, refer to the **Optimization/Computation** help page.

**MPS(X) File Support**

To import linear programs from a standard MPS(X) data file use the **ImportMPS** command.
Optimization Package Commands

Each Optimization package command solves the problem using a different optimization method. These are described in Table 5.9, along with the general input form for each command.

Table 5.9: Optimization Package Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LPSolve</td>
<td>Solve a linear program (LP), which involves computing the minimum (or maximum) of a linear objective function subject to linear constraints; input is in equation or Matrix form</td>
</tr>
<tr>
<td>LSSolve</td>
<td>Solve a least-squares (LS) problem, which involves computing the minimum of a real-valued objective function having the form ( \frac{1}{2} (f_1(x)^2 + f_2(x)^2 + \ldots + f_q(x)^2) ), where ( x ) is a vector of problem variables, possibly subject to constraints; input is in equation or Matrix form</td>
</tr>
<tr>
<td>Maximize</td>
<td>Compute a local maximum of an objective function, possibly subject to constraints</td>
</tr>
<tr>
<td>Minimize</td>
<td>Compute a local minimum of an objective function, possibly subject to constraints</td>
</tr>
<tr>
<td>NLPSolve</td>
<td>Solve a non-linear program (NLP), which involves computing the minimum (or maximum) of a real-valued objective function, possibly subject to constraints; input is in equation or Matrix form</td>
</tr>
<tr>
<td>QPSolve</td>
<td>Solve a quadratic program (QP), which involves computing the minimum (or maximum) of a quadratic objective function, possibly subject to linear constraints; input is in equation or Matrix form</td>
</tr>
</tbody>
</table>

For a complete list of commands and other Optimization package information, refer to the Optimization help page.

5.6 Statistics

The Statistics package provides tools for mathematical statistics and data analysis. The package supports a wide range of common statistical tasks including quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides a wide range of symbolic and numeric tools for computing with random variables. The package supports over 35 major probability distributions and can be extended to include new distributions.
Probability Distributions and Random Variables

The Statistics package supports:

- Continuous distributions, which are define along the real line by probability density functions. Maple supports many continuous distributions, including the normal, Student-t, Laplace, and logistic distributions.

- Discrete distributions, which have nonzero probability only at discrete points. A discrete distribution is define by a probability function. Maple supports many discrete distributions, including the Bernoulli, geometric, and Poisson distributions.

For a complete list of distributions, refer to the Statistics/Distributions help page.

You can define random variables by specifying a distribution in a call to the RandomVariable command.

```maple
> with(Statistics) :

> X := RandomVariable(Poisson(λ)) :
```

Find the probability distribution function for \(X\). (For information on statistics computations, see Statistical Computations (page 191).)

```maple
> PDF(X,t)

\[
\sum_{k=0}^{\infty} \frac{\lambda^k e^{-\lambda} \text{Dirac}(t - k)}{k!}
\]
```

Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the Distribution command.

```maple
> U := Distribution(PDF = t -> piecewise(t < 0, 0, t < 3, 1/3, 0)) :
```

To construct a piecewise-continuous function in 1-D Math, use the piecewise command, for example, \(t \rightarrow \text{piecewise}(t < 0, 0, t < 3, 1/3, 0)\).

Define a new random variable with this distribution.
Calculate the mean value of the random variable.

\[ Z := \text{RandomVariable}(U): \text{PDF}(Z, t) \]

\[
\begin{cases} 
0 & t < 0 \\ 
\frac{1}{3} & t < 3 \\ 
0 & \text{otherwise} 
\end{cases}
\]

Calculate the mean value of the random variable.

\[ > \text{Mean}(Z) \]

\[ \frac{3}{2} \]

**Statistical Computations**

In addition to basic functions, like mean, median, standard deviation, and percentile, the **Statistics** package contains commands that compute, for example, the interquartile range and hazard rate.

**Example 1 - Interquartile Range**

Compute the average absolute range from the interquartile of the **Rayleigh** distribution with scale parameter 3.

\[ > \text{InterquartileRange}(\text{Rayleigh}(3)) \]

\[ \sqrt{36} \sqrt{\ln(2)} - \sqrt{-18 \ln\left(\frac{3}{4}\right)} \]

To compute the result numerically:

- Specify the 'numeric' option.

\[ > \text{InterquartileRange}(\text{Rayleigh}(3), '\text{numeric}') \]

\[ 2.719744818 \]

**Example 2 - Hazard Rate**

Compute the hazard rate of the Cauchy distribution with location and scale parameters \(a\) and \(b\) at an arbitrary point \(t\).
You can specify a value for the point $t$.

$> \text{HazardRate}(\text{Cauchy}(a, b), t)$

\[
\frac{1}{\pi b \left(1 + \frac{(t - a)^2}{b^2}\right) \left(\frac{1}{2} - \frac{\arctan \left(\frac{t - a}{b}\right)}{\pi}\right)}
\]

You can also specify that Maple compute the result numerically.

$> \text{HazardRate}\left(\text{Cauchy}(a, b), \frac{1}{2}\right)$

\[
\frac{1}{\pi b \left(1 + \left(\frac{1}{2} - a\right)^2\right) \left(\frac{1}{2} - \frac{\arctan \left(\frac{1}{2} - a\right)}{\pi}\right)}
\]

You can also specify that Maple compute the result numerically.

$> \text{HazardRate}\left(\text{Cauchy}(10, 1), \frac{1}{2}, \text{numeric}\right)$

0.003608801460

For more information, refer to the Statistics/DescriptiveStatistics help page.

**Plotting**

You can generate statistical plots using the visualization commands in the Statistics package. Available plots include:

- Bar chart
- Frequency plot
- Histogram
- Pie chart
- Scatter plot

For example, create a scatter plot for a distribution of points that vary from $\sin\left(\frac{2 \pi x}{200}\right)$ by a small value determined by a normally distributed sample.

$> N := 200;$
To fit a curve to the data points, include the optional \texttt{fi} equation parameter.

Using the \texttt{plots[display]} command, create a plot that contains:

- a scatter plot of the data points
- a quartic polynomial fit to the data points: \( f(x) = a x^4 + b x^3 + c x^2 + d x + e \)
- the function \( \sin\left(\frac{2 \pi x}{N}\right) \)

\begin{verbatim}
> U := Sample(Normal(0, 1), N):
> X := <seq(x, x = 1 .. N)>:
> Y := <seq(\sin\left(\frac{2 \pi x}{N}\right) + \frac{U[x]}{5}, x = 1 .. N)>:
> ScatterPlot(X, Y, title = "Scatter Plot");

> P := ScatterPlot(X, Y, fit = [a \cdot x^4 + b \cdot x^3 + c \cdot x^2 + d \cdot x + e], thickness = 2):
\end{verbatim}
For more information on statistical plots, refer to the Statistics/Visualization help page.

For an overview of plotting, see Plots and Animations (page 237).

**Additional Information**

For more information on the Statistics package, including regression analysis, estimation, data manipulation, and data smoothing, refer to the Statistics help page.

The Data Analysis Assistant For more information, refer to the Statistics[InteractiveDataAnalysis] help page.

**5.7 Teaching and Learning with Maple**

Table 5.10 lists the available resources for instructors and students. For additional resources, see Available Resources (page 56).
Table 5.10: Student and Instructor Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Student Packages, Tutors, and Demonstrations** | The **Student** package contains computational and visualization (plotting and animation) functionality, and point-and-click interfaces for explaining and exploring concepts (**Tools→Tutors**). For more information, refer to the **Student** help page.  
  
  Maple's Demonstrations provide interactive visual illustrations of Precalculus concepts (**Tools→Demonstrations**). Use the provided Demos, or learn how these are created and using Maple's embedded components to create your own. For more information on how the Demonstrations were created, refer to the **Demonstrations/Details** help page.  
  
  The Demonstrations are connected to more complete teaching material provided in the Teacher Resource Center. |
| **Teacher Resource Center**              | The Maple Teacher Resource Center contains resources and tips for teachers using Maplesoft products to help in the classroom. Available resources include:  
  
  • Classroom content for subjects including Precalculus, Calculus, and Engineering  
  • Training videos  
  • E-books  
  
  ([http://www.maplesoft.com/teachercenter](http://www.maplesoft.com/teachercenter)) |
| **Maple Portal**                        | The Maple Portal includes material designed for all Maple users as well as specific portals for students and educators. The Maple Portal includes:  
  
  • How Do I... topics that give quick answers to essential questions  
  • Tutorials that provide an overview of topics from getting started to plotting and working with matrices  
  • Navigation to portals with specialized information for students, math educators, and engineers  
  
  Access the portal from the **Help** menu (**Help → Manuals, Resources, and More → Maple Portal**). |
<p>| <strong>Mathematics and Engineering Dictionary</strong> | The Maple Help System has an integrated dictionary of over 5000 mathematics and engineering terms. You can search the dictionary by entering a term in the Help System search field |</p>
<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maple Application Center</td>
<td>The Maple Application Center contains tutorials and applications that help instructors begin using Maple and use Maple in the classroom. Browse the many resources in the Education and Education PowerTools categories.</td>
</tr>
<tr>
<td></td>
<td>(<a href="http://www.maplesoft.com/applications">http://www.maplesoft.com/applications</a>)</td>
</tr>
<tr>
<td>Student Help Center</td>
<td>The Maple Student Help Center contains tutorials and applications that help students learn how to use Maple, explore mathematical concepts, and solve problems. Available resources include:</td>
</tr>
<tr>
<td></td>
<td>• Study guides - Complete lessons with examples for academic courses, including precalculus and calculus. For example, the Interactive Precalculus Study Guide contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.</td>
</tr>
<tr>
<td></td>
<td>• Free course lessons for many subjects including precalculus to vector calculus; high school, abstract, and linear algebra; engineering; physics; differential equations; cryptography; and classical mechanics.</td>
</tr>
<tr>
<td></td>
<td>• Applications for students, written by students, providing examples in many subject areas.</td>
</tr>
<tr>
<td></td>
<td>• Student FAQs with answers from experts.</td>
</tr>
<tr>
<td></td>
<td>(<a href="http://www.maplesoft.com/academic/students">http://www.maplesoft.com/academic/students</a>)</td>
</tr>
</tbody>
</table>

### Student Packages and Tutors

The **Student** package is a collection of subpackages for teaching and learning mathematics and related subjects. The **Student** package contains packages for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:
- Teach concepts without being distracted by the mechanics of the computations.
- Create examples and quickly update them during a lesson to demonstrate different cases or show the effect of the variation of a parameter.
- Create plots and animations to visually explain concepts, for example, the geometric relationship between a mathematical function and its derivatives ([Tools→Tutors→Calculus - Single Variable→Derivatives](Tools→Tutors→Calculus - Single Variable→Derivatives)). See Figure 5.10.
Students can:

- Perform step-by-step computations, for example, compute a derivative by applying differentiation rules using commands or a tutor (Tools→Tutors→Calculus - Single Variable→Differentiation Methods). See Figure 5.11.
- Perform computations.
- Visually explore concepts.
Figure 5.11: Calculus 1 Differentiation Methods Tutor

Tutors provide point-and-click interfaces to the Student package functionality.

**To launch a tutor:**
1. From the Tools menu, select Tutors.
2. Select a subject, for example, Calculus - Multivariate.
3. Select a tutor, for example, Gradients.

Maple inserts the Student[Calculus][GradientTutor] calling sequence (in Worksheet mode), and launches the Multivariate Calculus Gradient Tutor.
By rotating the three-dimensional plot, you can show that the gradient points in the direction of greatest increase of the surface (see Figure 5.12) and show the direction of the gradient vector in the x-y plane by rotating the plot (see Figure 5.13).

Figure 5.12: Multivariate Calculus Gradient Tutor
Figure 5.13: Multivariate Calculus Gradient Tutor Showing x-y Plane

When you close the tutor, Maple inserts the 3-D plot.
Many Student package commands can return a value, mathematical expression, plot, or animation. This allows you to compute the final answer, see the general formula applied to a specific problem, or visualize the underlying concepts.

For example, the Student[VectorCalculus][LineInt] (line integral) command can return the following.

- Plot that visually indicates the vector field path of integration, and tangent vectors to the path
- Unevaluated line integral
- Numeric value of the line integral

> with(Student[VectorCalculus]):
To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

\[
\int_{0}^{2\pi} (-\sin(t)^2 - \cos(t)^2)\, dt \quad (5.7)
\]

To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

\[
-2\pi \quad (5.8)
\]

By default, the `LineInt` command returns the value of the integral.

\[
-2\pi r^2
\]

For more information on the `Student` package, refer to the `Student` help page.
Calculus Problem Solving Examples

Maple is a powerful application with many resources to guide you. The following examples provide you with scenarios to learn about using Maple resources and the Maple program.

When using Maple to solve a problem, consider the following process.

1. Formulate your problem.
2. Obtain Maple resources that allow you to solve it.

Problem

Scenario A:

Your company is designing a bottle for its new spring water product. The bottle must contain 18 ounces of water and the height is fixed. The design includes an undulating curved surface. You know the amplitude and equation of the curve, but you must find the radius. You require the Volume of Revolution.

Scenario B:

You want to teach your students the concept of a Volume of Revolution. Specifically, you want to plot and compute the volume of a solid generated by rotating $f(x), a \leq x \leq b$, about an axis or a line parallel to an axis.
Check for Existing Tools: Tutor

Begin by examining the Tools menu for a Tutor to a Volume of Revolution problem.

To access a Tutor for the Volume of Revolution:

1. From the Tools menu, select Tutors, and then Calculus-Single Variable. Notice that a Volume of Revolution tutor exists.

2. Click the Volume of Revolution menu item. The following Maple command is entered in your document.
The Volume of Revolution Tutor is displayed. See Figure 5.15. Use this tutor to enter a function and an interval, view and manipulate the corresponding plot, and view the full Maple command associated with your entries and selections.
Figure 5.15: Volume of Revolution Tutor

After you Close the tutor, the plot is inserted into your worksheet.

Check for Existing Tools: Task Template

1. From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens, displaying a list of tasks in the left pane. The tasks are sorted by subject to help you quickly find the desired task.

2. Expand the Calculus - Integral → Applications → Solids of Revolution folder.

3. From the displayed list, select Volume. The Volume of Revolution task is displayed in the right pane of the Browse Tasks dialog.

4. Select the Insert into New Worksheet check box.

5. Click Insert Default Content. Before inserting a task, Maple checks whether the task variables have assigned values in your worksheet. If any task variable is assigned, the Task Variables dialog opens allowing you to modify the names. Maple uses the edited
variable names for all variable instances in the inserted task. The content is inserted into your document. See Figure 5.16.

**Volume of Revolution**

Calculate the volume of revolution for a solid of revolution when a function is rotated about the horizontal or vertical axis.

Enter the function as an expression and specify the range:

\[
> \text{sin}(x) \cos(x) + 1, 0, \frac{\pi}{2}
\]

\[
\text{sin}(x) \cos(x) + 1, 0, \frac{1}{2} \pi
\]

Calculate the volume of revolution:

\[
> \text{Student[Calculus1][VolumeOfRevolution]}(1)
\]

\[
\int_0^{\pi/2} \pi \text{sin}(x) \cos(x) + 1\, dx
\]

(2)

Display the floating-point value using the `evalf` command:

\[
> \text{evalf}(2)
\]

8.693245131

(3)

Figure 5.16: Inserted Task Template

6. When a Task Template is inserted, parameters are marked as placeholders, denoted by purple font. To navigate between placeholders, press the Tab key. After updating any parameters, execute the command by pressing Enter.

**Check for Instructions: Help Page and Example Worksheet**

The help system provides command syntax information.

**To access a help page:**

1. From the Help menu, select Maple Help.

2. In the search field enter volume of revolution and click Search. The search results include the command help page, the dictionary definition and the associated tutor help page.

3. Review the calling sequence, parameters, and description in the Student[Calculus1][VolumeOfRevolution] help page.

4. Copy the examples into your worksheet: from the help system Edit menu, select Copy Examples.

5. Close the Help Navigator.
6. In your document, from the **Edit** menu, select **Paste**. The examples are pasted into your document.

7. Execute the examples and examine the results.

**To access an example worksheet:**

1. In the worksheet, enter `index/examples`. The **Example Worksheet Index** opens.

2. Expand the **Calculus** topic.

3. Click the `examples/Calculus1IntApps` link. The **Calculus1: Applications of Integration** worksheet opens. See **Figure 5.17**.

4. Expand the **Volume of Revolution** topic.

5. Examine and execute the examples.

### Calculus 1: Applications of Integration

The **Student[Calculus1]** package contains four routines that can be used to both work with and visualize the concepts of function averages, arc lengths, and volumes and surfaces of revolution. This worksheet demonstrates this functionality.

For further information about any command in the **Calculus1** package, see the corresponding help page. For a general overview, see `Calculus1`.

**Getting Started**

While any command in the package can be referred to using the long form, for example, `Student[Calculus1][DerivativePlot]`, it is easier, and often clearer, to load the package, and then use the short form command names.

```maple
> restart;
> with(Student[Calculus1]):
```

The following sections show how the routines work. In some cases, examples show how to use these visualization routines in conjunction with the single-stepping **Calculus1** routines.

- **Function Average**
- **Volume of Revolution**
- **Arc Length**
- **Surface of Revolution**

**Figure 5.17: Example Worksheet**

### Check for Other Ready-To-Use Resources: Application Center

The Maple Application Center contains free user-contributed applications related to mathematics, education, science, engineering, computer science, statistics and data analysis, finance communications, graphics, and more.

**To access a free application for volume of revolution:**

1. Go to the Maplesoft web site, **http://www.maplesoft.com**.

2. In the menu of the main web page, click **Community**, and then **Application Center**.
3. In the **Application Search** section, enter **Calculus 2** in the **Keyword or phrase** field.

4. Click **Search**.

5. From the search results page, under **Displaying applications**, click the **Click here** link.

6. From the list of archived applications, select **Calculus II: Complete Set of Lessons**.

7. Click on the **Download Maple Document** link.

8. Download the **.zip** file

9. Extract the **L2-volumeRevolution.mws** file

10. Execute the worksheet and examine the results.

### 5.8 Clickable Math

For years, Maple has led the way in making math software easy to use. With its collection of Clickable Math tools, including palettes, interactive assistants, context-sensitive menus, tutors, and more, Maple has set the standard for making it easy to learn, teach, and do mathematics.

Two key features of the Clickable Math tool collection are Drag-to-Solve and Smart Popups.
Smart Popups

Smart Popups are menus that are invoked when you select an output equation, expression or a subexpression.

With Smart Popups you can:
• select operations to apply to just one part of your equation or mathematical expression, leaving the rest unchanged.
• Preview the result of the operation before going ahead.
• Explore your expression to deepen your understanding of the problem.
• Easily determine if your subexpression can be factored, what its plot looks like, what mathematical identities could be applied, and more.

Drag-to-Solve

The Drag-to-Solve feature enables you to solve your equations step-by-step by dragging terms to where you want them to be.

With Drag-to-Solve you can:
• Easily take complete control over each individual step of your calculation.
• Let Maple apply the appropriate addition, subtraction, division, or multiplication operation to both sides of your equation, to avoid mechanical errors.
• Keep the full record of steps produced by Maple to document your work.

For more information on Smart Popups and Drag-to-Solve, as well as examples, see the worksheet, expressions, clickablemath help page.

Examples

This chapter is designed to show several ways to solve the same problem in Maple. Throughout these examples, you will need to insert new document block regions. This is done through the Format menu, by selecting Create Document Block. Also, these examples only use the keyboard keys needed for a Windows operating system. Refer to Shortcut Keys by Platform (page xviii) for the keys needed for your operating system.

Example 1 - Graph a Function and its Derivatives

On the interval \([-\pi, \pi]\], graph \(f, f',\) and \(f''\) for \(f(x) = x\cos(x)\).

We solve this problem using the following methods:
• Solution by Context Menus (page 211)
• Solution by Tutor (page 213)
## Solution by Context Menus

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the expression $x \cos(x)$.</td>
<td>$x \cos(x)$</td>
</tr>
<tr>
<td><strong>Make a copy of the expression and calculate the derivative:</strong></td>
<td></td>
</tr>
<tr>
<td>2. Insert a new document block region by selecting from the <strong>Format</strong> menu <strong>Create Document Block</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Highlight the original expression. <strong>Ctrl</strong> + drag the expression to the new document block.</td>
<td></td>
</tr>
<tr>
<td>4. Right-click the expression and select <strong>Differentiate</strong> → <strong>With Respect To</strong> → $x$.</td>
<td></td>
</tr>
<tr>
<td><strong>Make a copy of the derivative and calculate the second derivative:</strong></td>
<td></td>
</tr>
<tr>
<td>5. Insert a new document block, and <strong>Ctrl</strong> + drag the derivative to the document block.</td>
<td></td>
</tr>
<tr>
<td>6. Right-click the derivative and select <strong>Differentiate</strong> → <strong>With Respect To</strong> → $x$.</td>
<td></td>
</tr>
<tr>
<td><strong>Plot the original expression:</strong></td>
<td></td>
</tr>
<tr>
<td>7. Insert a new document block, and <strong>Ctrl</strong> + drag the original expression to the new block.</td>
<td></td>
</tr>
<tr>
<td>8. Right-click the expression and select <strong>Plots</strong> → <strong>Plot Builder</strong>.</td>
<td></td>
</tr>
<tr>
<td>9. In the <strong>Interactive Plot Builder:</strong> Select Plot Type dialog, change the x Axis range to -Pi to Pi, and then click <strong>Plot</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

\[
\begin{align*}
x \cos(x) & \rightarrow \\
\cos(x) - x \sin(x) & \rightarrow \\
\cos(x) - x \sin(x) & \rightarrow \cos(x) - x \sin(x) \\
-2 \sin(x) - x \cos(x) & \rightarrow \\
x \cos(x) & \\
\end{align*}
\]
Add the first and second derivatives to the plot:

10. Select and then Ctrl + drag the derivative of the expression onto the plot region. Do the same for the second derivative.

Enhance the plot by adding a legend using context menus:

11. Right-click in the plot region and select Legend → Show Legend.

12. In the legend, double-click Curve 1. Notice that the Text icon is selected in the toolbar, [Text]. Delete the text and select the Math icon in the toolbar, [Math]. This allows you to enter 2-D Math in a text region. Enter the original expression, \( x \cos(x) \).

13. Repeat for Curve 2 and Curve 3.
14. Right-click in the plot region and select Title → Add Title.

15. In the legend, replace the text New title with the text "Plot the expression ".

16. Click the Math icon, and enter the expression $x \cos(x)$. Click the Text icon once again and enter "and its derivatives".

**Solution by Tutor**

The **Student Calculus 1** package contains a tutor called Derivatives, which displays a plot of the expression along with its derivatives. In this example, we solve the same problem as previously, using this tutor.

1. Load the **Student Calculus 1** package. From the Tools menu, select Load Package → Student Calculus 1.

2. Ctrl + drag the expression $x \cos(x)$ to a blank document block region.
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 3. Right-click the expression and select **Tutors → Calculus - Single Variable → Derivatives. Note:** The Tutors menu is now available in the context menu because we loaded the **Student Calculus 1** package in step 1. In the **Derivative Tutor**, the color swatch shown beside the original expression is the color used for the curve in the plot region. Similarly for \( f'(x) \) and \( f''(x) \). | ![Derivative Tutor](image1)

4. Change the lower endpoint to -Pi. Select the check box to display \( f''(x) \) in the plot. Click **Display** to make these changes take effect. | ![Display](image2)

5. You can change the expression and modify plot options from within this tutor. For each change made, click **Display** to view the altered plot. When complete, click **Close** to display the resulting plot in the document. | ![Resulting Plot](image3)
# Access the Tutor from a Task Template

Maple also comes with a Task Template to solve this problem without using any commands.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Launch the Task Template Browser by selecting <strong>Tools → Tasks → Browse</strong>.</td>
<td><img src="image" alt="Task Browser" /></td>
</tr>
<tr>
<td>2. In the table of contents of the <strong>Task Browser</strong> dialog, select <strong>Calculus - Differential → Derivatives → Graph ( f(x) ) and its Derivatives</strong>.</td>
<td><img src="image" alt="Task Browser" /></td>
</tr>
<tr>
<td>3. Click <strong>Insert Minimal Content</strong> at the top of the dialog to insert the task template into the current document.</td>
<td><img src="image" alt="Task Browser" /></td>
</tr>
<tr>
<td>4. Enter the new expression ( x \cdot \cos(x) ) in the ( f(x) ) region.</td>
<td><img src="image" alt="Task Browser" /></td>
</tr>
<tr>
<td>5. Enter the interval ([-\pi, \pi]). To insert the symbol for ( \pi ), you can use command completion or select ( \pi ) from the <strong>Common Symbols</strong> palette.</td>
<td><img src="image" alt="Task Browser" /></td>
</tr>
</tbody>
</table>
**Example 2 - Solve for x in a Quadratic Equation**

Solve for $x$ in the equation $(x - 7)^2 + (x - 1)^2 = 4[(x - 1)^2 + (x - 4)^2]$.

We solve this problem using the following methods:

- *Solution through Equation Manipulator (page 216)*
- *Instant Solution (page 218)*
- *Step-by-step Interactive Solution (page 218)*
- *Graphical Solution (page 219)*

**Solution through Equation Manipulator**

Maple provides a dialog that allows you to single-step through the process of manipulating an expression. This manipulator is available from the context menu.
1. Enter the equation 
\[(x - 7)^2 + (x - 1)^2 = 4 \left( (x - 1)^2 + (x - 4)^2 \right)\]
in a new document block region.
2. Right-click this equation and select Manipulate Equation. The Manipulate Equation dialog displays.

Group all of the terms to the left:
3. In the Addition region, the Group terms row allows you to group terms on a specific side. With the left side already selected, click Do.

Expand the left side of the equation:
4. In the Miscellaneous Operations region, we can manipulate the equation by applying a command from the drop-down menus. Since we want to expand the left side of the equation only, click the first drop-down menu in the second row and select expand. Click Do.
Result in Document Action

**Factor the equation:**

5. From the same drop-down menu, select **factor** and click **Do**.

6. Click **Return Steps** to close the dialog and return all of the steps to the Maple document.

\[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\]

\[\text{manipulate equation}\]

\[(x - 7)^2 + (x - 1)^2 = 4(x - 1)^2 + 4(x - 4)^2\]

\[(x - 7)^2 - 3(x - 1)^2 - 4(x - 4)^2 = 0\]

\[-6x^2 + 24x - 18 = 0\]

\[-6(x - 1)(x - 3) = 0\]

7. **Ctrl** + drag the factored form of the original equation to a new document block region.

8. Right-click and select **Solve → Obtain Solutions for → x**.

\[-6(x - 1)(x - 3) = 0 \quad \text{solutions for } x \rightarrow 1, 3\]

**Instant Solution**

To apply an instant solution to this problem, use context menus.

Action | Result in Document
---|---
1. **Ctrl** + drag the equation \[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\] to a new document block region. | \[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\]

2. Right-click the expression and select **Solve → Obtain Solutions for → x**. | \[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\] \[\text{solutions for } x \rightarrow 1, 3\]

**Step-by-step Interactive Solution**

This equation can also be solved interactively in the document, by applying context-menu operations or commands one step at a time.

Action | Result in Document
---|---
1. **Ctrl** + drag the equation \[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\] to a blank document block region. | \[(x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)\]
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group all terms on the right:</strong></td>
<td>((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2))</td>
</tr>
<tr>
<td>2. Right-click this equation and from the context menu select <strong>Move to Right</strong>.</td>
<td>(\quad\quad\quad\quad\quad\quad\quad\rightarrow\text{move to right})</td>
</tr>
<tr>
<td>3. Right-click on the result and from the context menu select <strong>Expand</strong>.</td>
<td>(0 = 3(x - 1)^2 + 4(x - 4)^2 - (x - 7)^2) expand</td>
</tr>
<tr>
<td><strong>Expand the expression on the right-hand side:</strong></td>
<td><strong>Use Maple's factor command on the resulting right-hand side:</strong></td>
</tr>
<tr>
<td>4. Right-click on the result and select <strong>Right-hand Side</strong>.</td>
<td><strong>Solve for x:</strong></td>
</tr>
<tr>
<td>5. Right-click on the result and select <strong>Factor</strong>.</td>
<td><strong>Graphical Solution</strong></td>
</tr>
<tr>
<td><strong>Solve for x:</strong></td>
<td>Now that we have seen several methods to solve this problem, we can check the answer by plotting the expression.</td>
</tr>
<tr>
<td>6. Right-click on the result and select <strong>Solve \rightarrow Obtain Solutions for \rightarrow x.</strong></td>
<td><strong>Action</strong></td>
</tr>
<tr>
<td><strong>Graphical Solution</strong></td>
<td><strong>Result in Document</strong></td>
</tr>
<tr>
<td>1. <strong>Ctrl</strong> + drag the equation</td>
<td>((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2))</td>
</tr>
<tr>
<td>((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2)) to a new document block region and press <strong>Enter</strong>.</td>
<td>((x - 7)^2 + (x - 1)^2 = 4((x - 1)^2 + (x - 4)^2))</td>
</tr>
<tr>
<td>((x - 7)^2 + (x - 1)^2 = 4(x - 1)^2 + 4(x - 4)^2) to a new document block region and press <strong>Enter</strong>.</td>
<td>((x - 7)^2 + (x - 1)^2 = 4(x - 1)^2 + 4(x - 4)^2)</td>
</tr>
<tr>
<td><strong>First, manipulate the equation to become an expression:</strong></td>
<td><strong>First, manipulate the equation to become an expression:</strong></td>
</tr>
<tr>
<td>2. Right-click the output and select <strong>Move to Left</strong>.</td>
<td><strong>First, manipulate the equation to become an expression:</strong></td>
</tr>
<tr>
<td><strong>Note the difference in the alignment when using context menus on output rather than input. The result is centered in the document with the self-documenting arrow positioned at the left.</strong></td>
<td><strong>First, manipulate the equation to become an expression:</strong></td>
</tr>
<tr>
<td>Action</td>
<td>Result in Document</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>3. Right-click the output and select <strong>Left-hand Side.</strong></td>
<td>((x - 7)^2 - 3 (x - 1)^2 - 4 (x - 4)^2 = 0)</td>
</tr>
<tr>
<td></td>
<td>(\text{left hand side} \rightarrow) ((x - 7)^2 - 3 (x - 1)^2 - 4 (x - 4)^2)</td>
</tr>
<tr>
<td>4. Right-click the output and select <strong>Expand.</strong></td>
<td>((x - 7)^2 - 3 (x - 1)^2 - 4 (x - 4)^2)</td>
</tr>
<tr>
<td></td>
<td>(\text{expand} \rightarrow -6x^2 + 24x - 18)</td>
</tr>
</tbody>
</table>

**Now that the equation is in its simplest form, plot the result:**

5. **Ctrl** + drag the output to a new document block.

6. Right-click the expression and select **Plots → 2-D Plot.**

![Graph of the equation \(-6x^2 + 24x - 18\).]
Action

| Change the \( x \) and \( y \) axis ranges using context menus: |
| 7. By default, plots generated using the context menus have an \( x \)-axis range of -10 to 10. To change the range, right-click the plot and select \textit{Axes} \rightarrow \textit{Properties}. In the \textit{Horizontal} tab of the \textit{Axes Properties} dialog, de-select \textit{Use data extents} and change the \textit{Range min} and \textit{Range max} to 0 and 5, respectively. |
| Click the \textit{Vertical} tab and de-select \textit{Use data extents}. Change the \textit{Range min} and \textit{Range max} to -5 and 10, respectively. |
| 8. Click \textit{OK} to apply the changes and return to the plot. |

The interception points of this graph with the \( x \)-axis are 1 and 3, the same solutions that we found previously.

**Example 3 - Solve a Quadratic Trig Equation**

Find all of the solutions to the equation \( 6 \cos^2(x) - \cos(x) - 2 = 0 \) in the interval \([0, 2 \pi]\).

We solve this problem using the following methods:

- \textit{Graphical Solution} (page 221)
- \textit{Solution by Task Template} (page 223)
- \textit{Analytic Solution} (page 223)

**Graphical Solution**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. \textbf{Ctrl} + drag the equation \( 6 \cos^2(x) - \cos(x) - 2 = 0 \) to a blank document block and press \textbf{Enter}. | \( 6 \cos^2(x) - \cos(x) - 2 = 0 \)  
\[
6 \cos^2(x) - \cos(x) - 2 = 0
\]
| 2. Right-click the output and select \textbf{Left-hand Side}. | \( 6 \cos^2(x) - \cos(x) - 2 = 0 \)  
\[
6 \cos(x)^2 - \cos(x) - 2 = 0
\]
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Right-click the output and select <strong>Plots → Plot Builder</strong>.</td>
<td>![Image of Plot Builder interface]</td>
</tr>
<tr>
<td>4. Modify the plot range to $x = 0$ to $2\pi$.</td>
<td>![Image of modified plot range]</td>
</tr>
<tr>
<td>5. Click <strong>Plot</strong> to display the plot in the document.</td>
<td>![Image of plot in document]</td>
</tr>
<tr>
<td>6. From the graph, we can see all of the solutions within the interval $[0, 2\pi]$. To approximate the values, click the plot, select the type of coordinates that you want to view from the selection menu (▲▼) in the toolbar, and then use the point probe tool to view the coordinates of the mouse pointer.</td>
<td>![Image of point probe tool usage]</td>
</tr>
</tbody>
</table>
### Solution by Task Template

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the <strong>Format</strong> menu, select <strong>Tasks → Browse</strong>. Expand the <strong>Algebra</strong> folder and select <strong>Solve Analytically in a Specific Interval</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

| **Solve Analytically in a Specific Interval** |  

| Enter an expression | \[ 12 \sin^2(x) - 5 \sin(x) - 3, \]
|---------------------|---------------------|
| Find the roots in a specified interval | \[ \text{Student} \{ \text{Calculus} \} \{ \text{Roots} \} \{ 15 \}, 0.2 \pi \]
| | \[ \text{arccos} \left( \frac{3}{4} \right), \text{arccos} \left( \frac{3}{4} \right) + \pi, \text{arccos} \left( \frac{1}{3} \right) \]
| | \[ + \pi, -\text{arccos} \left( \frac{1}{3} \right) + 2 \pi \]
| Express the roots in floating-point form | \[ \approx \{ 1.92, 3.14, 3.71 \} \]
| | \[ 0.84, 3.14, 3.49 \] |
| | \[ 0.84, 3.14, 3.49 \] |
| | \[ 0.84, 3.14, 3.49 \] |
| | \[ 0.84, 3.14, 3.49 \] |
| | \[ 0.84, 3.14, 3.49 \] |

2. Click **Insert Minimal Content**.  

| **Solve Analytically in a Specific Interval** |  

| Enter an expression | \[ 6 \cos^2(x) - \cos(x) - 2 = 0 \]
|---------------------|---------------------|
| Find the roots in a specified interval | \[ \text{Student} \{ \text{Calculus} \} \{ \text{Roots} \} \{ 15 \}, 0.2 \pi \]
| | \[ \text{acccos} \left( \frac{2}{3} \right), \text{acccos} \left( \frac{2}{3} \right) + \pi, \text{acccos} \left( \frac{2}{3} \right) \]
| | \[ + \pi \]
| Express the roots in floating-point form | \[ \approx \{ 1.04, 3.89, 1.04 \} \]
| | \[ 0.34, 3.14, 0.34 \] |
| | \[ 0.34, 3.14, 0.34 \] |
| | \[ 0.34, 3.14, 0.34 \] |
| | \[ 0.34, 3.14, 0.34 \] |
| | \[ 0.34, 3.14, 0.34 \] |

3. Replace the current equation with the one from this example, \[ 6 \cos^2(x) - \cos(x) - 2 = 0 \], and then execute the commands. Notice that equation labels are used to reference the results.

### Analytic Solution

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. <strong>Ctrl</strong> + drag the equation [ 6 \cos^2(x) - \cos(x) - 2 = 0 ] to a blank document block region.</td>
<td>[ 6 \cos^2(x) - \cos(x) - 2 = 0 ]</td>
</tr>
<tr>
<td>2. Right-click the expression and select <strong>Left-hand Side</strong>.</td>
<td>[ 6 \cos^2(x) - \cos(x) - 2 = 0 ] [ 6 \cos(x)^2 - \cos(x) - 2 ]</td>
</tr>
<tr>
<td>Action</td>
<td>Result in Document</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>3. Right-click the output and select <strong>Factor</strong>.</td>
<td>$6 \cos(x)^2 - \cos(x) - 2$ factor $(2 \cos(x) + 1)(3 \cos(x) - 2)$</td>
</tr>
<tr>
<td>4. <strong>Ctrl</strong> + drag the first factor to a blank document block region.</td>
<td>$(2 \cos(x) + 1)$ solve ${x = \frac{2}{3}, \pi}$</td>
</tr>
<tr>
<td>5. Right-click and select <strong>Solve → Solve</strong>.</td>
<td></td>
</tr>
<tr>
<td>6. <strong>Ctrl</strong> + drag the second factor to a blank document block region.</td>
<td>$(3 \cos(x) - 2)$ solve ${x = \arccos\left(\frac{2}{3}\right)}$</td>
</tr>
<tr>
<td>7. Right-click and select <strong>Solve → Solve</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

Notice that you have not found all of the solutions, as with the above methods. These are all of the solutions in the interval $[0, \pi]$.

**Example 4 - Find the Inverse Function**

If $f(x) = x^2 + 1, x \geq 0$, find and graph the rule for $f^{-1}(x)$, its functional inverse.

We solve this problem using the following methods:

- **Implement the Definition Graphically** (page 225)
- **Solution by Tutor** (page 228)
Implement the Definition Graphically

The graph of the inverse function is the set of ordered pairs formed by interchanging the ordinates and abscissas.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In a blank document block, enter ([x^2 + 1, x]) and press Enter.</td>
<td>([x^2 + 1, x])</td>
</tr>
<tr>
<td>2. Right-click the output and select Plots → Plot Builder.</td>
<td><img src="image" alt="Interactive Plot Builder: Select Plot Type" /></td>
</tr>
</tbody>
</table>
3. In the **Plot Builder : Select Plot Type** dialog, ensure that **2-D parametric plot** is selected in the **Select Plot** region.

4. Adjust the domain for $x$ to the interval $[0, 1]$.

5. Click **Plot** to return the plot to the document.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. In the <strong>Plot Builder : Select Plot Type</strong> dialog, ensure that <strong>2-D parametric plot</strong> is selected in the <strong>Select Plot</strong> region.</td>
<td><img src="image" alt="Plot" /></td>
</tr>
<tr>
<td>4. Adjust the domain for $x$ to the interval $[0, 1]$.</td>
<td></td>
</tr>
<tr>
<td>5. Click <strong>Plot</strong> to return the plot to the document.</td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td>Result in Document</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>6. Ctrl + drag the expression $x^2 + 1$ onto this graph. Notice that the axis ranges alter.</td>
<td><img src="image1" alt="Graph" /></td>
</tr>
<tr>
<td>7. Ctrl + drag the expression $x$ onto this graph. The resulting graph shows $f(x), f^{-1}(x)$, and the line $y = x$.</td>
<td><img src="image2" alt="Graph" /></td>
</tr>
</tbody>
</table>
Adjust the $x$ and $y$ axis ranges:
8. Right-click the plot and select Axes → Properties.
9. In the Axis Properties dialog, de-select Use data extents and change the range to 0 to 2.
10. Click the Vertical tab and repeat step 9. Click OK to apply these settings and close the dialog.

Solution by Tutor

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Load the Student Calculus 1 package. From the Tools menu, select Load Package → Student Calculus 1.</td>
<td>Loading Student:-Calculus1</td>
</tr>
<tr>
<td>2. Enter the expression $x^2 + 1$ in a blank document block.</td>
<td>$x^2 + 1$</td>
</tr>
<tr>
<td>4. Adjust the domain to $[0, 2]$.</td>
<td></td>
</tr>
</tbody>
</table>
When you are finished click **Close**. The plot of the function, its inverse, and the line $y = x$ is returned to the document.

---

**Example 5 - Methods of Integration - Trig Substitution**

Evaluate the integral $\int \frac{1}{\sqrt{4 - x^2}} \, dx$ by making the substitution $x = 2 \sin(u)$.

We solve this problem using the following methods:

- **Immediate Evaluation of the Integral** (page 229)
- **Solution by Integration Methods Tutor** (page 230)
- **Solution by First Principles** (page 231)

**Immediate Evaluation of the Integral**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the integral $\int \frac{1}{\sqrt{4 - x^2}} , dx$ in a blank document block region.</td>
<td>$\int \frac{1}{\sqrt{4 - x^2}} , dx$</td>
</tr>
<tr>
<td>2. Right-click the expression and select <strong>Evaluate and Display Inline</strong>.</td>
<td>$\int \frac{1}{\sqrt{4 - x^2}} , dx = \arcsin \left( \frac{1}{2} x \right)$</td>
</tr>
</tbody>
</table>
### Solution by Integration Methods Tutor

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Load the <strong>Student Calculus 1</strong> package. From the <strong>Tools</strong> menu, select <strong>Load Package → Student Calculus 1</strong>.</td>
<td><strong>Loading Student-Calculus1</strong></td>
</tr>
<tr>
<td>2. <strong>Ctrl</strong> + drag the integrand $\frac{1}{\sqrt{4 - x^2}}$ to a blank document block region.</td>
<td>$\frac{1}{\sqrt{4 - x^2}}$</td>
</tr>
<tr>
<td>3. Right-click the expression and select <strong>Tutors → Calculus Single Variable → Integration Methods</strong>. The <strong>Integration Methods Tutor</strong> displays.</td>
<td><img src="image" alt="Integration Methods Tutor" /></td>
</tr>
<tr>
<td>4. Perform a change of variables by selecting <strong>Change</strong> and entering $x = 2\sin(u)$.</td>
<td>$\int (4 - x^2)^{\frac{1}{2}} dx$ changes to $\int \frac{1}{2} du$ where the change rule has been applied.</td>
</tr>
</tbody>
</table>

**Mathematical Problem Solving**

230 • 5
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 5. Apply the constant rule by clicking **Constant**.                  | \[
\int (4 - x^2) \frac{1}{2} \, dx
\]
| 6. To revert back to the original variable, click **Revert**.         | \[
\int dx = \int du = \arcsin \left( \frac{1}{2} x \right)
\]
| 7. Now that the integral has been evaluated, click **Close** to close | \[
\int \frac{1}{\sqrt{4 - x^2}} \, dx
\]

**Solution by First Principles**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
</table>
| 1. Ctrl + drag the integrand \( \frac{1}{\sqrt{4 - x^2}} \) to a blank | \[
\frac{1}{\sqrt{4 - x^2}}
\]
| document block region and press **Enter**.                           | \[
\frac{1}{\sqrt{4 - x^2}}
\]
| Perform **trig substitution:**                                      | \[
\frac{1}{\sqrt{4 - 4 \sin(u)^2}}
\]
| 2. Right-click the output and select **Evaluate at a point**.         | evaluate at point
| In the dialog that displays, enter **2sin(u)**.                      | \[
\frac{1}{\sqrt{4 - 4 \sin(u)^2}}
\]
| 3. Right-click the output and select **Simplify → Symbolic**.         | simplify symbolic
|                                                                      | \[
\frac{1}{2 \cos(u)}
\]  

(5.9)
<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate ( \frac{du}{dx} ):</td>
<td>$x = 2 \sin(u)$</td>
</tr>
<tr>
<td>4. In a blank document block, enter the substitution equation: $x = 2 \sin(u)$ and press Enter.</td>
<td>$x = 2 \sin(u)$ [Implicit differentiation] $2 \cos(u)$ [\text{(5.10)}]</td>
</tr>
<tr>
<td>5. Right-click the output and select Differentiate \rightarrow Implicitly. In the dialog that displays, change the Independent Variable to $u$.</td>
<td></td>
</tr>
<tr>
<td>Calculate the integral in terms of $u$:</td>
<td>$\int(5.11) , du$ [5.9 \cdot 5.10]</td>
</tr>
<tr>
<td>6. Referencing the results by their equation labels, multiply the original simplify expression by this derivative.</td>
<td>$1$ [\text{(5.11)}]</td>
</tr>
<tr>
<td>7. Integrate the resulting expression.</td>
<td>$\int(5.11) , du$ [5.12]</td>
</tr>
<tr>
<td>Revert the substitution:</td>
<td>$x = 2 \sin(5.12)$ [\text{solve for } u] $\left[ u = \arcsin\left(\frac{1}{2} \cdot x\right) \right]$</td>
</tr>
<tr>
<td>8. Place the equation $x = 2 \sin(u)$ in a blank document block. Delete $u$ and insert the equation label for the previous result, the value of the integral in terms of $u$. Press Enter.</td>
<td>$x = 2 \sin(5.12)$ [\text{solve for } u] $\left[ u = \arcsin\left(\frac{1}{2} \cdot x\right) \right]$</td>
</tr>
<tr>
<td>9. Right-click the output and select Solve \rightarrow Solve for Variable \rightarrow $u$.</td>
<td></td>
</tr>
<tr>
<td>The solution is $\arcsin\left(\frac{1}{2} \cdot x\right)$.</td>
<td></td>
</tr>
</tbody>
</table>

**Example 6 - Initial Value Problem**

Solve and plot the solution of the initial value problem

\[
y''(t) + 4y'(t) + 13y(t) = \cos(2t) \\
y(0) = 2 \\
y'(0) = -1
\]
Solution by ODE Analyzer Assistant

The ODE Analyzer Assistant lets you solve ODEs numerically or symbolically and displays a plot of the solution.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Enter the ODE in a blank document block region.</td>
<td>$y''(t) + 4y'(t) + 13y(t) = \cos(2t)$</td>
</tr>
</tbody>
</table>

2. Right-click the equation and select **Solve DE Interactively**. The ODE Analyzer Assistant displays with the ODE automatically inserted.

To insert the initial conditions:

3. In the **Conditions** region, click **Edit**. The **Edit Conditions** dialog opens.

4. In the **Add Condition** region, with $y$ selected in the drop-down menu, enter $0$ in the first text field to the right and $2$ in the second text field. Click **Add**. Your entry should match the one shown to the right.
5. To enter the initial condition for $y'$, select $y'$ from the drop-down menu. In the text fields enter $0$ and $-1$. Click **Add**.

Click **Done** to close this dialog and return to the main dialog. Notice that the initial conditions are in the **Conditions** section.

6. Click **Solve Numerically**. A new dialog appears.

7. Click **Solve** to solve the initial value problem.

8. Click **Plot** to plot the solution of the DE.
9. Click the **Plot Options** button to modify the default graph, if desired.

10. Click **Quit** to close the ODE Analyzer and return a plot of the solution to the document.

\[
y''(t) + 4y'(t) + 13y(t) = \cos(2t) \quad \text{solve DE interactively}
\]
6 Plots and Animations

Maple can generate many forms of plots, allowing you to visualize a problem and further understand concepts.

- Maple accepts explicit, implicit, and parametric forms to display 2-D and 3-D plots and animations.
- Maple recognizes many coordinate systems.
- All plot regions in Maple are active; therefore, you can drag expressions to and from a plot region.
- Maple offers numerous plot options, such as axis styles, title, colors, shading options, surface styles, and axis ranges, which give you complete control to customize your plots.

For a reference to the types of plots available in Maple, see the Plotting Guide.

6.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Plots (page 238) - Interactive and command-driven methods to display 2-D and 3-D plots</td>
<td>• Interactive Plot Builder&lt;br&gt; • Context Menu&lt;br&gt; • Dragging to a Plot Region&lt;br&gt; • The plot and plot3d Commands&lt;br&gt; • The plots Package&lt;br&gt; • Multiple Plots in the Same Plot Region</td>
</tr>
<tr>
<td>Customizing Plots (page 263) - Methods for applying plot options before and after a plot displays</td>
<td>• Interactive Plot Builder Options&lt;br&gt; • Context Menu Options&lt;br&gt; • The plot and plot3d Command Options</td>
</tr>
<tr>
<td>Analyzing Plots (page 269) - Plot analyzing tools</td>
<td>• Point Probe&lt;br&gt; • Rotate&lt;br&gt; • Pan&lt;br&gt; • Zoom</td>
</tr>
<tr>
<td>Representing Data (page 270) - Templates for visual representation of your data</td>
<td>• The Live Data Plots Palette</td>
</tr>
<tr>
<td>Creating Animations (page 270) - Interactive and command-driven methods to display animations</td>
<td>• Interactive Plot Builder&lt;br&gt; • The plots[animate] Command&lt;br&gt; • The plot3d[viewpoint] Command</td>
</tr>
</tbody>
</table>
### 6.2 Creating Plots

Maple offers several methods to easily plot an expression. These methods include:

- **The Interactive Plot Builder**
- Context menus
- Dragging to a plot region
- Commands

Each method offers a unique set of advantages. The method you use depends on the type of plot to display, as well as your personal preferences.

**Interactive Plot Builder**

The Interactive Plot Builder is a point-and-click interface to the Maple plotting functionality. The interface displays plot types based on the expression you specify. The available plot types include plots, interactive plots, animations, or interactive animations. Depending on the plot type you select, you can create a:

- 2-D / 3-D plot
- 2-D polar plot
- 2-D / 3-D conformal plot of a complex-valued function
- 2-D / 3-D complex plot
- 2-D density plot
- 2-D gradient vector-field plot
- 2-D implicit plot
Using the **Interactive Plot Builder**, you can:

1. Specify the plotting domain before you display the graph
2. Specify the endpoints of the graph as symbolic, such as $\pi$ or $\sqrt{2}$
3. Select different kinds of graphs, such as animations or interactive plots with slider control of a parameter; that is, customize and display a plot by selecting from the numerous plot types and applying plot options without any knowledge of plotting command syntax
4. Apply the `discont=true` option for a discontinuous graph

The output from the **Interactive Plot Builder** is a plot of the expression or the command used to generate the plot in the document.

To launch the **Interactive Plot Builder**:

- From the **Tools** menu, select **Assistants**, and then **Plot Builder**. **Note**: The **Tools** menu also offers tutors to easily generate plots in several academic subjects. For more information, see *Teaching and Learning with Maple* (page 194).

**Table 6.1: Windows of the Interactive Plot Builder**

<table>
<thead>
<tr>
<th>1. Specify Expressions window</th>
<th>2. Select Plot Type window</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Specify Expressions window" /></td>
<td><img src="image2.png" alt="Select Plot Type window" /></td>
</tr>
</tbody>
</table>

1. **Specify Expressions window** - Add, edit, or remove expressions and variables. Once finished you can advance to the **Select Plot Type** window.

2. **Select Plot Type window** - Select the plot type and corresponding plot, and edit the ranges. Once finished you can display the plot or advance to the **Plot Options** window.
3. **Plot Options window** - Apply plot options. Once finished you can display the plot or return the command that generates the plot to the document.

**Example 1 - Display a plot of a single variable expression**

Maple can display two-dimensional graphs and offers numerous plot options such as color, title, and axis styles to customize the plot.
Launch the Interactive Plot Builder:
1. Make sure that the cursor is in a Maple input region.
2. From the Tools menu, select Assistants, and then Plot Builder.

Notes: 1. In worksheet mode, Maple inserts plots[interactive]() in the Maple document. Entering this command at the Maple prompt also opens the Plot Builder.
2. Interaction with the document is disabled while the Plot Builder is running.

Enter an expression:
3. In the Specify Expressions window:
   a. Add the expression, \( \sin(x)/x \).
   b. Click OK to proceed to the Select Plot Type window.

Plot the expression:
4. In the Select Plot Type window, notice the default setting of a 2-D plot type and an \( x \) axis range, \(-\pi..\pi\). Notice also the various plot types available for this expression.
5. Click Plot.

To see the Maple syntax used to generate this plot, see Maple commands from Creating Plots: Interactive Plot Builder (page 249)

Example 2 - Display a plot of multiple expressions in 1 variable

Maple can display multiple expressions in the same plot region to compare and contrast. The Interactive Plot Builder accepts multiple expressions.

Launch the Interactive Plot Builder and enter the expressions:
1. Launch the Interactive Plot Builder. The Plot Builder accepts expressions in 1-D Math and performs basic calculations on expressions. For example, entering \( \text{diff}(\sin(x^2),x) \) in the Specify Expression window performs the calculation and displays the expression as \( 2*\cos(x^2)*x \) in the Expression group box.
2. In the Specify Expressions window:
   • In three separate steps, add the expressions \( \sin(x^2) \), \( \text{diff}(\sin(x^2),x) \), and \( \text{int}(\sin(x^2),x) \).

Change the x-axis range:
3. In the Select Plot Type window:
   a. Change the x Axis range to -\( \pi \) .. \( \pi \).
   b. Click Options to proceed to the Plot Options window.
Launch the Plot Options window and return the plot command syntax to the document:

4. Click *Command*.

Display the actual plot:

5. Execute the inserted command to display the plot by using the context menu item *Evaluate*.

```maple
> plots[interactive]();
```

By default, Maple displays each plot in a plot region using a different color. You can also apply a line style such as solid, dashed, or dotted for each expression in the graph. For more information, refer to the *plot/options* help page. To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 249)

**Example 3 - Display a plot of a multi-variate expression**

Maple can display three-dimensional plots and offers numerous plot options such as light models, surface styles, and shadings to allow you to customize the plot.

Launch the Interactive Plot Builder and enter an expression:

1. Add the expression \( \frac{1+\sin(xy)}{x^2+y^2} \).

In the Select Plot Type window:

2. Notice the available plot types for an expression with 2 variables, as well as the plot objects for each type.

3. Click *Options*.

In the Plot Options window:

4. From the *Variables* column at the top of the dialog, change the *Range from* field to 0 .. 0.05.

5. From the *Label* column, enter z.

6. From the *Style* group box, select *surface*.

7. From the *Color* group box, in the *Light Model* drop-down menu, select *green-red*.

8. From the *Color* group box, in the *Shading* drop-down menu, select *z (grayscale)*.

9. From the *Miscellaneous* group box, in the *Grid Size* drop-down menu, select 40, 40.

Plot the expression:

10. Click *Plot*.

To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 249)
Example 4 - Display a conformal plot

Maple can display a conformal plot of a complex expression mapped onto a two-dimensional grid or plotted on the Riemann sphere in 3-D.

Launch the Interactive Plot Builder and enter an expression:

1. Add the expression $z^3$.

In the Select Plot Type window:
2. From the Select Plot group box, select 2-D conformal plot of a complex-valued function.
3. Change the range of the $z$ parameter to $0 .. 2+2*I$.

In the Plot Options window:
4. From the Axes group box, select normal.
5. From the Miscellaneous group box, select the Grid Size drop-down menu option 30, 30.

Plot the expression:
6. Click Plot.

Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports numerous other coordinate systems, including hyperbolic, inverse elliptic, logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cylindrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-dimensional plots. For a complete list of supported coordinate systems, refer to the coords help page.

Launch the Interactive Plot Builder and enter an expression:

1. Add the expression $1+4*cos(4*\theta)$.

Change the x-axis range:
2. In the Select Plot Type window:
   a. With 2-D polar plot selected, change the Angle of theta to $0 .. 8*Pi$.

In the Plot Options window:
3. From the Color group box, select Magenta.

Plot the expression:
4. Click Plot.

To see the Maple syntax used to generate this plot, see Maple commands from Creating Plots: Interactive Plot Builder (page 249)
Example 6 - Interactive Plotting

Using the Interactive Plot Builder, you can plot an expression with several of its variables set to numeric values. The Interactive Parameter window allows you to interactively adjust these numeric values within specified ranges to observe their effect. To access this window, enter an expression with two or more variables and select Interactive Plot with x parameter from the Select Plot Type and Functions drop-down menu.

Launch the Interactive Plot Builder and enter an expression:
1. Add the expression $x + 3 \sin(xt)$.
In the Select Plot Type window:

2. From the Select Plot group box, select Interactive Plot with 1 parameter.
3. Change the range of the x-axis to $0..2\pi$.
4. Change the $t$ range to $0..10$.
5. Click Plot to open the Interactive Parameter window.

Note: To apply plot options before interactively adjusting the plot, click Options to open the Plot Options window. After setting the plot options, click Plot to display the Interactive Parameter window.

6. To adjust the numeric values, use the slider.
7. Click Done to place the plot in the Maple document.

To see the Maple syntax used to generate this plot, see Maple commands from Creating Plots: Interactive Plot Builder (page 249)

For information on customizing plots using the Interactive Plot Builder, refer to Customizing Plots: Interactive Plot Builder Options (page 263).

**Context Menu**

A context menu in Maple displays a list of commands to manipulate, display, or calculate using a Maple expression. The commands in the menu depend on the type of the expression. To display the context menu for a Maple expression, right-click (Control-click for Macintosh) the expression.

For expressions, the context menu lists:

- 2-D or 3-D plot
- 2-D or 3-D implicit plot
- Interactive Plot Builder

based on the expression selected.

When you invoke the Interactive Plot Builder through the context menu, the expression automatically passes to the builder, and Maple does not display the Specify Expression window.
One advantage of using the context menu is the simplicity of creating an expression using menus. By using this method, you do not need any knowledge of plot command syntax.

1. Enter and evaluate an expression, for example, $\frac{xy}{x^2+y^2}$.

2. Right-click (Control-click for Macintosh) the expression.

3. From the context menu, select **Plots** → **3-D Plot** → **x,y**.
\[ \frac{xy}{x^2 + y^2} \]
For information on customizing plots using the context menu, see *Context Menu Options* (page 264).

**Dragging to a Plot Region**

To use the drag-and-drop method, use the plot region created by one of the other methods or insert an empty plot region into the document. Empty plot regions can be two-dimensional or three-dimensional.

Advantages of the drag-and-drop method include the ease of adding and removing plots and the independence from plotting command syntax.

**Example:**

1. From the **Insert** menu, select **Plot → 2-D**.

2. Enter the expression \( \sin(x) \) in an input region.

3. When dragging an expression to a plot region, you can either make a copy of the expression from the input region or you can cut the expression, thereby removing it from the input region. To make a copy of the expression, select the full expression in the input region and press **Ctrl** (*Command*, Macintosh) while you drag the expression to the plot region. To cut the expression and paste it in the plot region, highlight the expression and drag it to the plot region.

4. Repeat steps 2 and 3 using the following expressions: \( \sin(2x) \), \( \sin(x + 2) \), and \( \sin(x)^2 \).

5. To remove an expression from the plot region, drag-and-drop the expression plot from the plot region to a Maple input region.
The plot and plot3d Commands

The final method for creating plots is entering plotting commands.

The main advantages of using plotting commands are the availability of all Maple plot structures and the greater control over the plot output. Plot options are discussed in Customizing Plots (page 263).

Table 6.2: The plot and plot3d Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot(plotexpression, x=a..b, ...)</td>
<td>plot expression expression to be plotted</td>
</tr>
<tr>
<td>plot3d(plotexpression, x=a..b, y=a..b, ...)</td>
<td>plot expression expression to be plotted</td>
</tr>
<tr>
<td>• plotexpression - expression to be plotted</td>
<td>• x=a..b - name and horizontal range</td>
</tr>
<tr>
<td>• y=a..b - name and vertical range</td>
<td>• y=a..b - name and vertical range</td>
</tr>
</tbody>
</table>

Maple commands from Creating Plots: Interactive Plot Builder

The following examples show the plotting commands returned by the examples in Interactive Plot Builder (page 238).
Example 1 - Display a plot of a single variable expression

\[ \text{plot}\left( \frac{\sin(x)}{x}, x = -2\pi .. 2\pi \right) \]

Example 2 - Display a plot of multiple expressions in 1 variable

To display multiple expressions in a plot, include the expressions in a list. To enter \( \frac{d}{dx}\sin(x^2) \) and \( \int \sin(x^2) \, dx \), use the Expression palette. For more information, see Palettes (page 21).
\[ \text{plot} \left( \left[ \sin(x^2), \frac{d}{dx} \sin(x^2), \int \sin(x^2) \, dx \right], x = -\pi \ldots \pi \right) \]
Example 3 - Display a plot of a multi-variable expression

\[
> \text{plot3d}\left(\frac{1 + \sin(xy)}{x^2 + y^2}, x = -2\pi \ldots 2\pi, y = -2\pi \ldots 2\pi, \text{view} = 0 \ldots 0.5, \\
\text{lightmodel} = \text{light1}, \text{shading} = \text{zgrayscale}, \text{style} = \text{patchnogrid}, \text{grid} = [40, 40]\right)
\]

Example 4 - Display a conformal plot

A collection of specialized plotting routines is available in the \texttt{plots} package. For access to a single command in a package, use the long form of the command.
\[
> \text{plots[conformal]}(z^3, z = 0.2 \pm 2i, \text{axes=normal, grid=[20,20]})
\]
Example 5 - Display a plot in polar coordinates

\[ > \text{plots[polarplot]}(1 + 4 \cos(4 \theta), \theta = 0..8 \pi, \text{color = magenta}) \]
Example 6 - Interactive Plotting

> plots[animate](plot, [x + 3 sin(x t), x = 0 .. 5], t = 0 .. 10)

For more information on the plot options used in this section, refer to the plot/options and plot3d/options help pages.

Display a Parametric Plot

Some graphs cannot be specified explicitly. In other words, you cannot write the dependent variable as a function of the independent variable, \( y = f(x) \). One solution is to make both the x-coordinate and the y-coordinate depend upon a parameter.
Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimensional space. To customize the plot, include \texttt{plot3d} options in the calling sequence. For a list of plot options, see \textit{The plot and plot3d Options (page 267)}. 

> \texttt{plot}([\cos(3 \, t), \sin(5 \, t), t = 0 .. 2 \pi])
The plots Package

The plots package contains numerous plot commands for specialized plotting. This package includes: animate, contourplot, densityplot, fieldplot, odeplot, matrixplot, spacecurve, textplot, tubeplot, and more. For details about this package, refer to the plots help page.

> with(plots):

The pointplot Command

To plot numeric data, use the pointplot command in the plots package with the data organized in a list of lists structure of the form \([\{x_1, y_1\}, \{x_2, y_2\}, \ldots, \{x_n, y_n\}\]. By default, Maple does not connect the points. To draw a line through the points, use the style = line option. For further analysis of data points, use the Curve Fitting Assistant (Tools→Assistants→CurveFitting), which fits and plots a curve through the points. For more information, refer to the CurveFitting[Interactive] help page.
The `pointplot` command plots the values of a plot object of type `Matrix`. The `pointplot` command accepts options such as `heights` and `gap` to control the appearance of the plot. For more information on Matrices, see Linear Algebra (page 155).

```plaintext
> pointplot([[0, 1], [1, -1], [3, 0], [4, -3], [2, 0], [4, 1], [3, -2], [4, 1]],
    axes=BOXED, symbolsize=25, symbol=circle)
```

The `matrixplot` Command

The `matrixplot` command plots the values of a plot object of type `Matrix`. The `matrixplot` command accepts options such as `heights` and `gap` to control the appearance of the plot. For more information on Matrices, see Linear Algebra (page 155).

```plaintext
> with(LinearAlgebra) :
```
> $A := \text{HilbertMatrix}(6)$

$$A := \begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{2} & 1 & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} & \frac{1}{5} \\
\frac{1}{5} & \frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1 & \frac{1}{4} \\
\frac{1}{6} & \frac{1}{5} & \frac{1}{4} & \frac{1}{3} & \frac{1}{2} & 1 \\
\end{bmatrix}$$

> $B := \text{ToeplitzMatrix}([1, 2, 3, 4, 5, 6], \text{symmetric})$

$$B := \begin{bmatrix}
1 & 2 & 3 & 4 & 5 & 6 \\
2 & 1 & 2 & 3 & 4 \\
3 & 2 & 1 & 2 & 3 \\
4 & 3 & 2 & 1 & 2 \\
5 & 4 & 3 & 2 & 1 \\
6 & 5 & 4 & 3 & 2 \\
\end{bmatrix}$$

> $\text{matrixplot}(A + B, \text{heights} = \text{histogram}, \text{axes} = \text{normal}, \text{gap} = 0.25, \text{style} = \text{patch}$)
The contourplot Command

The contourplot command generates a topographical map for an expression or function. To create a smoother and more precise plot, increase the number of points using the **num-points** option.
Multiple Plots in the Same Plot Region

List of Expressions

To display multiple expressions in the same plot region, enter the expressions in a list data structure. To distinguish the surfaces, apply different shading options, styles, or colors to each surface.
To display different types of plots in the same plot region, use the `display` command in the `plots` package. This example plots a curve over a hill with the shadow of the curve projected onto the hill.

```maple
> plot3d([cos(5*x) + cos(5*y), x^2 + 3*y^2 - 4], x=-2..2, y=-1..1, shading = [zgrayscale, none], color=[default, grey], style=[patchnogrid, patch],
        lightmodel=light3, transparency=0.1)
```

Maple can draw curves in three-dimensional space.

---

**The display Command**

To display different types of plots in the same plot region, use the `display` command in the `plots` package.

This example plots a curve over a hill with the shadow of the curve projected onto the hill.

```maple
> z := 10 \left(x^2 + y^5 + \frac{x}{5}\right)e^{-x^2-y^2};

> hill := plot3d(z, x = -2..2, y = -2.5..2.5, shading = hue, style = patchnogrid,
                lightmodel = light3, orientation = [-125, 60]);

> xt := cos(t) :

> yt := 2*sin(t) :
```

Maple can draw curves in three-dimensional space.
6.3 Customizing Plots

Maple provides many plot options to display the most aesthetically pleasing, illustrative results. Plot options include line styles, colors, shadings, axis styles, and titles where applicable. Plot options are applied using the Interactive Plot Builder, the context menus, or as options in the command syntax.

**Interactive Plot Builder Options**

The Interactive Plot Builder offers most of the plot options available in Maple in an easy-to-use interface.
Example:

**Launch the Interactive Plot Builder and enter the expression:**

1. Add the expression $2x^5-10x^3+6x-1$. For information on interacting with the Interactive Plot Builder, see Example 1 - Display a plot of a single variable expression (page 240).

**Set the x-axis range:**

2. In the Select Plot Type window, change the x-axis range to $-2 .. 2$.

**In the Plot Options window:**

3. From the Line group box, select **dot** from the left drop-down menu.

4. From the Color group box, select **Blue**.

5. From the Axes group box, select **frame**.

6. From the Title group box, enter **My Plot** in the text field

**Plot the expression:**

7. Click **Plot**.

**Context Menu Options**

Using the context menu, you can alter a plot by right-clicking (Control-click for Macintosh) the plot output. You can also access a large subset of plot options using the **Plot** toolbar and **Plot** menu options. These menus display when a plot region is selected. Regardless of the method used to insert a plot into Maple, you can use the context menu to apply different plot options. For a list of options available when plotting in two and three dimensions, see *The plot and plot3d Options* (page 267).

**2-D Plot Options**

Some plots do not display as you would expect using default option values. A expression with a singularity is one such example.
In the previous plot, all interesting details of the plot are lost because there is a singularity at \( x = 1 \). The solution is to view a narrower range, for example, from \( y = 0 \) to 7.

**Alter the y-axis range:**
1. Right-click the plot region. Select **Axes**, and then **Properties**.
2. In the **Axes Properties** dialog, click the **Vertical** tab.
3. Clear the **Use data extents** check box and enter 0 and 7 in the **Range min** and **Range max** text regions, respectively.
4. Click **Apply** to view the changes, or **OK** to return to the document.

**Change the color:**
5. Place the mouse pointer on the curve and right-click (**Control**-click, Macintosh). **Note:** The curve is selected when it becomes highlighted.
6. Select **Color**, and then **Green**.

**Change the line style:**
7. Select **Style**, and then **Point**.
3-D Plot Options

By default, Maple displays the graph as a shaded surface with a wireframe and scales the plot to fit the window. To change these options, use the context menu.

> plot3d\left(\frac{xy}{x^2 + y^2}, x = -10..10, y = -5..5\right)

Maple has many preselected light source configurations

**Change the style:**
1. Right-click the plot region. Select **Style → Surface**.

**Apply a light scheme:**
2. Select **Lighting → Light 1**.

**Change the color:**
3. Select **Color → Z (Grayscale)**.

**Change the axes style:**
4. Select **Axes → Boxed**.
Alter the glossiness:
5. Select Glossiness and then select Set... Using the slider, adjust the level of glossiness.

The plot and plot3d Options

If you are using commands to insert a plot, you can specify plot options as arguments at the end of the calling sequence. You can specify the options in any order. Applying plot options in the command syntax offers a few more options and greater control than what is available in the Interactive Plot Builder and context menus.

Table 6.3: Common Plot Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>axes</td>
<td>Define the type of axes, one of: boxed, frame, none, or normal</td>
</tr>
<tr>
<td>caption</td>
<td>Define the caption for the plot</td>
</tr>
<tr>
<td>color</td>
<td>Define a color for the curves to be plotted</td>
</tr>
<tr>
<td>font</td>
<td>Define the font for text objects in the plot</td>
</tr>
<tr>
<td>glossiness (3-D)</td>
<td>Controls the amount of light reflecte from the surface</td>
</tr>
<tr>
<td>gridlines (2-D)</td>
<td>Define gridlines in the plot</td>
</tr>
<tr>
<td>lightmodel (3-D)</td>
<td>Controls the light model to illuminate the plot, one of: none, light1, light2, light3, or light4</td>
</tr>
<tr>
<td>linestyle</td>
<td>Define the dash pattern used to render lines in the plot, one of: dot, dash, dashdot, longdash, solid, spacedash, and spacedot</td>
</tr>
<tr>
<td>legend (2-D)</td>
<td>Define a legend for the plot</td>
</tr>
<tr>
<td>numpoints</td>
<td>Controls the minimum total number of points generated</td>
</tr>
<tr>
<td>scaling</td>
<td>Controls the scaling of the graph, one of: constrained or unconstrained</td>
</tr>
<tr>
<td>shading (3-D)</td>
<td>Define how the surface is colored, one of: xyz, xy, z, zgrayscale, zhue, or none</td>
</tr>
<tr>
<td>style</td>
<td>Define how the surface is to be drawn, one of: line, point, polygon, or polygonoutline for 2-D plots; contour, point, surface, surfacecontour, surfacewireframe, wireframe, or wireframeopaque for 3-D plots</td>
</tr>
<tr>
<td>symbol</td>
<td>Define the symbol for points in the plot, one of: asterisk, box, circle, cross, diagonalcross, diamond, point, solidbox, solidcircle, or soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonalcross, diamond, point, solidsphere, or sphere for 3-D plots</td>
</tr>
<tr>
<td>title</td>
<td>Define a title for the plot</td>
</tr>
<tr>
<td>thickness</td>
<td>Define the thickness of lines in the plot</td>
</tr>
<tr>
<td>transparency (3-D)</td>
<td>Controls the transparency of the plot surface</td>
</tr>
<tr>
<td>view</td>
<td>Define the minimum and maximum coordinate values of the axes displayed on the screen</td>
</tr>
</tbody>
</table>

For a complete list of plot options, refer to the plot/options and plot3d/options help pages.
To create a smoother or more precise plot, calculate more points using the `numpoints` option.

```plaintext
plot(Si(x), x=-20..20, title="Plot of the Sine Integral", titlefont = [HELVETICA, 12], color="Niagara 2", style=point)
```
> plot3d(x*exp(-x^2-y^2), x=-10..10, y=-10..10, axes=boxed, numpoints=1500, lightmodel=light3, shading=zgrayscale, orientation=[160,20], style=patchnogrid)

### 6.4 Analyzing Plots

#### Point Probe, Rotate, Pan, and Zoom Tools

To gain further insight into a plot, Maple offers various tools to analyze plot regions. These tools are available in the **Plot menu** menu, **Context Bar**, and in the context menu under **Transform** when the plot region is selected.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point probe</td>
<td><img src="point_probe_icon.png" alt="Point probe icon" /></td>
<td>Display the coordinates corresponding to the cursor position on a two-di-</td>
</tr>
<tr>
<td>(2-D)</td>
<td></td>
<td>densional plot in the context bar (upper left-hand corner).</td>
</tr>
<tr>
<td>Rotate</td>
<td><img src="rotate_icon.png" alt="Rotate icon" /></td>
<td>Rotate a three-dimensional plot to see it from a different point of view.</td>
</tr>
<tr>
<td>Name</td>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pan</td>
<td>🧵</td>
<td>Pan the plot by changing the view ranges for 2-D plots; smartplots re-sample to reflect the new view. Change the position of the plot in the plot region for 3-D plots.</td>
</tr>
<tr>
<td>Zoom</td>
<td>🧵</td>
<td>Zoom into or out of the plot by changing the view ranges for 2-D plots; smartplots re-sample to reflect the new view. Make the plot larger or smaller in the plot window for 3-D plots.</td>
</tr>
<tr>
<td>Selection Tool</td>
<td>🧵</td>
<td>Use the Selection Tool to select the information displayed in the point probe tool tooltip. You can choose to display coordinates derived from converted pixel coordinates or data points derived from the original data points.</td>
</tr>
</tbody>
</table>

### 6.5 Representing Data

The **Live Data Plots** palette has templates that allow you to represent your data in many different ways including:

- Area chart
- Bar chart
- Box plot
- Bubble plot
- Histogram
- Line chart
- Pie chart
- Scatter plot

Once you select a type of plot, an interactive environment allows you to change a number of options to refine the look of your plot. As you refine your plot, Maple automatically updates the plot command with your options.

If the **Live Data Plots** palette is not displayed in the palette dock, from the main menu select **View → Palettes → Arrange Palettes**, and then select **Live Data Plots** from the **Arrange Palettes** dialog.

### 6.6 Creating Animations

Animations allow you to emphasize certain graphical behavior, such as the deformation of a bouncing ball, more clearly than in a static plot. A Maple animation is a number of plot frames displayed in sequence, similar to the action of movie frames. To create an animation, use the **Interactive Plot Builder** or commands.
Interactive Plot Builder

Creating Animations Using the Interactive Plot Builder:

Launch the Interactive Plot Builder and enter the expression:

1. Add the expression \( \sin(i\sqrt{x^2+y^2}/10) \).

For information on interacting with the Interactive Plot Builder, see Example 1 - Display a plot of a single variable expression (page 240).

In the Select Plot Type window:

2. From the Select Plot Type drop-down menu, select Animation.
3. The default xAxis range is \(-2\pi .. 2\pi\). Change the xAxis range to \(-6 .. 6\).
4. The default yAxis range is \(-2\pi .. 2\pi\). Change the yAxis range to \(-6 .. 6\).
5. Change the Animation Parameter \(i\) range to \(1 .. 30\).

In the Plot Options window:

6. From the Style group box, select surface.
7. From the Color group box, in the Light Model drop-down menu, select red-turquoise.
8. From the Color group box, in the Shading drop-down menu, select z (grayscale).
9. In the View group box, select the Constrained Scaling check box.

Plot the expression:

10. Click Plot.

\>
plots[interactive]( );

For information on playing the animation, see Playing Animations (page 276). To see the Maple syntax used to generate this plot, see Maple Syntax for Creating Animations: Interactive Plot Builder Example (page 272).

The plots[animate] Command

You can also use the animate command, in the plots package, to generate animations.
Table 6.5: The animate Command

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>animate(plotcommand, plotarguments, t=a..b, ...)</td>
<td>Maple procedure that generates a 2-D or 3-D plot</td>
</tr>
<tr>
<td>animate(plotcommand, plotarguments, t=L, ...)</td>
<td>arguments to the plot command</td>
</tr>
<tr>
<td>• plotcommand</td>
<td>- name and range of the animation parameter</td>
</tr>
<tr>
<td>• t=a..b</td>
<td>- name and list of real or complex constants</td>
</tr>
</tbody>
</table>

To access the command, use the short form name after invoking the `with(plots)` command.

> with(plots):

**Maple Syntax for Creating Animations: Interactive Plot Builder Example**

The following example shows the plotting command returned by the example in *Interactive Plot Builder* (page 271).
> animate(plot3d, \sin \left( \frac{i \sqrt{x^2 + y^2}}{10} \right), x = -6..6, y = -6..6, style

= patchnogrid, lightmodel = light3, shading = zgrayscale, scaling
= constrained}, i = 1..30)
Animate a 2-D plot

> animate\left(polarplot, [5 \cos(2 \theta), \theta = 0 .. \pi / 4 .. 2 \pi, frames = 50]\right)

For more information on the \texttt{animate} command, refer to the \texttt{plots[animate]} help page.

The \texttt{plot3d[viewpoint]} Command

You can use the \texttt{viewpoint} command to create an animation in which the position from which you view a 3-D plot moves in all directions and in various angles around the plot surface based on coordinates and parameters you specify. This type of animation creates the effect of flying through, around, beside, towards, and away from a plot surface in three-dimensional space.

The moveable position from which you view the surface is called the \textit{camera}. You can specify the orientation of the camera to view different sides of a surface, the path along which the camera moves throughout and around a surface, and the location of the camera in 3-D space in each animation frame. For example, you can specify coordinates to move the camera to specific points beside a surface; a pre-defined camera path to move the camera in a circle around the surface; and the range of view to move the camera close to or away from the surface. Refer to the \texttt{viewpoint} help page for information on the available options.
To animate the following examples, click the plot object and then click the play button (_play_)
in the **Animation** context bar.

**Example 1: Moving the Camera Around a 3-D Plot**

In the following example, a pre-defined path **circleleft** moves the camera in a counter-clockwise circle around the plot surface.

\[
> \text{plot3d} \left( 1.3^x \sin(y), x = -1..2\pi, y = 0..\pi, \text{coords} = \text{spherical}, \text{style} = \text{patch}, \right.
\left. \text{viewpoint} = \left[ \text{"circleleft"} \right] \right)
\]

**Example 2: Specifying a Path to Move the Camera Towards and Around a 3-D Plot**

In the following example, a camera path is specified to zoom into and view different sides of the plot surface.
6.7 Playing Animations

Animation Context Bar

To run the animation, click the plot to display the **Animate** context bar.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Frame</td>
<td>[Previous Frame]</td>
<td>View the previous frame in the animation.</td>
</tr>
<tr>
<td>Stop</td>
<td>[Stop]</td>
<td>Stop the animation.</td>
</tr>
<tr>
<td>Play</td>
<td>[Play]</td>
<td>Play the selected animation.</td>
</tr>
<tr>
<td>Next Frame</td>
<td>[Next Frame]</td>
<td>View the next frame in the animation.</td>
</tr>
<tr>
<td>Current Frame</td>
<td>Current Frame</td>
<td>Slider control for viewing individual frames of an animated plot.</td>
</tr>
</tbody>
</table>
### 6.8 Customizing Animations

The display options that are available for static plots are also available for Maple animations.

#### Interactive Plot Builder Animation Options

Using the **Interactive Plot Builder**, you can apply various plot options within the **Plot Options** window. See *Interactive Plot Builder* (page 271).

#### Context Menu Options

As with static plots, you can apply plot options to the animation by right-clicking **(Control-click for Macintosh)** the animation output.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forward</td>
<td><img src="image" alt="Forward Icon" /></td>
<td>Forward - Play the animation forward.</td>
</tr>
<tr>
<td>Oscillate</td>
<td><img src="image" alt="Oscillate Icon" /></td>
<td>Oscillate - Play the animation forward and backward.</td>
</tr>
<tr>
<td>Backward</td>
<td><img src="image" alt="Backward Icon" /></td>
<td>Backward - Play the animation backward.</td>
</tr>
<tr>
<td>Single</td>
<td><img src="image" alt="Single Icon" /></td>
<td>Single - Run the animation in single cycle mode. The animation is displayed only once.</td>
</tr>
<tr>
<td>Continuous</td>
<td><img src="image" alt="Continuous Icon" /></td>
<td>Continuous - Run the animation in continuous mode. The animation repeats until you stop it.</td>
</tr>
<tr>
<td>Frames per second</td>
<td><img src="image" alt="FPS Icon" /></td>
<td>Set the animation to play at a faster or slower speed.</td>
</tr>
<tr>
<td>Point probe</td>
<td><img src="image" alt="Point Probe Icon" /></td>
<td>Determine the coordinates of a 2-D plot at the position of the cursor.</td>
</tr>
<tr>
<td>Zoom</td>
<td><img src="image" alt="Zoom Icon" /></td>
<td>Zoom into or out of the plot by changing the view ranges.</td>
</tr>
<tr>
<td>Pan</td>
<td><img src="image" alt="Pan Icon" /></td>
<td>Pan the plot by changing the view ranges.</td>
</tr>
<tr>
<td>Rotate (3-D)</td>
<td><img src="image" alt="Rotate Icon" /></td>
<td>Rotate a three-dimensional plot to see it from a different point of view.</td>
</tr>
</tbody>
</table>
Customize the animation using the context menu:

1. To change the line style, right-click the plot region. Select **Style → Point**.

2. To remove the axes, select **Axes → None**.

**The animate Command Options**

The `animate` command offers a few options that are not available for static plots. Refer to the `animate` help page for information on these additional options. By default, a two-dimensional animation consists of sixteen plots (frames) and a three-dimensional animation consists of eight plots (frames). To create a smoother animation, increase the number of frames using the **frames** option.

**Note:** Computing more frames increases time and memory requirements.

```maple
> sinewave := plot( sin(x) * exp(x/5), x = 0 .. 20 ) : 
> ball := proc(x, y) plots[pointplot]([ [x, y]], symbol = circle, symbolsize = 20 ) end proc:
```
> plots[animate](ball, \[t, \sin(t) e^{-\frac{t}{5}}, t=0..20, frames=60, background = \text{sinewave})

\[t=0, t=5, t=7, t=15.\]
6.9 Exporting

You can export a generated plot or animation to an image in various file formats, including DXF and X3D (for 3-D plots), EPS, GIF, JPEG/JPG, POV, Windows BMP, and WMF. Exporting an animation to GIF produces an animated image file. The exported images can be included in presentations, web pages, Microsoft Word, or other software.

To export an image:

1. Right-click the plot region (Control-click for Macintosh).
2. Select Export and the file format.

Alternatively:

1. Click the plot.
2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be automatically created without returning the image to the document. For more information, refer to the plot,device help page.

6.10 Code for Color Plates

Generating impressive graphics in Maple can require only a few lines of code, as shown by the examples in this chapter. However, other graphics require many lines of code. Code for the color plates is available at the Maple Application Center.

From the Help menu, select On the Web, User Resources, and then Application Center.

To access the color plate code:

1. Go to the Maple Application Center.
2. In the Keyword or phrase region, enter Color Plate.
7 Creating Mathematical Documents

Maple allows you to create powerful documents as business and education tools, technical reports, presentations, assignments, and handouts.

You can:

• Copy, cut, and paste information
• Format text for reports or course material
• Add headers and footers
• Insert images, tables, and symbols
• Generate two- and three-dimensional plots and animations
• Sketch in the document or on a plot
• Insert hyperlinks to other Maple files, web sites, or email addresses
• Place instructions and equations side by side
• Bookmark specific areas
• Easily update, revise, and distribute your documents

In this chapter, we will create a document that demonstrates many of Maple's documentation features. For further examples, note that this guide was written using Maple.

7.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Document Formatting (page 282) - Add various text formatting elements | • Copy and Paste (page 283)  
  • Quick Character Formatting (page 283)  
  • Quick Paragraph Formatting (page 285)  
  • Character and Paragraph Styles (page 287)  
  • Sections (page 294)  
  • Headers and Footers (page 296)  
  • Show or Hide Worksheet Content (page 297)  
  • Indentation and the Tab Key (page 298) |
| Commands in Documents (page 299) - Format and display or hide commands in a document | • Document Blocks (page 299)  
  • Typesetting (page 302)  
  • Auto-Execute (page 302) |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Tables (page 304) - Create tables and modify their attributes | • Creating a table  
• Cell contents  
• Navigating table cells  
• Modifying Structural Layout  
• Modifying Physical Dimensions  
• Modifying Appearance  
• Printing Options  
• Execution Order  
• Tables in the Classic Worksheet |
| Canvas (page 316) - Sketch an idea in the document by inserting a canvas | • Insert a Canvas  
• Drawing  
• Canvas Style  
• Inserting Images |
| Hyperlinks (page 320) and Bookmarks - Add hyperlinks to various sources | • Inserting a Hyperlink in the Document  
• Linking to an Email Address, Dictionary Topic, Help Page, Maplet Application, Web Page, or Document  
• Bookmarks |
| Embedded Components (page 326) - Insert buttons, sliders, and more in your document | • Overview of available components  
• Example using a task template |
| Spell Checking (page 328) - Verify text with the Maple spell checking utility | • How to Use the Spellcheck Utility  
• Selecting a Suggestion  
• User Dictionary |
| Creating Graded Assignments (page 331) - Create documents for automated testing and assessment | • Creating a Question  
• Viewing Questions in Maple  
• Saving Test Content |
| Worksheet Compatibility (page 332) - Compatibility Issues | • Classic Worksheet interface does not support all Standard Worksheet interface features |

7.2 Document Formatting

To begin, create a new Maple document. From the File menu, select New → Document Mode. For this example, you can copy and paste text from any file. The example text below is from a Maple help page, plot, but the formatting has been removed for demonstration purposes.
Copy and Paste

You can cut, copy, and paste content within Maple documents, and from other sources.

To copy an expression, or part of an expression, to another location on the document:
1. Select the expression, or part of the expression, to copy.
2. From the Edit menu, select Copy.
3. Place the cursor at the insertion point.
4. From the Edit menu, select Paste.

Result:

\[
\text{plot} - \text{create a two-dimensional plot}
\]

Calling Sequence

\[
\text{plot}(f, x) \\
\text{plot}(f, x=x_0..x_1) \\
\text{plot}(v_1, v_2)
\]

Parameters

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x_0, x_1 \) - left and right endpoints of horizontal range
- \( v_1, v_2 \) - x-coordinates and y-coordinates

If you paste into a math input region, Maple interprets all the pasted content as input. If you paste into a text region, Maple interprets all the pasted content as text. However, note that 2-D Math retains its format in both input and text regions.

When you copy and paste to another application, in general, Maple retains the original structure.

Quick Character Formatting

The Format→Character menu provides access to the following quick formatting features: Bold, Italic, Underline, Superscript, Subscript, Font Color, and Highlight Color.

To modify text:
1. In the document, select the text to modify.
2. From the Format menu, select Character, and then the appropriate feature.
For example, in the pasted text, select "Calling Sequences" and apply **Bold** character formatting.

Alternatively, use the context bar icons. For example, to apply a color to the parameters "f, x=x0..x1":

- **Font Color Context Bar Icon**
- **Highlight Color Context Icon**

For font and highlight colors, you can select from Swatches, a color wheel, RGB values, or choose a color using the eye dropper tool. See **Figure 7.1**.

![Select Color Dialog](image)

**Figure 7.1: Select Color Dialog**

In this example, choose a dark purple color, as in the help pages.

To format this text as bold, click the **Bold** toolbar icon, **B**. Also, select the text "Calling Sequence" and format as bold.

**Result:**

```latex
plot - create a two-dimensional plot

**Calling Sequence**

\texttt{plot(f, x)}

\texttt{plot(f, x=x0..x1)}

\texttt{plot(v1, v2)}

**Parameters**

- \texttt{f} - expression in independent variable \texttt{x}
- \texttt{x} - independent variable
- \texttt{x0, x1} - left and right endpoints of horizontal range
- \texttt{v1, v2} - x-coordinates and y-coordinates
```
Attributes Submenu: Setting Fonts, Character Size, and Attributes

You can also change various character attributes such as font, character size, style, and color in one dialog.

To modify text:
1. In the document, select text to modify.
2. From the Format menu, select Character, and then Attributes. The Character Style dialog opens. See Figure 7.2.

![Character Style Dialog]

Figure 7.2: Character Style Dialog

Quick Paragraph Formatting

The Format→Paragraph menu provides access to the following quick alignment features: Align Left, Center, Align Right, and Justify.
To modify a paragraph:

1. In the document, select the paragraph to modify.
2. From the Format menu, select Paragraph, and then the appropriate feature.

**Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line Break, and Page Break**

You can change various paragraph attributes in one dialog.

- From the Format menu, select Paragraph, and then Attributes. The Paragraph Style dialog opens. See Figure 7.3.
- When changing spacing, you must indicate units (inches, centimeters, or points) in the Units drop-down list.

![Paragraph Style Dialog](image)

**Figure 7.3: Paragraph Style Dialog**

For example, in the pasted text, select all of the items under "Parameters", then open the Paragraph Style dialog. Notice that the spacing has already been set.

In the Indent section, change the Left Margin indent to 10.0 pt.
In the **Bullets and Numbering** section, click the **Style** drop-down and select **Dash**. Click **OK** to close the dialog and apply the styles.

**Result:**

```
plot - create a two-dimensional plot

Calling Sequence

plot(f, x)
plot(f, x=x0..x1)
plot(x1, y2)
```

**Parameters**

- `f` - expression in independent variable `x`
- `x` - independent variable
- `x0, x1` - left and right endpoints of horizontal range
- `v1, v2` - x-coordinates and y-coordinates

For more information, refer to the **paragraphmenu** help page.

### Character and Paragraph Styles

Maple has predefine styles for characters and paragraphs. A style is a set of formatting characteristics that you can apply to text in your document to change the appearance of that text. When you apply a style, you apply a group of formats in one action.

- A **character style** controls text font, size, color, and attributes such as bold and italic. To override the character style within a paragraph style, you must apply a character style or character formatting.

- A **paragraph style** controls all aspects of a paragraph's appearance, such as text alignment, line spacing, and indentation. In Maple, each paragraph style includes a character style.
Applying Character Styles

By using the drop-down list in the document context bar, you can apply:

- Existing Maple character styles.
- New styles that you have created through the Style Management (Figure 7.4) and Character Style (Figure 7.5) dialogs.

To apply a character style to text in your document:

1. Select the text to modify.
2. In the styles drop-down list in the context bar of your document, select an appropriate character style. All character styles are preceded by the letter C. The selected text now reflect the attributes of the character style you have chosen.
3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.
Creating and Modifying Character Styles

You can create custom character styles to apply to text, or change existing character styles. New styles are automatically added to the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 7.4.

To create a character style:
• Click Create Character Style. The Character Style dialog opens. See Figure 7.5.
• In the first row of the dialog, enter a style name in the blank text region.

To modify a character style:
• From the style list, select the character style to modify. Recall that all character styles are preceded by the letter C, while paragraph styles are preceded by the letter P.
• Click Modify. The Character Style dialog opens with the current attributes displayed. See Figure 7.5.

For either action, continue:
2. Select the properties for the new character style, such as font, size, attributes, and color. In the font attributes, the Superscript and Subscript check boxes are mutually exclusive. When you select one of the two check boxes, the other is disabled. You must clear one before selecting the other.

Note: A preview of the style is displayed in the last row of the Character Style dialog.

3. To save the style, click OK or to abandon, click Cancel. If you have modified a style, all text in your document that uses the altered style is updated to reflect the changes.
Figure 7.5: Defining a Character Style

For example, in the pasted text, suppose we want to create a character style for the bold, purple parameter.

- From the Format menu, select Styles, then click Create Character Style.
- Enter the style name, "Placeholder", and then select the character attributes. In this case, click the Bold check box. Then click the Color button and choose a dark purple. Click OK to create the character style.

Now you can apply the style to any text. Under Calling Sequences, select each list of parameters inside the command. To apply the style, from the Styles drop-down menu in the toolbar, select Parameter.

Result:
Applying Paragraph Styles

By using the drop-down list in the document context bar, you can apply:

- Existing Maple paragraph styles.
- New styles that you have created through the Style Management (Figure 7.4) and Define a Paragraph Style (Figure 7.6) dialogs.

To apply a Maple paragraph style to text in your document:

1. Select the text to modify.
2. In the styles drop-down list in the context bar of your document, select an appropriate paragraph style. All Maple paragraph styles are preceded by the letter P. The selected text now reflect the attributes of the paragraph style you have chosen.

For example, to format the title of the pasted text as a title, first select the line: "plot - create a two-dimensional plot". In the Styles drop-down, select Title.

Result:
plot - create a two-dimensional plot

Calling Sequence

plot(f, x)

plot(f, x=x0..x1)

plot(v1, v2)

Parameters

- f - expression in independent variable x
- x - independent variable
- x0, x1 - left and right endpoints of horizontal range
- v1, v2 - x-coordinates and y-coordinates

3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

Creating and Modifying Paragraph Styles

You can create custom paragraph styles to apply to text, or change existing paragraph styles. New styles are automatically added to the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 7.4.

   To create a paragraph style:
   
   * Click Create Paragraph Style. The Paragraph Style dialog opens. See Figure 7.6.
   * In the first row of the dialog, enter a style name in the blank text field

   To modify a paragraph style:
   
   * Select a paragraph style to modify. Recall that all paragraph styles are preceded by the letter P.
   * Click Modify. The Paragraph Style dialog opens with the current attributes displayed.

   For either action, continue:

   4. In the Units drop-down menu, select the units used to determine spacing and indentation. Select from inches (in), centimeters (cm), or points (pt).

   5. Select the properties to use for this paragraph style, such as Spacing, Indent, Alignment, Bullets and Numbering, Page Break Before, and Linebreak.

   6. To add or modify a font style, click Font. The Character Style dialog opens. For detailed instructions, see Creating and Modifying Character Styles (page 289).
7. To save the style, click **OK**, or to abandon, click **Cancel**. If you are modifying an existing style, all text in your document that uses the altered style is updated to reflect the changes.

**Figure 7.6: Defining a Paragraph Style**

**Style Set Management: Saving Styles for Future Use**

You can use the style set of a particular document as the default style for all documents.
For information on creating and managing style sets, see the `worksheet/documenting/styles` help page.

**Sections**

You can organize your document into sections, either before or after the text has been entered.

\[ \text{First Section} \]

\[ \text{The introductory sentence.} \]

\[ \text{> } \int \cos(x) \, dx \]

\[ \text{Subsection} \]

\[ \text{> } \int \sin(x) \, dx \]

Using the Insert Menu to Add Sections

1. Place the cursor in the paragraph or execution group above the location at which you want to insert a new section.
   - If the cursor is inside a section, Maple inserts the new section after the current section.
• If the cursor is in an execution group, Maple inserts the new section after the execution group.

2. From the Insert menu, select Section. An arrow marks the start of the section.

3. Enter the section heading.

4. Press the Enter key.

5. Enter the body of the section.

**Tips for Adding Subsections**

The insert location of subsections is the same as for sections, with a few exceptions.

• Subsections are inserted at the current cursor location when in a subsection.

• To insert a subsection immediately after the current subsection, collapse the subsection and place the cursor in the subsection title.

**Using the Indent and Outdent Toolbar Icons**

You can shift sections to create or remove subsections.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Indent Icon]</td>
<td>Enclose the selection in a section or subsection</td>
</tr>
<tr>
<td>![Outdent Icon]</td>
<td>Outdent the selection to the next section level, if possible.</td>
</tr>
</tbody>
</table>

For example, to create two sections containing the two categories of information in the pasted text:

1. Select "Parameters" and all of the items under it.

2. Click the Indent toolbar item.

3. Cut and paste "Parameters" from inside the section to its title.

4. Similarly, create a section with the title "Calling Sequence", containing the items under that heading.
Result:

\[ \text{plot - create a two-dimensional plot} \]

\section*{Calling Sequence}

\begin{align*}
\text{plot}(f, x) \\
\text{plot}(f, x=a..b) \\
\text{plot}(x1, y2)
\end{align*}

\section*{Parameters}

\begin{itemize}
\item \textit{f} - expression in independent variable \textit{x}
\item \textit{x} - independent variable
\item \textit{x0}, \textit{x1} - left and right endpoints of horizontal range
\item \textit{v1}, \textit{v2} - \textit{x}-coordinates and \textit{y}-coordinates
\end{itemize}

\textbf{Note:} the section titles are automatically formatted as section titles, but you can change the formatting through the \textbf{Paragraph Style} dialog.

\section*{Headers and Footers}

You can add headers and footers to your document that will appear at the top and bottom of each page when you print the document.

To add or edit headers and footers:

From the \textbf{View} menu, select \textbf{Header Footer}. The \textbf{Header Footer} dialog appears. See \textbf{Figure 7.8}.

\begin{figure}
\centering
\includegraphics[width=\textwidth]{header_footer.png}
\caption{Header and Footer Dialog - Custom Header}
\end{figure}

The available elements include the current date, page number, number of pages, an image, the filename or any plain text. These elements can be placed in the left or right corner or the center of the page.
You can choose one of the predefined header or footer styles in the **Predefine Header and Footer** tab, or create your own by clicking the **Custom Header** or **Custom Footer** tab.

For more information on header and footer options, refer to the **headerfooter** help page.

**Show or Hide Worksheet Content**

You can hide document elements of a specific type so that they are not visible. This does not delete them, but hides them from view. Hidden elements are not printed or exported, but they can be copied and pasted.

In a document, use the **Show Contents** dialog to hide all spreadsheets, input, output, or graphics, plus markers for section boundaries, execution group boundaries, hidden table borders on mouse pointer roll over, and annotations. The dialog is accessed from the **View→Show/Hide Contents** menu.

**Using the Show Contents Dialog**

A check mark beside the item indicates that all document elements of that type are displayed for the current document. See **Figure 7.9**.

![Show Contents Dialog](image)

**Figure 7.9: Show Contents Dialog**
1. From the View menu, select Show/Hide Contents. The Show Contents dialog opens with all items selected for display.

2. Clear the check box associated with the document components or markers to hide them.

   Note: By clearing the Input check box, only Maple Input and 2-D Math input, that is, 2-D Math content that has been evaluated, are hidden. Clearing the Graphics check box ensures that a plot, an image, or the Canvas inserted in the document by using the Insert menu option is also hidden.

Command Output Versus Inserted Content

Output is considered an element that results from executing a command. Inserted components are not considered output.

Consider the following examples.

The plot resulting from executing the plot(sin) command is considered output.

- To show a plot from the plot(sin) command, select both the Output and Graphics check boxes in the Show Contents dialog.

If you insert a plot by using the Insert menu option, that plot is not considered output. Therefore, if you clear the Output check box in the Show Contents dialog, that plot will be visible in the document.

- To hide an inserted plot, clear the Graphics check box in the Show Contents dialog.

Inserted images and the Canvas are not considered output. As such, they are not hidden if you clear the Output check box.

- To hide an inserted image or canvas, clear the Graphics check box in the Show Contents dialog.

Indentation and the Tab Key

The Tab icon allows you to set the Tab key either to move between placeholders or to indent. For example, with the Tab icon off, click the exponent button in the Expression palette. The expression is inserted with the first placeholder highlighted. To move to the next placeholder, use the Tab key.

| Tab icon off. Allows you to move between placeholders using the Tab key. |
| Tab icon on. Allows you to indent in the document using the Tab key. |
7.3 Commands in Documents

**Document Blocks**

With document blocks, you can create documents that present text and math in formats similar to those found in business and education documents.

In a document block, an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create a document with better presentation flow. Before using document blocks, it is recommended that you display **Markers**. A vertical bar is displayed along the left pane of the document. Icons representing document blocks are displayed in this vertical bar next to associated content.

**To activate Markers:**

- From the **View** menu, select **Markers**.

For further details on document blocks, see *Document Blocks* (page 50) in Chapter 1.

**Working with Document Blocks**


1. Create a new document block after the last section of the pasted example, either by pressing **Enter**, or by selecting, from the **Format** menu, **Create Document Block**.

2. Enter text and an expression to evaluate. For example, enter "Plot the expression \( \sin(x) \) and its derivative, \( \frac{d}{dx} \sin(x) \)." For detailed instructions on entering this phrase, see *Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons* (page 30) in Chapter 1.

3. Select the expression **Control-click**, for Macintosh) to display the context menu.

4. Click the **Evaluate and Display Inline** menu item. The expression is evaluated.

5. Check that the input mode is **Text**, then enter the rest of the sentence: ", in the same plot." See Figure 7.10.
Document blocks can display content inline, that is, text, input, and output in one line as presented in business and education documents. In document mode, content is displayed inline by default.
To display content inline:
1. Place the cursor in the document block.
2. From the View menu, select Inline Document Output.

View Document Code

To view the contents, that is, all code and expanded execution groups within a document block, you must expand the document block.
1. Place the cursor in the document block region.
2. From the View menu, select Expand Document Block.

```
> plot(sin(x), x = -Pi .. Pi); # input placeholder
```

3. To hide code again, select View and then Collapse Document Block.

Expand an Execution Group within a Document Block

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket at the left called a group boundary.

As document blocks can contain many execution groups, you can select to expand an execution group within a document block.
1. Place the cursor near the end of the document block region.
2. From the View menu, select Expand Execution Group.

```
> plot(sin(x), x = -Pi .. Pi); # input placeholder
```

3. To hide the group, select View and then Collapse Execution Group.

Switch between Input and Output

1. Place the cursor in the document block region.
2. From the View menu, select Toggle Input-Output Display.
Input from any executable math or commands is displayed in one instance, or only output is displayed.

**Typesetting**

You can control typesetting and 2-D Math equation parsing options in the Standard Worksheet interface. Extended typesetting uses a customizable set of rules for displaying expressions.

The rule-based typesetting functionality is available when the **Typesetting level** is set to **Extended** (**Tools→Options→Display** tab). This parsing functionality applies to 2-D Math editing (**Math** mode) only.

For example, you can change the display of derivatives to suit the content and audience of your document.

\[
\frac{d}{dx} f(x)
\]

**Tools→Options→Display** tab: Typesetting level = Maple Standard.

\[
\frac{d}{dx} f(x)
\]

\[
f'(x)
\]

**Tools→Options→Display** tab: Typesetting level = Extended.

To specify rules, use the **Typesetting Rule Assistant**.

- From the **View** menu, select **Typesetting Rules**. The **Typesetting Rule Assistant** dialog opens.

For more information, see the **Typesetting**, **TypesettingRuleAssistant**, and **OptionsDisplay** help pages.

**Auto-Execute**

The **Autoexecute** feature allows you to designate regions of a document for automatic execution. These regions are executed when the document opens or when the **restart** command is executed. This is useful when sharing documents. Important commands can be executed as soon as the user opens your document. The user is not required to execute all commands.

For more information, refer to the **restart** help page.

**Setting the Auto-Execute Feature**

1. Select the region to be automatically executed when the document opens.
2. From the **Format** menu, select **Autoexecute**, and then **Set**.
Regions set to Autoexecute are denoted by exclamation mark symbols in the Markers region (View → Markers).

For example, to display a plot in your document without saving the plot, making your document use less memory, you can set a plot command to autoexecute.

1. After the plot instruction, enter a Maple prompt (Insert → Execution Group → After Cursor).

2. Enter the plot command: \( \text{plot}\left(\sin(x), \int \sin(x) \, dx\right) \) and press Enter to execute.

3. Select the plot, then select Edit → Remove Output → From Selection.

4. Place the cursor in the plot command, then select Format → Autoexecute → Set.

5. Save and close the document; on reopening, the command is re-executed.

Result:

\[
\text{plot} - \text{create a two-dimensional plot}
\]

\begin{itemize}
\item \textbf{Calling Sequence}
\begin{itemize}
\item \texttt{plot(f, x)}
\item \texttt{plot(f, x=x0..x1)}
\item \texttt{plot(v1, v2)}
\end{itemize}
\end{itemize}

\begin{itemize}
\item \textbf{Parameters}
\begin{itemize}
\item \texttt{f} - expression in independent variable \( x \)
\item \texttt{x} - independent variable
\item \texttt{x0, x1} - left and right endpoints of horizontal range
\item \texttt{v1, v2} - \( x \)-coordinates and \( y \)-coordinates
\end{itemize}
\end{itemize}

Plot the expression \( \sin(x) \) and its derivative, \( \frac{d}{dx} \sin(x) = \cos(x) \), in the same plot.

\[
> \text{plot}\left(\left[\sin(x), \frac{d}{dx} \sin(x)\right]\right)
\]

\textbf{Removing the Auto-Execute Setting}

To remove the setting in a region:

1. Select the region.

2. From the Format menu, select Autoexecute, and then Clear.

To remove all autoexecuted regions from a document:

- From the Format menu, select Autoexecute, and then Clear All.
Repeating Auto-Execution

To execute all marked groups:

- From the **Edit** menu, select **Execute**, and then **Repeat Autoexecution**.

Security Levels

By default, Maple prompts the user before automatically executing the document.

To set security levels for the autoexecute feature, use the **Security** tab in the **Options** dialog. For details, refer to the **OptionsDialogSecurity** help page.

7.4 Tables

Tables allow you to organize content in a document.

Creating a Table

To create a table:

1. From the **Insert menu**, select **Table**.
2. Specify the number of rows and columns in the table creation dialog.
3. Click **OK**.

The default properties for the table include visible borders and auto-adjustment to 100% of the document width. These options, as well as the table dimensions, can be modified after table creation.

Create a table with 4 rows and 2 columns at the end of your document. In document mode, the input mode is set to **Math** by default; in worksheet mode, the default is **Text** mode.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cell Contents

Any content that can be placed into a document can also be placed into a table cell, including other sections and tables. Table cells can contain a mix of:

- Input commands
- 2-D Math
- Embedded components: buttons, sliders, check boxes, and more
- Plots
Enter a heading in both columns of the first row, in 2-D Math. You can use any text formatting features within each cell; for example, bold and center the headings.

<table>
<thead>
<tr>
<th>$f(x)$</th>
<th>$\frac{d}{dx} f(x)$</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Navigating Table Cells**

Use the **Tab** key to move to the next cell. Ensure that the Tab toolbar icon is **off**.

<table>
<thead>
<tr>
<th><img src="image" alt="Tab icon off" /></th>
<th>Tab icon <strong>off</strong>. Allows you to move between cells using the <strong>Tab</strong> key.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Tab icon on" /></td>
<td>Tab icon <strong>on</strong>. Allows you to indent in the table using the <strong>Tab</strong> key.</td>
</tr>
</tbody>
</table>

Tab between the cells of the table and enter the following expressions in the first column. For each function, from the context menu, select **Differentiate → With respect to → $x$**. Cut and paste the resulting expression into the second column.

<table>
<thead>
<tr>
<th>$f(x)$</th>
<th>$\frac{d}{dx} f(x)$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{1}{1 + \frac{1}{1 + \frac{1}{x}}}$</td>
<td>$\frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2}$</td>
</tr>
<tr>
<td>$\sin(\omega x) e^{-5x}$</td>
<td>$\cos(\omega x) \omega e^{-5x} - 5 \sin(\omega x) e^{-5x}$</td>
</tr>
<tr>
<td>$\frac{d^2}{dx^2} \sin^2(x)$</td>
<td>$-8 \sin(x) \cos(x)$</td>
</tr>
</tbody>
</table>

**Modifying the Structural Layout of a Table**

The number of rows and columns in a table are modified using the **Insert** and **Delete** sub-menus in the **Table** menu or by using the **Cut** and **Copy/Paste** tools.

**Inserting Rows and Columns**

Row and column insertion is relative to the table cell that currently contains the cursor. If the document has an active selection, insertion is relative to the selection boundaries.

- Column insertion can be to the left or right of the document position marker or selection.
• Row insertion can be above or below the marker or selection.

In your table, add a third column on the right to display the plots of these expressions. Add the heading, and insert a blank plot region in each cell below it, by selecting **Insert → Plot → 2-D** (or **3-D** for the second expression). Then **Ctrl-drag** (**Control-drag** for Macintosh) each expression in the row into its plot region to display it. For details on this procedure, see *Plots and Animations* (page 237).

Resize the plots and table as desired.

<table>
<thead>
<tr>
<th>( f(x) )</th>
<th>( \frac{d}{dx} f(x) )</th>
<th>Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} )</td>
<td>( 1 \left( 1 + \frac{1}{1 + \frac{1}{x}} \right) \left( 1 + \frac{1}{x} \right) \frac{1}{x^2} )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
<tr>
<td>( \sin(\omega x) e^{-5x} )</td>
<td>( \cos(\omega x) \omega e^{-5x} - 5 \sin(\omega x) e^{-5x} )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
<tr>
<td>( \frac{d^2}{dx^2} \sin^2(x) )</td>
<td>( -8 \sin(x) \cos(x) )</td>
<td><img src="image" alt="Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )" /></td>
</tr>
</tbody>
</table>

**Deleting Rows and Columns**

With deleting operations using the **Delete** key, the **Delete Table Contents** dialog opens allowing you to specify the desired behavior. For example, you can delete the selected rows, or delete the contents of the selected cells. See *Figure 7.11*.
Pasting

Pasting a table subselection into a table may result in the creation of additional rows or columns, overwriting existing cell content, or the insertion of a subtable within the active table cell. When there is a choice, the **Table Paste Mode** dialog opens, allowing you to choose. See **Figure 7.12**.

Merging Cells

To merge adjacent cells in a table, select the cells you would like to merge. From the **Table** menu, select **Merge Cells**. You can merge cells across row or column borders. See **Figure 7.13**. The resulting cell must be rectangular. The contents of the individual cells in the merge operation are concatenated in execution order. See **Figure 7.14**. For details on cell execution order, see *Execution Order Dependency* (page 313).

![Figure 7.11: Delete Table Contents Verification Dialog](image)

![Figure 7.12: Table Paste Mode Selection Dialog](image)

![Figure 7.13: Two Cells](image)

![Figure 7.14: Merged Cells](image)
Modifying the Physical Dimensions of a Table

The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button, for Macintosh) while hovering over the left or right table boundary and dragging the mouse left or right. Upon release of the mouse button, the table boundary is updated. This approach can also be used to resize the relative width of table columns.

Alternatively, the size of the table can be controlled from the Table Properties dialog. Select the Table menu and then Properties. Two sizing modes are supported.

1. **Fixed percentage of page width.** Using this option, the table width adjusts whenever the width of the document changes. This option is useful for ensuring that the entire content of the table fit in the screen or printed page.

2. **Scale with zoom factor.** This option is used to preserve the size and layout of the table regardless of the size of the document window or the zoom factor. If the table exceeds the width of the document window, the horizontal scroll bar can be used to view the rightmost columns. **Note:** Using this option, tables may be incomplete when printed.

Modifying the Appearance of a Table

Table Borders

The style of exterior and interior borders is set using the Table Properties dialog. From the Table menu, select Properties.

- You can set all, none, or only some of the borders to be visible in a table. Exterior borders are controlled separately.

- You can control the visibility of interior borders by using the Group submenu of the Table menu; grouping rows or columns suppresses interior borders, provided that the interior border style is set by row and column group.
For example, group the columns together, and group rows 2 to 4 together. Then in the Table Properties dialog, select Exterior Borders: Top and bottom, and Interior Borders: By row and column group.

- Hidden borders are visible when the mouse hovers over a table. Note: You can hide the visibility of lines on mouse pointer roll over by using the View→Show/Hide Contents dialog, and clearing the Hidden Table Borders check box.

### Alignment Options

The table alignment tools control the horizontal alignment of columns and vertical alignment of rows.
For column alignment, the current selection is expanded to encompass all rows in the selected columns. The alignment choice applies to all cells within the expanded selection. If the document does not contain a selection, the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected rows for vertical alignment options. The following table illustrates the vertical alignment options. The baseline option is useful for aligning equations across multiple cells within a row of a table.

| Top   | \[
|-------|\]
| \[
\frac{1}{x}
\] | \[
\frac{1}{y}
\] |

| Center | \[
|-------|\]
| \[
\frac{1}{x}
\] | \[
\frac{1}{y}
\] |

| Bottom | \[
|-------|\]
| \[
\frac{1}{x}
\] | \[
\frac{1}{y}
\] |

| Baseline | \[
|-------|\]
| \[
\frac{1}{x}
\] | \[
\frac{1}{y}
\] |
For example, set the **Row** alignment to **Baseline** for all rows, and set the **Column** alignment to **Center** for all columns.

<table>
<thead>
<tr>
<th>$f(x)$</th>
<th>$\frac{d}{dx}f(x)$</th>
<th>Plot of $f(x)$ and $\frac{d}{dx}f(x)$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{1}{1 + \frac{1}{x}}$</td>
<td>$-\frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2}$</td>
<td><img src="image" alt="Plot of $f(x)$ and $\frac{d}{dx}f(x)$" /></td>
</tr>
<tr>
<td>$\sin(\omega x) e^{-5x}$</td>
<td>$\cos(\omega x) \omega e^{-5x} - 5 \sin(\omega x) e^{-5x}$</td>
<td><img src="image" alt="Plot of $f(x)$ and $\frac{d}{dx}f(x)$" /></td>
</tr>
<tr>
<td>$\frac{d^2}{dx^2} \sin^2(x)$</td>
<td>$-8 \sin(x) \cos(x)$</td>
<td><img src="image" alt="Plot of $f(x)$ and $\frac{d}{dx}f(x)$" /></td>
</tr>
</tbody>
</table>

**Cell Color**

You can set the background color of any cell or collection of cells to be any color. This coloring is independent of any highlighting or text color that may also be applied.

To change the color of a cell, place the cursor in the cell, then from the **Table** menu, select **Cell Color...** In the **Select A Color** dialog, choose a color from the swatches, the color wheel, or RGB. See the **DrawingTools** help page for details on color selection.
For example, select the first row of the table and apply a light blue color. This sets the header off from the content below.

<table>
<thead>
<tr>
<th>( f(x) )</th>
<th>( \frac{d}{dx} f(x) )</th>
<th>Plot of ( f(x) ) and ( \frac{d}{dx} f(x) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} ]</td>
<td>[ - \frac{1}{\left(1 + \frac{1}{1 + \frac{1}{x}}\right)^2 \left(1 + \frac{1}{x}\right)^2 x^2} ]</td>
<td></td>
</tr>
<tr>
<td>( \sin(\omega x) e^{-5x} )</td>
<td>( \cos(\omega x) \omega e^{-5x} - 5 \sin(\omega x) e^{-5x} )</td>
<td></td>
</tr>
<tr>
<td>( \frac{d^2}{dx^2} \sin^2(x) )</td>
<td>( -8 \sin(x) \cos(x) )</td>
<td></td>
</tr>
</tbody>
</table>

**Controlling the Visibility of Cell Content**

The Table Properties dialog includes two options to control the visibility of cell content. These options allow control over the visibility of Maple input and execution group boundaries. Thus, these elements can be hidden in a table even if they are set to visible for the document in the View → Show/Hide Contents dialog.

**Printing Options**

The Table Properties dialog contains options to control the placement of page breaks when printing. You can fit a table on a single page, allow page breaks between rows, or allow page breaks within a row.
Execution Order Dependency

The order in which cells are executed is set in the Table Properties dialog. The following tables illustrate the effect of execution order.

<table>
<thead>
<tr>
<th>Row-wise execution order</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt; ( x := 1 );</td>
<td>&gt; ( x := x + 1 );</td>
</tr>
<tr>
<td>( x := 1 ) \hspace{1cm} (7.1) \hspace{1cm} ( x := 2 ) \hspace{1cm} (7.2)</td>
<td></td>
</tr>
<tr>
<td>&gt; ( x := x + 1 );</td>
<td>&gt; ( x := x + 1 );</td>
</tr>
<tr>
<td>( x := 3 ) \hspace{1cm} (7.3) \hspace{1cm} ( x := 4 ) \hspace{1cm} (7.4)</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Column-wise execution order</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt; ( x := 1 );</td>
<td>&gt; ( x := x + 1 );</td>
</tr>
<tr>
<td>( x := 1 ) \hspace{1cm} (7.5) \hspace{1cm} ( x := 3 ) \hspace{1cm} (7.6)</td>
<td></td>
</tr>
<tr>
<td>&gt; ( x := x + 1 );</td>
<td>&gt; ( x := x + 1 );</td>
</tr>
<tr>
<td>( x := 2 ) \hspace{1cm} (7.7) \hspace{1cm} ( x := 4 ) \hspace{1cm} (7.8)</td>
<td></td>
</tr>
</tbody>
</table>

Tables and the Classic Worksheet

Tables are flattened on export to the Classic Worksheet interface. For example, the following table in the Standard Worksheet appears as one column in the Classic Worksheet interface.

<table>
<thead>
<tr>
<th>Table in Standard Worksheet</th>
<th>Table in Classic Worksheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>aaa  ddd</td>
<td>aaa</td>
</tr>
<tr>
<td>bbc  eee</td>
<td>bbc</td>
</tr>
<tr>
<td>ccc  fff</td>
<td>ccc</td>
</tr>
<tr>
<td></td>
<td>ddd</td>
</tr>
<tr>
<td></td>
<td>eee</td>
</tr>
<tr>
<td></td>
<td>fff</td>
</tr>
</tbody>
</table>

Additional Examples

For more practice creating and manipulating tables, try creating the following tables at the end of your document.
Table of Values

This example illustrates how to set the visibility options for cell contents to display a table of values.

\[ y := t \rightarrow \frac{1}{2} t^2 : \]

Create a table with 2 rows and 7 columns. Enter the values as below, and then select all table cells. In the **Table → Alignment** menu, select **Columns**, and then **Center**.

<table>
<thead>
<tr>
<th>( t )</th>
<th>( s )</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y(t) )</td>
<td>( m )</td>
<td>&gt; ( y(0) )</td>
<td>&gt; ( y(1) )</td>
<td>&gt; ( y(2) )</td>
<td>&gt; ( y(3) )</td>
<td>&gt; ( y(4) )</td>
<td>&gt; ( y(5) )</td>
<td>&gt; ( y(6) )</td>
</tr>
<tr>
<td>0</td>
<td>( 1 )</td>
<td>( 2 )</td>
<td>( 9 )</td>
<td>( 8 )</td>
<td>( 25 )</td>
<td>18</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Table settings:**

In the **Properties** dialog (**Table → Properties** menu):

1. Set **Table Size Mode** to **Scale with zoom factor**.
2. Hide Maple input and execution group boundaries: Clear the **Show input** and **Show execution group boundaries** check boxes.

<table>
<thead>
<tr>
<th>( t )</th>
<th>( s )</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y(t) )</td>
<td>( m )</td>
<td>0</td>
<td>( \frac{1}{2} )</td>
<td>2</td>
<td>( \frac{9}{2} )</td>
<td>8</td>
<td>( \frac{25}{2} )</td>
<td>18</td>
</tr>
</tbody>
</table>

**Formatting Table Headers**

The following table uses cell merging for formatting row and column headers, and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over. You can hide the visibility of lines on mouse pointer roll over by using the **View → Show/Hide Contents** dialog, and clearing the **Hidden Table Borders** check box.

<table>
<thead>
<tr>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td>13</td>
</tr>
<tr>
<td>High</td>
<td>18</td>
</tr>
</tbody>
</table>
Table settings:
1. Insert a table with 4 rows and 4 columns and enter the information shown above.

Using the Table menu:
2. Merge the following sets of (Row, Column) cells: (R1,C1) to (R2,C2), (R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).
3. Group columns 1 and 2, and columns 3 and 4.

In the Properties dialog (Table→Properties menu):
5. Set Exterior Borders to None.
6. (Optional) Change Table Size Mode size option to Scale with zoom factor.

Using the Table menu:
7. Set Alignment of columns 3 and 4 to Center.

2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and plots side by side.

Approximating exp(-x) as a rational polynomial using a 3rd order Padé approximation.

\[ e^{-x} \approx \frac{1 - \frac{1}{2}x + \frac{1}{10}x^2 - \frac{1}{120}x^3}{1 + \frac{1}{2}x + \frac{1}{10}x^2 + \frac{1}{120}x^3} \]

Insert a table with 1 row and 2 columns. Enter the information in text and executable 2-D Math to create the calculation and plot, as shown.
Table Settings:

In the Properties dialog (Table→Properties menu):
1. Set Exterior and Interior Borders to None.
2. Hide Maple input and execution group boundaries: Clear the Show input and Show execution group boundaries check boxes.

Using the Table menu:
3. Change row Alignment to Center.

7.5 Canvas

Using the drawing tools, you can sketch an idea in a canvas, draw on plots, and draw on images. See Figure 7.15. For details about the drawing feature, refer to the DrawingTools help page.

![Figure 7.15: Drawing Tools and Canvas](Image)
Insert a Canvas

To insert a canvas:
1. Place the cursor where the canvas is to be inserted.
2. From the Insert menu, select Canvas. A canvas with grid lines appears in the document at the insertion point. The Drawing icon is available and associated context bar icons are displayed.

The tools include the following: selection tool, pencil (free style drawing), eraser, text insert, straight line, rectangle, rounded rectangle, oval, diamond, alignment, drawing outline, drawing fill drawing linestyle, and drawing canvas properties.

Drawing

To draw with the pencil tool in the canvas:
1. From the Drawing icons, select the pencil icon.
2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

To adjust the color of drawing tools:
1. From the Drawing icons, select the Drawing Outline icon. See Figure 7.16.
2. Select one of the color swatches available or select the color wheel, RGB ranges, or eye dropper icon at the bottom of the dialog and customize the color to your preference.
3. After selecting a new color, draw on the canvas using the pencil icon and notice the new color.

![Figure 7.16: Drawing Outline Color Icon](image)

In your document, there are three plots, two of which are 2-D plots that can be drawn on. All of the information in the table you made in the previous section could be drawn onto the plot, putting the information in a more concise layout.
Consider one of the plots from the table:

\[ f(x) = \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}} \]

Click on the plot, and notice that the Plot toolbar is open. However, the Drawing toolbar is also available. Click on Drawing to see the toolbar.

Select the Text icon, \( \text{T} \), and click on the plot. Enter the expression \( f(x) \) in one text area, and its derivative in another, as shown. You can move the text areas around on the plot so that they indicate the correct lines.

For details on the rest of the drawing features, refer to the DrawingTools help page.

**Canvas Style**

You can alter the Canvas in the following ways:

- Add a grid of horizontal and/or vertical lines. By default, the canvas opens with a grid of horizontal and vertical lines.
- Change the grid line color.
- Change the spacing between grid lines.
- Change the background color.

These options can be changed in the Drawing Properties Canvas Icon. See Figure 7.17.
Inserting Images

You can insert images in these file formats into your document.

- Graphics Interchange Format - gif
- Joint Photographic Experts Group - jpe, jpeg, jpg
- Portable Network Graphics - png
- Bitmap Graphics - bmp
- Tagged Image File Format - tif, tiff, jfx
- Portable aNyMap - pnm
- Kodak FlashPix - fpx

To insert an image into the document at the cursor location:

1. From the Insert menu, select Image. The Load Image dialog opens.
2. Specify a path or folder name.
3. Select a filename.
4. Click Open. The image is displayed in the document.

If the source file is altered, the embedded image does not change because the original object is pasted into the document.
To resize an inserted image:
1. Click the image. Resizing anchors appear at the sides and corners of the image.
2. Move the mouse over the resize anchor. Resizing arrows appear.
3. Click and drag the image to the desired size.

**Note:** To constrain the proportions of the image as it is resized, press and hold the Shift key as you drag.

You can also draw on images in the same way as the drawing canvas. For more information, refer to the worksheet/documenting/drawingtools help page.

**ImageTools Package**

You can manipulate image data using the ImageTools package. This package is a collection of utilities for reading and writing common image file formats, and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-bit hardware floating-point numbers. Grayscale images are 2-D, whereas color images are 3-D (the third dimension representing the color channels).

In addition to the commands in the ImageTools package, many ordinary Array and Matrix operations are useful for image processing.

For details about this feature, refer to the ImageTools help page.

**7.6 Hyperlinks**

Use a hyperlink in your document to access any of the following.

- Web Page (URL)
- Email
- Worksheet
- Help Topic
- Task
- Dictionary Topic
- Maplet
Inserting a Hyperlink in a Document

To create a hyperlink from existing text in the document:

1. Highlight the text that you want to make a hyperlink.
2. From the Format menu, select Convert To and then Hyperlink.
3. In the Hyperlink Properties dialog box, the Link Text field is grayed out since the text region you highlighted is used as the link text. This is demonstrated in Figure 7.18. The highlighted text region, Diff, is grayed out.
4. Specify the hyperlink Type and Target as described in the appropriate following section.

To insert a text or image hyperlink into the document:

1. From the Insert menu, select Hyperlink.
2. In the Hyperlink Properties dialog box, enter the Link Text.
   
   Optionally, use an image as the link. Select the Image check box and click Choose Image for the file In .mw files the image appears as the link. You can resize the image as necessary. Click and drag from the corners of the image to resize.
3. Specify the hyperlink Type and Target as described in the appropriate following section.
Linking to a Web Page

To link to a Web page:
1. In the Type drop-down list, select URL.
2. In the Target field enter the full URL, for example, http://www.maplesoft.com.
3. Click OK.

Linking to an Email Address

To link to an email address:
1. In the Type drop-down list, select Email.
2. In the Target field enter the email address.
3. Click OK.

Note: For information about email hyperlinks in the Classic Worksheet interface, see Worksheet Compatibility (page 332).

Linking to a Worksheet

To link to a Maple worksheet or document:
1. In the Type drop-down list, select Worksheet.
2. In the Target field enter the path and filename of the document or click Browse to locate the file. (Optional) In the Bookmark drop-down list, enter or select a bookmark.

Note: To link within a single Maple document, leave the Target field blank and choose the bookmark from the Bookmark drop-down list.

Note: When linking to a custom document, the path is absolute. When sharing documents that contain hyperlinks, ensure that target documents are in the same directory.
3. Click OK.

Linking to a Help Page

To link to a help page:
1. In the Type drop-down list, select Help Topic.
2. In the Target field enter the topic of the help page. (Optional) In the Bookmark drop-down list, enter or select a bookmark.
3. Click OK.
Linking to a Task

To link to a task:
1. In the Type drop-down list, select Task.
2. In the Target field enter the topic name of the task template (see the status bar at the bottom of the Task Browser window).
3. Click OK.

Linking to a Dictionary Topic

To link to a Dictionary topic:
1. In the Type drop-down list, select Dictionary Topic.
2. In the Target field enter a topic name. Dictionary topics begin with the prefix Definition, for example, Definition/dimension.
3. Click OK.

Linking to a Maplet Application

To link to a Maplet application:
1. In the Type drop-down list, select Maplet.
2. In the Target field enter the local path to a file with the .maplet extension. Optionally, click Browse to locate the file.

If the Maplet application exists, clicking the link launches the Maplet application. If the Maplet application contains syntax errors, then error messages are displayed in a pop-up window.

When linking to a custom Maplet application, the path is absolute. When sharing documents that contain links to Maplet applications, ensure that target Maplet applications are in the same directory.
3. Click OK.

Note: To link to a Maplet application available on a MapleNet Web page, use the URL hyperlink type to link to the Web page. For information on MapleNet, see Embedded Components and Maplets (page 385).

Example

For this example, link the text "horizontal range" to the dictionary page for domain. As indicated in the section for Linking to a Dictionary Topic, select Dictionary Topic in the Type drop-down list, and then enter Definition/domain in the Target field.
Result:

plot - create a two-dimensional plot

Calling Sequence

\[
\text{plot}(f, x) \\
\text{plot}(f, x=x_0..x_1) \\
\text{plot}(v_1, v_2)
\]

Parameters

- \( f \) - expression in independent variable \( x \)
- \( x \) - independent variable
- \( x_0, x_1 \) - left and right endpoints of horizontal range
- \( v_1, v_2 \) - \( x \)-coordinates and \( y \)-coordinates

Bookmarks

Use a bookmark to designate a location in an active document. This bookmark can then be accessed from other regions in your document or by using hyperlinks in other documents.

To display bookmark formatting icons, activate the Marker feature.

- From the View menu, select Markers.

![Section 1.1 Bookmark Indicator](image)

![Section 1.2](image)

Figure 7.19: Bookmark Indicator

Note: You can display bookmark properties by holding the pointer over a bookmark indicator. See Figure 7.19.

Inserting, Renaming, and Deleting a Bookmark

To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark. For example, place the cursor in the Parameters section title.

2. From the Format menu, select Bookmarks. The Bookmark dialog opens, listing existing bookmarks in the document.
3. Click **New**. The **Create Bookmark** dialog opens. See **Figure 7.20**. Enter a bookmark name, "parameters", and click **Create**.

![Create Bookmark Dialog](image)

**Figure 7.20: Create Bookmark Dialog**

4. The new bookmark appears in the **Bookmark** dialog list. Click **OK**.

**Note**: You can also rename and delete bookmarks using the **Bookmark** dialog.

**Result:**

```
plot - create a two-dimensional plot
```

**Calling Sequence**

```
plot(f, x)
plot(f, x=x0..x1)
plot(v1, v2)
```

**Parameters**

- **Expression** - independent variable `x`
- **x0, x1** - left and right endpoints of **horizontal range**
- **v1, v2** - `x`-coordinates and `y`-coordinates
Go to a Bookmark

You can automatically move the cursor to the location of the bookmark in the active document.

1. From the Edit menu, select Go To Bookmark. The Go To Bookmark dialog opens with the current bookmarks listed.
2. Select the bookmark "parameters" and click OK. The cursor moves to the bookmark, at the beginning of the Parameters section.

For more information, refer to the bookmarks help page.

7.7 Embedded Components

You can embed simple graphical interface components, such as a button, in your document. These components can then be associated with actions that are to be executed. For example, the value of a slider component can be assigned to a document variable, or a text field can be used to input an equation.

Adding Graphical Interface Components

The graphical interface components can be inserted by using the Components palette (Figure 7.21) or by cutting/copying and pasting existing components to another area of the document. Although copied components have most of the same characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are not visible, use the following procedure.

1. From the View menu, select Palettes.
2. Select Expand Docks.
3. If the Components palette is not displayed, right-click (Control-click, for Macintosh) the palette dock. From the context menu, select Show Palette, and then Components.

For more information, see Palettes (page 21).

You can embed the following items.

- Button, Toggle Button
- Combo Box, Check Box, List Box, Radio Button
- Text Area, Label
- Slider, Plot, Mathematical Expression
- Dial, Meter, Rotary Gauge, Volume Gauge
- Data Table
In your document, you can add components that have already been configure to work together, by using a task template. Here, we use the Interactive Application template. For details on how to create and modify components, see Creating Embedded Components (page 388).

To insert the task template, from the Tools menu, select Tasks → Browse. In the table of contents, expand Document Templates, and select Interactive Application. Click Insert Minimal Content. The following is inserted into your document.
This configuration of components plots a linear function with slope and y-intercept given respectively by the two dials $\text{parameter}_2$ and $\text{parameter}_1$, and displays the function $\frac{\text{parameter}_2}{\text{parameter}_1}$ on a gauge. For details on how these components work together, see Embedded Components and Maplets (page 385).

### 7.8 Spell Checking

The Spellcheck utility examines all designated text regions of your document for potential spelling mistakes, including regions that are in collapsed sections. It does not check input, output, text in execution groups, or math in text regions. See Figure 7.23.

**Note:** The Spellcheck utility uses American spelling.
How to Use the Spellcheck Utility


2. If the Spellcheck utility finds a word that it does not recognize, that word is displayed in the Not Found text box.

You have six choices:

- To ignore the word, click Ignore.
- To ignore all instances of the word, click Ignore All.
- To change the word, that is, accept the suggested spelling that is in the Change To text box, click Change.
- To change all instances of the word, that is, accept the suggested spelling to replace all instances of the word, click Change All.
- To add the word to your dictionary, click Add. For details, see the following User Dictionary section.
- To close the Spellcheck dialog and stop the spelling check, click Cancel.

3. When the Spellcheck is complete, a dialog containing the message "The spelling check is complete" appears. Click OK to close this dialog.
Note: when using the Spellcheck utility, you can find spelling errors in the dialog, but you cannot change the text in document. The Spellcheck utility does not check grammar.

Selecting a Suggestion

To select one of the suggestions as the correct spelling, click the appropriate word from the list in the Suggestions text box.

If none of the suggestions are correct, highlight the word in the Change To text box and enter the correct spelling. Click Change to accept this new spelling.

User Dictionary

You can create and maintain a custom dictionary that works with the Maple Spellcheck utility.

Properties of the Custom Dictionary File

- It must be a text file that is, have the file extension .txt. For example, mydictionary.txt.
- It is a list of words, one word per line.
- It is case sensitive. This means that integer and Integer require individual entries in the dictionary file.
- It does not require manual maintenance. You build your dictionary file by using the Add functionality of the Spellcheck. However, you can manually edit the file.

To specify a custom dictionary to be used with the Maple Spellcheck utility:

1. Create a .txt file in a directory/folder of your choice.
2. In Maple, open the Options dialog, Tools → Options, and select the General tab.
3. In the User Dictionary field enter the path and name of the .txt file you created, or click Browse to select the location and filename.
4. To ignore Maple words that are command and function names, clear the Use Maple words in spellchecker check box.
5. Click Apply to Session or Apply Globally to save the settings, or Cancel to discard.

Adding a Word to Your Dictionary

When running the spellcheck, if the word in the Not Found text box is correct, you can add the word to your dictionary.

1. Click the Add button. If this is the first time you are adding a word, the Select User Dictionary dialog opens.
2. Enter or select the custom dictionary (.txt file you created. See User Dictionary (page 330).
3. Click Select. The word is automatically added to your custom dictionary file

Note: Specification in the Options dialog determine whether this word is recognized in your next Maple session. If you set your custom dictionary and clicked Apply to Session, then this word will not be recognized in a new Maple session. If you set your custom dictionary and clicked Apply Globally, then this new word will be recognized.

7.9 Creating Graded Assignments

You can use Maple to create graded assignments. Question types include multiple choice, essay, true-or-false, fill-in-the-blanks and Maple-graded.

Note: This feature can be used to create questions for Maple T.A.—an online automated testing and assessment system. For details about Maple T.A., see Maple T.A. (page 415).

Creating a Question

To create a question:
1. Open the Task browser (Tools→Tasks→Browser).
2. From the Maple T.A. folder, select the appropriate question type.
3. Insert the question template into a document.
4. Enter the question content as described in the template.
5. Repeat steps 1 to 4 for each question to add to the document.

Viewing Questions in Maple

To view and test your questions in Maple:
• From the View menu, select Assignment. This view displays all of the questions in your assignment with access to hints, plotting, and grading.

After answering your questions, you can test the grading function by clicking the Grade button. A Maplet dialog is displayed indicating if the question was answered correctly. If hints were provided in the question, these are also displayed.

Saving Test Content

When you save a document with test content, the authoring and assignment modes determine what the user sees when opening your document.
• If you save the document in authoring mode (task template contents visible), the user sees this content when opening the document.
• If you save the document in assignment mode, the user sees only the assignment layout.
In both cases the View→Assignment menu is accessible. As such, users (students) can switch between the original document contents and the displayed assignment.

## 7.10 Worksheet Compatibility

Maple provides users with two worksheet interfaces: the Standard Worksheet and the Classic Worksheet. Both have access to the full mathematical engine of Maple and take advantage of the new functionality in Maple. The Classic Worksheet has the traditional Maple worksheet look and uses less memory.

If you create a document in the Standard Worksheet interface of Maple and then open it in the Classic Worksheet interface, you should note possible changes to your file. For example, a bulleted list in the Standard Worksheet will not be displayed with bullets in the Classic Worksheet. Many of the graphical features in this manual, especially those in this chapter, are not available in the Classic Worksheet interface.

If you are creating documents for distribution, refer to the Compatibility help page.
8 Maple Expressions

This chapter provides basic information on using Maple expressions, including an overview of the basic data structures. Many of the commands described in this chapter are useful for programming. For information on additional Maple programming concepts, such as looping, conditional execution, and procedures, see Basic Programming (page 365).

8.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Creating and Using Data Structures (page 333) - How to define and use basic data structures | • Expression Sequences  
• Sets  
• Lists  
• Tables  
• Arrays  
• Matrices and Vectors  
• Functional Operators  
• Strings |
| Working with Maple Expressions (page 343) - Tools for manipulating and controlling the evaluation of expressions | • Low-Level Operations  
• Manipulating Expressions  
• Evaluating Expressions |

8.2 Creating and Using Data Structures

Constants, data structures, mathematical expressions, and other objects are Maple expressions. For more information on expressions, refer to the Maple Help System.

This section describes the key data structures:

• Expression sequences  
• Sets  
• Lists  
• Tables  
• Arrays  
• Matrices and Vectors  
• Functional operators  
• Strings
Expression Sequences

The fundamental Maple data structure is the *expression sequence*. It is a group of expressions separated by commas.

\[
> S := 2, y, \sin(x^2), I :
\]

**Accessing Elements**

To access one of the expressions:

- Enter the sequence name followed by the position of the expression enclosed in brackets (`[]`).

For example:

\[
> S[2]
\]

\[y\]

Using negative integers, you can select an expression from the end of a sequence.

\[
> S[-2]
\]

\[\sin(x^2)\]

You can select multiple expressions by specifying a range using the **range operator** (``..``).

\[
> S[2..-2]
\]

\[y, \sin(x^2)\]

**Note:** This syntax is valid for most data structures.

**Sets**

A set is an expression sequence enclosed in curly braces (`{}`).

\[
> \{4, 12, i, \sin\left(\frac{2}{3}\right)\}:
\]

A Maple set has the basic properties of a mathematical set.

- Each element is unique. Repeated elements are stored only once.
- The order of elements is not stored.
For example:

\[ \{ c, a, a, a, b, c, a \} \]

\[ \{ a, b, c \} \]

**Using Sets**

To perform mathematical set operations, use the set data structure.

\[ \{2, 6, 5, 1\} \cup \{2, 8, 6, 7\} \]

\[ \{1, 2, 5, 6, 7, 8\} \]

**Note:** The union operator is available in 1-D Math input as `union`. For more information, refer to the `union` help page.

For more information on sets, refer to the `set` help page.

**Lists**

A list is an expression sequence enclosed in brackets (`[ ]`).

\[ L := [2, 3, 3, 1, 0] \]

\[ L := [2, 3, 3, 1, 0] \]

**Note:** Lists preserve both the `order` and `repetition` of elements.

**Accessing Entries**

To refer to an element in a list:

- Use square brackets.

For example:

\[ L[−2..−1] \]

\[ [1, 0] \]

For more information, see *Accessing Elements* (page 334).

**Using Lists**

Some commands accept a list (or set) of expressions.
For example, you can solve a list (or set) of equations using a context menu or the `solve` command.

\[ \text{solve}\left([x - y^2 = -2, x + y = 0]\right) \]

\{x = 2, y = -2\}, \{x = -1, y = 1\}

For more information, see \textit{Solving Equations and Inequations (page 111)}.

For more information on sets and lists, refer to the \texttt{set} help page.

\textbf{Arrays}

Conceptually, the \texttt{Array} data structure is a generalized list. Each element has an index that you can use to access it.

The two important differences are:
- The indices can be any integers.
- The dimension can be greater than one.

\textbf{Creating and Using Arrays}

To define an Array, use the \texttt{Array} constructor.

Standard \texttt{Array} constructor arguments are:
- Expression sequences of ranges - Specify the indices for each dimension
- Nested lists - Specify the contents

For example:

\[ > a := \text{Array}(1..3, 1..3, [[1, 2, 3], [4, 5, 6], [7, 8, 9]]) \]

\[
\begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{bmatrix}
\]

\[ > b := \text{Array}(1..2, 2..5, [[1.2, 4.9, 6.3, 7.1], [9.2, 5.5, 2.4, 1.7]]) \]

\[ b := \text{Array}(1..2, 2..5, \{(1, 2) = 1.2, (1, 3) = 4.9, (1, 4) = 6.3, (1, 5) = 7.1, (2, 2) = 9.2, (2, 3) = 5.5, (2, 4) = 2.4, (2, 5) = 1.7\}, \text{datatype = anything}, \text{storage = rectangular}, \text{order = Fortran_order}) \]

To access entries in an Array, use either square bracket or round bracket notation.
Square bracket notation respects the actual index of an Array, even when the index does not start at 1.

> a[1, 1]

\[
1
\]

> a[2, 3]

\[
6
\]

> b[2, 3]

\[
5.5
\]

> b[1, 1]

Error, Array index out of range

Round bracket indexing normalizes the dimensions to begin at 1. Since this method is relative, you can access the end of the array by entering \(-1\).

> a(-1, 2)

\[
8
\]

> b(1, 1)

\[
1.2
\]

The **Array** constructor supports other syntaxes. It also supports many options. For more information on the **Array** constructor and the Array data structure, refer to the **Array** help page. For more information on indexing methods, refer to the **rtable_indexing** help page.

**Large Arrays**

Only one- and two-dimensional Arrays (with at most 10 indices in each dimension) display in the document. Larger Arrays display as a placeholder.

> Array(0 .. 100)

\[
\begin{array}{c}
\text{0 .. 100 Array} \\
\text{Data Type: anything} \\
\text{Storage: rectangular} \\
\text{Order: Fortran_order}
\end{array}
\]
To view large Arrays:

- Double-click the placeholder.

The **Matrix Browser** displays the Array. For more information, see *Viewing Large Matrices and Vectors* (page 160).

**Tables**

Tables are conceptually an extension of the Array data structure, but the table data structure is implemented using hash tables. Tables can be indexed by any values, not only integers.

**Defining Tables and Accessing Entries**

```maple
> Greek := table([a = α, b = β, c = γ]):
> Greek[b]

β
```

You can also assign anything, for example, a list, to each element.

```maple
> Translation := table([one = [un, uno], two = [deux, dos], three = [trois, tres]]):
> Translation[two]

[deux, dos]
```

For more information on tables, refer to the table help page.

**Matrices and Vectors**

Matrices and Vectors are specialized data structures used in linear algebra and vector calculus computations.

```maple
> M := Matrix([[12, 33], [83, 12]]): v := <2, 14>:
```

For information on defining Matrices and Vectors, see *Creating Matrices and Vectors* (page 156).
For more information on these data structures, including how to access entries and perform linear algebra computations, see *Linear Algebra* (page 155).

**Functional Operators**

A functional operator is a mapping \( f: x \rightarrow y(x) \). The value of \( f(x) \) is the result of evaluating \( y(x) \).

Using functional operators, you can define mathematical functions.

**Defining a Function**

1. In the Expression palette, click one of the function definition items. See Figure 8.1. Maple inserts the function definition.
2. Replace the placeholders, using Tab to move to the next placeholder. **Note:** If pressing the Tab key indents the text, click the Tab icon in the toolbar. This allows you to move between placeholders.
3. Press Enter.

\[
\begin{align*}
\text{Figure 8.1: Function Definition Palette Items}
\end{align*}
\]
For example, define a function that adds 1 to its input.

\[
> \text{add1} := x \rightarrow x + 1:
\]

**Note:** To insert the right arrow, you can enter the characters `->` in 2-D Math. In 2-D Math, Maple replaces `->` with the right arrow symbol `→`. In 1-D Math, the characters are not replaced.

You can evaluate the function `add1` with symbolic or numeric arguments.

\[
> \text{add1}(12); \text{add1}(x + y)
\]

```
13
x + y + 1
```

**Distinction between Functional Operators and Other Expressions**

The expression `x + 1` is different from the functional operator `x \rightarrow x + 1`.

Assign the functional operator `x \rightarrow x + 1` to `f`.

\[
> f := x \rightarrow x + 1:
\]

Assign the expression `x + 1` to `g`.

\[
> g := x + 1:
\]

**To evaluate the functional operator `f` at a value of `x`:**

- Specify the value as an argument to `f`.

\[
> f(22)
\]

```
23
```

**To evaluate the expression `g` at a value of `x`:**

- You **must** use the `eval` command.

\[
> g(22)
\]

```
x(22) + 1
```

\[
> \text{eval}(g, x=22)
\]

```
23
```
For more information on the `eval` command, and on using palettes and context menus to evaluate an expression at a point, see *Substituting a Value for a Subexpression (page 353).*

**Multivariate and Vector Functions**

**To define a multivariate or vector function:**

- Enclose coordinates or coordinate functions in parentheses (( )).

For example, a multivariate function:

```plaintext
> f := (x, y) -> x^3 / (y^2 + 1):

> f(0, 0); f(-2.1, 1.9)

0
-2.008893709
```

A vector function:

```plaintext
> g := t -> (sin(t), cos(t), t):

> g(0); g(\frac{\pi}{2})

0, 1, 0
1, 0, \frac{1}{2} \pi
```

**Using Operators**

To perform an operation on a functional operator, specify arguments to the operator. For example, for the operator \( f \), specify \( f(x) \), which Maple evaluates as an expression. See the following examples.

**Plotting:**

Plot a three-dimensional operator as an expression using the `plot3d` command.

```plaintext
> h := (x, y) -> x^2 * cos(y):
```
For information on plotting, see *Plots and Animations* (page 237).

**Integration:**

Integrate a function using the `int` command.

```
> k := x \rightarrow \sin(\cos(x)\pi):
```

```
> \text{int}\left(k(t), t = 0 .. \frac{\pi}{2}\right)
```

\[ \frac{1}{2} \pi \text{StruveH}(0, \pi) \]

For information on integration and other calculus operations, see *Calculus* (page 172).

**Strings**

A string is a sequence of characters enclosed in double quotes (" ").

```
> S := "This is a sequence of characters."
```
Accessing Characters

You can access characters in a string using brackets.

> S[11 .. -2]

"sequence of characters"

Using Strings

The StringTools package is an advanced set of tools for manipulating and using strings.

> with(StringTools):

> Random(9,'alnum')

"8dzrI9ema"

> Stem("impressive")

"impress"

> Split("Create a list of strings from the words in a string")

[ "Create", "a", "list", "of", "strings", "from", "the", "words", "in", "a", "string"]

8.3 Working with Maple Expressions

This section describes how to manipulate expressions using commands. Topics covered include testing the expression type, accessing operands of an expression, and evaluating an expression.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties. Maple contains over 200 types, including:

- `+`
- boolean
- constant
- integer
- Matrix
- trig
For more information and a complete list of Maple types, refer to the type help page.

The type commands return true if the expression satisfies the type check. Otherwise, they return false.

**Testing the Type of an Expression**

To test whether an expression is of a specific type:
- Use the type command.

```maple
> type(sin(x),'trig')
    true

> type(sin(x) + cos(x),'trig')
    false
```

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 361).

Maple types are not mutually exclusive. An expression can be of more than one type.

```maple
> type(3,'constant')
    true

> type(3,'integer')
    true
```

For information on converting an expression to a different type, see Converting (page 351).

**Testing the Type of Subexpressions**

To test whether an expression has a subexpression of a specific type:
- Use the hastype command.

```maple
> hastype(sin(x) + cos(x),'trig')
    true
```
Testing for a Subexpression

To test whether an expression contains an instance of a specific subexpression:

- Use the `has` command.

> `has(sin(x + y), x)`

    `true`

> `has(sin(x + y), x + y)`

    `true`

> `has(sin(x + y), sin(x))`

    `false`

The `has` command searches the structure of the expression for an exactly matching subexpression.

For example, the following calling sequence returns `false`.

> `has(x + y + z, x + z)`

    `false`

To return all subexpressions of a particular type, use the `indets` command. For more information, see Indeterminates (page 347).

Accessing Expression Components

Left and Right-Hand Side

To extract the left-hand side of an equation, inequality, or range:

- Use the `lhs` command.

To extract the right-hand side of an equation, inequality, or range:

- Use the `rhs` command.
For example:

\[
> y := x + 1
\]

\[y = x + 1\] \hspace{1cm} (8.1)

\[
> \text{lhs}\left( (8.1) \right)
\]

\[y\] \hspace{1cm} (8.2)

\[
> \text{rhs}\left( (8.1) \right)
\]

\[x + 1\] \hspace{1cm} (8.3)

For the following equation, the left endpoint of the range is the left-hand side of the right-hand side of the equation.

\[
> x := 3 .. 5
\]

\[x = 3 .. 5\] \hspace{1cm} (8.4)

\[
> \text{lhs}\left( \text{rhs}\left( (8.4) \right) \right)
\]

\[3\] \hspace{1cm} (8.5)

**Numerator and Denominator**

**To extract the numerator of an expression:**

- Use the `numer` command.

**To extract the denominator of an expression:**

- Use the `denom` command.

\[
> e := \frac{1 + \sin(x)^3 - \frac{y}{x}}{y^2 - 1 + x}:
\]

If the expression is not in normal form, Maple normalizes the expression before selecting the numerator or denominator. (For more information on normal form, refer to the `normal` help page.)
The expression can be any algebraic expression. For information on the behavior for non-rational expressions, refer to the `numer` help page.

**Components of an Expression**

The components of an expression are called its operands.

**To count the number of operands in an expression:**

- Use the `nops` command.

For example, construct a list of solutions to an equation.

```maple
> solutions := [solve(6*x^3 - x^2 + 7, x)]
solutions := [-1, 7/12 - 1/12*I*sqrt(119), 7/12 + 1/12*I*sqrt(119)]
```

Using the `nops` command, count the number of solutions.

```maple
> nops(solutions)
3
```

For more information on the `nops` command and operands, refer to the `nops` help page.

**Indeterminates**

**To find the indeterminates of an expression:**

- Use the `indets` command.

The `indets` command returns the indeterminates as a set. Because the expression is expected to be rational, functions such as `sin(x)`, `f(x)`, and `sqrt(x)` are considered to be indeterminate.
> \texttt{indets\((3 + \pi) x^2 \sin(\sqrt{1 + y})\)}

\[\{x, y, \sqrt{1 + y}, \sin(\sqrt{1 + y})\}\]

To return all subexpressions of a particular type, specify the type as the second argument. For information on types, see Testing the Type of an Expression (page 344).

> \texttt{indets\((3 + \pi) x^2 \sin(\sqrt{1 + y}), \text{\textquoteleft\textquoteleft radicat\textquoteright\textquoteright}\)}

\[\{\sqrt{1 + y}\}\]

To test whether an expression has subexpressions of a specific type (without returning them), use the \texttt{has} command. For more information, see Testing for a Subexpression (page 345).

\textbf{Manipulating Expressions}

This section introduces the most commonly used manipulation commands. For additional manipulation commands, see Iterative Commands (page 374).

\textbf{Simplifying}

\textbf{To simplify an expression:}

- Use the \texttt{simplify} command.

The \texttt{simplify} command applies simplification rules to an expression. Maple has simplification rules for various types of expressions and forms, including trigonometric functions, radicals, logarithmic functions, exponential functions, powers, and various special functions. You can also specify custom simplification rules using a set of side relations.

> \texttt{simplify\(5 + 32 - 8\left(\frac{1}{3}\right)\)}

35

> \texttt{simplify\((\sin(x))^2 + \ln(2y) + \cos(x)^2\)}

\[1 + \ln(2) + \ln(y)\]

To limit the simplification specify the type of simplification to be performed.
You can also use the \texttt{simplify} command with \textit{side relations}. See \textit{Substituting a Value for a Subexpression} (page 353).

### Factoring

**To factor a polynomial:**

- Use the \texttt{factor} command.

\begin{verbatim}
> factor(x^6 - x^5 - 9x^4 + x^3 + 20x^2 + 12x)

\end{verbatim}

\[ x(x - 2) (x - 3) (x + 2) (x + 1)^2 \]

\begin{verbatim}
> factor(x^3y + x^2y^2 - 3x^3 - x^2y + 2xy^2 - 6x^2 - 5xy + y^2 - 3x - 3y)

\end{verbatim}

\[ (y - 3) (x + 1)^2 (x + y) \]

Maple can factor polynomials over the domain specified by the coefficients. You can also factor polynomials over algebraic extensions. For details, refer to the \texttt{factor} help page.

For more information on polynomials, see \textit{Polynomial Algebra} (page 148).

**To factor an integer:**

- Use the \texttt{ifactor} command.

\begin{verbatim}
> ifactor(196911)

\end{verbatim}

\[ (3)^4 (11) (13) (17) \]

For more information on integers, see \textit{Integer Operations} (page 106).

### Expanding

**To expand an expression:**

- Use the \texttt{expand} command.

The \texttt{expand} command distributes products over sums and expands expressions within functions.
Combining

To combine subexpressions in an expression:

- Use the `combine` command.

The `combine` command applies transformations that combine terms in sums, products, and powers into a single term.

```maple
> combine((x-a)^2 * x)

\begin{bmatrix}
x^3 & x^5 & x^7 \\
x^9 & x^{11} & x^{13} \\
x^{15} & x^{17} & x^{19}
\end{bmatrix}
```

The `combine` command applies only transformations that are valid for all possible values of names in the expression.

```maple
> combine(4 ln(x) - ln(y))

4 \ln(x) - \ln(y)
```

To perform the operation under assumptions on the names, use the `assuming` command.

For more information about assumptions, see *Assumptions on Variables* (page 142).
To convert an expression:

- Use the `convert` command.

The `convert` command converts expressions to a new form, type (see *Expression Types* (page 343)), or in terms of a function. For a complete list of conversions, refer to the `convert` help page.

Convert a measurement in radians to degrees:

```maple
> convert(\pi, 'degrees')

180 degrees
```

To convert measurements that use units, use the Unit Converter or the `convert/units` command.

```maple
> convert(450.2[kg], 'units', lb)

992.5211043[lb]
```

For information on the Unit Converter and using units, see *Units* (page 127).

Convert a list to a set:

```maple
> convert([a, b, c, d], 'set')

\[
\begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{bmatrix}
, \text{Array}(1..2, 2..5, \{(1, 2) = 1.2, (1, 3) = 4.9, (1, 4) = 6.3, (1, 5) = 7.1, (2, 2) = 9.2, (2, 3) = 5.5, (2, 4) = 2.4, (2, 5) = 1.7\}, \text{datatype} = \text{anything}, \text{storage} = \text{rectangular}, \text{order} = \text{Fortran_order})\}
```

Maple has extensive support for converting mathematical expressions to a new function or function class.
> convert(cos(x), exp)
\[
\frac{1}{2} e^{x} + \frac{1}{2} e^{-x}
\]

Find an expression equivalent to the inverse hyperbolic cotangent function in terms of Legendre functions.

> convert(arccoth(z), Legendre)
\[
\text{LegendreQ}\left(0, \frac{1}{z}\right) + \frac{1}{2} \frac{\pi \sqrt{-\left(z - 1\right)^2}}{z - 1}
\]

For more information on converting to a class of functions, refer to the convert/to_special_function help page.

**Normalizing**

**To normalize an expression:**

• Use the normal command.

The normal command converts expressions into factored normal form.

> normal\left(\frac{x^2 - y^2}{(x - y)^3}\right)
\[
\frac{x + y}{(x - y)^2}
\]

You can also use the normal command for zero recognition.

> normal\left(x^3 + 1 - (x + 1)^3 + 3x (1 + x)\right)
\[
0
\]

To expand the numerator and denominator, use the expanded option.
Sorting

To sort the elements of an expression:
• Use the \texttt{sort} command.

The \texttt{sort} command orders a list of values or terms of a polynomial.

\begin{verbatim}
> sort([4, 3, 2.1, -4, 43, 0])

[ -4, 0, 2.1, 3, 4, 43 ]
\end{verbatim}

\begin{verbatim}
> sort(x + 4 x^5 - 7 x^2 + 1 + 9 x^4 - 5 x^3)

4 x^5 + 9 x^4 - 5 x^3 - 7 x^2 + x + 1
\end{verbatim}

\begin{verbatim}
> sort(x y - 6 y^2 x + 2 y^3 + 5 x - 1)

-6 x y^2 + 2 y^3 + x y + 5 x - 1
\end{verbatim}

For information on sorting polynomials, see \textit{Sorting Terms} (page 150).

For more information on sorting, refer to the \texttt{sort} help page.

Evaluating Expressions

Substituting a Value for a Subexpression

To evaluate an expression at a point, you must substitute a value for a variable.

\begin{verbatim}
> normal\left(\frac{x^2-y^2}{(x-y)^3}, \text{'expanded'}\right)

\frac{x + y}{x^2 - 2 x y + y^2}
\end{verbatim}

\begin{verbatim}
> normal\left(\sin\left(1 + \frac{1}{x}\right)\right)

\sin\left(\frac{x + 1}{x}\right)
\end{verbatim}
To substitute a value for a variable using context menus:
1. Right-click (Control-click, for Macintosh) the expression. Maple displays a context menu.
2. From the context menu, select Evaluate at a Point. The Evaluate at a Point dialog is displayed. See Figure 8.2.

![Figure 8.2: Evaluate at a Point](image)

3. In the drop-down list, select the variable to substitute.
4. In the text field enter the value to substitute for the variable. Click OK.

In Worksheet mode, Maple inserts the eval command calling sequence that performs the substitution. This is the most common use of the eval command.

For example, substitute \( x = 3 \) in the following polynomial.

\[
> x^3 + 4x^2 - 7x + 2 \\
> x^3 + 4x^2 - 7x + 2 \\
> \text{eval}(x^3 + 4x^2 - 7x + 2, [x = 3])
\]

To substitute a value for a variable using palettes:
1. In the Expression palette, click the evaluation at a point item.
2. Specify the expression, variable, and value to be substituted.
For example:

\[
> \sqrt{x^2 - x - 3} \bigg|_{x = 5} \\
\sqrt{17}
\]

Substitutions performed by the `eval` function are *syntactical*, not the more powerful *algebraic* form of substitution.

If the left-hand side of the substitution is a name, Maple performs the substitution.

\[
> \text{eval}\left(\cos(a \ b \ c), a = \frac{\pi}{6}\right) \\
\cos\left(\frac{1}{6} \pi b c\right)
\]

If the left-hand side of the substitution is not a name, Maple performs the substitution only if the left-hand side of the substitution is an operand of the expression.

\[
> \text{eval}\left(\cos(a \ b), a \ b = \frac{\pi}{6}\right) \\
\frac{1}{2} \sqrt{3}
\]

\[
> \text{eval}\left(\cos(a \ b \ c), a \ b = \frac{\pi}{6}\right) \\
\cos(a \ b \ c)
\]

Maple did not perform the evaluation because \( a \ b \) is not an operand of \( \cos(a \ b \ c) \). For information on operands, refer to the `op` help page.

For algebraic substitution, use the `algsubs` command, or the `simplify` command with side relations.
Numerical Approximation

To compute an approximate numerical value of an expression:

• Use the `evalf` command.

The `evalf` command returns a floating-point (or complex floating-point) number or expression.

```maple
> algsubs(a*b = \pi/6, \cos(a*b))
\cos\left(\frac{1}{6} \cdot c \pi\right)
```

```maple
> simplify(cos(a*b), \{a*b = \pi/6\})
\cos\left(\frac{1}{6} \cdot c \pi\right)
```

By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets (\(\square\)).

```maple
> evalf(cos(\pi/6))
0.8660254040
```

```maple
> evalf(\(\frac{17}{3} \cdot x^2 + x - e^\pi\))
9.814954579 \cdot x^2 + x - 23.14069264
```

```maple
> evalf(\pi)
3.141592654
```

By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets (\([\square]\)).

```maple
> evalf[40](\pi)
3.141592653589793238462643383279502884197
```

For more information, refer to the `evalf` help page.

See also *Numerically Computing a Limit (page 173)* and *Numeric Integration (page 181)*.
Evaluating Complex Expressions

To evaluate a complex expression:

• Use the `evalc` command.

If possible, the `evalc` command returns the output in the canonical form \( \text{expr1} + i \text{expr2} \).

In 2-D Math input, you can enter the imaginary unit using the following two methods.

• In the Common Symbols palette, click the \( i \) or \( j \) item. See Palettes (page 21).
• Enter \( i \) or \( j \), and then press the symbol completion key. See Symbol Names (page 28).

\[ > \text{evalc}(\sqrt{1+i}) \]
\[ \frac{1}{2} \sqrt{2 + 2 \sqrt{2}} + \frac{1}{2} i \sqrt{-2 + 2 \sqrt{2}} \]

\[ > \text{evalc}(\sin(3 + 5j)) \]
\[ \sin(3) \cosh(5) + i \cos(3) \sinh(5) \]

In 1-D Math input, enter the imaginary unit as an uppercase \( i \) (I).

\[ > \text{evalc}(2^{(1 + I)}) \]
\[ 2 \cos(\ln(2)) + 2 i \sin(\ln(2)) \]

Evaluating Boolean Expressions

To evaluate an expression involving relational operators (\( = \), \( \neq \), \( > \), \( < \), \( \leq \), and \( \geq \)):

• Use the `evalb` command.

Note: In 1-D Math input, enter \( \neq \), \( \leq \), and \( \geq \) using the \( <> \), \( <= \), and \( >= \) operators.

The `evalb` command uses a three-valued logic system. The return values are true, false, and FAIL. If evaluation is not possible, an unevaluated expression is returned.
> evalb(x = x)

    true

> evalb(x = y)

    false

> evalb(3 + 2*I < 2 + 3*I)

    FAIL

**Important:** The `evalb` command does not perform arithmetic for inequalities involving `<`, `<=`, `>`, or `>=`, and does not simplify expressions. Ensure that you perform these operations before using the `evalb` command.

> evalb(ℜ(x) < ℜ(x + 1))

    ℜ(x) < 1 + ℜ(x)

> evalb(ℜ(x) - ℜ(x + 1) < 0)

    true

**Applying an Operation or Function to All Elements in a List, Set, Table, Array, Matrix, or Vector**

You can use the tilde character (~) to apply an operation or function to all of the elements in a list, set, table, Array, Matrix, or Vector.

In the following example, each element in the Matrix $M$ is multiplied by 2 by adding a tilde character after the multiplication operator ($\cdot$).
> \( M := \begin{bmatrix} 1 & 2 & 3 \\ 4 & 5 & 6 \\ 7 & 8 & 9 \end{bmatrix} \) 

\[
\begin{bmatrix} 1 & 2 & 3 \\ 4 & 5 & 6 \\ 7 & 8 & 9 \end{bmatrix}
\]  

(8.6)

\( M \sim 2 \)

\[
\begin{bmatrix} 2 & 4 & 6 \\ 8 & 10 & 12 \\ 14 & 16 & 18 \end{bmatrix}
\]

(8.7)

In the following example, the function \texttt{sin} is applied to each element in the Matrix \( M \).

\( > \ \texttt{sin}(M) \)

\[
\begin{bmatrix} \text{sin}(1) & \text{sin}(2) & \text{sin}(3) \\ \text{sin}(4) & \text{sin}(5) & \text{sin}(6) \\ \text{sin}(7) & \text{sin}(8) & \text{sin}(9) \end{bmatrix}
\]

(8.8)

The tilde character can also be used to apply a function to multiple data sets, for example,

\( > \ \text{diff}(z \cdot x^2 + x \cdot y^2, [x, x, y, y, z, z], [y, z, x, z, x, y]) \);

\[ [2y, 2x, 2y, 0, 2x, 0] \]

(8.9)

You can use values in one data structure type to compute values in another data structure type, as long as both data structures are dimensional and contain the same number of elements. In the following example, the values in an Array are compared to the values in a Matrix that contains the same number of elements.

\( > \ [12, 88, 20] \sim (3, 100, 25) \)

\[
\begin{bmatrix} 3 < 12 \\ 100 < 88 \\ 25 < 20 \end{bmatrix}
\]

(8.10)

For more information, refer to the \texttt{elementwise} help page.
Levels of Evaluation

In a symbolic mathematics program such as Maple, you encounter the issue of *levels of evaluation*. If you assign \(y\) to \(x\), \(z\) to \(y\), and then 5 to \(z\), what is the value of \(x\)?

At the top-level, Maple *fully evaluates* names. That is, Maple checks if the name or symbol has an assigned value. If it has a value, Maple substitutes the value for the name. If this value has an assigned value, Maple performs a substitution, recursively, until no more substitutions are possible.

For example:

```maple
> x := y;
> y := z;
> z := 5;
```

Maple fully evaluates the name \(x\), and returns the value 5.

```maple
> x
5
```

**To control the level of evaluation of an expression:**

- Use the `eval` command with an integer second argument.

If passed a single argument, the `eval` command fully evaluates that expression. If you specify an integer second argument, Maple evaluates the expression to that level.

```maple
> eval(x)
5
> eval(x, 1)
y
> eval(x, 2)
z
> eval(x, 3)
5
```
For more details on levels of evaluation, refer to the \texttt{lastnameevaluation, assigned,} and \texttt{evaln} help pages.

**Delaying Evaluation**

To prevent Maple from immediately evaluating an expression:

- Enclose the expression in right single quotes (').

Because right single quotes delay evaluation, they are referred to as \textit{unevaluation quotes}.

\begin{verbatim}
> i := 4:
> i

4

> 'i'

i
\end{verbatim}

**Using an Assigned Name as a Variable or Keyword**

If you use an assigned name as a variable, Maple evaluates the name to its value, and passes the value to the command. In this example, that causes Maple to return an error message.

\begin{verbatim}
> \sum_{i=1}^{n} i^2

Error, (in sum) summation variable previously assigned, second argument evaluates to 4 = 1 .. n
\end{verbatim}

\textbf{Note:} In general, it is recommended that you unassign a name to use it as a variable. See \textit{Unassigning a Name Using Unevaluation Quotes} (page 362).

To use an assigned name as a variable:

- Enclose the name in unevaluation quotes. Maple passes the name to the command.

\begin{verbatim}
> \sum_{i'=1}^{n} i'^2

\frac{1}{3} (n + 1)^3 - \frac{1}{2} (n + 1)^2 + \frac{1}{6} n + \frac{1}{6}
\end{verbatim}

**Important:** It is recommended that you enclose keywords in unevaluation quotes.
For example, if you enclose the keyword `left` in unevaluation quotes, Maple uses the name, not its assigned value.

```maple
> left := 3;

> limit(1/x, x = 0, 'left')

-\infty
```

### Full Evaluation of an Expression in Quotes

Full evaluation of a quoted expression removes one set of right single quotes.

```maple
> i := 4;

> ' 'i' + 1'

'i' + 1  \quad (8.11)

> (8.11)

i + 1  \quad (8.12)

> (8.12)

5  \quad (8.13)
```

For information on equation labels and equation label references, see *Equation Labels* (page 95).

Enclosing an expression in unevaluation quotes delays evaluation, but does not prevent automatic simplification

```maple
> 'q - i + 3 q'

4 q - i  \quad (8.14)
```

### Unassigning a Name Using Unevaluation Quotes

To unassign a name:

- Assign the name enclosed in unevaluation quotes to itself.

```maple
> i := 'i';
```
> i

\[ i \]

You can also unassign a name using the **unassign** command. For more information, see *Unassigning Names* (page 94).
9 Basic Programming

You have used Maple interactively in the previous chapters, sequentially performing operations such as executing a single command. Because Maple has a complete programming language, you can also use sophisticated programming constructs.

In Maple, you can write programs called procedures, and save them in modules. These modules can be used and distributed in the same way as Maple packages.

**Important:** It is strongly recommended that you use the Worksheet mode and 1-D Math input when programming or using programming commands. Hence, all input in this chapter is entered as 1-D Math.

9.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Flow Control (page 366) - Basic programming constructs</em></td>
<td>• Conditional Execution (<strong>if</strong> Statement)</td>
</tr>
<tr>
<td></td>
<td>• Repetition (<strong>for</strong> Statement)</td>
</tr>
<tr>
<td><em>Iterative Commands (page 374) - Specialized, efficient iterative commands</em></td>
<td>• Creating a sequence</td>
</tr>
<tr>
<td></td>
<td>• Adding and Multiplying Expressions</td>
</tr>
<tr>
<td></td>
<td>• Selecting Expression Operands</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Command over a Set or List</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Binary Command over Two Lists or Vectors</td>
</tr>
<tr>
<td><em>Procedures (page 378) - Maple programs</em></td>
<td>• Defining and Running Simple Procedures</td>
</tr>
<tr>
<td></td>
<td>• Procedures with Inputs</td>
</tr>
<tr>
<td></td>
<td>• Procedure Return Values</td>
</tr>
<tr>
<td></td>
<td>• Displaying Procedure Definition</td>
</tr>
<tr>
<td></td>
<td>• Displaying Maple Library Procedure Definition</td>
</tr>
<tr>
<td></td>
<td>• Modules</td>
</tr>
<tr>
<td><em>Programming in Documents (page 382) - Display methods for Maple code</em></td>
<td>• Code Edit Region</td>
</tr>
<tr>
<td></td>
<td>• Startup Code</td>
</tr>
<tr>
<td></td>
<td>• Document Blocks</td>
</tr>
</tbody>
</table>
9.2 Flow Control

Two basic programming constructs in Maple are the if statement, which controls the conditional execution of statement sequences, and the for statement, which controls the repeated execution of a statement sequence.

Conditional Execution (if Statement)

You can specify that Maple perform an action only if a condition holds. You can also perform an action, from a set of many, depending on which conditions hold.

Using the if statement, you can execute one statement from a series of statements based on a boolean (true, false, or FAIL) condition. Maple tests each condition in order. When a condition is satisfied Maple executes the corresponding statement, and then exits the if statement.

Syntax

The if statement has the following syntax.

```maple
> if conditional_expression1 then
    statement_sequence1
elif conditional_expression2 then
    statement_sequence2
elif conditional_expression3 then
    statement_sequence3
    ...
else
    statement_sequenceN
end if;
```

The conditional expressions (conditional_expression1, conditional_expression2, ...) can be any boolean expression. You can construct boolean expressions using:

- Relational operators - <, <=, =, >=, >, <>
- Logical operators - and, or, xor, implies, not
- Logical names - true, false, FAIL

The statement sequences (statement_sequence1, statement_sequence2, ..., statement_sequenceN) can be any sequence of Maple statements, including if statements.

The elif clauses are optional. You can specify any number of elif clauses.

The else clause is optional.
Simple if Statements

The simplest if statement has only one conditional expression.

```maple
> if conditional_expression then
    statement_sequence
  end if;
```

If the conditional expression evaluates to true, the sequence of statements is executed. Otherwise, Maple immediately exits the if statement.

For example:

```maple
> x := 1173:
> if not isprime(x) then
    ifactor(x);
  end if;
```

```
(3)(17)(23)
```

else Clause

In a simple if statement with an else clause, if the evaluation of the conditional expressions returns false or FAIL, Maple executes the statement sequence in the else clause.

For example:

```maple
> if false then
    "if statement";
else
    "else statement";
end if;
```

"else statement"

elif Clauses

In an if statement with elif clauses, Maple evaluates the conditional expressions in order until one returns true. Maple executes the corresponding statement sequence, and then exits the if statement. If no evaluation returns true, Maple exits the if statement.

```maple
> x := 11:
> if not type(x, integer) then
    printf("%a is not an integer.", x);
  elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
  elif x >= 0 then
```

```maple
9.2 Flow Control • 367
```
printf("%a is an integer with one digit.", x);
end if;

11 is an integer with more than one digit.

**Order of elif Clauses:** An *elif* clause's statement sequence is executed only if the evaluation of all previous conditional expressions returns *false* or *FAIL*, and the evaluation of its conditional expression returns *true*. This means that changing the order of *elif* clauses may change the behavior of the *if* statement.

In the following *if* statement, the *elif* clauses are in the **wrong order**.

```plaintext
> if not(type(x, integer)) then
   printf("%a is not an integer.", x);
   elif x >= 0 then
      printf("%a is an integer with one digit.", x);
      elif x >= 10 then
         printf("%a is an integer with more than one digit.", x);
      end if;
end if;

11 is an integer with one digit.
```

**elif and else Clauses**

In an *if* statement with *elif* and *else* clauses, Maple evaluates the conditional expressions in order until one returns *true*. Maple executes the corresponding statement sequence, and then exits the *if* statement. If no evaluation returns *true*, Maple executes the statement sequence in the *else* clause.

```plaintext
> x := -12:
> if not type(x, integer) then
   printf("%a is not an integer.", x);
   elif x >= 10 then
      printf("%a is an integer with more than one digit.", x);
      elif x >= 0 then
         printf("%a is an integer with one digit.", x);
      else
         printf("%a is a negative integer.", x);
      end if;
end if;

-12 is a negative integer.
```

For more information on the *if* statement, refer to the *if* help page.
Repetition (for Statement)

Using repetition statements, you can repeatedly execute a statement sequence. You can repeat the statements in three ways.

- Until a counter variable value exceeds a limit (for/from loop)
- For each operand of an expression (for/in loop)
- Until a boolean condition does not hold (while loop)

for/from Loop

The for/from loop statement repeats a statement sequence until a counter variable value exceeds a limit.

Syntax

The for/from loop has the following syntax.

```plaintext
> for counter from initial by increment to final do
    statement_sequence
  end do;
```

The behavior of the for/from loop is:

1. Assign the initial value to the name counter.
2. Compare the value of counter to the value of final. If the counter value exceeds the final value, exit the loop. (This is the loop bound test.)
3. Execute the statement_sequence.
4. Increment the counter value by the value of increment.
5. Repeat steps 2 to 4, until Maple exits the loop.

The from, by, and to clauses are optional and can be in any order between the for clause and the do keyword. Table 9.1 lists the default clause values.

Table 9.1: Default Clause Values

<table>
<thead>
<tr>
<th>Clause</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>from initial</td>
<td>1</td>
</tr>
<tr>
<td>by increment</td>
<td>1</td>
</tr>
<tr>
<td>to final</td>
<td>infinit (∞)</td>
</tr>
</tbody>
</table>

Examples

The following loop returns the square root of the integers 1 to 5 (inclusive).
for n to 5 do
    evalf(sqrt(n));
end do;

1.
1.414213562
1.732050808

2.
2.236067977

When the value of the counter variable n is strictly greater than 5, Maple exits the loop.

> n;

6

The previous loop is equivalent to the following for/from statement.

for n from 1 by 1 to 5 do
    evalf(sqrt(n));
end do;

1.
1.414213562
1.732050808

2.
2.236067977

The by value can be negative. The loop repeats until the value of the counter variable is strictly less than the final value.

> for n from 10 by -1 to 3 do
    if isprime(n) then
        print(n);
    end if;
end do;
for/in Loop

The for/in loop statement repeats a statement sequence for each component (operand) of an expression, for example, the elements of a list.

Syntax

The for/in loop has the following syntax.

```plaintext
> for variable in expression do
    statement_sequence
  end do;
```

The for clause must appear first.

The behavior of the for/in loop is:
1. Assign the first operand of expression to the name variable.
2. Execute the statement_sequence.
3. Assign the next operand of expression to variable.
4. Repeat steps 2 and 3 for each operand in expression. If there are no more operands, exit the loop. (This is the loop bound test.)

Example

The following loop returns a floating-point approximation to the sin function at the angles (measured in degree) in the list L.

```plaintext>
> L := [23.4, 87.2, 43.0, 99.7];
```
> for i in L do
  evalf(sin(i*Pi/180));
end do;

0.3971478907
0.9988061374
0.6819983602
0.9857034690

**while Loop**

The **while loop** repeats a statement sequence until a boolean expression does not hold.

**Syntax**

The **while** loop has the following syntax.

```plaintext
> while conditional_expression do
  statement_sequence
end do;
```

A **while** loops repeats until its **boolean expression** `conditional_expression` evaluates to `false` or `FAIL`. For more information on boolean expressions, see *Conditional Execution (if Statement)* (page 366).

**Example**

The following loop computes the digits of 872,349 in base 7 (in order of *increasing* significance)

```plaintext
> x := 872349:
> while x > 0 do
  irem(x, 7);
  x := iquo(x, 7);
end do;
```
To perform such conversions efficiently, use the `convert/base` command.

```plaintext
> convert(872349, base, 7):

[2, 0, 2, 2, 6, 2, 0, 1]
```

For information on non-base 10 numbers, see *Non-Base 10 Numbers* (page 108).

**General Loop Statements**

You can include a `while` statement in a `for/from` or `for/in` loop.

The general `for/from` loop has the following syntax.
The general for loop has the following syntax.

```markdown
> for counter from initial by increment to final
  while conditional_expression do
    statement_sequence
  end do;
```

The general for/in loop has the following syntax.

```markdown
> for variable in expression
  while conditional_expression do
    statement_sequence
  end do;
```

After testing the loop bound condition at the beginning of each iteration of the for loop, Maple evaluates conditional_expression.

- If conditional_expression evaluates to false or FAIL, Maple exits the loop.
- If conditional_expression evaluates to true, Maple executes statement_sequence.

**Infinite Loops**

You can construct a loop for which there is no exit condition, for example, a while loop in which the conditional_expression always evaluates to true. This is called an infinite loop. Maple indefinitely executes an infinite loop unless it executes a break, quit, or return statement or you interrupt the computation using the interrupt icon. For more information, refer to the break, quit, return, and interrupt help pages.

**Additional Information**

For more information on the for statement and looping, refer to the do help page.

### 9.3 Iterative Commands

Maple has commands that perform common selection and repetition operations. These commands are more efficient than similar algorithms implemented using library commands. Table 9.2 lists the iterative commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>seq</td>
<td>Create sequence</td>
</tr>
<tr>
<td>add</td>
<td>Compute numeric sum</td>
</tr>
<tr>
<td>mul</td>
<td>Compute numeric product</td>
</tr>
<tr>
<td>select</td>
<td>Return operands that satisfy a condition</td>
</tr>
<tr>
<td>remove</td>
<td>Return operands that do not satisfy a condition</td>
</tr>
</tbody>
</table>
Command | Description
---|---
selectremove | Return operands that satisfy a condition and separately return operands that do not satisfy a condition
map | Apply command to the operands of an expression
zip | Apply binary command to the operands of two lists or vectors

### Creating a Sequence

The `seq` command creates a sequence of values by evaluating a specific expression over a range of index values or the operands of an expression. See Table 9.3.

Table 9.3: The seq Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| `seq(expression, name = initial .. fina);` | \( > \text{seq}(\exp(x), \ x = -2..0); \)  
\( \exp^{-2}, \exp^{-1}, 1 \)  
\( > \text{seq}(u, \ u \in [\pi/4, \ \pi^2/2, \ \pi/\pi]); \)  
\( \frac{1}{4} \pi, \ \frac{1}{2} \pi^2, \ \frac{1}{\pi} \) |

### Adding and Multiplying Expressions

The `add` and `mul` commands add and multiply sequences of expressions over a range of index values or the operands of an expression. See Table 9.4.

Table 9.4: The add and mul Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| `add(expression, name = initial .. fina);` | \( > \text{add}(\exp(x), \ x = 2..4); \)  
\( \exp^2 + \exp^3 + \exp^4 \)  
\( > \text{mul}(2*x, \ x = 1..10); \)  
\( 3715891200 \) |

--- | ---
Examples

Calling Sequence Syntax  Examples

| add(expression, name in expression); | > add(u, u in [Pi/4, Pi/2, Pi]); |
| mul(expression, name in expression); | > mul(u, u in [Pi/4, Pi/2, Pi]); |
|                                        | \( \frac{7}{4} \pi \)          |
|                                        | \( \frac{1}{8} \pi^3 \)        |

The endpoints of the index range (initial and final) in the add and mul calling sequence must evaluate to numeric constants. For information on symbolic sums and products, refer to the sum and product help pages.

Selecting Expression Operands

The select, remove, and selectremove commands apply a boolean-valued procedure or command to the operands of an expression. For information on operands, refer to the op help page.

- The select command returns the operands for which the procedure or command returns true.
- The remove command returns the operands for which the procedure or command returns false or FAIL.
- The selectremove command returns two expressions of the same type as the input expression.
  - The first consists of the operands for which the procedure or command returns true.
  - The second consists of the operands for which the procedure or command returns false or FAIL.

The structure of the output is the same as the structure of the input. See Table 9.5.

For information on Maple procedures, see Procedures (page 378).

Table 9.5: The select, remove, and selectremove Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>select(proc_cmd, expression);</td>
<td>&gt; select(issqr, {198331, 889249, 11751184, 9857934});</td>
</tr>
<tr>
<td></td>
<td>{889249, 11751184}</td>
</tr>
</tbody>
</table>
**Examples**

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>remove(proc_cmd, expression);</code></td>
<td><code>&gt; remove(var -&gt; degree(var) &gt; 3, 2*x^3*y - y^3*x + z );</code></td>
</tr>
<tr>
<td><code>selectremove(proc_cmd, expression);</code></td>
<td><code>&gt; selectremove(x -&gt; evalb(x &gt; round(x)), [sin(0.), sin(1.), sin(3.)]);</code></td>
</tr>
</tbody>
</table>

For information on optional arguments to the selection commands, refer to the `select` help page.

### Mapping a Command over a Set or List

The `map` command applies a name, procedure, or command to each element in a set or list. See Table 9.6.

**Table 9.6: The `map` Command**

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>map(name_proc_cmd, expression);</code></td>
<td><code>&gt; map(f, {a, b, c});</code></td>
</tr>
<tr>
<td></td>
<td><code> {f(a),f(b),f(c)}</code></td>
</tr>
<tr>
<td></td>
<td><code>&gt; map(u -&gt; int(cos(x), x = 0 .. u), [Pi/4, Pi/7, Pi/3.0]);</code></td>
</tr>
<tr>
<td></td>
<td><code> [ \frac{1}{2} \sqrt{2}, \cos\left(\frac{5}{14} \pi\right), 0.8660254038 ]</code></td>
</tr>
</tbody>
</table>

For information on mapping over the operands of other expressions, optional arguments to the `map` command, and other mapping commands, refer to the `map` help page.

### Mapping a Binary Command over Two Lists or Vectors

The `zip` command applies a name or binary procedure or command component-wise to two lists or vectors.

By default, the length of the returned object is that of the shorter list or vector. If you specify a value as the (optional) fourth argument, it is used as the value of the missing elements of the shorter list or vector. In this case, the length of the return value is that of the longer list or vector. See Table 9.7.
Table 9.7: The zip Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>zip(proc_cmd, a, b);</code></td>
<td><code>&gt; zip(f, [i, j], [k, l]);</code></td>
</tr>
<tr>
<td><code>zip(proc_cmd, a, b, fil);</code></td>
<td><code>&gt; zip(AiryAi, [1, 2], [0], 1);</code></td>
</tr>
</tbody>
</table>

For more information on the `zip` command, refer to the `zip` help page.

**Additional Information**

For more information on looping commands, refer to the corresponding command help page.

**9.4 Procedures**

A Maple procedure is a program consisting of Maple statements. Using procedures, you can quickly execute the contained sequence of statements.

**Defining and Running Simple Procedures**

To define a procedure, enclose a sequence of statements between `proc(...)` and `end proc` statements. In general, you assign a procedure definition to a name.

The following procedure returns the square root of 2.

```maple
> p := proc() sqrt(2); end proc;
```

```maple
  p := proc() sqrt(2) end proc
```

**Note:** Maple returns the procedure definition

To improve readability of procedures, it is recommended that you define a procedure using multiple lines, and indent the lines using space characters. To begin a new line (without evaluating the incomplete procedure definition) press **Shift+Enter**. When you have finished entering the procedure, press **Enter** to create the procedure.
For example:

```maple
> p := proc()
>     sqrt(2);
> end proc:
```

To run the procedure `p`, enter its name followed by parentheses `( )`.

```maple
> p();
```

\[ \sqrt{2} \]

**Procedures with Inputs**

You can define a procedure that accepts user input. In the parentheses of the `proc` statement, specify the parameter names. For multiple parameters, separate the names with commas.

```maple
> geometric_mean := proc(x, y)
>     sqrt(x*y);
> end proc:
```

When the user runs the procedure, the parameter names are replaced by the argument values.

```maple
> geometric_mean(13, 17);
```

\[ \sqrt{221} \]

```maple
> geometric_mean(13.5, 17.1);
```

\[ 15.19374871 \]

For more information on writing procedures, including options and local and global variables, refer to the `procedure` help page.

**Procedure Return Values**

When you run a procedure, Maple returns only the last statement result value computed. Maple does not return the output for each statement in the procedure. It is irrelevant whether you use semicolons or colons as statement separators.

```maple
> p := proc(a, b)
>     a + b;
>     a - b;
> end proc:
> p(1, 2);
```

\[ -1 \]
Displaying Procedure Definitions

Unlike simple Maple objects, you cannot display the value of a procedure by entering its name.

```maple
> geometric_mean;

geometric_mean
```

You must evaluate the name of the procedure using the `print` (or `eval`) command.

```maple
> print(geometric_mean);

proc(x, y) sqrt(x*y) end proc
```

Displaying Maple Library Procedure Definitions

Maple procedure definition are a valuable learning tool. To learn how to program in Maple, it is recommended that you examine the procedures available in the Maple library.

By default, the `print` command returns only the `proc` and `end proc` statements and (if present) the description field of a Maple procedure.

```maple
> print(lcm);

proc(a, b) ... end proc
```

To display a Maple library procedure definition first set the value of the `interface verboseproc` option to 2. Then re-execute the `print` calling sequence.

```maple
> interface('verboseproc' = 2):
```
> print(lcm);

proc(a, b)
    option remember,
    Copyright (c) 1990 by the University of Waterloo. All rights reserved;
    local q, t;
    if nargs = 0 then
        1
    elif nargs = 1 then
        t := expand(a); sign(t) * t
    elif 2 < nargs then
        foldl(procname, args)
    elif type(a, 'integer') and type(b, 'integer') then
        ilcm(a, b)
    else
        gcd(a, b, 'q'); q * b
    end if
end proc

Modules

Maple procedures associate a sequence of commands with a single command. The module, a more complex programming structure, allows you to associate related procedures and data.

A key feature of modules is that they export variables. This means that the variables are available outside the module in which they are created. Most Maple packages are implemented as modules. The package commands are exports of the module.

For more information on modules, refer to the module help page.

Objects

Objects take the idea of associating data and procedures beyond what modules provide. With objects, multiple instances of a class of objects can be created. Each individual object can have its own data, yet share other values and procedures with the entire class objects. A well implemented class of objects can be used in Maple as naturally as a built-in Maple type.

For more information on objects, refer to the object help page.
9.5 Programming in Documents

To write Maple code, you could simply open a Maple worksheet and start typing. However, if you want to create a readable document with the code interspersed or hidden, there are several options available.

**Code Edit Region**

The code edit region allows you to program in one contained region, in a natural way. Features include the ability to press Enter for line breaking and indentation preservation. Figure 9.1 shows the expanded code edit region.

To insert a new code edit region into your worksheet:

• From the Insert menu, select Code Edit Region.

![Figure 9.1: Code Edit Region](image)

To execute the code within this region, right-click in the region and select Execute Code.

You can hide the code in a code edit region by minimizing the region. To minimize, right-click in the region and select Collapse Code Edit Region. When the region is minimized, an icon appears with the first line of the code written next to it. It is recommended that you make the first line a comment describing the program or programs contained in the region. See Figure 9.2.

```plaintext
# My program
```

![Figure 9.2: Collapsed Code Edit Region](image)

To re-execute the code in the region while it is collapsed, click this icon.

For more information, refer to the CodeEditRegion help page.
Startup Code

Startup code allows you to define commands and procedures that are executed each time the document is opened and after restart is called. This code is completely hidden to others reading the document. For example, use this region to define procedures that will be used throughout the document code but that would take up space and distract readers from the message of the document.

**To enter startup code for a document:**

1. From the **Edit** menu, select **Startup Code**. Alternatively, click the startup code icon in the toolbar, ![Startup Code Icon](Image).
2. Enter commands to be run each time the worksheet is opened or restart is called.
3. Click **Syntax** to check the syntax of the entered code before closing.
4. Click **Save** to save the contents and close the dialog.

![Startup Code Editor](Image)

**Figure 9.3: Startup Code Editor**

For more information, refer to the **startupcode** help page.
10 Embedded Components and Maplets

These graphical components help you to create documents to use and share with colleagues or students, that interact with Maple code within the document without needing the reader to understand that Maple code. Other methods of interaction with Maple are described throughout this guide.

10.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Using Embedded Components (page 385) - Basic interacting with Maple documents containing embedded components | • Interacting with Components  
• Printing and Exporting |
| Creating Embedded Components (page 388) - Methods for creating embedded components that work together and with your document | • Inserting Components  
• Editing Components  
• Removing Components  
• Integrating into a Document |
| Using Maplets (page 396) - Methods for launching a Maplet | • Maplet File  
• Maple Document |
| Authoring Maplets (page 397) - Methods for authoring and saving a Maplet | • Maplet Builder  
• Maplets Package  
• Saving |

10.2 Using Embedded Components

Interacting

Embedded components allow readers to interact with Maple code through graphical components, rather than commands. They can be used alone, as with a button that you click to execute code, or together, such as a drop-down menu where you select an item, and a change takes place in a plot component.

Component Descriptions

Table 10.1: Embedded Component Descriptions

<table>
<thead>
<tr>
<th>Component Name and Description</th>
<th>Inserted Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button - Click to perform an action; that is, execute code.</td>
<td><img src="Button" alt="Button" /></td>
</tr>
<tr>
<td>CheckBox - Select or de-select. Change the caption, and enter code to execute when the value changes.</td>
<td><img src="CheckBox" alt="CheckBox" /></td>
</tr>
<tr>
<td>Component Name and Description</td>
<td>Inserted Image</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td><strong>ComboBox</strong> - Select one of the listed options from the drop-down menu. Change the items listed, and enter code to execute when the value changes.</td>
<td><img src="image" alt="ComboBox" /></td>
</tr>
<tr>
<td><strong>DataTable</strong> - Link this embedded component to a Matrix, Vector, or Array in your worksheet.</td>
<td><img src="image" alt="DataTable" /></td>
</tr>
<tr>
<td><strong>Dial</strong> - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td><img src="image" alt="Dial" /></td>
</tr>
<tr>
<td><strong>Label</strong> - Display a label. The value can be updated based on code in the document or another embedded component.</td>
<td><img src="image" alt="Label" /></td>
</tr>
<tr>
<td><strong>ListBox</strong> - Display a list of items. Change the items listed, and enter code to execute when an item is selected.</td>
<td><img src="image" alt="ListBox" /></td>
</tr>
<tr>
<td><strong>Math Expression</strong> - Enter or display a mathematical expression. The value can be updated based on code in the document or another embedded component.</td>
<td><img src="image" alt="Math Expression" /></td>
</tr>
<tr>
<td><strong>Meter</strong> - Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes.</td>
<td><img src="image" alt="Meter" /></td>
</tr>
<tr>
<td><strong>Plot</strong> - Display a 2-D or 3-D plot or animation. This plot or animation can be interacted with in the same way as other plots (see <em>Plots and Animations</em> (page 237)). The value can be updated based on code in the document or another embedded component. You can also enter code to be executed when the <code>execute code</code> pointer is used to click or drag in the plot region.</td>
<td><img src="image" alt="Plot" /></td>
</tr>
<tr>
<td><strong>RadioButton</strong> - Use with other radio buttons to select one in a group. Enter code to execute when the value changes.</td>
<td><img src="image" alt="RadioButton" /></td>
</tr>
</tbody>
</table>
### Component Name and Description

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Inserted Image</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rotary Gauge</strong></td>
<td><img src="image" alt="Rotary Gauge" /></td>
</tr>
<tr>
<td>Select or display an integer or floating point value. Change the display, and enter code to execute when the value changes.</td>
<td></td>
</tr>
</tbody>
</table>

| **Slider**           | ![Slider](image) |
| Select or display an integer or floating-point value. Change the display, and enter code to execute when the value changes. |

| **TextArea**         | ![TextArea](image) |
| Enter or display plain text. The value can be updated based on code in the document or another embedded component, and you can enter code to execute when the value changes. |

| **ToggleButton**     | ![ToggleButton](image) |
| Select or display one of two options. Change the images displayed, and enter code to execute when the value changes. |

| **Volume Gauge**     | ![Volume Gauge](image) |
| Select or display an integer or floating point value. Change the display, and enter code to execute when the value changes. |

### Example 1 - Using Embedded Components

This example demonstrates several components working together to perform a task. The user inputs an expression, which is plotted when the button is clicked. Plot options are controlled by text areas, a combo box, a math expression, and radio buttons.

For an interactive version of this example, see the .mw version of this manual. In Maple, from the Help menu, select Manuals, Resources, and More... → Manuals → User Manual.
Printing and Exporting a Document with Embedded Components

**Printing:** When printing a document, embedded components are rendered as they appear on screen.

**Exporting:** Exporting a document with embedded components to other formats produces the following results.

- HTML format - components are exported as `.gif` files
- RTF format - components are rendered as bitmap images in the `.rtf` document.
- LaTeX - components are exported as `.eps` files
- PDF - components are rendered as static images.

### 10.3 Creating Embedded Components

Embedded Components are graphical components that you can add to your document. They provide interactive access to Maple code without requiring the user to know Maple commands, and include buttons, sliders, math and text input areas, and plot display.
Inserting Components

The graphical interface components can be inserted by using the Components palette (Figure 10.1) or by cutting/copying and pasting existing components to another area of the document. Although copied components have most of the same characteristics, they are distinct.

If the Components palette is not visible, see Palettes (page 21) for instructions on viewing palettes.

![Components Palette]

Figure 10.1: Components Palette

Editing Component Properties: General Process

To edit properties of components embedded in the document:

1. Right-click (Control-click, for Macintosh) the component to display the context menu.
2. If available, select Component Properties...; otherwise, select Components → Component Properties... The related dialog opens.
3. Enter values and contents in the field as necessary.
4. For actions, such as Action When Value Changes in the Slider component dialog, click Edit. A blank dialog opens allowing you to enter Maple code that is executed when the event occurs. For details, refer to the DocumentTools help page.
Removing Graphical Interface Components

You can remove an embedded component by:

- Using the **Delete** key
- Using the **Backspace** key
- Placing the cursor at the component and selecting from the document menu, **Edit→Delete Element**

Integrating Components into a Document

Use embedded components to display information from calculations, obtain input from a reader, or perform calculations at the click of a button, all without your readers having an understanding of Maple commands. They can be entered in any part of a Maple document, including a document block or table. For details on each component, see its help page.

This simple example inserts a slider with a label that indicates the current value of the slider.

1. Place the cursor in the location where the embedded component is to be inserted.
2. In the **Components** palette, click the **Slider** item. A slider is inserted into the document.
3. In the **Components** palette, click the **Label** item. A label is inserted next to the slider.
4. Right-click (**Control-click**, for Macintosh) the label component. Select **Component Properties**. The **Label Properties** dialog opens. See **Figure 10.2**.
5. Name the component **SliderLabel** and click **Ok**.
6. Right-click (**Control**-click, Macintosh) the slider component. Select **Component Properties**. The **Slider Properties** dialog opens. See **Figure 10.3**.
7. Name the component **Slider1**.
8. Enter the value at the lowest position as **0** and the highest as **100**.
9. Enter major tick marks at **20** and minor tick marks at **10**.
10. To define an action, click the **Edit** button for the **Action When Value Changes**. The dialog that opens allows you to program the action of displaying the slider value in the label component. The dialog includes instructions on how to program embedded components. The **use...in/end use**; statement allows you to specify routines using the short form of accessing a package command without invoking the package. For details on this command, refer to the **use help page**.
11. Before the **end use**; statement at the bottom of the dialog, enter the following command.

   `Do(%SliderLabel(caption)=%Slider1(value));`

12. Click **OK**.
13. Make sure that the **Update Continuously while Dragging** check box is selected.
The value from the slider as you move the arrow indicator populates the Label caption field. For details on this command, refer to the DocumentTools[Do] help page.

**Example 2 - Creating Embedded Components**

In chapter 7 (see *Embedded Components* (page 326)), you created a document that included embedded components, imported from a task template. Here, we re-create that configuration of components. This example takes two parameters, \(a\) and \(b\), as inputs, then plots the function \(y = bx + a\) and calculates \(\frac{a}{b}\).

1. **Create the components.**

The table layout is best done after the components are finished in case the configuration of the components changes as you are working.

Create two DialComponents to set the parameters, \(a\) and \(b\), one GaugeComponent to display the result, \(\frac{a}{b}\), one PlotComponent to display the plot, and one MathContainer-Component to display the function. Note that you do not need to use the dial and gauge components here, there are others, such as the slider, that could also be used.
2. **Edit the display of the components.**

Open the **Component Properties** dialog for the first **DialComponent**, and notice that it already has a name. This name is used to reference the component from other components, and is unique. Change the display of each of the components as follows:

- **Dial0**: no changes.
- **Dial1**: change the **Value at Highest Position** to 10, the **Spacing of Major Tick Marks** to 1, and the **Spacing of Minor Tick Marks** to 1.
- **RotaryGauge0**: change the **Value at Highest Position** to 40, the **Spacing of Major Tick Marks** to 5, and the **Spacing of Minor Tick Marks** to 1.
- **Plot0**: no changes.
• MathContainer0: change the Width in Pixels to 200, and the Height in Pixels to 45.

Note the names of all of the components, and close each dialog before moving on.

3. **Create actions for the components.**

Components can perform actions when their values are changed, so the code to execute needs to be in the dials. That way, whenever one of them is changed, the other components are updated to reflect that change.

The following Maple commands retrieve the values of the parameters and display them in the other three components:

```maple
> parameter1 := Do(%Dial0):
> parameter2 := Do(%Dial1):
> Do(%RotaryGauge0 = parameter1 / parameter2);
> Do(%Plot0 = plot((parameter2 * x + parameter1), x = -50..50, y = -50..50));
> Do(%MathContainer0 = (y = parameter2 * x + parameter1));
```

4. **Test the actions.**

To test these commands, first load the DocumentTools package with the following command.

```maple
> with(DocumentTools):
```

Execute the commands in the document, and verify that the components you inserted are updated: the gauge should change to the computed value, a plot should appear in the plot component, and the function should display in the math container.

5. **Troubleshooting.**

The first Do command gives an error, because the second parameter is 0. One way to avoid this problem is to change the range of the second dial. In the Component Properties dialog for the second DialComponent, change the Value at Lowest Position from 0 to 1. Alternatively, you could change the code to compensate, with an if statement.

6. **Copy the actions to the components.**

Once the commands work as expected, you can copy them into the components.

• Open the Component Properties dialog for the first DialComponent and click the Edit button for Action When Value Changes. Copy and paste the commands into the space between the use statements.
7. Create the layout for the components.

Create a table, and then cut and paste the components into it, along with explanatory text. **Important:** you must cut, not copy, the components, or their names will be changed to avoid duplication. For information on creating and modifying tables, refer to *Tables (page 304).*
10.4 Using Maplets

A Maplet is a pop-up graphical user interface that provides interactive access to the Maple engine through buttons, text regions, slider bars, and other visual interfaces. You can create your own Maplets, and you can take advantage of the built-in Maplets that cover numerous academic and specialized topics. Built-in Maplets include some assistants and tutors, such as the ODE Analyzer. For more information on this assistant, see *Ordinary Differential Equations (ODEs)* (page 120).

Maplet applications are launched by executing Maplet code. Maplet code can be saved in a Maplet (.maplet) file or Maple document (.mw).

**Maplet File**

*To launch a Maplet application saved as a Maplet file*

- In Windows, double-click the file from a Windows file browser.
• In UNIX and on Macintosh, use the command-line interface. At the command-line, enter `maple -q <maplet_filenam >`.

To view and edit the Maplet code contained within the .maplet file

1. Start Maple.
2. From the File menu, select Open. Maple displays the Open dialog.
3. In the Files of Type drop-down list, select .maplet.
4. Navigate to the location of the .maplet file and select the file
5. Click Open.

Maple Document

To launch a Maplet application for which the Maple code is contained in a Maple document, you need to execute the Maplet code. To display the Maplet application, you must use the `Maplets[Display]` command. Note: The Maplet code may be quite large if the Maplet application is complex. In this case, execute the document to ensure user-define procedures that are referenced in the Maplet application are also defined

Typical procedure:

1. If present, evaluate user-define procedures.

    `Myproc:=proc..`


    `with( Maplets[Elements] );`

3. Evaluate the Maplet definition

    `Maplet_name:=Maplet( Maplet_definition );`

4. Display the Maplet application.

    `Maplets[Display]( Maplet_name );`

Important: When a Maplet application is running, you cannot interact with the Maple document.

10.5 Authoring Maplets

To author Maplets, you can use the Maplet Builder (GUI-based) or the `Maplets` package (syntax-based). The Maplet Builder allows you to drag and drop buttons, sliders, text regions, and other elements to define the Maplet application and set the element properties to perform an action upon selection or update of the element. The Maplet Builder is designed
to create simple Maplets. The Maplets package offers more capabilities, control, and options when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When building a house, you first construct the skeletal structure (that is, foundation, floors and walls) and then proceed to add the windows and doors. Constructing a Maplet is no different. First define the rows and columns of the Maplet application and then proceed to add the body elements (such as buttons, text fields and plot regions).

**Simple Maplet**

A Maplet application can be defined using the commands in the Maplets[Elements] package and then launched using the Maplets[Display] command. The following commands define and run a very simple Maplet application that contains the text string "Hello World".

```maple
> with(Maplets[Elements]):
> MySimpleMaplet:= Maplet(["Hello World"])::
> Maplets[Display](MySimpleMaplet):
```

![Figure 10.6: A Simple Maplet](image)

**Maplet Builder**

To start the Maplet Builder:

- From the Tools menu, select Assistants → Maplet Builder.
Figure 10.7: Maplet Builder Interface

The Maplet Builder is divided into four different panes.

- The Palette pane displays palettes, which contain Maplet elements, organized by category. For a description of the elements, see the MapletBuilder/Palette help page. The Body palette contains the most popular elements.
- The Layout pane displays the visual elements of the Maplet.
- The Command pane displays the commands and corresponding actions define in the Maplet.
- The Properties pane displays the properties of an instance of a define element in the Maplet.

Example 3 - Design a Maplet Using the Maplet Builder

In this example, shown in Figure 10.8, the Maplet user enters a function and plots the result.
Defining the number of rows in the Maplet:

1. In the Properties pane:
   a. In the drop-down list, select BoxColumn1.
   b. Change the numrows field to 2.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in MapletBuilder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define the number of rows in the Maplet:</td>
<td></td>
</tr>
<tr>
<td>1. In the Properties pane:</td>
<td></td>
</tr>
<tr>
<td>a. In the drop-down list, select BoxColumn1.</td>
<td></td>
</tr>
<tr>
<td>b. Change the numrows field to 2.</td>
<td></td>
</tr>
</tbody>
</table>
### Add a plot region to row 1:

2. From the **Body** palette, drag the **Plotter** element to the first row in the **Layout** pane.

### Add columns to row 2:

3. In the **Properties** pane:
   - a. In the drop-down list, select **BoxRow2**.
   - b. Change the **numcolumns** field to 3.

### Add a label to row 2:

4. From the **Body** palette, drag the **Label** element to the left column in the **Layout** pane.

5. In the **Properties** pane:
   - a. In the drop-down list, select **Label1**.
   - b. Change the caption field to **Enter a function of x.**
### Action

<table>
<thead>
<tr>
<th>Add a text region to row 2:</th>
</tr>
</thead>
<tbody>
<tr>
<td>6. From the <strong>Body</strong> palette, drag the <strong>TextField</strong> element to the middle column. The <strong>TextField</strong> element allows the Maplet user to enter input that can be retrieved in an action.</td>
</tr>
<tr>
<td>7. If necessary, resize the Maplet Builder to display the entire <strong>Layout</strong> pane.</td>
</tr>
</tbody>
</table>

### Result in MapletBuilder

<table>
<thead>
<tr>
<th>Add a button to row 2:</th>
</tr>
</thead>
<tbody>
<tr>
<td>8. From the <strong>Body</strong> palette, drag the <strong>Button</strong> element to the right column in the <strong>Layout</strong> pane.</td>
</tr>
<tr>
<td>9. In the <strong>Properties</strong> pane:</td>
</tr>
<tr>
<td>a. In the drop-down list, select <strong>Button1</strong>.</td>
</tr>
<tr>
<td>b. Change the <strong>caption</strong> field to <strong>Plot</strong>.</td>
</tr>
<tr>
<td>c. In the <strong>onclick</strong> property drop-down list, select <code>&lt;Evaluate&gt;</code>.</td>
</tr>
<tr>
<td>Action</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>In the Evaluate Expression dialog that displays, the Target drop-down list contains the define elements to which you can send information, in this case, <strong>Plotter1</strong> and <strong>TextField1</strong>. The List group box, located below the Expression group box, displays the define elements to which you can retrieve information, in this case, <strong>TextField1</strong>.</td>
</tr>
<tr>
<td>a. In the Target drop-down list, select <strong>Plotter1</strong>.</td>
</tr>
<tr>
<td>b. In the Command Form tab, enter <code>plot(TextField1, x=-10..10)</code> in the Expression group box. <em>(Note: Do not include a semicolon (;) at the end of the plot command.)</em> You can also double-click <strong>TextField1</strong> in the List group box to insert this element in the command syntax.</td>
</tr>
<tr>
<td>c. Click <strong>Ok</strong>.</td>
</tr>
</tbody>
</table>

### Run the Maplet:

11. From the File menu, select **Run**. You are prompted to save the Maplet. Maplets created with the **Maplet Builder** are saved as `.maplet` files.

12. Click **Yes** and navigate to a location to save this Maplet.

For further information on the **Maplet Builder**, see the **MapletBuilder** help page. For more examples of designing Maplets using the **Maplet Builder**, see `examples/MapletBuilder`.

### Maplets Package

When designing a complicated Maplet, the **Maplets** package offers greater control. The **Maplets[Elements]** subpackage contains the elements available when designing a Maplet application. After you define the Maplet, use the **Maplets[Display]** command to launch the Maplet.

For more information on the **Maplets** package, refer to the **MapletsPackage** help page. For more examples of designing Maplets using the **Maplets** package, see the **Maplets/Roadmap** help page.
Example 4 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package, this example illustrates the equivalent syntax for the Example 3 - Design a Maplet Using the Maplet Builder (page 399).

Load the Maplets[Elements] package.

> with(Maplets[Elements]);

Define the Maplet application. To suppress the display of the data structure associated with the Maplet application, end the definition with a colon.

> PlottingMaplet := Maplet(
    BoxLayout(
        BoxColumn(
            # First Box Row
            BoxRow(
                # Define a Plot region
                Plotter('reference' = Plotter1)
            ),
            # Second Box Row
            BoxRow(
                # Define a Label
                Label("Enter a function of x "),
                # Define a Text Field
                TextField('reference' = TextField1),
                # Define a Button
                Button(caption="Plot", Evaluate(value = 'plot(TextField1, x = -10..10)', 'target' = Plotter1))
            ),
            # End of BoxColumn
        ),
        # End of BoxLayout
    ),
    # End of Maplet
):

Launch the Maplet.

> Maplets[Display](PlottingMaplet);
For further examples using both the MapletBuilder and Maplets package commands, see the Maplets example worksheets. For a listing, refer to the examples/index help page.

**Saving**

When saving a Maplet, you can save the document as an `.mw` file or you can export the document as a `.maplet` file

**Maple Document**

To save the Maplet code as an `.mw` file

1. From the File menu, select Save.
2. Navigate to the save location.
3. Enter a filename
4. Click Save.

If the document contains only Maplet code, it is recommended that you export the document as a `.maplet` file

**Maplet File**

To export the Maplet code as a `.maplet` file

1. From the File menu, select Export As.
2. In the Files of Type drop-down list, select Maplet.
3. Navigate to the export location.
4. Enter the filename
5. Click Save.
11 Input, Output, and Interacting with Other Products

11.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Writing to Files (page 407) - Saving to Maple file formats | • Saving Data to a File  
• Saving Expressions to a File |
| Reading from Files (page 409) - Opening Maple file | • Reading Data from a File  
• Reading Expressions from a File |
| Exporting to Other Formats (page 412) - Exporting documents in file formats supported by other software | • Exporting Documents  
• MapleNet  
• Maple T.A. |
| Connectivity (page 416) - Using Maple with other programming languages and software | • Translating Maple Code to Other Programming Languages  
• Accessing External Products from Maple  
• Accessing Maple from External Products  
• Sharing and Storing Maple Worksheet Content with the MapleCloud™ |

11.2 Writing to Files

Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a file for later processing with Maple or another program.

**Saving Data to a File**

If the result of a Maple calculation is a long list or a large array of numbers, you can convert it to Matrix form and write the numbers to a file using the `ExportMatrix` command. This command writes columns of numerical data to a file allowing you to import the numbers into another program. To convert a list or a list of lists to a Matrix, use the `Matrix` constructor. For more information, refer to the `Matrix` help page.
If the data is a Vector or any object that can be converted to type Vector, use the `ExportVector` command. To convert lists to Vectors, use the `Vector` constructor. For more information, refer to the `Vector` help page.

\[
\begin{bmatrix}
-81 & -98 & -76 & -4 & 29 \\
-38 & -77 & -72 & 27 & 44 \\
-18 & 57 & -2 & 8 & 92 \\
87 & 27 & -32 & 69 & -31 \\
33 & -93 & -74 & 99 & 67
\end{bmatrix}
\]

\[L := \begin{bmatrix}
-81 & -98 & -76 & -4 & 29 \\
-38 & -77 & -72 & 27 & 44 \\
-18 & 57 & -2 & 8 & 92 \\
87 & 27 & -32 & 69 & -31 \\
33 & -93 & -74 & 99 & 67
\end{bmatrix}\]

\[\text{ExportMatrix}("\text{matrixdata.txt"}, L) :\]

If the data is a Vector or any object that can be converted to type Vector, use the `ExportVector` command. To convert lists to Vectors, use the `Vector` constructor. For more information, refer to the `Vector` help page.

\[R := [3, 3.1415, -65, 0]\]

\[\begin{bmatrix}
3 \\
3.1415 \\
-65 \\
0
\end{bmatrix}\]

\[V := \text{Vector}(R)\]

\[\text{ExportVector}"\text{vectordata.txt"}, V) :\]

You can extend these routines to write more complicated data, such as complex numbers or symbolic expressions. For more information, refer to the `ExportMatrix` and `ExportVector` help pages.

For more information on matrices and vectors, see Linear Algebra (page 155).

**Saving Expressions to a File**

If you construct a complicated expression or procedure, you can save them for future use in Maple. If you save the expression or procedure in the Maple internal format, Maple can retrieve it more efficiently than from a document. Use the `save` command to write the expression to a `.m` file. For more information on Maple internal file formats, refer to the `fil` help page.
In this example, small expressions are used. In practice, Maple supports expressions with thousands of terms.

\[ qbinomial := (n, k) \rightarrow \prod_{i=n-k+1}^{n} \frac{(1 - q^i)}{(1 - q^i)} \]

In this example, small expressions are used. In practice, Maple supports expressions with thousands of terms.

\[ expr := qbinomial(10, 4) \]

\[ expr := \frac{(1 - q^7) (1 - q^8) (1 - q^9) (1 - q^{10})}{(1 - q) (1 - q^2) (1 - q^3) (1 - q^4)} \] (11.3)

\[ nexpr := normal(expr) \]

\[ nexpr := (q^6 + q^5 + q^4 + q^3 + q^2 + q + 1) (q^4 + 1) (q^6 + q^3 + 1) (q^8 + q^6 + q^4 + q^2 + 1) \] (11.4)

You can save these expressions to the file `qbinom.m`.

\[ save qbinomial, expr, nexpr, "qbinom.m" \]

Clear the memory using the `restart` command and retrieve the expressions using the `read` command.

\[ restart \]

\[ read "qbinom.m" \]

\[ expr \]

\[ \frac{(1 - q^7) (1 - q^8) (1 - q^9) (1 - q^{10})}{(1 - q) (1 - q^2) (1 - q^3) (1 - q^4)} \] (11.5)

For more information on writing to files refer to the `save` help page.

### 11.3 Reading from Files

The most common reason for reading file is to load data, for example, data generated in an experiment. You can store data in a text file and then read it into Maple.
Reading Data from a File

Import Data Assistant

If you generate data outside Maple, you can read it into Maple for further manipulation. This data can be an image, a sound file, or columns of numbers in a text file. You can easily import this external data into Maple using the **Import Data Assistant**, where the supported file formats include file of type Excel®, MATLAB, Image, Audio, Matrix Market, and Delimited.

**To launch the Import Data Assistant:**

1. From the **Tools** menu, select **Assistants**, and then **Import Data**.
2. A dialog window appears where you can navigate to your data file. Select the file that you want to import data from, and then select the file type before clicking **Next**.
3. From the main window, you can preview the selected file and choose from the applicable options based on the format of the file read in before importing the data into Maple. See **Figure 11.1** for an example.

![Data Import Assistant](image)

**Figure 11.1: Import Data Assistant**

**ImportMatrix Command**

The **Import Data Assistant** provides a graphical interface to the **ImportMatrix** command. For more information, including options not available in the assistant, refer to the **ImportMatrix** help page.
Reading Expressions from a File

You can write Maple programs in a text file using a text editor, and then import the file into Maple. You can paste the commands from the text file into your document or you can use the `read` command.

When you read a file with the `read` command, Maple treats each line in the file as a command. Maple executes the commands and displays the results in your document but it does not, by default, insert the commands from the file in your document.

For example, the file `ks.txt` contains the following Maple commands.

\[
S := n \rightarrow \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^{\beta}} - \beta! \beta \right);
\]

\[
S(19);
\]

Note that the file should not contain prompts (`>` at the start of lines).

When you read the file Maple displays the results but not the commands.

\[
S := n \rightarrow \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^{\beta}} - \beta! \beta \right)
\]

\[
102493736166644598071114328769317982974 \quad \text{(11.6)}
\]

\[
> \text{filename} := \text{cat(kernelopts(datadir), kernelopts(dirsep), "ks.txt")} :
\]

\[
> \text{read filename}
\]

\[
S := n \rightarrow \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^{\beta}} - \beta! \beta \right)
\]

\[
102493736166644598071114328769317982974 \quad \text{(11.7)}
\]

If you set the `interface echo` option to 2, Maple inserts the commands from the file into your document.
> interface(echo = 2):
    read filename
> S:= n -> sum( binomial( n, beta ) * ( ( 2*beta )! / 2^beta - beta!*beta ), beta=1..n );

\[ S := n \rightarrow \sum_{\beta=1}^{n} \binom{n}{\beta} \left( \frac{(2\beta)!}{2^\beta} - \beta! \beta \right) \]

> S(19);

1024937361666644598071114328769317982974 (11.8)

For more information, refer to the read and interface help pages.

11.4 Exporting to Other Formats

Exporting Documents

You can save your documents by selecting Save or Save As from the File menu. By selecting Export As from the File menu, you can also export a document in the following formats: HTML, LaTeX, Maple input, Maplet application, Maple text, plain text, PDF, and Rich Text Format. This allows you to access your work outside Maple.

HTML

The .html file that Maple generates can be loaded into any HTML browser. Exported mathematical content can be displayed in one of the following formats: GIF, MathML 2.0 Presentation, MathML 2.0 Content, or Maple Viewer, and is saved in a separate folder. MathML is the Internet standard, sanctioned by the World Wide Web Consortium (W3C), for the communication of structured mathematical formulae between applications. For more information about MathML, refer to the MathML help page.

Maple documents that are exported to HTML translate into multiple documents when using frames. If the frames feature is not selected, Maple creates only one page that contains the document contents.

LaTeX

The .tex file generated by Maple is ready for processing by LaTeX. All distributions of Maple include the necessary style files. By default, the LaTeX style files are set for printing the .tex file using the dvips printer driver. You can change this behavior by specifying an option to the \usepackage LaTeX command in the preamble of your .tex file. For more information, refer to the exporttoLaTeX help page.
Maple Input

You can export a Maple document as Maple input so that it can be loaded using the Maple Command-line version.

**Important:** When exporting a document as Maple input for use in Command-line Maple, your document must contain explicit semicolons in 1-D Math input. If not, the exported `.mpl` file does not contain semicolons, and Command-line Maple generates errors.

Maplet Application

The Export as Maplet facility saves a Maple document as a `.maplet` file so that you can run it using the command-line interface or the MapletViewer. The MapletViewer is an executable program that can launch saved Maplet applications. It displays and runs Maplet applications independently of the Maple Worksheet interface.

**Important:** When exporting a document as a Maplet Application for use in Command-line Maple or the MapletViewer, your document must contain explicit semicolons. If not, the exported `.maplet` file does not contain semicolons, and Command-line Maple and the MapletViewer generates errors.

Maple Text

Maple text is marked text that retains the distinction between text, Maple input, and Maple output. Thus, you can export a document as Maple text, send the text file by email, and the recipient can import the Maple text into a Maple session and regenerate the computations in the original document.

PDF

Export a Maple document to a Portable Document Format (PDF) file so that you can open the file in a reader such as Adobe Acrobat. The PDF document is formatted as it would appear when the Maple worksheet is printed using the active printer settings.

**Note:** Images, plots, and embedded components may be resized in the PDF file.

Plain Text

Export a Maple document as plain text so that you can open the text file in a word processor.

Rich Text Format (RTF)

Export a Maple document to a rich text format file so that you can open and edit the file in a word processor.

**Note:** The generated `.rtf` format is compatible with Microsoft Word and Microsoft WordPad only.
## Summary of Translation

### Table 11.1: Summary of Content Translation When Exporting to Different Formats

<table>
<thead>
<tr>
<th>Content</th>
<th>HTML</th>
<th>LaTeX</th>
<th>Maple Input</th>
<th>Maplet Application</th>
<th>Maple Text</th>
<th>Plain Text</th>
<th>Rich Text Format</th>
<th>PDF Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
</tr>
<tr>
<td>1-D Math</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by &gt;</td>
<td>Preceded by &gt;</td>
<td>Static image</td>
<td>Static image</td>
<td>Either text or shapes depending on option selected</td>
</tr>
<tr>
<td>2-D Math</td>
<td>GIF or MathML</td>
<td>1-D Math or LaTeX 2e</td>
<td>1-D Math (if possible)</td>
<td>1-D Math or character-based typesetting</td>
<td>1-D Math or character-based typesetting</td>
<td>Static image</td>
<td>Static image</td>
<td></td>
</tr>
<tr>
<td>Plot</td>
<td>GIF</td>
<td>Postscript Fil</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
<td>Static image</td>
</tr>
<tr>
<td>Animation</td>
<td>Animated GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
<tr>
<td>Hidden content</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Manually inserted page break</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>RTF page break object</td>
<td>Maintained</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Links to help pages become plain text. Links to documents are renamed and converted to HTML links</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
</tr>
<tr>
<td>Embedded image or sketch output</td>
<td>GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
<td>Static image</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>HTML table</td>
<td>LaTeX tables</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>RTF table</td>
<td>Static image</td>
</tr>
</tbody>
</table>
MapleNet

Overview of MapleNet

Using MapleNet, you can deploy Maple content on the web. Powered by the Maple computation engine, MapleNet allows you to embed dynamic formulas, models, and diagrams as live content in web pages. The MapleNet software is not included with the Maple software. For more information on MapleNet, visit http://www.maplesoft.com/maplenet.

MapleNet Documents and Maplets

After you upload your Maple document to the MapleNet server, it can be accessed by anyone in the world using a Web browser. Even if viewers do not have a copy of Maple installed, they can view documents and Maplets, manipulate 3-D plots, and execute code at the click of a button.

Custom Java Applets and JavaServer Pages™ Technology

MapleNet provides a programming interface to the Maple math engine so commands can be executed from a Java applet or using JavaServer Pages™ technology. Embed MapleNet into your web application, and let Maple handle the math and visualization.

Maple T.A.

Overview of Maple T.A.

Maple T.A. is a web-based automated testing system, based on the Maple engine. Instructors can use pre-written questions or create custom question banks and then choose from these questions to form quizzes and assignments. Maple T.A. automatically grades responses as students complete assignments and tests.

For more information, visit http://www.maplesoft.com/mapleta.
Exporting Assignments to Maple T.A.

You can use Maple to create graded questions for use in Maple T.A. For information on creating and testing questions, see Creating Graded Assignments (page 331). Using the Maple T.A. export feature, you can create and test Maple T.A. content.

To export the document:
1. From the File menu, select Export As.
2. In the Export As dialog, specify a filename and the Maple T.A. (.zip) file type. The .zip file containing your questions and assignment can be uploaded to Maple T.A. as a course module.

Any document content outside Maple T.A. sections (indicated by green section markers) is ignored by the export process.

For more details, refer to the exporttoMapleTA help page.

11.5 Connectivity

Translating Maple Code To Other Programming Languages

Code Generation

The CodeGeneration package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages. Languages currently supported include C, C#, Fortran 77, Java, MATLAB, and Visual Basic.

For details on Code Generation, refer to the CodeGeneration help page.

Accessing External Products from Maple

External Calling

External calling allows you to use compiled C, C#, Fortran 77, or Java code in Maple. Functions written in these languages can be linked and used as if they were Maple procedures. With external calling you can use pre-written optimized algorithms without the need to translate them into Maple commands. Access to the NAG library routines and other numerical algorithms is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical algorithms. Routines exist that accomplish a variety of non-mathematical tasks. You can use these routines in Maple to extend its functionality. For example, you can link to controlled hardware via a serial port or interface with another program. The Database package uses external calling to allow you to query, create, and update databases in Maple. For more information, refer to the Database help page.
For more information on using external calling, refer to the **ExternalCalling** help page.

**Mathematica Translator**

The **MmaTranslator** package provides translation tools for converting Mathematica® expressions, command operations, and notebooks to Maple. The package can translate Mathematica input to Maple input and Mathematica notebooks to Maple documents. The **Mma** subpackage contains commands that provide translation for Mathematica commands when no equivalent Maple command exists. In most cases, the command achieves the translation through minor manipulations of the input and output of similar Maple commands.

**Note:** The **MmaTranslator** package does not convert Mathematica programs.

There is a Maplet interface to the **MmaTranslator** package. For more information, refer to the **MmaToMaple** help page.

**Matlab Package**

The **Matlab** package enables you to translate MATLAB code to Maple, as well as call selected MATLAB functions from a Maple session, provided you have MATLAB installed on your system.

For more information, refer to the **Matlab** help page.

**Accessing Maple from External Products**

**Microsoft Excel Add-In**

Maple is available as an add-in to Microsoft Excel. This add-in is supported for Excel 2010 and Excel 2007 for Windows, and provides the following features.

- Access to Maple commands from Excel
- Ability to copy and paste between Maple and Excel
- Access to a subset of the Maple help pages
- Maple Function Wizard to step you through the creation of a Maple function call

**To enable the Maple Excel Add-in in Excel 2010:**

1. Click the **File** menu and select **Options**.
2. Click **Add-ins**.
3. In the **Manage** box select **Excel Add-ins**, and then **Go**.
4. Navigate to the Excel subdirectory of your Maple installation and select the appropriate file
   - For 32-bit Windows, select \texttt{WMIMPLEX.xla} (that is, select $\text{MAPLE/Excel/WMIMPLEX.xla}$), and click \texttt{OK}.
   - For 64-bit Windows, select \texttt{WMIMPLEX64.xla} (that is, select $\text{MAPLE/Excel/WMIMPLEX64.xla}$), and click \texttt{OK}.

5. Select the \textbf{Maple Excel Add-in} check box.

6. Click \texttt{OK}.

For details on enabling the Maple Excel Add-in for Excel 2007, refer to the \texttt{Excel} help page.

For information on using this add-in, refer to the \textbf{Using Maple in Excel} help file within Excel.

\textbf{To view this help file}

1. Enable the add-in.

2. From the \texttt{View} menu, select \texttt{Toolbars}, and then \texttt{Maple}.

3. On the Maple toolbar, click the Maple help icon \texttt{?}.

\textbf{OpenMaple}

OpenMaple is a suite of functions that allows you to access Maple algorithms and data structures in your compiled C, C\#, Java, or Visual Basic programs. (This is the reverse of external calling, which allows access to compiled C, C\#, Fortran 77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your application to any licensed Maple user. For additional terms and conditions on the use of OpenMaple, refer to the \texttt{extern/OpenMapleLicensing.txt} file in your Maple installation.

For more details on using OpenMaple functions, refer to the \textbf{OpenMaple} help page.

\textbf{MapleSim}

MapleSim\textsuperscript{TM} is a complete environment for modeling and simulating multidomain engineering systems. During a simulation, MapleSim uses the symbolic Maple computation engine to generate the mathematical models that represent the system behavior.

Because both products are tightly integrated, you can use Maple commands and technical document features to edit, manipulate, and analyze a MapleSim model. For example, you can use Maple commands and tools to manipulate your model equations, develop custom components based on a mathematical model, and visualize simulation results.
MapleSim software is not included with the Maple software. For more information on MapleSim, visit http://www.maplesoft.com/maplesim.

**MaplePlayer for iPad**

The Maple Player is a free application for the iPad that uses the Maple computation engine to enable you to view and interact with documents created in desktop Maple.

For more information on the Maple Player for iPad, visit http://www.maplesoft.com/products/MaplePlayer.

**Sharing and Storing Maple Worksheet Content**

**The MapleCloud**

You can use the MapleCloud to share worksheet content with other users, view content shared by other users, and store entire standard Maple worksheets or selected content from standard Maple worksheets. Through the MapleCloud palette, you can upload standard Maple worksheet content and allow other users to download a copy of that content. You can also upload and store content in a user-specific area that only you can access.

A list of shared worksheets that you have permissions to view are displayed in the MapleCloud palette. To share content with specific users, you can either create a user group or select an existing group and allow only those group members to access your content. For more information about groups, refer to the worksheet.cloud.groups help page.

Users need an internet connection to use the MapleCloud. To share worksheet content, create, manage and join user groups; and view group-specific content, you must log in to the MapleCloud using a Maplesoft.com, Gmail™, or Google Mail™ account name and password.

A Maplesoft.com membership account gives you access to thousands of free Maple resources and MaplePrimes, which is an active web community for sharing techniques and experiences with Maple and related products. To sign up for a free Maplesoft.com membership account, visit http://www.maplesoft.com/members/sign_up_form.aspx. The MapleCloud is integrated with several of these online features, so it is strongly recommended that you use a Maplesoft.com membership account.
Index

Symbols

! toolbar icon, 66
!!! toolbar icon, 66
"", 342
$, 175
%H, 168
%T, 168
&gt;, 78
&lt;&lt;&gt;, 156, 159
&amp; x, 168
', 94, 361
(), 379
- &gt;, 94
., 167
1-D Math, 79
   switching to 2-D, 79
2-D Math, 78
   converting to 1-D, 80
   entering, 5
   shortcuts, 7
   switching to 1-D, 79
:, 79, 80
::, 142
:=, 93
::, 79, 80
?
   help topic, 54
[], 165, 334, 335
^, 6, 110
   entering, 110
_. 95
   entering, 95
ZN ~, 115
\ ~, 95
{}, 334
[, 159
~, 115, 143
   element-wise operations, 358

A
about command, 143
abs command, 107
absolute value, 107
add
   word to your dictionary, 330
add command, 375
additionally command, 143
algebra, 153
   linear, 171
   polynomial, 148
algsubs command, 355
alignment format, 286
American spelling
   spellcheck, 328
and operator, 366
angle brackets, 156, 159, 203
angles, 351
animations
   creating, 275
   customizing, 279
Application Center, 59
applications
   sample documents, 57
apply
   character styles, 288
   paragraph styles, 291
approximation, 103
   least-squares, 170
   numeric, 356
arguments, 379
arithmetic, 66
   finite-precision 102
   interval, 138
   matrix and vector, 166
   modular, 107, 109
   polynomial, 148
Arrays, 336
   indexing, 336
   large, 337
arrow operator, 94
assign command, 118
assigned command, 361
assignment operator (:=), 93
Assistants
  Back-Solver, 35
  CAD Link, 36
  Curve Fitting, 34, 155
  Data Analysis, 35, 194
  eBook Publisher, 36
  Equation Manipulator, 36
  Import Data, 36, 410
  Installer Builder, 36
  Library Browser, 36
  Maplet Builder, 36
  ODE Analyzer, 36, 120
  Optimization, 36, 184
  overview, 32
  Plot Builder, 36, 238
  Scientific Constants, 36
  Special Functions, 36
  Tools menu, 32
  Unit Converter, 351
  Units Calculator, 36, 128
  Worksheet Migration, 36
assume command, 142
  adding assumptions, 143
  and procedure variables, 145
  imposing multiple assumptions, 143
  removing assumptions, 144
  setting relationships between variables, 142
  setting variable properties, 142
  testing property, 143
  using with assume command, 145
  viewing assumptions, 143
assuming command, 142, 144, 180, 350
  additionally option, 145
  and procedure variables, 145
  applying to all names, 144
  using with assume command, 145
Attributes submenu
  character, 285
  paragraph, 286
auto-execute, 302
  repeating, 304
security levels, 304
Avogadro constant, 113, 134
B
Back-Solver Assistant, 35
bar chart, 192
basis
  vector space, 170
  binary numbers, 108
  Bohr radius, 134
  bold format, 283
  bookmarks
    using, 324
  boolean expressions, 357, 366, 372
  brackets
    angle, 156, 159
  break statement, 374
  browser
    Matrix, 160, 338
    Task, 90
  bullets
    format, 286
  button
    embedding, 326
  Button component, 385
by clause, 369
  excluding, 369
  negative, 370
C
CAD Link Assistant, 36
calculus, 183
  clickable problem solving, 235
  multivariate, 182
  Student package, 183
of variations, 183
packages, 182
  study guides, 196
teaching, 183, 196
vector, 182
  Student package, 183
calling sequence, 81
canvas
  inserting, 317
canvas style
  sketch pad, 318
caret
  entering, 110
central tendency, 138
character styles
  creating, 289
description, 287
Check Box component, 385
Cholesky decomposition, 168
Classic Worksheet
  tables, 313
Classic Worksheet Interface, xvii
clickable math, 235
Code Edit Region, 382
CodeGeneration
  package description, 85
coeff command, 153
coefficient
  polynomials, 153
coeffs command, 154
collect command, 153
colon, 79, 80
color
  of plots, 267
combine command, 350
  errors option, 141
Combo Box component, 386
command completion, 7, 47
Command-line Interface, xvii
commands, 85
  and task templates, 91
displaying procedures, 380
entering, 45
help, 53
hiding, 382, 383
iterative, 377
mapping over set or list, 377
package, 83
top, 83
top-level, 81
compatibility
  worksheet, 332
complex expressions, 357
complex numbers, 29
compoly command, 155
components
  adding GUI elements, 326
  palette, 326
computations
  assistants, 90
  commands, 85
  context menus, 89
  errors, 105
    avoiding, 105
  integers, 109
  interrupting, 374
  linear algebra, 166
  mathematics, 147
  numeric, 105
  palettes, 87
  performing, 101, 147
  Real number system, 141
  symbolic, 105
  syntax-free, 75
task templates, 91
tutors, 90
under assumptions, 142
  single evaluation, 144
  updating, 66
  with uncertainty, 140
  with units, 131
conditional execution, 366
constants, 63
title command, 154
toilex
  context
    of unit, 128
title command, 68, 89, 168
  customizing animations, 277
equation, 111
  integer, 88, 106
overview, 39
tutors, 74
using, 39
convert command, 351
  base option, 108, 373
degrees option, 351
mathematical functions, 351
polynom option, 179
set option, 351
temperature option, 130
units option, 129, 351
copy, 283
copy expressions, 12
correlation, 140
coulditbe command, 144
covariance, 140
cross product, 168
Curl command, 183
Curve Fitting
  package
    PolynomialInterpolation command, 155
Curve Fitting Assistant, 34, 155
cut and paste
  in tables, 306

dictionary, 57, 195
dictionary topic
  adding hyperlink to, 323
diff command, 121, 175
differential equations
  ordinary, 120
  partial, 124
differentiation, 174
  with uncertainty, 140
  with units, 132
Differentiation Methods Tutor, 197
Digits environment variable, 104
dimension, 127, 168
  base, 127
Directional Derivative Tutor, 176
discrim command, 155
display
  bookmark, 324
distribution
  probability, 190
divide command, 149
divisors, 107
document blocks, 50, 299
Document mode, 61
documents
  running, 9
DocumentTools, 394
double colon operator, 142
dsolve command, 124

e-notation, 104
eBook Publisher Assistant, 36
Edit menu
  in help system, 56
eigenvalues, 168
eigenvectors, 168
element-wise operators, 358
elementary charge, 134
elements, 133
definition 135
  isotopes, 135
definition 135
properties, 135
list, 135
properties
  list, 135
  uncertainty, 138
  units, 137
  using, 134
  value, 136
  value and units, 137
elif clauses, 367
order, 368
else clause, 367
email
  adding hyperlink to, 322
embedded components, 326, 385
  inserting, 388
  properties, 389
end do keywords, 369, 371, 372
end if keywords, 366
end proc keywords, 378
engineers
  portal for, 57
environment variables
  Digits, 104
  Order, 179
equation
  solving step-by-step, 216
equation labels, 99
  displaying, 96
  features, 99
  formatting, 50
  inserting, 49
  numbering schemes, 98
  overview, 48
  references to, 96
  versus names, 99
  with multiple outputs, 97
Equation Manipulator, 36, 216
equations
  solving, 111
    for real solutions, 141
    numerically, 116
    symbolically, 113
transcendental, 115
errors
  quantities with, 138
Euclidean algorithm, 155
eval command, 354, 380
evalb command, 357
evalc command, 357
evalf command, 104, 115, 136, 139, 356
  with Int command, 181
  with Limit command, 173
evaln command, 361
evaluation
  boolean expressions, 357
  complex expressions, 357
  delaying, 361
  levels of, 360
  Maple expressions, 353
  of expression at a point, 353
  output below, 65
  output inline, 65, 68
  updated computations, 66
exact
  computation, 103
  numbers, 102
quantities
  converting to floating-point 104
example worksheets
  copy, 56
execution group, 79
execution groups, 18
expand
  command, 349
  document block, 301
  execution group, 301
  series, 178
Exploration Assistant, 43
exponents
  entering, 6
export, 381
  to HTML, 412
  to LaTeX, 412
  to Maple input, 413
  to Maple T.A., 416
to Maple text, 413
  to Maplet application, 413
  to other formats, 415
  to PDF, 413
  to plain text, 413
  to Rich Text Format, 413
worksheets, 412
exporting
  embedded components, 388
expression sequences, 113, 334
  creating, 375
expressions, 63, 333
  adding, 375
  evaluating, 353
  manipulating, 348
  multiplying, 375
  right-click, 40
  versus functional operators, 340

F
factor
  integers, 106
  polynomials, 154
    QR factorization, 170
factor command, 154, 349
factored normal form, 352
factorial command, 107
FAIL, 366, 372
false, 366, 372
Faraday constant, 134
Favorites palette, 21
file
  image formats, 319
    reading from, 411
    writing to, 407
file option, 163
fini fields 109
  solving equations, 125
fini rings, 109
floating-point computation
  accuracy, 105
  hardware, 105
  significant digits, 104
  numbers, 102
  rational approximation, 89
Flux command, 183
font color, 283
foot-pound-second (FPS) system, 72, 128
footers, 296
for/from loops, 369
for/in loops, 371
formal power series solutions, 124
format labels, 49
Format menu
  bookmarks, 324
    quick formatting, 283
  frac command, 144
fractions
  approximating, 69
    entering, 6
  frequency plot, 192
Frobenius form
  matrix, 170
from clause, 369
  excluding, 369
fsolve command, 116
full evaluation, 360, 362
FunctionAdvisor command, 81
functional operators, 339
  differentiating, 175
  plotting, 341
  versus expressions, 340
functions
  converting between, 351
  definin as functional operators, 339

G
Gaussian elimination, 170
Gaussian integers, 110
GaussInt package, 110
gcd command, 155
gcdex command, 155
Global Optimization Toolbox, 184
global variables, 379
glossiness
of 3-D plots, 267
go to
  bookmark, 326
gradient, 199
Gradient Tutor, 198
Graphing Calculator, xvii
greatest common divisor, 107, 155

H
Handwriting palette, 27
has command, 345
hastype command, 344
HazardRate command, 191
headers, 296
Help Navigator
  Using, 55
help page
  adding hyperlink to, 322
help system
  accessing, 53
  description, 57
  Edit menu, 56
  Help Navigator, 54
  manuals, 55
  search, 55
  table of contents, 55
  tasks, 55
  topic search, 55
  tutorials, 55
  View menu, 56
Hermitian transpose
  matrix and vector, 168
Hessenberg form, 170
hexadecimal numbers, 108
hide
  worksheet content, 297
highlight color, 283
Hilbert Matrix, 170
histogram, 192
How Do I ... topics, 57
hyperlinks
  in worksheet, 320

I
i
  entering, 29, 110
icons
  open as example worksheet, 56
if statement, 366
ifactor command, 106, 107, 349
igcd command, 107
images
  adding hyperlink to, 321
  fil format, 319
  inserting, 319
imaginary unit
  entering, 29, 110
implied multiplication, 6
implies operator, 366
Import Data Assistant, 36, 410
indent
  format, 286
indeterminates, 347
indets command, 347
indices, 81, 165
inequations
  solving, 111
  for real solutions, 141
  symbolically, 113
infinit loops, 374
infolevel command, 124
input
  1-D Math, 79
  2-D Math, 78
  prompt, 78
  separating, 80
  setting default mode, 80
insert
  bookmark, 324
  hyperlink, 321
  images, 319
  section, 295
  sketch pad, 317
  table, 304
Installer Builder Assistant, 36
instructor resources, 207
int command, 181
Int command, 181
integers
  commands, 107
  computations, 109
  context menu, 88
  factoring, 106
  Gaussian, 110
  modulo m, 109
  solving equations, 125
  solving modular equations, 125
integration, 67, 87, 179
  definite 180
  functional operators, 342
  indefinite 180
  iterated, 181
  line, 181, 201
  numeric, 181
  surface, 181
  with units, 132
interactive commands
  Student, 38
Interactive Linear System Solving tutor, 73
Interactive Plot Builder Assistant
  creating animations, 271
  creating plots, 238
  customizing animations, 277
  customizing plots, 263
interface command
  rtablesize option, 162
  verboseproc option, 380
international system (SI), 128
InterquartileRange command, 191
interval arithmetic, 138
iquo command, 107
iroot command, 107
is command, 143
isprime command, 107
isqrt command, 107
italic format, 283

J

j

entering, 110
Jordan form, 168

K
keyboard keys
  Command Completion, xviii
  Context Menu, xviii
  keystrokes, 6

L
Label component, 386
labels, 99
last name evaluation, 361
lcm command, 155
lcoeff command, 153
ldegree command, 154
least-squares, 170
left single quotes, 95
left-hand side, 345
levels of evaluation, 360
lexicographic order, 151
lhs command, 345
Library Browser
  description, 36
limit command, 172
Limit command, 173
limits, 172
  multidimensional, 173
line break, 286
line integrals, 201
linear algebra, 171
  computations, 166
  efficiency, 162, 171
  LinearAlgebra package, 170
  teaching, 171, 196
Linear System Solving tutor, 74
linear systems
  solving, 125, 170
  interactive, 73
LinearAlgebra
  package description, 85
  LinearAlgebra package, 168
commands, 170
  numeric computations, 171
LinearSolve command, 125
List Box component, 386
lists, 165, 335
  returning solutions as, 113
local variables, 379
logical operators, 366
loops, 369
  general, 373
  infinite 374

M
Macintosh
  command complete, 7
  context menus, 39
manipulate
  equation, 216
map command, 377
Maple Application Center, 196
Maple library, 45
Maple Portal, 57, 195
Maple Student Help Center, 196
MapleCloud, 419
MaplePrimes, 59
Maplet Builder
  description, 36
  launching, 398
  Maplet authoring, 398
Maplets
  adding hyperlink to, 323
  authoring, 405
    Maplet Builder, 398
    Maplets package, 403
launching
  Maple worksheet, 397
  Maplet file type, 396
Maplets package
  Display command, 403
  Elements subpackage, 403
  Maplet authoring, 403
saving
  Maple worksheet, 405
  maplet file 405
using, 396
markers
  bookmarks, 324
  displaying, 51
  for document blocks, 299
math dictionary
  description, 57
math educators
  portal for, 195
Math Expression component, 386
Math mode, 19
  shortcuts, 7
mathematical functions
  list, 81
mathematics
  computations, 147
  teaching and learning, 207
matrices, 338
  arithmetic, 166
  context menus, 168
  data type, 162, 163
  defining 156
  efficiency, 162
  filling 163
  Hermitian transpose, 168
  image, 161
  large, 160
  multiplication, 167
  operations, 168
  random, 160
  scalar multiplication, 167
  selecting submatrices, 165
  shape, 162, 163
  transpose, 168
  type, 162
Matrix
  Browser, 160, 338
  constructor, 163
  data structure, 155
  palette, 126, 156, 162
Matrix command, 156
  max command, 107
maximize, 184
maximum, 107
Mean command, 191
Meter component, 386
min command, 107
minimize, 184
minimum, 107
mod command, 107
mod operator, 109
modes
Document, 61
Worksheet, 61
modify
table, 305
modp command, 109
mods command, 109
modular arithmetic, 107, 109
modules, 381
MPS(X) files 188
msolve command, 125
mul command, 375
multiplication
implied, 6
not operator, 366
numbers, 63
exact, 102
floating-point 102
non-base 10, 108
numer command, 346
numeric
approximation, 356
computation, 102
numtheory[divisors] command, 107

O
objects, 381
ODE Analyzer Assistant, 36, 120
online help, 60
operands, 347
selecting, 376
operators, 63
functional, 339
logical, 366
relational, 366
Optimization
package description, 85
optimization, 187
efficiency, 187
plotting, 186
point-and-click interface, 184
Optimization Assistant, 32, 36, 184
Plotter, 186
Options dialog, 20
or operator, 366
Order environment variable, 179
ordinary differential equations
plotting solution, 123
solving, 120
orthogonal matrix, 170
output
suppressing, 79

P
packages, 81
accessing commands, 47
Index • 431

definition 45
help, 53
loading, 83
top, 86
unloading, 84
page break, 286
page headers and footers, 296
palette
custom, 28
Snippets, 28
palettes, 63, 67, 87, 354
categories, 23
Components, 389
favorites, 21
managing, 24
Matrix, 156, 162
overview, 21
symbol recognition, 27
Units, 72, 130
paragraph styles
creating, 292
description, 287
parameters, 379
parametric solutions, 116
partial derivative
entering, 63
partial differential equations
solving, 124
paste, 283
examples, 56
PDEs, 124
pdsolve command, 124
pencil
sketch pad, 317
Physics
package description, 85
pie chart, 192
piecewise command, 190
Planck constant, 134
Plot Builder
description, 36
plot command, 179
Plot component, 386

plot3d command, 341
plots
analyzing, 269
pan, 269
point probe, 269
rotate, 269
scale, 269
code for color plates, 280
creating, 261
customizing, 267
displaying multiple plots, 261
insert plot, 248
Interactive Plot Builder, 238
plot command, 249
plot3d command, 249
plots package, 257
creating animations
animate command, 271
Interactive Plot Builder, 271
plot3d[viewpoint] command, 274
data, 270
equations, 270
exporting, 280
functional operators, 341
gradient, 200
line integral, 201
Live Data Plots palette, 270
ODEs
numeric solution, 122
symbolic solution, 123
optimization problem, 186
playing animations, 276
plots package
animate command, 271
contourplot command, 260
display command, 262
matrixplot command, 258
pointplot command, 257
series, 179
statistics, 192
viewing animations
animate context bar, 276
point-and-click, 32
polynomial equations
solving, 115
numerically, 116
polynomials
algebra, 148
arithmetic, 148
coefficients 153
collecting terms, 153
degree, 153
division, 148, 149
efficien arithmetic, 155
expanding, 149
factoring, 154
implied multiplication, 150
numeric
algebraic manipulation, 155
operations, 154
sorting, 150
pure lexicographic, 151
total degree, 151
PolynomialTools package, 155
IsSelfReciprocal command, 155
powers
entering, 6
precalculus
demos, 195
teaching, 196
precision, 104
prem command, 155
previously assigned, 361
primality testing, 107
primpart command, 155
print
command, 380
table, 312
printing
embedded components, 388
probability distribution, 190
proc key word, 378
procedures, 381
and assumptions, 145
calling, 378
defining 378
displaying, 380
inputs, 379
multiple lines, 378
output, 379
using, 378
product command, 376
products
entering, 6
implied, 6
programming, 365
access to Maple's programming guides, 58
programs, 365
modules, 381
objects, 381
procedures, 381
prompt
input, 78
properties
testing, 143
protected names, 94
Q
QPSolve command, 188
QR factorization, 170
quadratic programs, 188
quantities with uncertainty, 139
accessing error, 139
accessing value, 139
computing with, 140
constructing, 139
element properties, 140
rounding the error, 139
scientific constants, 140
with units, 140
quick
  character formatting, 283
  paragraph formatting, 285
quit statement, 374
quo command, 148
quotes
  double, 342
  left single, 95
  right single, 94, 361
  unevaluation, 361
quotient
  integer, 107

R
Radio Button component, 386
random
  matrices, 160
  variables, 190
randpoly command, 155
range
  in plots, 265
  operator, 165
rank, 168
rational expressions
  entering, 6
read
  from files, 411
RealDomain
  package description, 85
recurrence relation
  solving, 126
reference
  equation labels, 99
  names, 93
relational operators, 366
rem command, 148
remainder
  integer, 107
remove command, 376
repetition statements, 369
reserved names, 94
resources
  in help system, 55
restart command, 84, 95
resultant command, 155
return
  statement, 374
  values, 379
rhs command, 345
right single quotes, 94, 361
right-click
  expressions, 40
  right-hand side, 345
RootOf structure, 115
roots
  command, 155
  of equations, 115
Rotary Gauge component, 387
row vector
  creating, 163
rsolve command, 126
running
  documents, 9
  worksheets, 9

S
saving a Maple Document, 18
scatter plot, 192
scientific constants, 133
  list, 134
  name, 134
  symbol, 134
  uncertainty, 138
  units, 137
  using, 134
  value, 136
  value and units, 137
Scientific Constants Assistant, 36
ScientificConstant
  package description, 85
ScientificConstant
  package, 133
  extensibility, 138
  objects, 136
ScientificErrorAnalysis
  package description, 85
ScientificErrorAnalysis package, 138
extensibility, 141
objects, 139
search
  help system, 55
sections
  in worksheet, 294
security levels
  auto-execute, 304
security tab
  options dialog, 304
select command, 376
selection
  execute, 9
selectremove command, 376
semicolon, 79, 80
seq command, 375
series, 178
  command, 178
  plotting, 179
  Taylor, 178
  type, 179
sets, 334
shape option, 163
show
  worksheet content, 297
show contents dialog
  using, 297
significan digits, 104
simplify command, 348, 355
sketch pad
  canvas style, 298
slider
  embedding, 326
Slider component, 387
Snippets palette, 28
solutions
  assigning as expression, 118
  assigning as function, 119
details, 124
formal, 124
formal power series, 124
integers, 125
real, 141
series, 124
verifying, 118
solve
  equations, 111
    for real solutions, 141
    numerically, 116
    symbolically, 113
  inequations, 111
    for real solutions, 141
    symbolically, 113
  integer equations, 125
  linear system, 125, 170
  modular integer equations, 125
  ODEs, 120
  PDEs, 124
  recurrence relation, 126
  transcendental equations, 115
solve command, 113, 336
  findin all solutions, 115
  findin parametric solutions, 116
real solutions, 141
solving procedures, 116
sort
  lists, 353
  polynomials, 150, 353
sort command, 150, 353
  plex option, 151
spacing format, 286
Special Functions Assistant, 36
spellcheck, 328
  American spelling, 328
dictionary, 330
sqrfree command, 155
Standard Document Interface, xvii
starting, 3
Standard Units environment, 131
Standard Worksheet Interface, xvii
startup code, 9
Startup Code, 383
statements
  multiple lines, 378
Statistics package, 193
  continuous distributions, 190
description, 85
discrete distributions, 190
plots, 192
strings, 342
StringTools package, 343
Student
   package description, 86
Student Help Center, 59
Student package, 177, 195, 196
calculus subpackages, 183
   LinearAlgebra subpackage, 171
Maplets, 195
Tutors, 195
student resources, 207
students
   portal for, 195
study guides, 196
style set management, 293
subscripts
   entering, 7
   format, 283
substitute, 353
sum command, 376
superscript format, 283
Sylvester matrix, 170
symbol completion, 7
symbolic
   computation, 102
   objects, 103
symbols
   entering, 28
   names, 28
system of units, 128
   controlling, 132
systeme international (SI), 72, 128
help system, 55
tables, 338
   alignment, 309
   and Classic worksheet, 313
   appearance, 308
   borders, 308
   contents, 304
   execution order, 313
   physical dimensions, 308
   printing, 312
   using, 304
   visibility of cell content, 312
Task Browser, 90
task template, 40
task templates, 91, 106, 127, 155, 172
taylor command, 178
Taylor series, 178
tcoeff command, 154
Teacher Resource Center, 59
teachers
   portal for, 195
   teaching with Maple, 207
Technical Support
   access, 60
temperature conversion, 129
Text Area component, 387
text file
   embedding, 326
Text mode, 19
text regions, 92
tilde, 115, 143, 358
to clause, 369
   excluding, 369
Toggle Button component, 387
Tolerances package, 138
toolboxes
   Global Optimization, 184
Tools menu
   assistants, 32
   Assistants and Tutors, 90
   Tasks, 90
topic search, 55
Torsion command, 183
total degree, 151
transparency
  of 3-D plots, 267
transpose
  matrices and vectors, 168
ttrue, 366
tutorials
  help system, 55
Tutorials, 57
Tutors, 195, 196
  Derivatives, 196
  Differentiation Methods, 197
  Directional Derivative, 176
  Gradient, 198
  Linear System Solving, 74
  using, 37
tutors
  accessing, 37
type command, 344
types, 142, 343
  converting, 351
  series, 179
  testing, 344
  subexpressions, 344
typesetting rule assistant, 298

U
unapply command, 119
unassign command, 94
unassigning names, 94, 362
uncertainty, 138
  quantities with, 138
underline format, 283
unevaluation quotes, 94, 361
union
  of sets, 335
Unit Converter Assistant, 351
units, 72, 127, 351
  adding to expressions, 72
  applying to expression, 130
  computing with, 131
  context, 128
  converting between, 128
environment, 131
  evaluating with, 73
in 1-D Math, 131
  inserting, 130
overview, 127
prefixes, 131
system of
  controlling, 132
  systems of, 128
Units
  package description, 86
Units Calculator, 128
Units Calculator Assistant, 36
Units package, 127
  environments, 131
  extensibility, 133
  UseSystem command, 133
  UsingSystem command, 132
Units palettes, 72, 130
universal gravitational constant, 134
UNIX
  command complete, 7
  context menus, 39
unwith command, 84
URL
  adding hyperlink to, 322

V
variables, 63
variance, 140
VariationalCalculus package, 183
Vector
  constructor
    vectorfield attribute, 182
  data structure, 155
vector fields 182
vector spaces
  basis, 170
VectorCalculus
  package description, 86
VectorCalculus package, 182
  Student version, 183
vectors, 338
arithmetic, 166
column, 159
cross product, 168
data type, 163
defining, 159
efficiency, 162
filling, 163
large, 160
multiplication, 167
row, 159, 163
scalar multiplication, 167
selecting entries, 164
shape, 163
transpose, 168

View menu
  in help system, 56
  markers, 51

Volume Gauge component, 387

W

Web page
  adding hyperlink to, 322
Web site
  access to Maple help pages, 60
  Application Center, 59, 196
  MaplePrimes, 59
  Student Center, 196
  Student Help Center, 59
  Teacher Resource Center, 59
  Technical Support, 60
  Training, 59
  Welcome Center, 58

Welcome Center, 58
while loops, 372
Windows
  command complete, 7
  context menus, 39
  with command, 83
worksheet
  adding hyperlink to, 322
Worksheet Environment, 3
Worksheet Migration Assistant, 36

Worksheet mode, 61, 77

worksheets
  running, 9
  write
    to files 407

X
  xor operator, 366

Z
  zero recognition, 352
  zip command, 377