
体験例題1
Twin Builder 基本操作

システムシミュレーション・ROM体験セミナー



対応プロダクト
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• この体験例題に必要なプロダクトとライセンスは、以下の通り
です。

プロダクト 対応可能ライセンス

ANSYS Twin Builder ANSYS Twin Builder Enterprise



体験例題1-1
回路モデルの基本的な作成手順

• かんたんな電気回路、バネマスモデルの作成



Twin Builderの起動とGUI

• 以下のメニューからTwin Builderを起動します。
– スタートメニュー > A > ANSYS EM Suite 2023 R2 > ANSYS Twin Builder 2023 R2

プロジェクトマネージャー
プロジェクトとそのデザイ
ンツリーが表示されます。

プロパティウィンドウ
選択しているオブジェクト
のプロパティが表示されま
す。

メッセージウィンドウ
プロジェクトに関するエ
ラーやワーニングが表示さ
れます。

プログレスウィンドウ
プロジェクトの解析状況が
表示されます。

デスクトップスペース
デザインや解析結果が表示
されます。

コンポーネントライブラリ
既存モデルが格納されてい
ます。ドラッグ＆ドロップ
でデスクトップスペースに
配置できます。

※メッセージウィンドウ、またはプロ
グレスウィンドウが表示されていない
場合は、右下の「Show Message」ま
たは、「Show Progress」ボタンを押
してください。
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プロジェクトとデザイン

• Twin Builder起動時に新規プロジェクト(Project1)と新規デザ
イン(TwinBuilder1)が開かれます。
下記手順でプロジェクト名とデザイン名を変更します。

①Project1をセレクトします。

②右クリックから
”Rename”をセレクトします。 ③”Basic01”に変更します。

④同様にデザイン名を”LCR”に変更します。
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※[F2]：ショートカット キー



LCR：電圧源の配置

• 既存モデルを使用してLCR回路を作成します。
Component Librariesから電圧源(Voltage Source)を配置します。

①下記のモデルを選択します。
[Basic Elements] > [Circuit] > [Sources] > [E]

②ドラッグ＆ドロップでデスク
トップスペースに配置します。

③[Esc] キーで入力モードを
解除します。
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LCR：電圧源の設定

• 配置した電圧源(E1)の電圧を設定します。

①電圧源をダブル
クリックします。

②EMF Valueに”100V”を指定します。

③”OK”ボタンを押します。
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• Component Librariesから抵抗器(Resister)を配置します。

LCR：抵抗器の配置

①下記のモデルを選択します。
[Basic Elements] > [Circuit] > [Passive Elements] > [R]

②ドラッグ＆ドロップでデスク
トップスペースに配置します。

③[Esc] キーで入力モードを
解除します。
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• 配置した抵抗器(R1)の抵抗値を設定します。

LCR：抵抗器の設定

②Resistanceに”1000 ohm”を指定します。
※デフォルトのままです。

③”OK”ボタンを押します。

①抵抗器をダブル
クリックします。
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LCR：インダクタの配置

①下記のモデルを選択します。
[Basic Elements] > [Circuit] > [Passive Elements] > [L]

②ドラッグ＆ドロップでデスク
トップスペースに配置します。③[Esc] キーで入力モードを

解除します。
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• Component Librariesからインダクタ(Inductor)を配置します。



• 配置したインダクタ(L1)のインダクタンス、初期値を
設定します。

LCR：インダクタの設定

②Inductanceに”0.1 H”を指定します。

④”OK”ボタンを押します。

①インダクタをダブル
クリックします。

③Initial Valueに”0 A”を指定します。
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LCR：コンデンサの配置

①下記のモデルを選択します。
[Basic Elements] > [Circuit] > [Passive Elements] > [C]

②ドラッグ＆ドロップでデスク
トップスペースに配置します。

③[Esc] キーで入力モードを
解除します。
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• Component Librariesからコンデンサ(Capacitor)を配置します。



• 配置したコンデンサ(C1)の静電容量を設定します。

LCR：コンデンサの設定

③”OK”ボタンを押します。

①コンデンサをダブル
クリックします。

②Capacitanceに”1e-06 farad”を指定します。
※デフォルトのままです。

© 2023 CYBERNET SYSTEMS CO., LTD. All Rights Reserved. EX1-13



• 配置したモデルを下記のようにレイアウトします。
表示の縮小/拡大、モデルの移動、回転/反転(必要であれば)
などの操作は以降のページを参照してください。

LCR：レイアウト
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• 回路図の拡大/縮小表示はアイコンでも可能ですが、ショート
カットキー、マウスを使用すると便利です。

LCR：表示の拡大/縮小

アイコン ショートカットキー マウス

Zoom Fit [Ctrl] + [D]

Zoom In [Ctrl] + [＋] Shift + ホイールキー

Zoom Out [Ctrl] + [－] Shift + ホイールキー

Zoom Area [Ctrl] + [Q]

Pan Shift + マウス左ボタン
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LCR：移動/回転

【移動】
モデルを選択後、ドラッグしたままカーソル
を移動します。

【回転】
モデルを選択後、アイコン、または右クリッ
クから”Rotate”を選ぶことで左に90度回転し
ます。
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• 配置したモデルは任意に移動、または回転させることが可能です。

※[Ctrl＋R]：ショートカット キー



LCR：反転

【反転：上下】
モデルを選択後、アイコン、または右クリックか
ら”Flip Vertical”を選ぶことで上下に反転します。

【反転：左右】
モデルを選択後、アイコン、または右クリックか
ら”Flip Horizontal”を選ぶことで左右に反転しま
す。
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• 配置したモデルは上下、または左右に反転させることが可能です。



• 各モデル間を結線します。

LCR：結線

①”Wire”アイコン
をクリックします。

②結線の開始点でクリックします。
※モデルのポート上でクリックす
ることでモデルに接続されたこと
になります。

③クリックして方向を変えます。

④結線したいモデルのポート上で
クリックします。

⑤下記のように結線を完了させます。
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• グラウンドを接続して回路図を完成させます。

LCR：グラウンドの接続

①”Ground”アイコン
をクリックします。

②配置(クリック)時にWireに接続します。
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• 過渡解析の条件を設定します。

LCR：解析条件の設定

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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• 解析結果を表示するための設定を行います。

LCR：グラフの設定/挿入

③左のダイアログボックス内で抵抗器(R1) 
の電流(I)を解析対象とします。
以下のように設定します。

Category：All
Quantity：R1.I
Function：<none>

④”Add Trace”ボタンを押し
“Close”ボタンで終了します。

①グラフ挿入のメニューは下記です。
[Draw] > [Report] > [Rectangular Plot]

②グラフを配置する位置を任意で決めます。
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• 設定した内容で過渡解析を行い結果を表示します。

LCR：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。

※解析の進捗がプログレスウィンドウに表示されます。

解析結果
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• 作成した回路図や解析結果を保存します。
下記のいずれかの方法で保存が可能です。
– File > Save / Save As...

– Saveアイコン

– Ctrl + S

LCR：保存

回路図や結果にアップデートがある場
合、プロジェクト、またはデザイン名
の横に “*” が付きます。
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MKD：新規デザイン

• 新規デザインを作成します。
下記手順でデザインの追加とデザイン名を変更します。

①Basic01プロジェクトをセレクト

②右クリックから下記メニューを選択
Insert > Insert Twin Builder Design

③TwinBuilder1をセレクトし、右クリック
から”Rename”を選択します。

④デザイン名を”MKD”に
変更します。
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MKD：回路図作成
• LCR同様に既存モデルを使用して回路を作成します。

Component Librariesに格納されるモデルは右図を、
完成図は左図を参考に回路図を作成してください。
注１：必要に応じてモデルを回転してください。
注２：Ground を接続すると自動的に へ切り替わります。

MKD完成図
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MKD：ダンパーの設定

②DAMPINGに”5 Ns/m”を指定します。

③”OK”ボタンを押します。

①ダンパーをダブル
クリックします。
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• ダンパーのダンピング係数を変更します。

※力、質量、バネはデフォルト値を使用

F 010［N］
MASS 001［kg］
SPRING 100［Ns/m］



• 過渡解析の条件を設定します。

MKD：解析条件の設定

①Project Manager上、MKDデザイン側の
Analysis内のTRをダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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• 解析結果を表示するためのグラフの設定/挿入を行います

MKD：グラフの設定/挿入

④”Add Trace”ボタンを押し
“Close”ボタンで終了します。

①グラフ挿入のメニューは下記です。
[Draw] > [Report] > [Rectangular Plot]

②グラフを配置する位置を任意で決めます。
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③左のダイアログボックスを以下のように
設定します。

Category：All
Quantity：MASS_TRB1.S
Function：<none>

⑤以下のいずれかの方法で保存します。

(メニュー)：File > Save / Save As...
(アイコン)：Saveアイコン
(ショートカットキー)：Ctrl + S



• 設定した内容で過渡解析を行い結果を表示します。

MKD：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。

解析結果
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• MKDに関しても、下記のいずれかの方法で保存してください。
– File > Save / Save As...

– Saveアイコン

– Ctrl + S

MKD：保存

回路図や結果にアップデートがある場
合、プロジェクト、またはデザイン名
の横に “*” が付きます。
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体験例題1-2
モータモデルの作成

• 例題1-1のRLモデルを再利用
• 実際のモータとの挙動の違いを理解し、モデル変更



概要：DCモータのモデル化
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• モータのようなアプリケーションを模擬できるモデルが
Twin Builderには用意されています。

• DCモータのモデルを実際に使い、またおなじ挙動が生じる回路
モデルで作成してみましょう。



プロジェクトとデザイン

• 例題1-1のプロジェクト(Basic01)とは別にプロジェクトを用意
します。デザインは自動的に挿入されます。

①File > New メニューを選びます。 ②新規で作成されたプロジェクト
(Project1)とデザイン(TwinBuilder1)の
名前を変更します。

Project1 → Motor_Basic
TwinBuilder → LR_Model1
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LR_Model1：回路図作成

• 2つの回路図を作成します。 Component Librariesに格納され
るモデルは右図を、完成図は左図を参考に回路図を作成してく
ださい。

”Ground”アイコン
を接続してください。

配置の方向に
注意ください。
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LR_Model1：インスタンスの設定

• 配置した各インスタンスは以下のように設定ください。

①EMF Valueに”1.5 V”を指定します。
※E1, E2の両方に同じ設定を行います。

②Resistanceに”1 ohm”を指定します。

③Inductanceに”10 mH”を指定します。

④Initial Valueにチェックし、
値を”0 A”に指定します。
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LR_Model1：解析条件の設定

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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• 過渡解析の条件を設定します。



• 回路図に対して、解析結果を表示するための設定を行います。

LR_Model1：グラフの設定/挿入

④”Add Trace”ボタンを押します。

①グラフ挿入のメニューは下記です。
[Draw] > [Report] > [Rectangular Plot]

②グラフを配置する位置を任意で決めます。

③ダイアログボックス内で以下のように設定
します。

Category：All
Quantity：R1.I
Function：<none>

⑤引き続きダイアログボックス内で以下のよ
うに設定します。

Category：All
Quantity：DCMP1.IA
Function：<none>

⑥”Add Trace”ボタンを押し
“Close”ボタンで終了します。
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• 設定した内容で過渡解析を行い結果を表示します。

LR_Model1：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。

解析結果
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概要：DCモータのモデル化
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• 単純なRLモデルではDCモータの挙動と一致しません。

• DCモータには発電作用があり逆起電力が生じます。

• モータに流れる電流からトルクを求め、トルクから回転速度を
求め、回転速度に応じた逆起電力を電気回路に戻します。



LR_Model2：デザインのコピー

①LR_Model1をセレクト

②右クリックから”Copy”メニューを選択

③Motor_Basic1をセレクトし、右クリッ
クから”Paste”を選択します。

④デザイン名を”LR_Model2”に
変更します。
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• LR_Model1を利用して別デザインを作成します。
下記手順でデザインのコピーとデザイン名を変更します。



LR_Model2：回路図作成①
• 上の回路図を編集します。以下の手順に従い回路図(途中)を作

成させてください。 I(Current)ピンを”Show Pin”にチェックを
入れることで表示させます。

既存の結線はセレクト
後、”Delete”キーで削除
可能です。
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EMFピンを”Show Pin”にチェックを入れる
ことで表示させます。



LR_Model2：回路図作成②

• 引き続き回路図を編集します。以下の手順に従い回路図を作成
してください。

ピンの方向に注意ください。
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左右逆転させる場合は、
Flip Horizontal を使う



LR_Model2：回路図作成③

VALUEピンを”Show Pin”にチェックを
入れることで表示させます。

OMEGAピンを”Show Pin”にチェッ
クを入れることで表示させます。

”Ground”アイコン
から接続してください。
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• 引き続き回路図を編集します。



LR_Model2：インスタンスの設定

JのValue欄を”0.075”に変更します。
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• 配置した各インスタンスは以下のように設定ください。

①KPのValue欄に未定義の”ke”を
入力します。

②”ke”は未定義のため自動的に変数
の設定ダイアログが表示されます。
Value欄に”1”を入力してください。



• 過渡解析の条件を設定します。

LR_Model2：解析条件の設定

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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• 回路図に対して、解析結果を表示するための設定を行います。

LR_Model2：グラフの設定/挿入

①LR_Model1で挿入したグラフを削除します。
②改めてグラフを挿入します。

メニューは下記です。
[Draw] > [Report] > [Rectangular Stacked Plot]

③グラフを配置する位置を任意で決めます。
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• 回路図に対して、解析結果を表示するための設定を行います。

LR_Model2：グラフの設定/挿入

⑤”Add Trace”ボタンを押します。

④ダイアログボックス内で以下のように設定します。
Category：All
Quantity： R1.I; MASS_ROTB1.OMEGA

※Ctrlキーを押しながら複数を指定可能です。
赤枠のようにY欄で指定する場合は”;”で
複数指定します。

Function：<none>

⑥引き続きダイアログボックス内で以下のよ
うに設定します。

Category：All
Quantity： DCMP1.IA; DCMP1.OMEGA
Function：<none>

⑦”Add Trace”ボタンを押し
“Close”ボタンで終了します。
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• 設定した内容で過渡解析を行い結果を表示します。

LR_Model2：解析と結果

①Project Manager上のAnalysis内のTR
を選択します。
②右クリックより”Analyze”メニューを実
行します。

解析結果
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• 例題1-2 Motor_Basicプロジェクトを保存します。下記のいず
れかの方法で実行してください。
– File > Save / Save As...

– Saveアイコン

– Ctrl + S

Motor_Basic：保存

回路図や結果にアップデートがある場合、
プロジェクト、またはデザイン名の横に
“*” が付きます。
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体験例題1-3
モータからの発熱

• モータからの損失をもとに熱の計算を組み込んでみる



概要：熱回路との連携
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• モータから発生する発熱は、モータケースやヒートシンクを
伝って放熱されます。

• 各パーツでの熱抵抗と熱容量をモデル化し、各部の温度変化を
確認してみましょう。

1.5→3.0Vの電圧波形の入力

モータの損失

モータケースの
熱抵抗と熱容量

ヒートシンクの
熱抵抗と熱容量

空間への
熱伝達と空間温度



プロジェクトとデザイン

• 新たにプロジェクトを用意します。デザインは自動的に挿入さ
れます。

①File > New メニューを選びます。 ②新規で作成されたプロジェクト
(Project1)とデザイン(TwinBuilder1)の
名前を変更します。

Project1 → Motor_Appli
TwinBuilder → 1.Motor_StepV
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1.Motor_StepV：回路図のコピー
• 演習2で作成した回路図を利用します。下記手順で回路図をコ

ピーします。

①Motor_Basicプロジェクト内のLR_Model2を
ダブルクリック
②LR_Model2の下の回路図全体をセレクトし
ます。左クリック後、カーソルで囲むことでセ
レクト可能です

③右クリックで
”Copy”を実行します。

④Motor_Aplliプロジェクトの
1.Motor_StepVをダブルクリック

⑤右クリックで”Paste”します。
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• コピーした回路図を編集します。 Component Librariesに格納
されるモデルは右図を、完成図は左図を参考に回路図を作成し
てください。

1.Motor_StepV：回路図作成

EMFピンを”Show Pin”にチェックを入れる
ことで表示させます。
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1.Motor_StepV：LUTの編集①

①DATAPAIRSをダブルクリック

②”Characteristic”ボタンをクリック

③”Datasets...”ボタンをクリック

④”Add...”ボタンをクリック
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• 配置したDATAPAIRSのルックアップテーブル(LUT)を編集す
るため下記の操作を行います。



1.Motor_StepV：LUTの編集②

⑤XY値を青枠の従い入力してください。
右には入力した数値を元にグラフが表示
されます。

⑥”OK”ボタンをクリック
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• データセットは以下のように設定してください。



• 過渡解析の条件を設定します。

1.Motor_StepV：解析条件の設定

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。

© 2023 CYBERNET SYSTEMS CO., LTD. All Rights Reserved. EX1-57



• 回路図に対して、解析結果を表示するための設定を行います。

①グラフを挿入します。
メニューは下記です。
[Draw] > [Report] > [Rectangular Stacked Plot]

②グラフを配置する位置を任意で決めます。
③ダイアログボックス内で以下のように設定します。

Category：All
Quantity： DATAPAIRS1.VAL; DCMP1.IA; DCMP1.OMEGA 

※Ctrlキーを押しながら複数を指定可能です。
赤枠のようにY欄で指定する場合は”;”で複数指定します。

Function：<none>

④”Add Trace”ボタンを押します。
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1.Motor_StepV：グラフ設定/挿入



• 設定した内容で過渡解析を行い結果を表示します。

1.Motor_StepV：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。

解析結果
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①1.Motor_StepVをセレクト

②右クリックから”Copy”メニューを選択

④デザイン名を”2.Motor_Thermal”
に変更します。

③Motor_Appliをセレクトし、右クリック
から”Paste”を選択します。
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2.Motor_Thermal：デザインコピー

• 1.Motor_StepVを利用して別デザインを作成します。
下記手順でデザインのコピーとデザイン名を変更します。



• 回路図を編集します。 Component Librariesに格納されるモデ
ルは右図を、完成図は左図を参考に回路図を作成してください。

2.Motor_Thermal：回路図作成

DCMPのPWRLOSSピンを”Show Pin”に
チェックを入れることで表示させます。

Heat Flow SorceのVALUEピンを”Show 
Pin”にチェックを入れることで表示させます。

”Ground”アイコン
から接続してください。
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2.Motor_Thermal：初期値の設定

アイコンをクリックし、追加された
行に” Tamb:=293”を入力します。
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• 配置したFML_INITは以下のように設定ください。



2.Motor_Thermal：熱抵抗の設定

Value欄に”1.5”を設定

Value欄に”0.2”を設定

Value欄に”1.5”を設定
© 2023 CYBERNET SYSTEMS CO., LTD. All Rights Reserved. EX1-63

• 配置したThermal Resistanceの各インスタンスは以下のよう
に設定ください。



2.Motor_Thermal：熱容量の設定
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• 配置した各Thermal Capacitanceは以下のように設定ください。

熱容量：0.1
初期温度：Tamb

熱容量：0.5
初期温度：Tamb



Value欄に”Tamb”を設定
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• 配置したTemperature Sourceを以下のように設定ください。

2.Motor_Thermal：絶対温度の設定



• 過渡解析の条件を設定します。

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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2.Motor_Thermal：解析条件の設定



• 回路図に対して、解析結果を表示するための設定を行います。
既存のものはそのままでグラフを追加します。

①グラフを挿入します。
メニューは下記です。
[Draw] > [Report] > [Rectangular Plot]

②グラフを配置する位置を任意で決めます。
③ダイアログボックス内で以下のように設定します。

Category：All
Quantity： CTH1.T; CTH2.T 

※Ctrlキーを押しながら複数を指定可能です。
赤枠のようにY欄で指定する場合は”;”で複数指定します。

Function：<none>

④”Add Trace”ボタンを押します。
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2.Motor_Thermal：グラフ設定/挿入



• 設定した内容で過渡解析を行い結果を表示します。

2.Motor_Thermal：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。

解析結果
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体験例題1-4
モータの速度制御

• モータの速度制御をやってみる



概要：モータの速度制御
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• モータの回転速度を目標値に制御するフィードバック回路を組
み込んでみましょう。

• フィードバック係数（GAINの値）を変更することで目標値に
制御されるまでの時間が変化する様子を確認できます。

回転速度

目標の回転速度

目標値－回転速度の演算

差分×係数を加える

投入する電圧を加算

電圧初期値



① 2.Motor_Thermalをセレクト

②右クリックから”Copy”メニューを選択

④デザイン名を” 3.Motor_Cont”に
変更します。

③Motor_Appliをセレクトし、右クリック
から”Paste”を選択します。
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3.Motor_Cont：デザインコピー

• 2.Motor_Thermalを利用して別デザインを作成します。
下記手順でデザインのコピーとデザイン名を変更します。



• 回路図を編集します。 コピーしてきた回路図で
不要なインスタンスを下記のように削除してください。

3.Motor_Cont：回路図作成①
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• DCMPの設定を変更します。下記の手順で変更してください。

3.Motor_Cont：回路図作成②

① DCMP1をダブルクリックします。

②Output / Displayタブを開きます。

③右のようにOMEGAとPWRLOSS
の”Show Pin”の設定を変更します。
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• 回路図を編集します。 使用するモデルは右図を、完成図は左図
を参考に回路図を作成してください。

3.Motor_Cont：回路図作成③
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※上下反転

※左右反転



3.Motor_Cont：固定値の設定
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• 配置したCONST1/CONST2では固定値を以下のように設定し
てください。



3.Motor_Cont：比例ゲインの設定

①KPのValue欄に未定義の”kp”を
入力します。

②”kp”は未定義のため自動的に変数
の設定ダイアログが表示されます。
Value欄に”5”を入力してください。
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• 配置したGAINで比例ゲイン(KP)を変数kpとします。設定は下
記を参照してください。



• 過渡解析の条件を設定します。

①Project Manager上のAnalysis内のTR
をダブルクリックします。

②表示されたダイアログボックスで下記
のように解析条件を設定します。
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3.Motor_Cont：解析条件の設定①



• 既存のグラフを削除し、新たに2つのグラフを追加します。

①グラフを挿入します。
メニューは下記です。
[Draw] > [Report] > [Rectangular Stacked Plot]

②グラフを配置する位置を任意で決めます。
③ダイアログボックス内で以下のように設定します。

Category：All
Quantity： SUM1.VAL; SUM2.VAL; DCMP1.OMEGA 

※Ctrlキーを押しながら複数を指定可能です。
赤枠のようにY欄で指定する場合は”;”で複数指定します。

Function：<none>

④”Add Trace”ボタンを押します。

⑤同じようにもう1つグラフを挿入します。
メニューは下記です。
[Draw] > [Report] > [Rectangular Plot]

⑥グラフを配置する位置を任意で決めます。
⑦ダイアログボックス内で以下のように設定し
ます。

Category：All
Quantity： NEG1.VAL 
Function：<none>

⑧”Add Trace”ボタンを押します。
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3.Motor_Cont：グラフ設定/挿入



• 設定した内容で過渡解析を行い結果を表示します。

3.Motor_Cont：解析と結果

①Project Manager上のAnalysis内のTRを選択します。
②右クリックより”Analyze”メニューを実行します。
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解析結果



• 例題1-3 Motor_Appliプロジェクトを保存します。下記のいず
れかの方法で実行してください。
– File > Save / Save As...

– Saveアイコン

– Ctrl + S

Motor_Appli：保存

回路図や結果にアップデートがある場合、
プロジェクト、またはデザイン名の横に
“*” が付きます。
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