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Release Highlights for CAM350 Product Version 10.7 

 
 

Introduction 

CAM350 Version 10.7 is a support release that introduces new functionality, including 
encryption of CAM350 macros. 

New Functionality 
The following functional enhancements are contained in CAM350 Version 10.7 
 

 Encryption of CAM350 macros 
 

 Clear Silkscreen Utility Update 
 
 

Details 
Macro Encryption – CAM350 VB scripts can now be encrypted.  Encryption allows 
customers to distribute CAM350 macros without losing intellectual property (IP).  Macro 
playback is updated to accept either decrypted or encrypted CAM350 macros. 
 
Clear Silkscreen Update – The CAM350 utility command the removes silkscreen from 
solder mask openings has been enhanced.  Previously, the clear silkscreen command only 
operated on drawn silkscreen data.  Now any combination of silkscreen and solder mask 
data types are compared and operating upon in the clear silkscreen operation. 
 
Defect Fixes – Software corrections have been made to previously existing functionality, 
further improving upon CAM350’s quality and reliability: 

 
 
Highlights from Earlier Versions of 10.x 

CAM350 10.6 introduces Flying Probe export to Microcraft tester format. The Microcraft 
testers support continuity and isolation tests on both side of PCB board.  CAM350 10.6 
supports import of spline geometry formats from DXF files.  CAM350 10.6 supports 
zoom control for viewing Streams Rules Check errors. 

CAM350 Version 10.5 introduces important new functionality, including the Design 
Analyzer, new data translation updates for BluePrint-PCB integration, Large Address 
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Aware (LAA) implementation for expanded memory access, Pastemask rules checks, 
Stream Rules Checks updates, and DXF interface updates. 

CAM350 Version 10.2 is a support release for CAM350.  CAM350 10.2 includes Gerber 
import improvements for polygon self intersection analysis and DRC analysis accuracy 
updates for polygon outlines with arcs. 

CAM350 Version 10.1 is a support release for CAM350.  CAM350 10.1 includes 
performance improvements and memory usage improvements over previous releases of 
CAM350. Areas of improved performance include Gerber import and ODB++ import. 
Optimization for memory usage is delivered in CAM350 10.1 for all polygon analysis, 
which means that larger more complex layers of polygons can now be processed for 
commands such as Netlist Extract and Gerber Import. CAM350 10.1 also delivers over 
50 important customer reported defect resolutions. 

CAM350 Version 10.0 introduced significant new functionality, including reading and 
writing BluePrint-PCB files, new graphics user interface, a project explorer bar, flip 
panel support, design compare, Expedition cross probing, and various enhancements. 
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Defect fixes for CAM350 V10.7 

Software corrections and enhancements have been made to previously existing functionality, further 
improving upon CAM350’s quality and reliability: 
 
 
*** CAM350 BUILD 564 **** 
 
 
FILE > IMPORT 
-------------- 
 
Areas affected: File Import ODB++ 
Symptoms: For certain ODB++ files from Genesis, mirrored rotated pads may not be 
imported correctly. 
Reference number: 54887 
 
Areas affected: File Import DXF 
Symptoms: For certain DXF files with long multi-line strings, the File Import 
DXF command fails to complete. 
Reference number: 54993 
 
 
FILE > EXPORT 
-------------- 
 
Areas affected: File Export DXF 
Symptoms: For certain DXF files, the File Export DXF command fails to complete for 
R14 DXF format. 
Reference number: 54904 
 
ANALYSIS 
--------------- 
 
Areas affected: Pad to Drill Check 
Symptoms: When the DRC or Streams RC check for Pad to Drill spacing is run, errors 
are missed for pads that are contained within drills. 
Reference number: 54893 
 
 
EDIT > LINE CHANGE 
-------------- 
 
Areas affected: Segments To Arcs 
Symptoms: For certain design files, the Edit > Line Change > Segments To Arcs 
command incorrectly converts segments to arcs. 
Reference number: 54908 
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UTILITIES 
--------------- 
 
Areas affected: Draw To One-Up Border 
Symptoms: The Utilities > Draw to One-up Border command fails to create correct board 
outlines when the selected drawn lines contain arcs that have not been sectorized. 
Reference number: 54370 
 
 
*** CAM350 BUILD 558 **** 
 
FILE > IMPORT 
-------------- 
 
Areas affected: File Import IPC-D356A 
Symptoms: For certain IPC-D356A netlist files with long net name mapping, the long  
versions of net names are not imported properly. 
Reference number: 54866 
 
EDIT 
-------- 
 
Areas affected: Edit Commands 
Symptoms: The D-Code filter for the Edit commands such as Move does not accept more 
than ten (10) D-Codes. 
Reference number: 43239 
 
ANALYSIS 
--------------- 
 
Areas affected: Netlist Compare 
Symptoms: For certain CAM files, if you run netlist extract after running Netlist 
Compare, successive Netlist Compare executions will fail to complete. 
Reference number: 54799 
 
Areas affected: Track to Pad Check 
Symptoms: When the DRC or Streams RC check for Track to Pad spacing is run, 
clearance errors are missed for certain CAD designs. 
Reference number: 54505 
 
Areas affected: Pad to Drill Check 
Symptoms: When the DRC or Streams RC check for Pad to Drill  spacing is run, false 
clearance errors are reported for laser drills that are placed within SMD pads. 
Reference number: 54549 
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Areas affected: Streams RC 
Symptoms: When the command Run One-Up Border is executed to run Streams RC 
checks, any area exclusions that defined for the executed checks are ignored. 
Reference number: 54086 
 
Areas affected: Streams RC 
Symptoms: For certain graphics cards, Streams RC results tab will cause the graphics 
screen to flicker. 
Reference number: 54795 
 
Areas affected: Streams RC 
Symptoms: When the Streams RC check for Copper Slivers is run, false errors may occur 
when small pin holes exist and cause copper slivers to be detected. 
Reference number: 54586 
 
 
 
 
UTILITIES 
--------------- 
 
Areas affected: Clear Silkscreen 
Symptoms: The Utilities > Clear Silkscreen command does not handle different 
combinations of silkscreen and solder mask data types. For example, Clear Silkscreen 
only works for drawn silkscreen items; it needs support for flashes and polygons. 
Reference number: 34781 
 
PANEL EDITOR 
--------------- 
 
Areas affected: Panel Editor 
Symptoms: For various zoom levels in the Panel Editor, polygon fill is dropped for 
certain panel designs with polygons and stepped images. 
Reference number: 54458 
 
MACROS 
--------------- 
 
Areas affected: Macro Scripting 
Symptoms: Macro commands should support encryption so that CAM350 users can 
create and distribute CAM350 macros without losing the intellectual property (IP) that is 
contained in the CAM350 macros. 
Reference number: 54682 
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*** CAM350 BUILD 517 **** 
 
FILE > OPEN 
--------------- 
 
Areas affected: File Open 
Symptoms: The File > Open command fails to complete for certain old version CAM 
files with complex custom apertures. 
Reference number: 54746 
 
FILE > IMPORT 
--------------- 
 
Areas affected: File Import Gerber 
Symptoms: The File > Import > Gerber creates duplicate Dcodes on import rather than 
reusing existing Dcodes for certain Gerber files. 
Reference number: 51576 
 
Areas affected: File Import DXF 
Symptoms: The File > Import > DXF creates text that is incorrectly offset for certain 
DXF files with MTEXT (embedded text style) constructs. 
Reference number: 54737 
 
Areas affected: File Import Mill Data 
Symptoms: The File > Import > Mill Data incorrectly imports arcs in the IJ format for 
Sieb & Meyer format NC data files. 
Reference number: 54243 
 
FILE > PRINT 
--------------- 
 
Areas affected: File Print 
Symptoms: The File > Print fails to output text and filled polygons for certain CAM350 
database files. 
Reference number: 54714 
 
EDIT COMMANDS 
--------------- 
 
Areas affected:  
Symptoms: After you delete a polygon vertex, the Copy, Move and Delete commands do 
not select the edited polygon when you use the "Select All" command button. 
Reference number: 53960 
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ADD COMMANDS 
--------------- 
 
Areas affected: Add Polygon 
Symptoms: The Add > Polygon fails to maintain specified clearance when pouring 
around shapes for certain CAM files. 
Reference number: 54224 
 
 
 
 
 
 
UTILITIES 
--------------- 
 
Areas affected: Teardrops 
Symptoms: The Teardrops command fails to maintain specified clearance when creating 
teardrops for certain CAM files. 
Reference number: 54727 
 
 
ANALYSIS 
--------------- 
 
Areas affected: Find Pin Holes 
Symptoms: The Analysis Pin Holes command fails to find some pin holes for certain 
CAM files. 
Reference number: 54780 
 
 
 
*** CAM350 BUILD 514 **** 
 
FILE > IMPORT 
--------------- 
 
Areas affected: File Import and Export ODB++ 
Symptoms: The File > Import > ODB++ command incorrectly imports drilled slots from 
ODB++ files when slots are defined as oval pad symbols.   
Reference number: 54535 
 
Areas affected: File Import ODB++ 
Symptoms: The File > Import > ODB++ command incorrectly imports certain Expedition 
ODB++ files that have negative planes definitions with anti-pads. 
Reference number: 54510 
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 Areas affected: File Import CAD Data 
Symptoms: The File > Import > CAD data command incorrectly imports PADS ASCII 
files for free standing copper cutouts defined for decal pads. 
Reference number: 54558 
 
 
 
 
Areas affected: File Import CAD Data 
Symptoms: The File > Import > CAD data command incorrectly imports PADS ASCII 
files for rotated SMD components that have thermal pad definitions for split mixed plane 
polygons. 
Reference number: 54571 
 
 Areas affected: File Import Gerber Data 
Symptoms: The File > Import > Gerber Data incorrectly repairs self intersecting 
polygons for bow tie shaped polygons that have four edges.   
Reference number: 54539 
 
Areas affected: File Import DXF 
Symptoms: The File > Import > DXF creates text that is undersized for rotated text in a 
DXF file that was created by exporting the text to R2004 format. 
Reference number: 54594 
 
Areas affected: File Import DXF 
Symptoms: The File > Import > DXF incorrectly imports special characters (for example, 
the degree character and the diameter symbol) when the code page is Chinese. 
Reference number: 53967 
 
 
Areas affected: File Import DXF 
Symptoms: The File > Import > DXF fails to complete for certain DXF files. 
Reference number: 39444 
 
 
FILE > EXPORT 
--------------- 
 
Areas affected: File Export Panel Gerber Data 
Symptoms: The File > Export Panel > Gerber Data results in Gerber files with undefined 
apertures for certain panel designs with flipped stepped images.   
Reference number: 54459 
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Areas affected: File Export ODB++ 
Symptoms: The File > Export > ODB++ command  causes duplicate drill hit definitions 
in the exported ODB++ file.  The drill count is incorrectly increased after ODB++ export. 
Reference number: 54506 
 
Areas affected: File Export ODB++ 
Symptoms: The File > Export > ODB++ command  does not export the nonplated status 
for drill hits for NC layers. 
Reference number: 54530 
 
 
Areas affected: File Export ODB++ 
Symptoms: The File > Export > ODB++ command  fails to complete for certain 
CAM350 database that are reverse engineered. 
Reference number: 54536 
 
 
Areas affected: File Export DXF 
Symptoms: The File > Export > DXF command  fails to complete for certain CAM350 
database files with empty strings. 
Reference number: 54541,54485 
 
 
FILE > MERGE 
--------------- 
 
Areas affected: File Merge 
Symptoms: When the File > Merge command merges databases with all graphic layers, 
after the merge operation is complete,  the merged data cannot be exploded nor edited. 
Reference number: 54575 
 
 
 
 
FILE > OPEN 
--------------- 
 
Areas affected: File Open BluePrint file 
Symptoms: The File > Open command for a BluePrint database file may incorrectly drop 
SMT pads when the pads are centered on vias.   
Reference number: 54695 
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 FILE > PRINT 
--------------- 
 
Areas affected: File Print 
Symptoms: The File > Print command incorrectly assigns colors to drill tools when you 
print to a color printer or plotter from the NC Editor.   
Reference number: 54321 
 
 
 
EDIT 
--------------- 
 
Areas affected: Copy NC Data 
Symptoms: The Edit > Copy command results in reverse order for mill paths when 
copying mill paths from one layer to another layer and the source layer also contains drill 
paths. 
Reference number: 53929 
 
 
ANALYSIS 
--------------- 
 
Areas affected: Streams RC 
Symptoms: The View > Streams RC command should include zoom controls to specify 
the minimum and maximum zoom level for the graphics port when cross probing errors 
in the Streams results tab. 
Reference number: 53694 
 
Areas affected: Trace to Pad DRC 
Symptoms: The DRC check for Trace to Pad misses certain trace to pad violations for 
certain noncircular pads. 
Reference number: 54505,54597  
 
 
 
 
 
MACROS 
------------------- 
 
Areas affected: Variable Text 
Symptoms: When playing back a macro that defines the values for variable text in Panel 
Symbols, the variable text values are not properly set for the associated symbols. 
Reference number: 53931 
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PANEL EDITOR 
--------------- 
 
Areas affected: Panel View Zoom 
Symptoms: The View Zoom commands drops polygon display when zoomed in for 
certain panel designs with polygons and stepped images. 
Reference number: 53466 
 
 
 
*** CAM350 BUILD 471 **** 
 
Areas affected: File Import ODB++ 
Symptoms: The File > Import > ODB++ command  results in incorrect pad orientation 
for certain Allegro ODB++ files when assymetric pads are offset from pin centers for 
components and those components are placed on the bottom of the PCB board. 
Reference number: 54455 
 
 
LICENSING 
--------------- 
 
Areas affected: Hardware Key Support 
Symptoms: A single license file cannot be used to specify license features for more than 
one dongle. 
Reference number: 53959 
 
 
PANEL EDITOR 
--------------- 
 
Areas affected: Panel Centroid Report 
Symptoms: The Info Report Centroid command reports incorrect component rotations 
when stepped images in the panel definition are rotated. 
Reference number: 54432 
 
 
 
ANALYSIS 
--------------- 
 
Areas affected: Streams RC 
Symptoms: For certain designs with complex one-up borders, Streams run using One-up 
Border may fail to complete. 
Reference number: 54392 
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*** CAM350 BUILD 468 **** 
 
FILE > SAVE 
--------------- 
 
Areas affected: File Save Panel NC Data 
Symptoms: The File > Save command fails to save any change made to Panel NC Drill 
data by using the Utilities > Sort Drills Hits command to sort the Panel NC drill path. 
Reference number: 54312 
 
 
FILE > IMPORT 
--------------- 
 
Areas affected: File Import ODB++ 
Symptoms: The File > Import > ODB++ command  results in incorrect  pad orientation 
for certain Allegro ODB++ files when pads are offset from pin centers for components 
and those components are placed on the bottom of the PCB board. 
Reference number: 54333,54334 
 
Areas affected: File Import DXF 
Symptoms: The File > Import > DXF command fails to complete for certain DXF files 
that have font definitions that are not installed in the Windows OS. 
Reference number: 54362 
 
 
Areas affected: File Import GENCAD 
Symptoms: The File > Import > CAD data command fails to complete for certain 
GENCAD files that have FILLED keywords in the ROUTES sections of the file format. 
Reference number: 54387 
 
 
 
 
 
FILE > EXPORT 
--------------- 
 
Areas affected: File Import Zuken Redac 
Symptoms: The File > Export > CAD data command fails to complete for certain 
CAM350 files that have paste mask layers in the component footprint definitions. 
Reference number: 54387 
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ANALYSIS 
--------------- 
 
Areas affected: Design Analyzer 
Symptoms: Design Analyzer does not report SMD pad criteria when components are not 
defined in the CAM file. 
Reference number: 54373 
 
 
 
*** CAM350 BUILD 464 **** 
 
FILE > OPEN 
--------------- 
 
Areas affected: File Open Large Designs 
Symptoms: The File > Open command may fail to open large CAM350 database files 
and report out of memory.  The repair for this problem is only delivered for Windows XP 
64 bit or Windows 7 64 bit. 
Reference number: 53510 
 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import Gerber Data 
Symptoms: The File > Import > Gerber command fails to complete for certain files with 
complex polygons. 
Reference number: 53952,54174 
 
 
 
Areas affected: Import PADS ASCII 
Symptoms: The File > Import > CAD Data command for PADS ASCII files does not 
support decal copper voids for certain PADS Layout designs.  
Reference number: 54146 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may fail to complete for certain 
Genesis ODB++ files that have internal parameters for pad feature oversize or undersize. 
Reference numbers: 54230 
 
 



CAM350 Version 10.7 Build 564                                                                 5/4/2012 

DownStream Technologies, LLC,  Copyright © 2006-2011 14 of 29 

Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may shift component pads that are 
offset from pin centers for certain Allegro and Expedition ODB++ files. 
Reference numbers: 54249,54261 
 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may drop component pads that are 
offset from pin centers for certain Allegro ODB++ files. 
Reference numbers: 54201, 54109 
 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may not properly define blind and 
buried layer pairs for certain Allegro ODB++ files. 
Reference number: 53255 
 
 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may fail to complete for certain DXF 
files. 
Reference number: 53962,54238,54247,54248 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may drop circles for certain DXF files. 
Reference number: 53721 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may fail to properly import arcs for 
certain DXF files. The arcs are shifted or offset. 
Reference number: 53306 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may fail to properly import embedded 
text styles for certain DXF files. 
Reference number: 54089 
 
 
Areas affected: Import CAD Data - GENCAD 
Symptoms: The File > Import > CAD Data command may fail to properly import custom 
pads for certain GENCAD files with FILLED keywords. 
Reference number: 54193 
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Areas affected: Import CAD Data - GENCAD 
Symptoms: The File > Import > CAD Data command may fail to complete for certain 
GENCAD files with FILLED keywords. 
Reference number: 54192 
 
Areas affected: Import CAD Data - GENCAD 
Symptoms: The File > Import > CAD Data command may fail to create correct padstacks 
for certain GENCAD files with FILLED keywords. 
Reference number: 54191 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export Gerber Data 
Symptoms: The File > Export > Gerber command may fail to complete certain designs 
with complex polygons. 
Reference number: 54235 
 
 
 
 
Areas affected: Export DXF 
Symptoms: The File > Export > DXF command may fail to fill circles for the exported 
DXF file for certain design data.   
Reference number: 53961 
 
 
EDIT 
--------------- 
 
Areas affected: Rotate 
Symptoms: The Edit > Rotate command may result in incorrect display of raster 
polygons with arcs. 
Reference number: 54237 
 
 
 
 
 
ANALYSIS 
--------------- 
 
Areas affected: Streams Execution 
Symptoms: Stream RC execution fails to complete for certain designs for isolated thermal 
check with complex negative planes. 
Reference number: 53437 
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Areas affected: Streams Execution 
Symptoms: Stream RC execution fails to complete for certain designs for track to pad 
check for large designs. 
Reference number: 53214 
 
Areas affected: Streams Negative Plane Checks 
Symptoms: The Negative Plane Check analysis for Isolated Plane Thermals may fail to 
complete for certain complex negative planes. 
Reference number: 53958, 53953, 53911, 53588 
 
 
Areas affected: Streams Pastemask Checks 
Symptoms: Pastemask analysis checks are requested by the user to verify pastemask 
configuration with respect to soldermask, copper and through holes pads. 
Reference number: 53855 
 
 
Areas affected: Streams Signal Checks 
Symptoms: Signal Layer analysis checks may hang on Track to Pad (TP) analysis for 
certain design databases. 
Reference number: 53792 
 
 
Areas affected: Streams Signal Checks 
Symptoms: Positive Plane Layer analysis checks may fail to complete for certain design 
databases. 
Reference number: 53787 
 
Areas affected: Stream Rules Checks 
Symptoms: True arc analysis may cause poor execution performance times for certain 
design databases. 
Reference number: 53662 
 
Areas affected: Streams Signal Checks 
Symptoms: Signal Layer analysis checks for Pads without Drills (PWOD) may cause 
false errors for designs with SMD pads on top and bottom sides at the same location. 
Reference number: 54221 
 
Areas affected: Streams Signal Checks 
Symptoms: Signal Layer analysis checks for Unplated Drills to Copper (UDC) and Plated 
Drills to Copper (DC) may cause false errors for so-called spot pads that are smaller than 
the drill sizes. 
Reference number: 53767 
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Areas affected: Streams Execution 
Symptoms: Stream RC execution fails to complete for certain designs for isolated thermal 
check with complex negative planes. 
Reference number: 53437 
 
Areas affected: Find Pin Holes 
Symptoms: When Pin Holes are automatically fixed by the Analysis > Find Pin Holes 
command, polygon voids may be incorrectly removed for certain designs. 
Reference number: 54197 
 
 
 
 
 
 
 
UTILITIES 
--------------- 
 
Areas affected: Netlist Extract 
Symptoms: The Utilities > Net Extract command does not properly merge stacked vias 
into the same net for stacked vias which are located at the same position and terminate on 
a negative plane. 
Reference number: 54141 
 
Areas affected: Netlist Extract 
Symptoms: The Utilities > Net Extract command may short nets together erroneously 
when mill route data is present in the design database. 
Reference number: 54043, 54018 
 
Areas affected: Netlist Extract 
Symptoms: The Utilities > Net Extract command may fail to complete for large 
databases. 
Reference number: 54223 
 
Areas affected: Netlist Extract 
Symptoms: The Utilities > Net Extract command may fail to complete for certain 
designs. 
Reference number: 54262 
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Areas affected: Draw To Flash 
Symptoms: The Utilities > Draw To Flash > Any Angle command may fail to complete 
for large databases.  The repair for this problem is only delivered for Windows XP 64 bit 
or Windows 7 64 bit. 
Reference number: 54222 
 
Areas affected: Remove Covered Data 
Symptoms: The Utilities > Data Optimization > Remove Covered Data command may 
incorrectly remove pads that are not covered. 
Reference number: 45273,51482 
 
Areas affected: Remove Covered Data 
Symptoms: The Utilities > Data Optimization > Remove Covered Data command may 
fail to complete for certain designs. 
Reference number: 48842 
 
 
 
 
 
 
 
REPORTS 
--------------- 
 
Areas affected: Info Report Centroid 
Symptoms: The Info > Report > Centroid command may fail to complete for design 
databases with long device names. 
Reference number: 53745 
 
 
USER INTERFACE 
--------------- 
 
Areas affected: View Dashboard 
Symptoms: After using the View > Dashboard command to turn off the Dashboard 
toolbar, if you then save the CAM file (or Save Defaults) and then load the saved CAM 
file, CAM350 may be unstable and may crash. 
Reference number: 54218 
 
Areas affected: Navigation Pane 
Symptoms: When the path name is long for imported Gerber files, selection of layer 
names in the Navigation Pane layer bar may cause CAM350 to crash. 
Reference number: 53788 
 
 



CAM350 Version 10.7 Build 564                                                                 5/4/2012 

DownStream Technologies, LLC,  Copyright © 2006-2011 19 of 29 

 
 
 
 
 
 
MACROS 
------------------- 
 
Areas affected: Netlist Import 
Symptoms: When playing back a macro that imports a netlist as an External Netlist into 
CAM350, the final dialog for the File > Import IPC356 or IPC356A command is 
erroneously displayed. 
Reference number: 54199 
 
 
 
 
 
*** CAM350 BUILD 401 **** 
 
FILE > OPEN 
--------------- 
 
Areas affected: Mill Route Visibility 
Symptoms: The File > Open command may fail to properly display mill  
routes for certain mill closed cutout shapes. 
Reference number: 54076 
 
 
ANALYSIS 
--------------- 
 
Areas affected: Streams RC Checks 
Symptoms: For certain design files with fine patterns, Streams RC may 
report erroneous errors for Track to Track and Plated Drill to Copper  
checks. 
Reference number: 54074 
 
INFO REPORTS 
--------------- 
 
Areas affected: Centroid Report 
Symptoms: For certain design files with long device names, the  
Info > Reports > Centroid command may fail to complete. 
Reference number: 54072 
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BED OF NAILS EDITOR 
-------------------- 
 
Areas affected: Export CircuitLine 
Symptoms: For certain design files, the File > Export command in the  
Bed Of Nails Editor may fail to complete for CircuitLine format. 
Reference number: 54075 
 
 
*** CAM350 BUILD 400 **** 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import Gerber 
Symptoms: The File > Import > Gerber Data command may fail or cause incorrect 
graphics for Gerber files that have undefined apertures. 
Reference number: 53976,53815 
 
Areas affected: Import Gerber 
Symptoms: The File > Import > Gerber Data command may fail for certain Gerber 
files that have the percent character ("%") in aperture macro names. 
Reference number: 42567 
 
 
 
 
Areas affected: Import PADS ASCII 
Symptoms: The File > Import > CAD Data command does not support PADS Layout 
version 9.2 ASCII files. 
Reference number: 54003 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may cause pads to shift for ODB++ 
files that contain pads that are offset from the associated component pin origins. 
Reference number: 53975 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command fails to properly import and  
flatten ODB++ files that contain flipped images. 
Reference number: 53778 
 
Areas affected: Import Drill Data 
Symptoms: The File > Import > Drill Data command does not support the Excellon 
command ("%SR*%") to end step and repeat data in drill files. 
Reference number: 53863 
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Areas affected: Import Drill Data 
Symptoms: The File > Import > Drill Data command may fail for certain Allegro 
generated NC Drill files. 
that have very small arcs. 
Reference number: 53486,51315,50813 
 
Areas affected: Import AutoImport 
Symptoms: The File > Import > AutoImport command fails to initialize colors for 
layers properly when the NEXT button is selected on the AutoImport dialog. 
Reference number: 53852 
 
 
 
 
 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export ODB++ 
Symptoms: The File > Import > ODB++ command may fail to export correct Mill  
data for certain Mill route definitions with arcs. 
Reference number: 53853 
 
 
 
 
 
 
PANEL EDITOR 
--------------- 
 
Areas affected: Edit Flip 
Symptoms: The Edit > Flip command may fail to properly display mill data that  
contains arcs for stepped images that are flipped. 
Reference number: 53847 
 
NC EDITOR 
--------------- 
 
Areas affected: Add Mill Tab 
Symptoms: The Add > Mill Tab command may incorrect add mill tab locations and  
associated perforations for certain jagged mill route patterns. 
Reference number: 53822 
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Areas affected: Settings View Options 
Symptoms: The Middle Mouse zoom setting will be lost after modifying and saving  
changes to the Settings > View Options dialog in the Panel Editor. 
Reference number: 54002 
 
Areas affected: Explode Step & Repeat Data 
Symptoms: The Edit > Change > Explode Step & Repeat command fails to report 
that step and repeat (SR) NC data does not exist in the current design. 
Reference number: 53848 
 
UTILITIES 
--------------- 
 
Areas affected: Netlist Extract 
Symptoms: The Utilities > Netlist Extract command may fail to complete for  
designs that have zero size Dcodes. 
Reference number: 53868 
 
 
USER INTERFACE 
--------------- 
 
Areas affected: Grid Visibility 
Symptoms: The Grid Visibility toggle on the command toolbar may cause CAM350 to 
crash when the dashboard toolbar is not visible. 
Reference number: 53872 
 
 
 
*** CAM350 BUILD 391 **** 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may fail for certain DXF files 
that have very small arcs. 
Reference number: 53874 
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*** CAM350 BUILD 391 **** 
 
 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import DXF 
Symptoms: The File > Import > DXF command may fail for certain DXF files 
that have very small arcs. 
Reference number: 53874 
 
Areas affected: Import Drill Data 
Symptoms: The File > Import > Drill Data command is incorrect for Seib&Meyer  
3000 files that have drilled slots (code G85). 
Reference number: 53835 
 
Areas affected: Import PADS ASCII 
Symptoms: The File > Import > CAD Data command will display reference  
designators that have PADS Label visibility set to "None". 
Reference number: 53844 
 
Areas affected: Import PADS ASCII 
Symptoms: The File > Import > CAD Data command may drop drill definitions 
for pad stacks that have square pads. 
Reference number: 53862 
 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export DXF 
Symptoms: The File > Import > DXF command will fail to complete when exporting 
DXF data and panel mill data layers are specified for output. 
Reference number: 53834 
 
EDIT 
--------------- 
 
Areas affected: Break At Vertex 
Symptoms: The Edit > Line Change > Break At Vtx command will fail to complete  
when modify segments for an added circle that has been sectorized. 
Reference number: 53866 
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ANALYSIS 
--------------- 
 
Areas affected: Streams Report 
Symptoms: The Info > Report > Streams Results command truncates net name lists 
for long names or long lists of net names. 
Reference number: 53776 
 
 
 
 
 
USER INTERFACE 
--------------- 
 
Areas affected: Cursor Display 
Symptoms: For certain Microsoft Intellimouse Mouse drivers, the CAM350 cursor 
graphics may disappear for various window commands. 
Reference number: 44126 
 
 
 
 
 
*** CAM350 BUILD 389 **** 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import Gerber 
Symptoms: The File > Import > Gerber command loses arc precision for polygons in for 
certain small designs. 
Reference number: 53699 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command incorrectly assigns nets to finger edge 
pads for certain files output by Mentor Expedition. 
Reference number: 53590 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command incorrectly imports bottom mounted 
finger connector components for certain ODB++ files. 
Reference number: 53686 
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Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command incorrectly handles angles for 
components and other elements for ODB++ files output by PADS Layout 9.1. 
Reference number: 53668 
 
Areas affected: Import PADS ASCII 
Symptoms: The File > Import > CAD Data command may drop custom apertures for 
PADS 9.x files when alphanumeric pin mapping does not specify all pins in a component. 
Reference number: 53675 
 
Areas affected: Import HPGL 
Symptoms: The File > Import > HPGL command fails to complete for certain HPGL files 
with filled polygons. 
Reference number: 53666 
 
 
 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export Gerber 
Symptoms: The File > Export > Gerber command may drop some features after the 
import DXF command is executed for certain DXF files with polygons. 
Reference number: 53672 
 
Areas affected: Export Gerber 
Symptoms: The File > Export > Gerber command may drop resolution for certain designs 
with filled polygons. 
Reference number: 53616 
 
Areas affected: Export Drill and Mill Data 
Symptoms: The File > Export > Drill Data and Mill Data command dialogs should 
support the Copy Names button to copy layer names to file names just as the Export 
Gerber dialog already does. 
Reference number: 53629 
 
ANALYSIS 
--------------- 
 
Areas affected: Find Pin Holes 
Symptoms: The Analysis > Find Pin Holes command may find false errors for certain 
designs with complex polygons. 
Reference number: 53663 
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Areas affected: Find Pin Holes 
Symptoms: The Analysis > Find Pin Holes command may fail to complete for certain 
designs with polygons that have arcs. 
Reference number: 53644 
 
Areas affected: Acid Traps 
Symptoms: The Analysis > Acid Traps command may find false errors for certain 
designs with complex polygons. 
Reference number: 53680 
 
 
UTILITIES 
--------------- 
 
Areas affected: Quick Part 
Symptoms: The Utilities > Quick Part command does not keep track of the side of the 
board on which the parts are placed. Quick Part should allow you to create parts from 
pads on the bottom side and match pads on either top or bottom side of the board. 
Reference number: 53135 
 
 
 
 
 
 
 
 
*** CAM350 BUILD 386 **** 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command may create invalid CAM data for  
certain ODB++ data files. 
Reference number: 53591 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export Composites 
Symptoms: The File > Export > Composites command may fail to complete for 
composite definitions created by deleting table entries. 
Reference number: 53597 
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EDIT 
--------------- 
 
Areas affected: Delete Segment 
Symptoms: The Delete Segment command may fail to complete for certain arcs or circles 
that have be sectorized. 
Reference number: 53631 
 
 
 
ANALYSIS 
--------------- 
 
Areas affected: DRC 
Symptoms: The Analysis > DRC command may fail to complete for certain designs with 
polygons that have arcs with out of memory message. 
Reference number: 53627 
 
Areas affected: Streams DFF 
Symptoms: The Streams DFF check for Copper for Border minimum gap may report 
false errors for certain board outlines with arcs. 
Reference number: 53660 
 
 
Areas affected: Streams Design Compare 
Symptoms: For an ODB++ file import, the Design Compare function reports false errors 
for TopPartOutline and BotPartOutline layers. 
Reference number: 53640 
 
UTILITIES 
--------------- 
 
Areas affected: Clear Silkscreen 
Symptoms: The Utilities > Clear Silkscreen command may fail to complete for certain 
CAM files. 
Reference number: 53595 
 
*** CAM350 BUILD 384 **** 
 
FILE IMPORT 
--------------- 
 
Areas affected: Import Gerber 
Symptoms: The File > Import > Gerber Data command drops certain voids for complex 
cutline polygons. 
Reference number: 53484 



CAM350 Version 10.7 Build 564                                                                 5/4/2012 

DownStream Technologies, LLC,  Copyright © 2006-2011 28 of 29 

 
Areas affected: Auto Import 
Symptoms: The File > Import > Auto Import command should load IPC-D-356 and  
IPC-D-356-A netlist formats. 
Reference number: 53551 
 
 
Areas affected: Drill Data 
Symptoms: The File > Import > Drill Data command does not support G85 (drilled slots) 
for Sieb & Meyer format. 
Reference number: 53160 
 
 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command fails to complete for certain Genesis 
files that have annular ring attributes and CAMTEK attributes. 
Reference number: 53573 
 
Areas affected: Import ODB++ 
Symptoms: The File > Import > ODB++ command fails to complete for certain Zuken 
files that illegal references to layers that are not defined. 
Reference number: 53577 
 
 
 
 
 
FILE EXPORT 
--------------- 
 
Areas affected: Export Gerber 
Symptoms: The File > Export > Gerber Data command does not properly export arcs that 
are in mirrored raster polygon outlines. 
Reference number: 53575 
 
 
UTILITIES 
--------------- 
 
Areas affected: Draw To Raster 
Symptoms: The Utilities > Polygon Conversion > Draw To Raster command displays the  
warning message for polygons with more than 16,000 vertices multiple times for one 
command. There should be an option to not display the warning again. 
Reference number: 53570 
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GUI 
--------------- 
 
Areas affected: Arc segmentation 
Symptoms: Arc graphics are not smooth for large arcs when you zoom such that the  
arc radius is larger than the width of the graphics port. 
Reference number: 53579 
 

 


