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Release Highlights for CAM350 Product Version 10.5

Introduction

CAM350 Version 10.5 introduces important new functionality, including the Design Analyzer, new data
translation updates for BluePrint-PCB integration, Large Address Aware (LAA) implementation for
expanded memory access, Pastemask rules checks, Stream Rules Checks updates, and DXF interface
updates.

New Functionality
The following functional enhancements are contained in CAM350 Version 10.5

Design Analyzer

BluePrint-PCB Integration Updates for Panel Data
Large Address Aware (LAA) expanded memory access
Pastemask Rules Checks

Stream Rules Checks Updates

DXF Interface Updates
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Details

Design Analyzer - The new Design Analyzer tool calculates the overall complexity of
the design for quoting purposes or for deciding which fabricator is qualified to
manufacture the design. Sometimes changing a few rules in the design may allow it to be
manufactured more quickly and accurately. The Design Analyzer allows the user to judge
the technology level of a particular design. A set of analyses are run on the design to
judge the complexity, not to look for design errors.

BluePrint-PCB Integration Updates for Panel Data - The File > Open command for
BluePrint-PCB (*.BPD) files has been updated to transfer additional Panel information
from the BluePrint-PCB database to CAM350 database. The File > Open command now
transfers pinning hole, fiducial and mill tab drills (perforations) from BluePrint-PCB to
CAM350. New Panel Symbols are defined for pinning holes and fiducials that are passed
from BluePrint-PCB to CAM350.

Large Address Aware (LAA) expanded memory access - The LAA update expands the
available memory from the standard 2 GB to a maximum of 4 GB for CAM350 on
Windows XP 64 bit and Windows 7 64 bit OS platforms. The new LAA support allows
users to load larger Gerber files and manage larger CAM files than previously possible.
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Pastemask Rules Checks - The new layer check type for Pastemask layer type has been
added to the Stream Rules Checks. The new Pastemask check includes verification for
Pastemask placement and clearance. The following checks are available for the
Pastemask layer type: (1) Pastemask on Throughhole Pads, (2) Missing Pastemask on
SMD parts, (3) Pastemask with no Solder Mask opening, and (4) PasteMask to Copper
annular ring check.

Stream Rules Checks Updates - Pads without Drills (PWOD) has been updated to
optionally ignore non-circular pads. Unplated Drills to Copper (UDC) and Plated Drills
to Copper (DC) checks have been updated to optionally ignore spot pads that are smaller
than the drill size. Performance improvements have been delivered by algorithm updates
for the following checks: Copper Slivers (CS), Solder Mask Slivers (MS), Track to Pad
(TP) and Track to Track (TT). Performance improvements also include true arc clearance
verification.

DXF Interface Updates - The File > Import > DXF command has been updated to
support embedded direct formatting of text objects in DXF R2004 format. The File >
Export > DXF command has been updated to support DXF version R2004.

Defect Fixes — Over 30 software corrections have been made to previously existing
functionality, further improving upon CAM350’s quality and reliability:

Highlights from Earlier Versions of 10.x

CAMB350 Version 10.2 is a support release for CAM350. CAM350 10.2 includes Gerber
import improvements for polygon self intersection analysis and DRC analysis accuracy
updates for polygon outlines with arcs.

CAM350 Version 10.1 is a support release for CAM350. CAM350 10.1 includes
performance improvements and memory usage improvements over previous releases of
CAM350. Areas of improved performance include Gerber import and ODB++ import.
Optimization for memory usage is delivered in CAM350 10.1 for all polygon analysis,
which means that larger more complex layers of polygons can now be processed for
commands such as Netlist Extract and Gerber Import. CAM350 10.1 also delivers over
50 important customer reported defect resolutions.

CAM350 Version 10.0 introduced significant new functionality, including reading and

writing BluePrint-PCB files, new graphics user interface, a project explorer bar, flip
panel support, design compare, Expedition cross probing, and various enhancements.

DownStream Technologies, LLC, Copyright © 2006-2011 20f 19



CAM350 Version 10.5 Build 471 5/9/2011

Defect fixes for CAM350 VV10.5

Software corrections and enhancements have been made to previously existing functionality, further
improving upon CAM350’s quality and reliability:

*** CAM350 BUILD 471 ****

Avreas affected: File Import ODB++

Symptoms: The File > Import > ODB++ command results in incorrect pad orientation
for certain Allegro ODB++ files when assymetric pads are offset from pin centers for
components and those components are placed on the bottom of the PCB board.
Reference number: 54455

LICENSING

Avreas affected: Hardware Key Support

Symptoms: A single license file cannot be used to specify license features for more than
one dongle.

Reference number: 53959

PANEL EDITOR

Avreas affected: Panel Centroid Report

Symptoms: The Info Report Centroid command reports incorrect component rotations
when stepped images in the panel definition are rotated.

Reference number: 54432

ANALYSIS

Areas affected: Streams RC

Symptoms: For certain designs with complex one-up borders, Streams run using One-up
Border may fail to complete.

Reference number: 54392

*** CAM350 BUILD 468 ****

FILE > SAVE

Areas affected: File Save Panel NC Data
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Symptoms: The File > Save command fails to save any change made to Panel NC Dirill
data by using the Utilities > Sort Drills Hits command to sort the Panel NC drill path.
Reference number: 54312

FILE > IMPORT

Avreas affected: File Import ODB++

Symptoms: The File > Import > ODB++ command results in incorrect pad orientation
for certain Allegro ODB++ files when pads are offset from pin centers for components
and those components are placed on the bottom of the PCB board.

Reference number: 54333,54334

Avreas affected: File Import DXF

Symptoms: The File > Import > DXF command fails to complete for certain DXF files
that have font definitions that are not installed in the Windows OS.

Reference number: 54362

Areas affected: File Import GENCAD

Symptoms: The File > Import > CAD data command fails to complete for certain
GENCAD files that have FILLED keywords in the ROUTES sections of the file format.
Reference number: 54387

FILE > EXPORT

Avreas affected: File Import Zuken Redac

Symptoms: The File > Export > CAD data command fails to complete for certain
CAM350 files that have paste mask layers in the component footprint definitions.
Reference number: 54387

ANALYSIS

Avreas affected: Design Analyzer

Symptoms: Design Analyzer does not report SMD pad criteria when components are not
defined in the CAM file.

Reference number: 54373

*** CAM350 BUILD 464 ****
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FILE > OPEN

Avreas affected: File Open Large Designs

Symptoms: The File > Open command may fail to open large CAM350 database files
and report out of memory. The repair for this problem is only delivered for Windows XP
64 bit or Windows 7 64 bit.

Reference number: 53510

FILE IMPORT

Areas affected: Import Gerber Data

Symptoms: The File > Import > Gerber command fails to complete for certain files with
complex polygons.

Reference number: 53952,54174

Areas affected: Import PADS ASCII

Symptoms: The File > Import > CAD Data command for PADS ASCI|I files does not
support decal copper voids for certain PADS Layout designs.

Reference number: 54146

Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may fail to complete for certain
Genesis ODB++ files that have internal parameters for pad feature oversize or undersize.
Reference numbers: 54230

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may shift component pads that are
offset from pin centers for certain Allegro and Expedition ODB++ files.

Reference numbers: 54249,54261

Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may drop component pads that are
offset from pin centers for certain Allegro ODB++ files.

Reference numbers: 54201, 54109

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may not properly define blind and
buried layer pairs for certain Allegro ODB++ files.

Reference number: 53255
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Avreas affected: Import DXF

Symptoms: The File > Import > DXF command may fail to complete for certain DXF
files.

Reference number: 53962,54238,54247,54248

Areas affected: Import DXF
Symptoms: The File > Import > DXF command may drop circles for certain DXF files.
Reference number: 53721

Areas affected: Import DXF

Symptoms: The File > Import > DXF command may fail to properly import arcs for
certain DXF files. The arcs are shifted or offset.

Reference number: 53306

Avreas affected: Import DXF

Symptoms: The File > Import > DXF command may fail to properly import embedded
text styles for certain DXF files.

Reference number: 54089

Areas affected: Import CAD Data - GENCAD

Symptoms: The File > Import > CAD Data command may fail to properly import custom
pads for certain GENCAD files with FILLED keywords.

Reference number: 54193

Areas affected: Import CAD Data - GENCAD

Symptoms: The File > Import > CAD Data command may fail to complete for certain
GENCAD files with FILLED keywords.

Reference number: 54192

Avreas affected: Import CAD Data - GENCAD

Symptoms: The File > Import > CAD Data command may fail to create correct padstacks
for certain GENCAD files with FILLED keywords.

Reference number: 54191

FILE EXPORT

Avreas affected: Export Gerber Data
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Symptoms: The File > Export > Gerber command may fail to complete certain designs
with complex polygons.
Reference number: 54235

Avreas affected: Export DXF

Symptoms: The File > Export > DXF command may fail to fill circles for the exported
DXF file for certain design data.

Reference number: 53961

Areas affected: Rotate

Symptoms: The Edit > Rotate command may result in incorrect display of raster
polygons with arcs.

Reference number: 54237

ANALYSIS

Avreas affected: Streams Execution

Symptoms: Stream RC execution fails to complete for certain designs for isolated thermal
check with complex negative planes.

Reference number: 53437

Avreas affected: Streams Execution

Symptoms: Stream RC execution fails to complete for certain designs for track to pad
check for large designs.

Reference number: 53214

Avreas affected: Streams Negative Plane Checks

Symptoms: The Negative Plane Check analysis for Isolated Plane Thermals may fail to
complete for certain complex negative planes.

Reference number: 53958, 53953, 53911, 53588

Avreas affected: Streams Pastemask Checks

Symptoms: Pastemask analysis checks are requested by the user to verify pastemask
configuration with respect to soldermask, copper and through holes pads.

Reference number: 53855

Avreas affected: Streams Signal Checks

Symptoms: Signal Layer analysis checks may hang on Track to Pad (TP) analysis for
certain design databases.

Reference number: 53792
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Areas affected: Streams Signal Checks

Symptoms: Positive Plane Layer analysis checks may fail to complete for certain design
databases.

Reference number: 53787

Avreas affected: Stream Rules Checks

Symptoms: True arc analysis may cause poor execution performance times for certain
design databases.

Reference number: 53662

Areas affected: Streams Signal Checks

Symptoms: Signal Layer analysis checks for Pads without Drills (PWOD) may cause
false errors for designs with SMD pads on top and bottom sides at the same location.
Reference number: 54221

Areas affected: Streams Signal Checks

Symptoms: Signal Layer analysis checks for Unplated Drills to Copper (UDC) and Plated
Drills to Copper (DC) may cause false errors for so-called spot pads that are smaller than
the drill sizes.

Reference number: 53767

Avreas affected: Streams Execution

Symptoms: Stream RC execution fails to complete for certain designs for isolated thermal
check with complex negative planes.

Reference number: 53437

Avreas affected: Find Pin Holes

Symptoms: When Pin Holes are automatically fixed by the Analysis > Find Pin Holes
command, polygon voids may be incorrectly removed for certain designs.

Reference number: 54197

UTILITIES

Areas affected: Netlist Extract

Symptoms: The Utilities > Net Extract command does not properly merge stacked vias
into the same net for stacked vias which are located at the same position and terminate on
a negative plane.

Reference number: 54141

Areas affected: Netlist Extract

Symptoms: The Utilities > Net Extract command may short nets together erroneously
when mill route data is present in the design database.

Reference number: 54043, 54018
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Areas affected: Netlist Extract

Symptoms: The Utilities > Net Extract command may fail to complete for large
databases.

Reference number: 54223

Avreas affected: Netlist Extract

Symptoms: The Utilities > Net Extract command may fail to complete for certain
designs.

Reference number: 54262

Areas affected: Draw To Flash

Symptoms: The Utilities > Draw To Flash > Any Angle command may fail to complete
for large databases. The repair for this problem is only delivered for Windows XP 64 bit
or Windows 7 64 bit.

Reference number: 54222

Areas affected: Remove Covered Data

Symptoms: The Utilities > Data Optimization > Remove Covered Data command may
incorrectly remove pads that are not covered.

Reference number: 45273,51482

Avreas affected: Remove Covered Data

Symptoms: The Utilities > Data Optimization > Remove Covered Data command may
fail to complete for certain designs.

Reference number: 48842

REPORTS

Avreas affected: Info Report Centroid

Symptoms: The Info > Report > Centroid command may fail to complete for design
databases with long device names.

Reference number: 53745

USER INTERFACE

Areas affected: View Dashboard
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Symptoms: After using the View > Dashboard command to turn off the Dashboard
toolbar, if you then save the CAM file (or Save Defaults) and then load the saved CAM
file, CAM350 may be unstable and may crash.

Reference number: 54218

Areas affected: Navigation Pane

Symptoms: When the path name is long for imported Gerber files, selection of layer
names in the Navigation Pane layer bar may cause CAM350 to crash.

Reference number: 53788

MACROS

Avreas affected: Netlist Import

Symptoms: When playing back a macro that imports a netlist as an External Netlist into
CAM350, the final dialog for the File > Import IPC356 or IPC356A command is
erroneously displayed.

Reference number: 54199

*xx CAM350 BUILD 401 ****

FILE > OPEN

Avreas affected: Mill Route Visibility

Symptoms: The File > Open command may fail to properly display mill
routes for certain mill closed cutout shapes.

Reference number: 54076

ANALYSIS

Avreas affected: Streams RC Checks

Symptoms: For certain design files with fine patterns, Streams RC may
report erroneous errors for Track to Track and Plated Drill to Copper
checks.

Reference number: 54074

INFO REPORTS
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Avreas affected: Centroid Report

Symptoms: For certain design files with long device names, the
Info > Reports > Centroid command may fail to complete.
Reference number: 54072

BED OF NAILS EDITOR

Areas affected: Export CircuitLine

Symptoms: For certain design files, the File > Export command in the
Bed Of Nails Editor may fail to complete for CircuitLine format.
Reference number: 54075

*xx CAM350 BUILD 400 ****

FILE IMPORT

Areas affected: Import Gerber

Symptoms: The File > Import > Gerber Data command may fail or cause incorrect
graphics for Gerber files that have undefined apertures.

Reference number: 53976,53815

Avreas affected: Import Gerber

Symptoms: The File > Import > Gerber Data command may fail for certain Gerber
files that have the percent character ("%") in aperture macro names.

Reference number: 42567

Avreas affected: Import PADS ASCII

Symptoms: The File > Import > CAD Data command does not support PADS Layout
version 9.2 ASCII files.

Reference number: 54003

Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may cause pads to shift for ODB++
files that contain pads that are offset from the associated component pin origins.
Reference number: 53975

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command fails to properly import and
flatten ODB++ files that contain flipped images.

Reference number: 53778
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Avreas affected: Import Drill Data

Symptoms: The File > Import > Drill Data command does not support the Excellon
command ("%SR*%") to end step and repeat data in drill files.

Reference number: 53863

Areas affected: Import Drill Data

Symptoms: The File > Import > Drill Data command may fail for certain Allegro
generated NC Drill files.

that have very small arcs.

Reference number: 53486,51315,50813

Areas affected: Import Autolmport

Symptoms: The File > Import > Autolmport command fails to initialize colors for
layers properly when the NEXT button is selected on the Autolmport dialog.
Reference number: 53852

FILE EXPORT

Areas affected: Export ODB++

Symptoms: The File > Import > ODB++ command may fail to export correct Mill
data for certain Mill route definitions with arcs.

Reference number: 53853

PANEL EDITOR

Avreas affected: Edit Flip

Symptoms: The Edit > Flip command may fail to properly display mill data that
contains arcs for stepped images that are flipped.

Reference number: 53847

NC EDITOR

Areas affected: Add Mill Tab

Symptoms: The Add > Mill Tab command may incorrect add mill tab locations and
associated perforations for certain jagged mill route patterns.

Reference number: 53822

Avreas affected: Settings View Options
Symptoms: The Middle Mouse zoom setting will be lost after modifying and saving
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changes to the Settings > View Options dialog in the Panel Editor.
Reference number: 54002

Areas affected: Explode Step & Repeat Data

Symptoms: The Edit > Change > Explode Step & Repeat command fails to report
that step and repeat (SR) NC data does not exist in the current design.

Reference number: 53848

UTILITIES

Avreas affected: Netlist Extract

Symptoms: The Utilities > Netlist Extract command may fail to complete for
designs that have zero size Dcodes.

Reference number: 53868

USER INTERFACE

Areas affected: Grid Visibility

Symptoms: The Grid Visibility toggle on the command toolbar may cause CAM350 to
crash when the dashboard toolbar is not visible.

Reference number: 53872

*xx CAM350 BUILD 391 **x

FILE IMPORT

Avreas affected: Import DXF

Symptoms: The File > Import > DXF command may fail for certain DXF files
that have very small arcs.

Reference number: 53874

*xx CAM350 BUILD 391 **xx

FILE IMPORT

Avreas affected: Import DXF
Symptoms: The File > Import > DXF command may fail for certain DXF files
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that have very small arcs.
Reference number: 53874

Areas affected: Import Drill Data

Symptoms: The File > Import > Drill Data command is incorrect for Seib&Meyer
3000 files that have drilled slots (code G85).

Reference number: 53835

Avreas affected: Import PADS ASCII

Symptoms: The File > Import > CAD Data command will display reference
designators that have PADS Label visibility set to "None".

Reference number: 53844

Areas affected: Import PADS ASCII

Symptoms: The File > Import > CAD Data command may drop drill definitions
for pad stacks that have square pads.

Reference number: 53862

FILE EXPORT

Avreas affected: Export DXF

Symptoms: The File > Import > DXF command will fail to complete when exporting
DXF data and panel mill data layers are specified for output.

Reference number: 53834

Areas affected: Break At Vertex

Symptoms: The Edit > Line Change > Break At Vix command will fail to complete
when modify segments for an added circle that has been sectorized.

Reference number: 53866

ANALYSIS

Avreas affected: Streams Report

Symptoms: The Info > Report > Streams Results command truncates net name lists
for long names or long lists of net names.

Reference number: 53776

USER INTERFACE
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Areas affected: Cursor Display

Symptoms: For certain Microsoft Intellimouse Mouse drivers, the CAM350 cursor
graphics may disappear for various window commands.

Reference number: 44126

*** CAM350 BUILD 389 ****

FILE IMPORT

Areas affected: Import Gerber

Symptoms: The File > Import > Gerber command loses arc precision for polygons in for
certain small designs.

Reference number: 53699

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command incorrectly assigns nets to finger edge
pads for certain files output by Mentor Expedition.

Reference number: 53590

Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command incorrectly imports bottom mounted
finger connector components for certain ODB++ files.

Reference number: 53686

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command incorrectly handles angles for
components and other elements for ODB++ files output by PADS Layout 9.1.
Reference number: 53668

Avreas affected: Import PADS ASCII

Symptoms: The File > Import > CAD Data command may drop custom apertures for
PADS 9.x files when alphanumeric pin mapping does not specify all pins in a component.
Reference number: 53675

Avreas affected: Import HPGL

Symptoms: The File > Import > HPGL command fails to complete for certain HPGL files
with filled polygons.

Reference number: 53666

FILE EXPORT

Avreas affected: Export Gerber
Symptoms: The File > Export > Gerber command may drop some features after the
import DXF command is executed for certain DXF files with polygons.
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Reference number: 53672

Avreas affected: Export Gerber

Symptoms: The File > Export > Gerber command may drop resolution for certain designs
with filled polygons.

Reference number: 53616

Areas affected: Export Drill and Mill Data

Symptoms: The File > Export > Drill Data and Mill Data command dialogs should
support the Copy Names button to copy layer names to file names just as the Export
Gerber dialog already does.

Reference number: 53629

ANALYSIS

Avreas affected: Find Pin Holes

Symptoms: The Analysis > Find Pin Holes command may find false errors for certain
designs with complex polygons.

Reference number: 53663

Areas affected: Find Pin Holes

Symptoms: The Analysis > Find Pin Holes command may fail to complete for certain
designs with polygons that have arcs.

Reference number: 53644

Avreas affected: Acid Traps

Symptoms: The Analysis > Acid Traps command may find false errors for certain
designs with complex polygons.

Reference number: 53680

UTILITIES

Areas affected: Quick Part

Symptoms: The Utilities > Quick Part command does not keep track of the side of the
board on which the parts are placed. Quick Part should allow you to create parts from
pads on the bottom side and match pads on either top or bottom side of the board.
Reference number: 53135

*x% CAM350 BUILD 386 ****

FILE IMPORT
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Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command may create invalid CAM data for
certain ODB++ data files.

Reference number: 53591

FILE EXPORT

Areas affected: Export Composites

Symptoms: The File > Export > Composites command may fail to complete for
composite definitions created by deleting table entries.

Reference number: 53597

Avreas affected: Delete Segment

Symptoms: The Delete Segment command may fail to complete for certain arcs or circles
that have be sectorized.

Reference number: 53631

ANALYSIS

Areas affected: DRC

Symptoms: The Analysis > DRC command may fail to complete for certain designs with
polygons that have arcs with out of memory message.

Reference number: 53627

Areas affected: Streams DFF

Symptoms: The Streams DFF check for Copper for Border minimum gap may report
false errors for certain board outlines with arcs.

Reference number: 53660

Avreas affected: Streams Design Compare

Symptoms: For an ODB++ file import, the Design Compare function reports false errors
for TopPartOutline and BotPartOutline layers.

Reference number: 53640

UTILITIES
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Areas affected: Clear Silkscreen

Symptoms: The Utilities > Clear Silkscreen command may fail to complete for certain
CAM files.

Reference number: 53595

*** CAM350 BUILD 384 ****

FILE IMPORT

Areas affected: Import Gerber

Symptoms: The File > Import > Gerber Data command drops certain voids for complex
cutline polygons.

Reference number: 53484

Areas affected: Auto Import

Symptoms: The File > Import > Auto Import command should load IPC-D-356 and
IPC-D-356-A netlist formats.

Reference number: 53551

Avreas affected: Drill Data
Symptoms: The File > Import > Drill Data command does not support G85 (drilled slots)
for Sieb & Meyer format.
Reference number: 53160

Areas affected: Import ODB++

Symptoms: The File > Import > ODB++ command fails to complete for certain Genesis
files that have annular ring attributes and CAMTEK attributes.

Reference number: 53573

Avreas affected: Import ODB++

Symptoms: The File > Import > ODB++ command fails to complete for certain Zuken
files that illegal references to layers that are not defined.

Reference number: 53577

FILE EXPORT

Avreas affected: Export Gerber

Symptoms: The File > Export > Gerber Data command does not properly export arcs that
are in mirrored raster polygon outlines.

Reference number: 53575
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UTILITIES

Areas affected: Draw To Raster

Symptoms: The Utilities > Polygon Conversion > Draw To Raster command displays the
warning message for polygons with more than 16,000 vertices multiple times for one
command. There should be an option to not display the warning again.

Reference number: 53570

Areas affected: Arc segmentation

Symptoms: Arc graphics are not smooth for large arcs when you zoom such that the
arc radius is larger than the width of the graphics port.

Reference number: 53579
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