サイドバイサイド方式のステレオ動画を作成する

MicroAVSは標準機能として時分割のステレオ立体視に対応しており、対応グラフィックスボードと液晶シャッター眼鏡により立体視が可能です(別記事1別記事2 参照)。

一方、ステレオ動画の汎用フォーマットとして3D放送でも採用されている 『サイドバイサイド方式』 があります。
これは画面を左右2分割にし、それぞれに左目用、右目用の映像を収録する方式です。分割のため横方向の解像度は半分となりますが、一般的な動画フォーマットでも作成でき、簡単にステレオ視を行えます。

このサイドバイサイド方式の動画を、MicroAVS でも作成することができます。
正確には MicroAVSフリービューワ 3D AVS Player を使用します。
動画フォーマットは AVI または MPEG となります。

サイドバイサイド動画の作成手順概要

  1. MicroAVS で可視化を行い、アニメータ3D で撮影し GFA ファイルを作成する
  2. GFA ファイルを 3D AVS Player に読み込み、[ステレオ] - [左右分割] の状態にして「キャプチャ」機能で撮影する

3D AVS Player のステレオ機能

3D AVS Player の [表示] メニューにある [ステレオ] - [左右分割] を選択(もしくは [F2] キー押下)すると画面が左目用と右目用に分かれます。

※上下分割にもできます

ステレオパラメータの設定は、[ツール] - [設定] パネルで行います。

[バランス] … 飛び出し(奥行き)具合の調整
[オフセット] … ステレオ効果の強さ
[左右反転] … チェックの有無で左目用画像と右目用画像が入れ替わります
      (“平行法” と “交差法” の切り替え)。

3D AVS Player の動画撮影(キャプチャ)機能

3D AVS Player の [ツール] メニューにある [キャプチャ] を選択すると、撮影のためのダイアログが表示されます。

[スタート] ボタンを押すと "●REC" 表示が出現します。
この状態でGFAのステップ再生やマウスによる幾何変換を行うと撮影が行われます(何も動かしていない状態は撮影されません)。

[ストップ] ボタンを押すと撮影が中断され、撮影したフレーム数が表示されます。再生ボタンによりプレビュー再生が行えます(ステレオ表示の場合片方のみ再生されます)。

[動画] ボタンを押すとファイルブラウザが開くので動画(AVIもしくはMPEG)の保存場所・ファイル名を決めてください。
保存中はファイルブラウザが出たままとなりますが、しばらく待つと『動画を保存しました』 というダイアログが表示され、保存が完了します。

※3D AVS Playerではfps値が固定となります(AVI:20fps、MPEG:30fps)。この数値を変えたい場合は [画像(連番)] ボタンを押して撮影したフレームを連番画像として保存し、別の動画作成ソフトを用いて動画作成を行ってください。



サンプル動画(※Youtube側の設定で「2D」と「3D(アナグリフ等)」を切り替え可能)

元動画ファイル(500x250, WMV, 886KB)
(クリックで再生もしくはダウンロード)


MicroAVSお問い合わせ窓口
MicroAVS評価版ダウンロード
AVS/Express English Website