GFA ファイルを 3D (立体視) で見る

エンタテインメント方面での導入が相次いだおかげで、一般の方々にも 3D (ステレオ視・立体視) がすっかり認知されていますが、今回はその立体視の話題です。

MicroAVS では Ver.5.0 (2001年3月発売) から時分割方式の立体視に標準対応しています。

例えば NVIDIA の 3D Vision のシステム一式があればMicroAVS で表示した結果がそのまま 3D の立体視で観察できます。
もちろん 3D Vision 以外でも、時分割立体視対応のシステムであればOKです。
3D で見ることで、既存の可視化結果にも新たな知見が得られるかもしれません。

この通常の立体視の設定については、以前にも記事にしていますが(ステレオ表示の設定)、今回はその延長で「MicroAVS で GFA ファイルのステレオ視を行う」 方法を紹介します。

GFA の再生

GFA ファイルは (基本的に) 元の時系列 FLD データ等に比べてスムーズに再生できる為、プレゼンで 3D のアニメーションをさせたい時には重宝します。
基本的には無料ダウンロード可能な 3D AVS Player でGFA を再生することになりますが、いざステレオ視、となった場合、3D AVS Player は時分割立体視には対応していません。

※視差画像を左右または上下に2分割しての表示は 3D AVS Player でも可能なので、ハードウェアがその方式に対応していれば立体視は可能です。

ところで、アニメータ 3D で GFA ファイルとして保存したデータは、(3D AVS Player が無くても) 再びアニメータ 3D で読み込ませて再生することができます。その時に適切な設定をすれば、アニメータ 3D のプレビューウインドウに表示されたGFA ファイルを立体視することができます。

アニメータ 3D で GFA ファイルを再生する

まず前提として、アニメータ 3D で GFA ファイルを読み込ませる時は、通常の FLD データや MGF データ等をMicroAVS に読み込ませない状態で行って下さい。
つまり MicroAVS 起動直後に [ファイル] メニューから [アニメータ3Dの起動]
を選択します。

アニメータ 3D の [ファイル] - [GFAファイルの読み込み] でGFA を読み込みます。撮影時のプレビューと同じように再生することができます。

アニメータ 3D で立体視をする

(あらかじめ、通常のステレオ表示設定がされている状態と仮定します)
アニメータ 3D の [表示] メニューから [カメラエディタ] を選択します。
(あるいはカメラのアイコンをクリック)

パネルの [透視投影] と [ステレオモード] にチェックを入れて下さい。
バランス・オフセットスライダーには初期値設定された値が入りますが、立体に見えにくい場合は画像を見ながら調節します。

[表示] メニューの [別ウインドウに表示] を選択
(あるいは下図アイコンをクリック)してプレビューウインドウを分離させ、ウインドウ右上の最大化ボタンを押すと、ディスプレイ全体で立体視表示できます。

物体を動かしているうちに見失ってしまった場合は、カメラエディタパネルの [カメラのリセット] ボタンを押すと、初期状態に復帰できます(ただし [透視投影] のチェックも外れてしまうので、チェックし直して下さい)。

価格的にも身近になった立体視で、より深い可視化の世界を体験してみましょう。


MicroAVSお問い合わせ窓口
MicroAVS評価版ダウンロード
AVS/Express English Website